E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Wastegate Ticking Resolved Without Getting 29.2! Works With 29.2 As Well!



Reply
 
Thread Tools Search this Thread
      11-22-2008, 10:35 PM   #133
GAaaAR
Captain
 
Drives: 2009 E92 335i
Join Date: May 2006
Location: NYC

Posts: 661
iTrader: (1)

Quote:
Originally Posted by Mr. 5 View Post
If it's the front wastegate then you can't do anything.
If you look at the picture in the first post then you will see that getting to the front actuator is impossible unless you take off the turbo.

So theres no way i can prove if its the wastegate or if its just something normal the car goes through during a cold start?

For example what if my car only does the ticking during cold starts but after its been warmed up, even if i rev the car and let the rpm drop I cant duplicate the noise. Would that mean its not wastegate?

Im just thinking there has to be some sort of test to diagnose whether its the wastegate or not without actually going under the car or taking anything out.
GAaaAR is offline  
0
Reply With Quote
      11-23-2008, 01:05 AM   #134
Mr. 5
Modder Raider
 
Mr. 5's Avatar
 
Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

Posts: 8,626
iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by maui86 View Post
that is gay. and im not sure what program i have. i have an 05/07 build. i took it to the dealership twice, once for a few limp modes upon cold start, SA told me it was just a glitch and they cleared everything and that was it, he didn't say they updated the computer. other time was for brakes but they didn't hook up the computer.
i figured i have pre 29.x. if i dont then i pretty much screwed myself for warranty since i dont run the doomsday maps.
i guess i can live with it since it only rattles for the first minute or less. then its completely gone.
Of course, when I say you can't do anything, I mean strictly this--YOU, yourself cannot fix the problem. Unless, if you want to take the steering out, DPs off, and front turbo off to adjust.
This is what it will take.

Quote:
Originally Posted by GAaaAR View Post
So theres no way i can prove if its the wastegate or if its just something normal the car goes through during a cold start?

For example what if my car only does the ticking during cold starts but after its been warmed up, even if i rev the car and let the rpm drop I cant duplicate the noise. Would that mean its not wastegate?

Im just thinking there has to be some sort of test to diagnose whether its the wastegate or not without actually going under the car or taking anything out.
I have had guys over with the newer program.
What happens is the front wastegate will tick for a bit and then go away after the car has warmed up.
I believe that some of them still here the wastegate ticking at light acceleration.

If you have the newer program then you should not and mostly will not here it under deceleration because the wastegates will not be closed during this time.



A lot of people PM me hoping that I can answer their questions by over the internet and it's really hard.
It's just like when you try to explain a situation to a mechanic on the phone.
During mid sentance, the mechanic will say "bring it in."
The only true way to know for sure is if the car is in front of you acting up.

This first thread is a guideline for those who are having the same issues.
Unfortunately, it is only a fix for the rear wastegate.
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Mr. 5 is offline   Scotland
0
Reply With Quote
      11-23-2008, 02:17 AM   #135
GAaaAR
Captain
 
Drives: 2009 E92 335i
Join Date: May 2006
Location: NYC

Posts: 661
iTrader: (1)

Quote:
Originally Posted by Mr. 5 View Post
Of course, when I say you can't do anything, I mean strictly this--YOU, yourself cannot fix the problem. Unless, if you want to take the steering out, DPs off, and front turbo off to adjust.
This is what it will take.



I have had guys over with the newer program.
What happens is the front wastegate will tick for a bit and then go away after the car has warmed up.
I believe that some of them still here the wastegate ticking at light acceleration.

If you have the newer program then you should not and mostly will not here it under deceleration because the wastegates will not be closed during this time.



A lot of people PM me hoping that I can answer their questions by over the internet and it's really hard.
It's just like when you try to explain a situation to a mechanic on the phone.
During mid sentance, the mechanic will say "bring it in."
The only true way to know for sure is if the car is in front of you acting up.

This first thread is a guideline for those who are having the same issues.
Unfortunately, it is only a fix for the rear wastegate.

O wells.. I guess as long as its not doing any harm. The sound isn't too loud now and happens only during cold starts. Sometimes it doesn't even happen. I guess I can just leave it.
GAaaAR is offline  
0
Reply With Quote
      11-23-2008, 02:49 AM   #136
ren
Captain
 
Drives: E92 335
Join Date: Jan 2007
Location: U.S.

Posts: 825
iTrader: (8)

Quote:
Originally Posted by stressdoc View Post
Now I am confused. I took my car in with the wastegate rattle last spring -- early April -- and I was pretty certain that they PROGMANed me. Ticking was gone for a while, but returned, and is clearly noticeable now when I rev and let off. I assumed that I got PROGMAN 29.x -- I noticed a slight power loss, pretty much across the board, but no special lag at low rpm. But from Mr.5's description, it sounds like I still have a pre-29 version. I clearly have the open wastegate farty exhaust sound, and the rattle on deceleration.

Now I am thinking that what I might have lost was my initial hot tune, but got 28.x ??? Regardless, I am waiting to have my actuators replaced when 32.x is released next month.
I have the same situation with my car. 29.2 or newer and rattle only during deceleration (lasts for half a second or less). I'm confused after reading this thread.
ren is offline  
0
Reply With Quote
      11-23-2008, 03:31 PM   #137
maui86
Captain
 
Drives: 07 335i
Join Date: Nov 2007
Location: paradise

Posts: 738
iTrader: (1)

Send a message via AIM to maui86 Send a message via Skype™ to maui86
Quote:
Originally Posted by Mr. 5 View Post
Of course, when I say you can't do anything, I mean strictly this--YOU, yourself cannot fix the problem. Unless, if you want to take the steering out, DPs off, and front turbo off to adjust.
This is what it will take.



I have had guys over with the newer program.
What happens is the front wastegate will tick for a bit and then go away after the car has warmed up.
I believe that some of them still here the wastegate ticking at light acceleration.

If you have the newer program then you should not and mostly will not here it under deceleration because the wastegates will not be closed during this time.



A lot of people PM me hoping that I can answer their questions by over the internet and it's really hard.
It's just like when you try to explain a situation to a mechanic on the phone.
During mid sentance, the mechanic will say "bring it in."
The only true way to know for sure is if the car is in front of you acting up.

This first thread is a guideline for those who are having the same issues.
Unfortunately, it is only a fix for the rear wastegate.
might of got the quotes backwards, but its ok haha. ah sucks balls if i have v29+ i noticed there is that slight micro sec response delay, but i figured it was how its supposed to be. i'll just call the dealership to see if they updated my car. stupid tuner code definitely there im sure.
__________________
http://videos.streetfire.net/video/s...rays_37268.htm

gotta do what i gotta do to get them donuts
04 spec-v: rip dec07
maui86 is offline   United_States
0
Reply With Quote
      11-23-2008, 06:03 PM   #138
GAaaAR
Captain
 
Drives: 2009 E92 335i
Join Date: May 2006
Location: NYC

Posts: 661
iTrader: (1)

Ok heres an update to my situation. I popped the hood to check it out and apparently the ticking seems to be coming from my engine? Although it is possible that it can be under the engine, but it really sounds like its from my engine. Im guessing its not the front wastegate?
GAaaAR is offline  
0
Reply With Quote
      11-23-2008, 09:14 PM   #139
itsbrokeagain
 
itsbrokeagain's Avatar
 
Drives: E28 535, 1996 Dodge Ram Diesel
Join Date: Mar 2007
Location: Valley Stream, NY

Posts: 15,737
iTrader: (7)

Send a message via AIM to itsbrokeagain
you know whats funny...back last year when you guys started getting this problem, I suggested to tighten up the wastegates if you could, because I used to have the problem all the time with DSMs....that would cure the rattling issue all the time

But hey, what do I know lol
__________________
AUTOCouture Motoring: Handling reflector installs to turbo upgrades and superchargers, and everything in between
15-01 Pollitt Drive, Fairlawn NJ 201-666-3500

<-Official Vehicle Transport for AUTOCouture
itsbrokeagain is offline   United_States
0
Reply With Quote
      11-23-2008, 09:16 PM   #140
itsbrokeagain
 
itsbrokeagain's Avatar
 
Drives: E28 535, 1996 Dodge Ram Diesel
Join Date: Mar 2007
Location: Valley Stream, NY

Posts: 15,737
iTrader: (7)

Send a message via AIM to itsbrokeagain
Quote:
Originally Posted by GAaaAR View Post
Ok heres an update to my situation. I popped the hood to check it out and apparently the ticking seems to be coming from my engine? Although it is possible that it can be under the engine, but it really sounds like its from my engine. Im guessing its not the front wastegate?
Some N54 engines had lifter tick, the early E90s had this issue with the valvetronic not being programmed right. When I used to work for the dealer, a simple reprogram of the valvetronic cured the noise.

My engine ticks on startup if Ive let it sit for a while in the freezing cold for a few days. Once it gets hot and I take it for a good drive she stops makin noise.
__________________
AUTOCouture Motoring: Handling reflector installs to turbo upgrades and superchargers, and everything in between
15-01 Pollitt Drive, Fairlawn NJ 201-666-3500

<-Official Vehicle Transport for AUTOCouture
itsbrokeagain is offline   United_States
0
Reply With Quote
      11-23-2008, 09:44 PM   #141
vase330
Colonel
 
vase330's Avatar
 
Drives: E92 335i ; 14 RangeRover SSC
Join Date: Jan 2007
Location: Arlington, Va

Posts: 2,676
iTrader: (1)

Mine had the wastegates changed a couple weeks ago. It still ticks when cold, but totally different from the rattle from the wastegates that sounded more like cans dragging under the car on deceleration. Not really bothered now. Just baby sitting to see if anything else breaks before deciding if I want to mod more.
__________________
E92 335 | Space Gray | Saddle Brown Dakota | Dark Burl Trim | ZPP | ZSP | AT | Idrive | 6FL | FBO | Dinan CAI | Quaife LSD | STG3 PROCede.
vase330 is offline   United_States
0
Reply With Quote
      11-23-2008, 09:52 PM   #142
jadeddjay
Major
 
jadeddjay's Avatar
 
Drives: e92 335i
Join Date: Oct 2005
Location: jackson, ms

Posts: 1,426
iTrader: (4)

Garage List
2007 e92 335i  [0.00]
same here
jadeddjay is offline   United_States
0
Reply With Quote
      11-23-2008, 10:25 PM   #143
Mr. 5
Modder Raider
 
Mr. 5's Avatar
 
Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

Posts: 8,626
iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by vase330 View Post
Mine had the wastegates changed a couple weeks ago. It still ticks when cold, but totally different from the rattle from the wastegates that sounded more like cans dragging under the car on deceleration. Not really bothered now. Just baby sitting to see if anything else breaks before deciding if I want to mod more.
I had mine replaced under warranty but the ticking came back.
This is why I adjusted them myself.
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Mr. 5 is offline   Scotland
0
Reply With Quote
      11-23-2008, 10:37 PM   #144
1clean335i
Perf BMW mag issue 147, 159
 
1clean335i's Avatar
 
Drives: Project Estoril
Join Date: Feb 2007
Location: Central Florida

Posts: 6,752
iTrader: (30)

Garage List
Quote:
Originally Posted by Mr. 5 View Post
If it's the front wastegate then you can't do anything.
If you look at the picture in the first post then you will see that getting to the front actuator is impossible unless you take off the turbo.
i've replaced like 3 sets of wastegates without removing either of the turbos this was done on a lift though and not at home with jack stands... definately not a diy or even do it at home task!
__________________
'13 Estoril Blue 335i M-sport
*Don't PM me!* Message me here- http://www.facebook.com/ProjectEstoril

Last edited by 1clean335i; 11-23-2008 at 11:15 PM.
1clean335i is offline   Vietnam
0
Reply With Quote
      11-23-2008, 11:14 PM   #145
Mr. 5
Modder Raider
 
Mr. 5's Avatar
 
Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

Posts: 8,626
iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by 1clean335i View Post
i've replaced like 3 sets of wastegates without removing either of the turbos this was done on a lift though and not at home with jack stands...
3 sets of wastegates or 3 sets of actuators?
Even the actuators, that's one hell of a hard job to do with the front actuator.
Are you sure you were working on an N54?
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Mr. 5 is offline   Scotland
0
Reply With Quote
      11-23-2008, 11:54 PM   #146
BlueLion
she likes the flavor......
 
Drives: A51-E92
Join Date: Nov 2006
Location: Bradenton - FL

Posts: 1,618
iTrader: (4)

Garage List
2007 BMW 335  [0.50]
Quote:
Originally Posted by SfValley335i View Post
See if you can get a loaner procede, it now has a rattle fix which might help you.
doesn't work to fix a front wastegate rattle
__________________

E92 Montego Blue silfa718 ..::STETT CAI|ADVAN RS|WAGNER FMIC|MS DP|VANGUARD|PROCEDE|FORGE DV|BMS OCC|KWV2|MICHELIN PSS|OOS::..

BlueLion is offline   United_States
0
Reply With Quote
      11-23-2008, 11:55 PM   #147
BlueLion
she likes the flavor......
 
Drives: A51-E92
Join Date: Nov 2006
Location: Bradenton - FL

Posts: 1,618
iTrader: (4)

Garage List
2007 BMW 335  [0.50]
Quote:
Originally Posted by Mr. 5 View Post
3 sets of wastegates or 3 sets of actuators?
Even the actuators, that's one hell of a hard job to do with the front actuator.
Are you sure you were working on an N54?
im sure he knows if he is working on a N54
__________________

E92 Montego Blue silfa718 ..::STETT CAI|ADVAN RS|WAGNER FMIC|MS DP|VANGUARD|PROCEDE|FORGE DV|BMS OCC|KWV2|MICHELIN PSS|OOS::..

BlueLion is offline   United_States
0
Reply With Quote
      11-24-2008, 06:35 PM   #148
1clean335i
Perf BMW mag issue 147, 159
 
1clean335i's Avatar
 
Drives: Project Estoril
Join Date: Feb 2007
Location: Central Florida

Posts: 6,752
iTrader: (30)

Garage List
Quote:
Originally Posted by Mr. 5 View Post
3 sets of wastegates or 3 sets of actuators?
Even the actuators, that's one hell of a hard job to do with the front actuator.
Are you sure you were working on an N54?
actuators.... yea its a royal pain but the 3 cars ive replaced them on, i did not remove either turbo one of the cars belongs to a member on here but rarely posts....
__________________
'13 Estoril Blue 335i M-sport
*Don't PM me!* Message me here- http://www.facebook.com/ProjectEstoril
1clean335i is offline   Vietnam
0
Reply With Quote
      11-24-2008, 10:03 PM   #149
maui86
Captain
 
Drives: 07 335i
Join Date: Nov 2007
Location: paradise

Posts: 738
iTrader: (1)

Send a message via AIM to maui86 Send a message via Skype™ to maui86
mr.5 is right, sorry i doubted you man. given your description of what you said about the whole front WG thing on certain program cars and when i was in mcdonalds drive through next to their wall i revved it up to 4k then let it off and can hear the rattle upon decel.very very quiet though. i guess i gotta deal with it. shit. now it makes me notice all types of noises haha. like now i notice the apparent lifter noise.(not injectors) these sounds slightly different :-) thanks mr.5 for your help and clearing things up.

teri
__________________
http://videos.streetfire.net/video/s...rays_37268.htm

gotta do what i gotta do to get them donuts
04 spec-v: rip dec07
maui86 is offline   United_States
0
Reply With Quote
      12-09-2008, 02:35 PM   #150
ren
Captain
 
Drives: E92 335
Join Date: Jan 2007
Location: U.S.

Posts: 825
iTrader: (8)

Here's my situation: February 2007 built E92 with 10K miles, all stock except Procede v3.1 (11-14-08 maps), lagfix enabled. My software is 29.2 or newer.

What do you think of this noise? It's getting worse each day. Rattle around 2500-3000 rpm mostly when I let off the gas pedal and sometimes even during acceleration. I don't have an aftermarket exhaust, it's just the disabled exhaust flap in case you wonder why it sounds louder than stock.

Let me know what you guys think.

ren is offline  
0
Reply With Quote
      12-10-2008, 02:01 AM   #151
jgalaxy
Gearing
 
jgalaxy's Avatar
 
Drives: E46 M3
Join Date: Oct 2006
Location: Montreal

Posts: 3,794
iTrader: (3)

Quote:
Originally Posted by erensf View Post
Here's my situation: February 2007 built E92 with 10K miles, all stock except Procede v3.1 (11-14-08 maps), lagfix enabled. My software is 29.2 or newer.

What do you think of this noise? It's getting worse each day. Rattle around 2500-3000 rpm mostly when I let off the gas pedal and sometimes even during acceleration. I don't have an aftermarket exhaust, it's just the disabled exhaust flap in case you wonder why it sounds louder than stock.

Let me know what you guys think.

Does it go away after warming up?
__________________
"Our enemies are innovative and resourceful, and so are we. They never stop thinking
about new ways to harm our country and our people, and neither do we." - George W

jgalaxy is offline   Canada
0
Reply With Quote
      12-10-2008, 10:32 AM   #152
ren
Captain
 
Drives: E92 335
Join Date: Jan 2007
Location: U.S.

Posts: 825
iTrader: (8)

Quote:
Originally Posted by jgalaxy View Post
Does it go away after warming up?
no it does not.
ren is offline  
0
Reply With Quote
      12-21-2008, 08:57 PM   #153
Kerosene Hat
Regional Governor
 
Kerosene Hat's Avatar
 
Drives: '10 E92 335i
Join Date: Apr 2007
Location: ATL

Posts: 555
iTrader: (0)

Quote:
Originally Posted by GGreek5 View Post
I hear ticking when I start the car in the morning. If I rev it, it goes away, but at idle I hear it. Its pretty distinct. Could this be the wastegate rattle??
No, I believe that is lifter noise - nothing to be concerned about.

WG rattle is noticeable when revving as engine slows down.

And yes, this fix WORKS - thank you, Mr5!
__________________
2010 E92 335i | Alpine White |Coral Red | M-Sport | Logic 7 |
My Website| My Flickr Page
Kerosene Hat is offline  
0
Reply With Quote
      12-21-2008, 10:27 PM   #154
Mr. 5
Modder Raider
 
Mr. 5's Avatar
 
Drives: M3
Join Date: Apr 2007
Location: Surf City, HB

Posts: 8,626
iTrader: (31)

Garage List
2007 e90 335i  [4.00]
Quote:
Originally Posted by Kerosene Hat View Post
No, I believe that is lifter noise - nothing to be concerned about.

WG rattle is noticeable when revving as engine slows down.

And yes, this fix WORKS - thank you, Mr5!
Awesome man!
For those who are wondering, I have done this fix with my car and 4 others.
One car, in addition, was part failure since we found that the front was ticking also.

It's so nice to hear the engine and exhaust sound like a normal car.

I'm glad you're happy Kerosene!
__________________
e36 M3 Coupe, e36 325i Sedan
e90 335i--SOLD

Best 60-130-------------9.15 Seconds------------------WWW.MR5RACING.COM
Mr. 5 is offline   Scotland
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:55 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST