E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Alpine Hifi upgrade



Reply
 
Thread Tools Search this Thread
      08-23-2010, 03:44 PM   #463
GIFBMW
Registered
0

 
Drives: X1
Join Date: Aug 2010
Location: South Wales


Posts: 1
iTrader: (0)

Quote:
Originally Posted by Craski-M3 View Post
Its just an issue with mounting the amp, nothing else. I did it to mine, see this thread for more info and photos...
http://www.e90post.com/forums/showth...ght=alpine+dab
Hi, just dropped in from the 1 Forum to say hello and get some assistance on this issue I hope

When you did this was re-coding an issue and what did you do regarding the Amp switch position? Did the install on my 123d before, no problems and the Amp switch in Pos 2 for the Pro HU. Looking to do it again now on an X1 with DAB but getting the same bull from dealers regarding compatibility.

Any advice much welcomed as there are a few of us on the Forum struggling with the same issue.

Thanks
Appreciate 0
      08-24-2010, 11:26 AM   #464
lbortnick
New Member
1

 
Drives: 128i 6speed
Join Date: Jun 2010
Location: Toronto


Posts: 24
iTrader: (0)

2011 128i coupe Help with Alpine retrofit kit

I have conflicting info from different dealers. I have a 2011 128i coupe that comes with the basic stereo here in north america. It has a separate amp already. I want to install the alpine retrofit kit 65412163268 with the new tweeters, midrange units, amp and wiring harness. Does anyone know if this will work or have done the same install? This would be the same for a 135i that came with the basic stereo.

Any help would be appreciated
Appreciate 0
      09-02-2010, 08:43 AM   #465
neocleous
Private
2

 
Drives: 325i SE E92 Coupe
Join Date: Apr 2007
Location: UK


Posts: 67
iTrader: (0)

I have rang the Warrington dealer ship and the Liverpool dealership both quoted me 310 including VAT for the kit and I used part number 65 41 0 445 684 did I ask for the wrong thing or has the price just generally gone up as every one seems to have paid around 250 for theirs

Thanks
Appreciate 0
      09-02-2010, 10:37 AM   #466
TikoV
Captain
Scotland
12

 
Drives: BMW 335d/X5 40d
Join Date: Aug 2009
Location: Glasgow


Posts: 664
iTrader: (0)

That's about right now...I was quoted 300 too up here. Think the ones that got it at that price did so by group buying.
__________________
Appreciate 0
      09-02-2010, 01:55 PM   #467
neocleous
Private
2

 
Drives: 325i SE E92 Coupe
Join Date: Apr 2007
Location: UK


Posts: 67
iTrader: (0)

That's ok if that's the going rate I thought I had rang two greedy dealers
Appreciate 0
      09-03-2010, 11:09 AM   #468
marlonmarc
Private
0

 
marlonmarc's Avatar
 
Drives: BMW 318i
Join Date: Jun 2010
Location: London


Posts: 69
iTrader: (0)

Getting mine delivered to Cooper BMW Banstead tomorrow morning for ~286

Straight up asked for a 10% discount and they gave me 7.5%.

Annekas away for a good while and I'm not really too fussed at another 20 quid off.

Haven't bought the new triangle tweeter housings though. Going to leave them for the timebeing and see if I can fashion my own holes in the existing housings as I like to think I'm quite handy with neat little installs.

Quick question though: I have ready on the 1 series forum that BMW updated the Alpine kit so you no longer had to cut into and crimp to speaker wires underneath the door sills - is this true or are some people talking b*ll*cks?

Hopefully should be a 2 hour job otherwise. The amount of bloody installs I've done I'd hope so anyway.
Appreciate 0
      09-03-2010, 06:10 PM   #469
Steve748
Lieutenant
United Kingdom
6

 
Steve748's Avatar
 
Drives: Corvette & Jeep Commander
Join Date: Dec 2008
Location: North Yorks & Granite Hills CA


Posts: 564
iTrader: (0)

Don't be a cheapskate and buy the proper tweeter mounts as the original bits probably won't hold them properly.

+ they will look better and you get little 'Alpine' badges to put on them
Appreciate 0
      10-22-2010, 01:17 PM   #470
Craski-M3
New Member
1

 
Drives: 2008 E90 M3
Join Date: Nov 2009
Location: Scotland


Posts: 9
iTrader: (0)

Quote:
Originally Posted by GIFBMW View Post
Hi, just dropped in from the 1 Forum to say hello and get some assistance on this issue I hope

When you did this was re-coding an issue and what did you do regarding the Amp switch position? Did the install on my 123d before, no problems and the Amp switch in Pos 2 for the Pro HU. Looking to do it again now on an X1 with DAB but getting the same bull from dealers regarding compatibility.

Any advice much welcomed as there are a few of us on the Forum struggling with the same issue.

Thanks
Oops ... havent been on here for a while.
No, I had no problems with coding, it was plug and play.
The amp switch is in position 2 as advised in the BMW installation instructions for the kit.
Appreciate 0
      10-23-2010, 03:13 AM   #471
Dancer-Davies
New Member
Wales
0

 
Drives: E93
Join Date: Oct 2010
Location: Newport, WALES


Posts: 9
iTrader: (1)

About to order this kit from a Newport dealer and was wonering if the best price was still around 300. Also do you get 2 tweeters only some photos only show 1
Appreciate 0
      10-23-2010, 07:50 AM   #472
Boyd1963
Major
United Kingdom
16

 
Boyd1963's Avatar
 
Drives: 2011 320d e92
Join Date: Sep 2009
Location: Bournemouth


Posts: 1,301
iTrader: (0)

Garage List
Sep 2011 E92  [0.00]
300 is a decent price and from memory you get two tweeters, two replacement door speaker, the amplifier and some wiring.
Appreciate 0
      10-26-2010, 01:45 AM   #473
Dancer-Davies
New Member
Wales
0

 
Drives: E93
Join Date: Oct 2010
Location: Newport, WALES


Posts: 9
iTrader: (1)

Thanks, placed my order on Saturday for the kit and should get it it tomorrow . Only wish I'd seen the 15% discount before I ordered
Appreciate 0
      10-26-2010, 07:12 PM   #474
Steve748
Lieutenant
United Kingdom
6

 
Steve748's Avatar
 
Drives: Corvette & Jeep Commander
Join Date: Dec 2008
Location: North Yorks & Granite Hills CA


Posts: 564
iTrader: (0)

Make sure you get the tweeter covers, they are extra to the Alpine upgrade kit
Appreciate 0
      10-27-2010, 01:41 AM   #475
Dancer-Davies
New Member
Wales
0

 
Drives: E93
Join Date: Oct 2010
Location: Newport, WALES


Posts: 9
iTrader: (1)

Quote:
Originally Posted by Steve748 View Post
Make sure you get the tweeter covers, they are extra to the Alpine upgrade kit
Cheers, did do. Picked it up yesterday having it fitted tomorrow by an audio specialist. Just hope the change in sound is alot fuller, not expecting earth shattering bass but anything's gotta be better than the standard speakers.

Paid 330 all in for the kit and covers,but what made it gutting when I collected was the fact an old work mate now works over there and could have got me discount
Appreciate 0
      10-28-2010, 08:51 AM   #476
sbce90
Me Boosta
Australia
81

 
sbce90's Avatar
 
Drives: 320i / MB C63 / VW up!
Join Date: Jan 2010
Location: Sydney, Australia


Posts: 5,552
iTrader: (3)

I posted a while ago mentioning that I was having problems with my Alpine system and my dealer was attempting to fix it. After an extensive 9 month ordeal no solution was found, and the Alpine unit had to be removed from my car. Disappointed, yet glad it was all covered under the warranty and will get money back.
Appreciate 0
      10-29-2010, 04:41 PM   #477
rogerdiaz
Lieutenant
United_States
6

 
Drives: 2011 335d
Join Date: Sep 2010
Location: Durham,NC


Posts: 536
iTrader: (2)

Anyone put the alpine upgrade kit on a 2011 335d stock sound system. US vehicle

ne1 know part number for alpine upgrade kit that has PnP harness? No splicing required?

Last edited by rogerdiaz; 11-01-2010 at 05:59 PM. Reason: ?
Appreciate 0
      10-30-2010, 11:21 AM   #478
Steve748
Lieutenant
United Kingdom
6

 
Steve748's Avatar
 
Drives: Corvette & Jeep Commander
Join Date: Dec 2008
Location: North Yorks & Granite Hills CA


Posts: 564
iTrader: (0)

Quote:
Originally Posted by SBC View Post
I posted a while ago mentioning that I was having problems with my Alpine system and my dealer was attempting to fix it. After an extensive 9 month ordeal no solution was found, and the Alpine unit had to be removed from my car. Disappointed, yet glad it was all covered under the warranty and will get money back.
Hmmm...did you get your dealer to fit it who might not have done many or any fittings or did you take it to a specialist fitter who does these all day long?
Appreciate 0
      11-04-2010, 12:31 PM   #479
Dancer-Davies
New Member
Wales
0

 
Drives: E93
Join Date: Oct 2010
Location: Newport, WALES


Posts: 9
iTrader: (1)

Well I've had the upgraded Alpine speakers for a week now and I must say there is a good improvement
Only downside is that I'm still after a bit more punch, so yesterday I ordered the Earthquake sws-8 subs. Will this be it I wonder
Appreciate 0
      11-12-2010, 10:51 PM   #480
Imperator
Major
United_States
18

 
Imperator's Avatar
 
Drives: 2010 E92 335i
Join Date: Mar 2010
Location: Plano, Texas


Posts: 1,128
iTrader: (7)

Post

I'm planning to install the Alpine HiFi Upgrade amplifier tomorrow along with a set of BSW Stage 1 front components and OEM Logic7 8" subwoofers into my 2010 E92.

I found some spare time tonight to disassemble the amplifier in attempt to identify the Class-D amplifier ICs Alpine chose. After stripping the amp down to the board and wiping away some residual heatsink compound, I found the front channels and subwoofer channels each use the NXP TDA8920BTH.

Manufacturer specifications rate the IC output at 86W per channel @ 4ohm loads with 10% THD. That's a lot of punch for such a small package, but I'm not an EE and can't attest to the validity of these ratings or real-world performance.

Here's the IC data sheet:

http://www.nxp.com/documents/data_sheet/TDA8920B.pdf

http://www.nxp.com/#/pip/pip=[pi...ip,i=TDA8920B]

I hope my reassembly went smoothly and installation tomorrow proves successful. I'll return to this thread with my impressions after I give it some time to break in.
Appreciate 0
      11-18-2010, 03:44 PM   #481
Dancer-Davies
New Member
Wales
0

 
Drives: E93
Join Date: Oct 2010
Location: Newport, WALES


Posts: 9
iTrader: (1)

Quote:
Originally Posted by Dancer-Davies View Post
Well I've had the upgraded Alpine speakers for a week now and I must say there is a good improvement
Only downside is that I'm still after a bit more punch, so yesterday I ordered the Earthquake sws-8 subs. Will this be it I wonder
Had the Earthquake subs fitted today and I can't believe there is now even less bass. Could it be I need a more powerful amp rather than the alpine or do the subs need breaking in for a few days ? Starting to get depressed now
Appreciate 0
      11-18-2010, 05:40 PM   #482
Imperator
Major
United_States
18

 
Imperator's Avatar
 
Drives: 2010 E92 335i
Join Date: Mar 2010
Location: Plano, Texas


Posts: 1,128
iTrader: (7)

Quote:
Originally Posted by Dancer-Davies View Post
Had the Earthquake subs fitted today and I can't believe there is now even less bass. Could it be I need a more powerful amp rather than the alpine or do the subs need breaking in for a few days ? Starting to get depressed now
Did you install the 2-ohm (SWS-8Xi) or 4-ohm (SWS-8X) drivers? I'm tempted to try them in my car but I think I'd rather go with a more powerful amplifier to push them. A pair of Logic7 subwoofers should work well with the Alpine amp if you don't wish to make any further upgrades.
Appreciate 0
      11-20-2010, 03:21 PM   #483
Dancer-Davies
New Member
Wales
0

 
Drives: E93
Join Date: Oct 2010
Location: Newport, WALES


Posts: 9
iTrader: (1)

Imperator I installed the sws-8 4ohm ( wasnt sure which to get)
Bought another amp yesterday which I hope will power the subs a bit harder. The amp is a kenwood kac-846, anybody know anything about this amp ? Picked it up on eBay for 40 quid which I thought was worth a try. It supposedly puts out between 751-1000 watts. When it's fitted if it doesn't improve things I'm gonna throw in the towel and go back to the original subs and eBay the earthquakes.
Happy Saturday.
Appreciate 0
      11-20-2010, 06:56 PM   #484
Imperator
Major
United_States
18

 
Imperator's Avatar
 
Drives: 2010 E92 335i
Join Date: Mar 2010
Location: Plano, Texas


Posts: 1,128
iTrader: (7)

I looks as if the Kenwood KAC-846 produces 150W x 2 @ 14.4V, when bridged to two channels. This should be sufficient power for the SWS-8s and you'll want to set the crossover to low-pass at 150Hz. Unfortunately, it doesn't look as if the KAC-846 has high-level inputs so you may need a line driver to convert the subwoofer channel outputs to RCA for the amplifier.

http://www.scribd.com/doc/3275892/Ma...Manual-English
Appreciate 0
Reply

Bookmarks

Tags
alpine

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:05 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST