E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Eureka!! My DIY answer to no audio/sos malfunction



Reply
 
Thread Tools Search this Thread
      05-24-2014, 07:59 PM   #1
jbelles330i
New Member
0
Rep
16
Posts

 
Drives: 2006 BMW 330i
Join Date: Aug 2013
Location: Collierville TN

iTrader: (0)

Talking Eureka!! My DIY answer to no audio/sos malfunction

So In previous posts I described the infamous no audio/sos malfunction light.
I had been without a radio for seven months because i just wasn't going to give in to the stealership.

First and most important!! if any of you are experiencing this issue--SOS light radio looks like its playing but you have no sound, I beg you to not make going to the stealership your first option!! Arm yourself with all the knowledge you can or you will be taken to the cleaners!! Search here in these forums- unless you know of course what happened such as water dumping on your amp. This was not the case for me there was no reason for this issue to occur nothing odd took place other that my husband touching a few buttons on the radio. (2-do not let your husband touch your radio!)
3. Go to ECS tuning or pelican parts and get a MOST bus jumper. You can test your components yourself to find which is the faulty problem.
4. Many people will be surprised by this answer as if you have been tiresly searching for an answer to this the issue has usually been bad amp or bad TCU. NOT my problem it ended up being the satellite radio box!!! When I plugged in thie jumper to the satellite radio box my radio started playing!! I almost fell over.
5. Please I beg you to take the power of this problem in your own hands before you start purchasing amps, and TCU units (700.00-2000.00 repair)
the most bus jumper cost me $30.00 and a tiny piece of duct tape (for good measure) to keep it from getting bounced around.
I now have all functions running great and all gongs going off that need to be.
The funny thing is is I don't even use the satellite radio. Please feel free to ask questions--I am happy to answer and help! Have perseverence and arm yourself with all the knowledge you can! It paid off bg time for me!

Last edited by jbelles330i; 05-25-2014 at 08:49 AM. Reason: corrections
Appreciate 0
      05-24-2014, 08:12 PM   #2
big_ed
Private First Class
1
Rep
104
Posts

 
Drives: e93 335i
Join Date: Oct 2013
Location: NYC

iTrader: (0)

Good post
Appreciate 0
      05-25-2014, 11:15 AM   #3
I6TT
Enlisted Member
I6TT's Avatar
0
Rep
38
Posts

 
Drives: 2007 BMW 335i
Join Date: Feb 2014
Location: Texas, USA

iTrader: (0)

thats awesome.
Appreciate 0
      05-25-2014, 12:10 PM   #4
tlegend
Private
0
Rep
65
Posts

 
Drives: 328i
Join Date: Apr 2014
Location: sac

iTrader: (0)

So my radio works fine, but I have SOS malfunction error at startup and my Bluetooth phone does not work


So far I have unplug battery, removed tcu connections and reinserted them and still same thing.


Pleas advise I have a 2007 328i sedan.


Thx
Appreciate 0
      05-25-2014, 12:21 PM   #5
tlegend
Private
0
Rep
65
Posts

 
Drives: 328i
Join Date: Apr 2014
Location: sac

iTrader: (0)

While googling for most bus jumper I ran into this link


Is it simple as just purchasing a most bus jumper for $30 and plugging it in to my tcu plug.

Will that remove the SOS malfunction error and I will get Bluetooth back??


Can someone confirm please


http://www.justanswer.com/bmw/61ixl-bmw-330i-part-number-jumper.html
Appreciate 0
      05-25-2014, 12:25 PM   #6
tlegend
Private
0
Rep
65
Posts

 
Drives: 328i
Join Date: Apr 2014
Location: sac

iTrader: (0)

Is this the part I need??

http://m.ebay.com/itm/BMW-E65-E66-Me...-/360624381367
Appreciate 0
      05-25-2014, 12:59 PM   #7
ctuna
Brigadier General
45
Rep
4,338
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

No that won't remove the Sos Error

No that won't remove the Sos Error
You have to program it out if you are not going to
leave it functional.
That jumper is used to remove modules from the Most
Bus Loop.
If you plug it into the bluetooth module you have only bypassed bluetooth.
Appreciate 0
      05-25-2014, 01:05 PM   #8
tlegend
Private
0
Rep
65
Posts

 
Drives: 328i
Join Date: Apr 2014
Location: sac

iTrader: (0)

Quote:
Originally Posted by ctuna View Post
No that won't remove the Sos Error
You have to program it out if you are not going to
leave it functional.
That jumper is used to remove modules from the Most
Bus Loop.
If you plug it into the bluetooth module you have only bypassed bluetooth.

will i get my Bluetooth phone capability back?
Appreciate 0
      05-25-2014, 01:20 PM   #9
ctuna
Brigadier General
45
Rep
4,338
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

If your TCU is bad that's the bluetooth.

If your TCU is bad that's the bluetooth and the phone.
(unless you have a 2011 or newer car where bluetooth
is inside the radio)
If you have a bad satellite module like the OP it may fix things.
http://www.e90post.com/forums/attach...2&d=1260829447

In the case above the OP didn't have anything wrong with
his bluetooth module it was his satellite module that caused the problem do you have a satellite module . Whats on your Most Bus? Did you add any aftermarket equipment?
Appreciate 0
      05-25-2014, 01:26 PM   #10
tlegend
Private
0
Rep
65
Posts

 
Drives: 328i
Join Date: Apr 2014
Location: sac

iTrader: (0)

Quote:
Originally Posted by ctuna View Post
If your TCU is bad that's the bluetooth and the phone.
(unless you have a 2011 or newer car where bluetooth
is inside the radio)
If you have a bad satellite module like the OP it may fix things.
http://www.e90post.com/forums/attach...2&d=1260829447

In the case above the OP didn't have anything wrong with
his bluetooth module it was his satellite module that caused the problem do you have a satellite module . Whats on your Most Bus. Did you add any aftermarket equipment.
i dont think i have a satelite module, i have non i drive and my radio works fine. Just bluetooth does not work and i get sos malfunction error.

so will most bus jumper fix the issue? going crazy trying to resolve this
Appreciate 0
      05-25-2014, 01:28 PM   #11
ctuna
Brigadier General
45
Rep
4,338
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

No

No
Putting the jumper in removes the module it does
not fix it.
Also is it L7 or Hi Fi as the L7 is on the Most Loop.
If you press your menu button does it show the telephone
symbol?
If not you most probably have a bad TCU or you have somehow lost programming to it.
The satellite module would be to the left of the TCU.
There could also be something wrong with the FZD which
is the SOS button module above the Mirror.
Have you tried disconnecting the battery for awhile
which essentially reboots the car.

Last edited by ctuna; 05-25-2014 at 01:39 PM.
Appreciate 0
      05-25-2014, 01:55 PM   #12
tlegend
Private
0
Rep
65
Posts

 
Drives: 328i
Join Date: Apr 2014
Location: sac

iTrader: (0)

Quote:
Originally Posted by ctuna View Post
No
Putting the jumper in removes the module it does
not fix it.
Also is it L7 or Hi Fi as the L7 is on the Most Loop.
If you press your menu button does it show the telephone
symbol?
If not you most probably have a bad TCU or you have somehow lost programming to it.
The satellite module would be to the left of the TCU.
There could also be something wrong with the FZD which
is the SOS button module above the Mirror.
Have you tried disconnecting the battery for awhile
which essentially reboots the car.
So i checked the fuses first according to the fuse diagram, fuse 17 5amp 26 10 amp and 27 5 amp should be plugged in.

but only 17 was plugged in, i checked the fuse pulled and reinserted, still nothing, so inserted 26 and 27 in, and still nothing.



I then unlpugged the fiber optics from the TCU / bluetooth inside the trunk and plugged back in still nothing.

then i unplugged the battery for 40 mins and replugged in, still nothing.

bmw assist warning comes up and phone option does not come up.


i am thinking the TCU is fried, anyway to test it? Also, on the fuse panel the phone option should have 17 only or 26 and 27 fuses as well?



any ideas.....

i do have a speaker grill underneath the seats does that mean i have L7 or hifi?
Appreciate 0
      05-25-2014, 03:25 PM   #13
ctuna
Brigadier General
45
Rep
4,338
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Speaker in the center of the dash indicates L7

Since L7 is part of the fiber optic Most Bus loop when something goes
wrong with the Loop you don't get sound.
The Entertainment system PDF shows a picture of the TCU and all
devices attached. It could be one of those but most likely is the TCU. Can you measure voltage at the TCU?
Scanning for error codes with a BMW compatible scanner or coding setup
might tell you something.
If you can't locate a TCU to swap in you might think about a Dension gateway 500s bt . That would give bluetooth phone streaming bluetooth music usb and ipod. You would have to program out SOS though.
Appreciate 0
      05-25-2014, 03:30 PM   #14
tlegend
Private
0
Rep
65
Posts

 
Drives: 328i
Join Date: Apr 2014
Location: sac

iTrader: (0)

Quote:
Originally Posted by ctuna View Post
Since L7 is part of the fiber optic Most Bus loop when something goes
wrong with the Loop you don't get sound.
The Entertainment system PDF shows a picture of the TCU and all
devices attached. It could be one of those but most likely is the TCU. Can you measure voltage at the TCU?
Scanning for error codes with a BMW compatible scanner or coding setup
might tell you something.
If you can't locate a TCU to swap in you might think about a Dension gateway 500s bt . That would give bluetooth phone streaming bluetooth music usb and ipod. You would have to program out SOS though.

i dont even care about the Bluetooth phone. Since it does not work all that great. I am using bluetooth a2dp via aux to stream music.

I just dont like having a ! on my dash and the SOS keeps popping up during startup.

I have purchased the BMW bluetooth OBD 2 i will plug it in and see what the codes tell me.
Appreciate 0
      05-25-2014, 03:59 PM   #15
ctuna
Brigadier General
45
Rep
4,338
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Does Sos stay on or go out is it consistent?

Does Sos stay on or go out is it consistent?
The Sos error can be coded out of the Instrument Cluster
if you are not interested in fixing it.
The cluster can be coded to ignore the error and not set the light.
see entry 9 in the following link for the correct code.

http://www.e90post.com/forums/showthread.php?t=805677
Appreciate 0
      05-26-2014, 01:44 AM   #16
tlegend
Private
0
Rep
65
Posts

 
Drives: 328i
Join Date: Apr 2014
Location: sac

iTrader: (0)

Quote:
Originally Posted by ctuna View Post
Does Sos stay on or go out is it consistent?
The Sos error can be coded out of the Instrument Cluster
if you are not interested in fixing it.
The cluster can be coded to ignore the error and not set the light.
see entry 9 in the following link for the correct code.

http://www.e90post.com/forums/showthread.php?t=805677
can it be coded out using the BMW what app?

I downloaded the full version and check the codes, i have the following code.
Attached Images
 
Appreciate 0
      05-26-2014, 01:59 AM   #17
ctuna
Brigadier General
45
Rep
4,338
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Clearing and Programming are not the same

Clearing and Programming are not the same.
Still you might try it. If the problem is still there it
will just come back.
Appreciate 0
      05-26-2014, 10:33 AM   #18
tlegend
Private
0
Rep
65
Posts

 
Drives: 328i
Join Date: Apr 2014
Location: sac

iTrader: (0)

I cleared the error using that app and it still came back




The bmwwhat app has a coding option for comfort access etc however no remove SOS error out. I will have to read up and code out using the other threads


I think tcu is fried
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:35 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST