Bimmerpost for iOS has just been updated to version 3.8.9 with a host of new features and bug fixes. Try it out!

  E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > squeaky brake issue



Reply
 
Thread Tools Search this Thread
      01-03-2009, 11:45 PM   #1
kimbo
Private
Australia
3
Rep
65
Posts

Drives: E90
Join Date: Sep 2008
Location: sydney

iTrader: (0)

squeaky brake issue

Hi all

Everytime I come to a stop I can hear a squeaking noise. I'm assuming its my brakes making the noise. I have check the brake pads and I still have a fair bit left so im not sure why its making the squeaky noise. Does anyone else have this issue?

I also noticed that when i park my car and pull up the hand brake it always rolls a little bit more then usual. Is that normal? it just feels like the hand brake is never up completely but I always double check now but it still rolls back.

Thanks for your help
Appreciate 0
      01-04-2009, 12:20 AM   #2
Z22Z
Lieutenant
Z22Z's Avatar
Armenia
5
Rep
536
Posts

Drives: WRX
Join Date: Dec 2008
Location: Glendale, CA

iTrader: (0)

do your breaks squeak while driving very slow as well?
Appreciate 0
      01-04-2009, 12:30 AM   #3
McLuVan
Lieutenant General
McLuVan's Avatar
Vietnam
145
Rep
13,118
Posts

Drives: ///M3
Join Date: Jan 2008
Location: Socal~818~

iTrader: (1)

Quote:
Originally Posted by Z22Z View Post
do your breaks squeak while driving very slow as well?
that's the worst
I had it
Appreciate 0
      01-04-2009, 12:34 AM   #4
googoomas
Second Lieutenant
googoomas's Avatar
United_States
2
Rep
284
Posts

Drives: 155mph (Stupid Limiter)
Join Date: Apr 2007
Location: Redlands/Santa Barbara CA

iTrader: (1)

Send a message via AIM to googoomas Send a message via Skype™ to googoomas
hate this problem, its happened to me twice... take it to the dealer
Appreciate 0
      01-04-2009, 12:41 AM   #5
kimbo
Private
Australia
3
Rep
65
Posts

Drives: E90
Join Date: Sep 2008
Location: sydney

iTrader: (0)

when im driving slowly it doesnt squeak unless i step on the brakes.

when im going a bit faster and apply the brakes, there is no noise. It only happens when im coming to a stop or driving at like 10kmp/h and apply the brakes.
Appreciate 0
      01-04-2009, 09:10 PM   #6
BMW //MPOWER
Major
Australia
16
Rep
1,398
Posts

Drives: BMW 325CI MY04 //M Clubsport
Join Date: Feb 2007
Location: Sydney, Australia

iTrader: (0)

Garage List
Send a message via MSN to BMW //MPOWER
I suggest scrolling down the forum and reading Chris.G's "My First Problem" thread.
__________________

BMW 325Ci MY2004 Individual //M Clubsport Edition, //M Clubsport package, //M Sport 18"s, Manual //M Short Shift, Carbon Black, Black Aluminium Cube Interior.
Appreciate 0
      01-05-2009, 05:24 AM   #7
Chris.G
Banned
Chris.G's Avatar
Australia
46
Rep
3,122
Posts

Drives: 2011 LCI MSPORT X5 30d
Join Date: Aug 2006
Location: Sydney, Australia

iTrader: (0)

Quote:
Originally Posted by Z22Z View Post
do your breaks squeak while driving very slow as well?
haha thats my problem mate! Do you have the same problem when your rolling in Glendale picking up some of the Armo beauties around the area? If you do they will most likely run away from the car when they hear the noise it makes.
Appreciate 0
      01-05-2009, 06:08 AM   #8
kimbo
Private
Australia
3
Rep
65
Posts

Drives: E90
Join Date: Sep 2008
Location: sydney

iTrader: (0)

we must have the same problem then

I think your noise is heard while accelerating where as mine one starts as soon as i tap on the brakes.

Is there a way to fix this by myself? or do I need to take this to a professional to fix?
Appreciate 0
      01-05-2009, 06:50 AM   #9
Chris.G
Banned
Chris.G's Avatar
Australia
46
Rep
3,122
Posts

Drives: 2011 LCI MSPORT X5 30d
Join Date: Aug 2006
Location: Sydney, Australia

iTrader: (0)

Quote:
Originally Posted by kimbo View Post
we must have the same problem then

I think your noise is heard while accelerating where as mine one starts as soon as i tap on the brakes.

Is there a way to fix this by myself? or do I need to take this to a professional to fix?
haha

I took my car to BMW and they really had no proper fix, i am hoping BMW can either fix or replace your brake pads depending on how new your car is. I am soon going to ask BMW Sydney to replace my brake pads because its starting to annoy me slightly, i mean i feel like im in a torana when im starting to speed up. Oh the looks i get when im driving in the city and this whistling noise occurs.
Appreciate 0
      01-05-2009, 05:24 PM   #10
ansch
Captain
Australia
8
Rep
610
Posts

Drives: TiAg E90 320i, SGM 135i
Join Date: Dec 2008
Location: Brisbane, Australia

iTrader: (1)

does it only tend to squeal when the brakes are cold? (common on hi performance pads). I notice my e90 does the same when brakes are cold on light applications. The only solution that may work is to drive the car harder.

Try to do a few harder than normal deceleration once the brakes have warmed up a bit. eg. 60km/h down to stop at a set of lights.. (don't do it when someone's behind you though!! watch for traffic behind).

Not sure what pad compound bmw uses but if it is a hi performance/ high operating temp pad then driving it in slow traffic and not using it hard enough over time will cause the pad and rotor to glaze over and start squeaking real bad. Sometimes if it's got to that stage the only option is to get new pads and ground/ machine the rotors then bed and use the new set "properly"

Last edited by ansch; 01-05-2009 at 05:58 PM.
Appreciate 0
      01-29-2009, 05:27 AM   #11
kimbo
Private
Australia
3
Rep
65
Posts

Drives: E90
Join Date: Sep 2008
Location: sydney

iTrader: (0)

hey alll

Just a little update on my squeaky brakes issue. Well I did alot of reading on this forum and came across some helpful infomation and things to try before taking it to the shop.

Well from what I read is that I should put the car in reverse and then slam on the brakes. I tried this a few time and to my surprise this actually worked. Its been a week now and still no noise from my brakes.

ansch - i tried what you suggested .. as fun as it was, it didnt seem to work for my car... its was actually more fun in reverse... and as a added bonus i dont have any squeaky brakes
Appreciate 0
      01-29-2009, 04:02 PM   #12
Chris.G
Banned
Chris.G's Avatar
Australia
46
Rep
3,122
Posts

Drives: 2011 LCI MSPORT X5 30d
Join Date: Aug 2006
Location: Sydney, Australia

iTrader: (0)

Quote:
Originally Posted by kimbo View Post
hey alll

Just a little update on my squeaky brakes issue. Well I did alot of reading on this forum and came across some helpful infomation and things to try before taking it to the shop.

Well from what I read is that I should put the car in reverse and then slam on the brakes. I tried this a few time and to my surprise this actually worked. Its been a week now and still no noise from my brakes.

ansch - i tried what you suggested .. as fun as it was, it didnt seem to work for my car... its was actually more fun in reverse... and as a added bonus i dont have any squeaky brakes
Thanks for the update! Any excuse will do for me, so now i can do reverse drifting in order to fix my brake pad noise
Appreciate 0
      02-06-2009, 12:17 AM   #13
manyways
Private First Class
manyways's Avatar
1
Rep
135
Posts

Drives: E90 335i M-Sport
Join Date: May 2007
Location: Melbourne, AU

iTrader: (0)

Quote:
Originally Posted by kimbo View Post
hey alll

Just a little update on my squeaky brakes issue. Well I did alot of reading on this forum and came across some helpful infomation and things to try before taking it to the shop.

Well from what I read is that I should put the car in reverse and then slam on the brakes. I tried this a few time and to my surprise this actually worked. Its been a week now and still no noise from my brakes.

ansch - i tried what you suggested .. as fun as it was, it didnt seem to work for my car... its was actually more fun in reverse... and as a added bonus i dont have any squeaky brakes
my car started this a few 1000ks ago as well, its annoying....goin to try this later and see if it works...
Appreciate 0
      02-06-2009, 01:14 AM   #14
Wake27
Lieutenant Colonel
Wake27's Avatar
United_States
20
Rep
1,682
Posts

Drives: '06 330i ZPP ZSP
Join Date: Dec 2008
Location: NoVA missing SoCal

iTrader: (1)

Pretty sure its a huge BMW thing. I've seen a lot about it on this forum. My dad's 5 and my 3 both do it. It comes and goes, with no realtion to the weather. BMW didn't do anything for it.
__________________
2006 JB 330i/ZPP/ZSP/I-Drive/Heated Seats/L7/Blacklines/19" Gunmetal V710's on Vredestein Ultrac Sessantas/BMS PBX/Red MFD Scoops/Matte black grilles/Matte black Amber Gone 2.0s/BSW center midrange speaker/35% tint/Black and white roundels
Appreciate 0
      02-07-2009, 09:10 AM   #15
Bliss
Private
Australia
4
Rep
51
Posts

Drives: e90
Join Date: Nov 2006
Location: Sydney, Australia

iTrader: (0)

I've got it too guys. It is quite embarrassing . I will try the reverse thing tomorrow and let you know how i go.
Appreciate 0
      02-08-2009, 09:05 PM   #16
qkdwksha
qkdwksha's Avatar
Australia
1
Rep
90
Posts

Drives: E90 320i
Join Date: Jan 2009
Location: sydney

iTrader: (0)

i think i have exactly same problem. indeed i was just about to call bmw sydney to book for service. squicky noise at whatver speed and hand brake issues as well.
wish me luck boys it might have tough arguement trying to get it fixed^^;;;
Appreciate 0
      02-09-2009, 05:43 PM   #17
kimbo
Private
Australia
3
Rep
65
Posts

Drives: E90
Join Date: Sep 2008
Location: sydney

iTrader: (0)

This seems like a very common problem. I wonder why they havent done anything about it. Well please keep us updated on how it goes.
Appreciate 0
      02-09-2009, 06:12 PM   #18
Alpha
Enlisted Member
0
Rep
39
Posts

Drives: 07 335
Join Date: Feb 2009
Location: Anywhere

iTrader: (0)

Hey guys this is actually a very common problem with the new bmws. I think it has to do something with the fact that they use dual brake sensors. My car has the same problem.

Anyway, you should print out this service bulletin and show it to the service person.

http://www.bmwtis.com/tsb/bulletins/...p/B340808g.htm
Appreciate 0
      02-09-2009, 09:42 PM   #19
qkdwksha
qkdwksha's Avatar
Australia
1
Rep
90
Posts

Drives: E90 320i
Join Date: Jan 2009
Location: sydney

iTrader: (0)

oh great!! thanks for that alpha, i am taking mine this friday to bmw sydney....
Appreciate 0
      02-10-2009, 01:26 AM   #20
Chris.G
Banned
Chris.G's Avatar
Australia
46
Rep
3,122
Posts

Drives: 2011 LCI MSPORT X5 30d
Join Date: Aug 2006
Location: Sydney, Australia

iTrader: (0)

Thanks Alpha! Im also going to take this to BMW Sydney to get brake pad replacements.
Appreciate 0
      02-10-2009, 06:15 AM   #21
kash_0
Private
Australia
0
Rep
96
Posts

Drives: F30 328 MSport
Join Date: Feb 2007
Location: Sydney

iTrader: (0)

Quote:
Originally Posted by Chris.G View Post
Thanks Alpha! Im also going to take this to BMW Sydney to get brake pad replacements.
Quote:
Originally Posted by qkdwksha View Post
oh great!! thanks for that alpha, i am taking mine this friday to bmw sydney....
Hey guys,
Let me know how the both of you go, my brakes love to squeal so might give this service bulletin a go as well.

Cheers,
Appreciate 0
      02-10-2009, 09:10 PM   #22
Alpha
Enlisted Member
0
Rep
39
Posts

Drives: 07 335
Join Date: Feb 2009
Location: Anywhere

iTrader: (0)

Also when you go to your dealer, they might insist on cleaning and sanding the brakes. This will only fix the problem temporarily and it will come back later. When you bring the service bulletin with you, tell them that you already tried to clean the brakes and that it only delays the problem. I have researched this problem alot and the only fix that works includes them replacing something(brake pads, brake lingings, caliphers,). Usually they replace all these things togther, just make sure you look at your service receipt to see what they replaced or otherwise did.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:19 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST