E90Post
 


 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > Climate control. Do I have a problem?



Reply
 
Thread Tools Search this Thread
      01-19-2009, 05:29 PM   #1
MEGA
Dieseasal
MEGA's Avatar
United Kingdom
108
Rep
6,849
Posts

 
Drives: LCI E92 335d M-Sport
Join Date: Jan 2009
Location: Harrow, London

iTrader: (2)

Send a message via MSN to MEGA
Climate control. Do I have a problem?

I have an E90 M-sport so dual zone climate control.


Basically I put it up to 28 degrees both sides, full power on the fan, And I hear no fan noise at all, and after 20+mins I still feel cold in the cabin. The center vent on full Red mode gives a tiny bit of warm air but the side vents are barely producing anything at all. Basically main question is on full fan, should I be hearing anything? And how long does it take to warm me up. My old 1994 nissan warmed me up faster than this..

Do I need to take the car to BMW, or is the climate control just shit lol. What do you think guys?
Appreciate 0
      01-19-2009, 05:33 PM   #2
willhollin
Major General
willhollin's Avatar
England
123
Rep
9,918
Posts

 
Drives: VW T5
Join Date: Apr 2008
Location: Worcestershire

iTrader: (1)

Garage List
Sure you havent got it set to fahrenheit?
__________________
Appreciate 0
      01-19-2009, 05:35 PM   #3
MEGA
Dieseasal
MEGA's Avatar
United Kingdom
108
Rep
6,849
Posts

 
Drives: LCI E92 335d M-Sport
Join Date: Jan 2009
Location: Harrow, London

iTrader: (2)

Send a message via MSN to MEGA
LOL yes.

Serious opinion appreciated also by the way
Appreciate 0
      01-19-2009, 05:36 PM   #4
willhollin
Major General
willhollin's Avatar
England
123
Rep
9,918
Posts

 
Drives: VW T5
Join Date: Apr 2008
Location: Worcestershire

iTrader: (1)

Garage List
Quote:
Originally Posted by MEGA View Post
LOL yes.

Serious opinion appreciated also by the way
Ooops sorry.

Seriously it doesn't sound correct.

My fan on full blast is plenty loud enough.

Best get it checked.
__________________
Appreciate 0
      01-19-2009, 05:42 PM   #5
TMP
Colonel
TMP's Avatar
United Kingdom
60
Rep
2,882
Posts

 
Drives: M135i
Join Date: Nov 2008
Location: Cheshire

iTrader: (0)

Is it in AUTO or have you selected which vents air are on?

Either way, sounds fooked to me. I start to get warm air after about 1 mile, then fan ramps up after a couple more.
__________________
M-Lite v2 & Family 5er v2
Appreciate 0
      01-19-2009, 05:44 PM   #6
MEGA
Dieseasal
MEGA's Avatar
United Kingdom
108
Rep
6,849
Posts

 
Drives: LCI E92 335d M-Sport
Join Date: Jan 2009
Location: Harrow, London

iTrader: (2)

Send a message via MSN to MEGA
Anyone around north or west of london that could quickly have a passenger seat and confirm so I'm 100% sure before I take it to dealer? Dealer is in blimmin Reigate, 3 hour round trip for me...

Although it sounds like there is indeed an issue..
Appreciate 0
      01-19-2009, 05:45 PM   #7
MEGA
Dieseasal
MEGA's Avatar
United Kingdom
108
Rep
6,849
Posts

 
Drives: LCI E92 335d M-Sport
Join Date: Jan 2009
Location: Harrow, London

iTrader: (2)

Send a message via MSN to MEGA
ps - selected, front facing vent only. no noise, barely anything coming out any of the front 4 vents.
Appreciate 0
      01-19-2009, 05:46 PM   #8
booforty
Major General
booforty's Avatar
United Kingdom
129
Rep
8,813
Posts

 
Drives: E92 M3
Join Date: Mar 2005
Location: London, UK

iTrader: (0)

Garage List
2008 E92 M3  [0.00]
Simply press auto and select a warm temperature

If the fans don't start up, you have a problem
Appreciate 0
      01-19-2009, 05:47 PM   #9
willhollin
Major General
willhollin's Avatar
England
123
Rep
9,918
Posts

 
Drives: VW T5
Join Date: Apr 2008
Location: Worcestershire

iTrader: (1)

Garage List
Any dealer will do. Is it still in warranty or have a AUC warranty
__________________
Appreciate 0
      01-19-2009, 05:49 PM   #10
MEGA
Dieseasal
MEGA's Avatar
United Kingdom
108
Rep
6,849
Posts

 
Drives: LCI E92 335d M-Sport
Join Date: Jan 2009
Location: Harrow, London

iTrader: (2)

Send a message via MSN to MEGA
Main dealer warranty for 8 months (H) Good to know any will do. I'm new to this Cheers.
Appreciate 0
      01-19-2009, 05:50 PM   #11
willhollin
Major General
willhollin's Avatar
England
123
Rep
9,918
Posts

 
Drives: VW T5
Join Date: Apr 2008
Location: Worcestershire

iTrader: (1)

Garage List
Quote:
Originally Posted by MEGA View Post
Main dealer warranty for 8 months (H) Good to know any will do. I'm new to this Cheers.
Sure someone will point to your nearest decent stealer.
__________________
Appreciate 0
      01-19-2009, 05:51 PM   #12
MEGA
Dieseasal
MEGA's Avatar
United Kingdom
108
Rep
6,849
Posts

 
Drives: LCI E92 335d M-Sport
Join Date: Jan 2009
Location: Harrow, London

iTrader: (2)

Send a message via MSN to MEGA
It had better be free of f**king charge to get sorted..
Appreciate 0
      01-19-2009, 06:02 PM   #13
ed335d
Major General
ed335d's Avatar
United Kingdom
81
Rep
6,899
Posts

 
Drives: E92 M3
Join Date: Jun 2008
Location: Surrey, UK

iTrader: (3)

Garage List
57 e92 M3  [5.00]
2008 e92 335d  [0.00]
Quote:
Originally Posted by MEGA View Post
Anyone around north or west of london that could quickly have a passenger seat and confirm so I'm 100% sure before I take it to dealer? Dealer is in blimmin Reigate, 3 hour round trip for me...

Although it sounds like there is indeed an issue..
I'm in Northwood tomorrow, depending on meetings and how long they gone on for, may be around late afternoon. I could swing past on the way home if you still want a second op? If yup, PM me your number
__________________
E92 M3, Jerez Black, Fox Red Novillo, 19'' M Double Spoke, folding mirrors, lumbar support, front seat heating, PDC, USB, DAB, EDC, Bluetooth, Logic 7, High Gloss Shadowline, big smile
Appreciate 0
      01-19-2009, 06:05 PM   #14
F104
Captain
Belgium
8
Rep
727
Posts

 
Drives: E92 320D M-sport
Join Date: Apr 2008
Location: belgium

iTrader: (0)

Quote:
Originally Posted by MEGA View Post
I have an E90 M-sport so dual zone climate control.


Basically I put it up to 28 degrees both sides, full power on the fan, And I hear no fan noise at all, and after 20+mins I still feel cold in the cabin. The center vent on full Red mode gives a tiny bit of warm air but the side vents are barely producing anything at all. Basically main question is on full fan, should I be hearing anything? And how long does it take to warm me up. My old 1994 nissan warmed me up faster than this..

Do I need to take the car to BMW, or is the climate control just shit lol. What do you think guys?
I play around with mine a lot. 'Auto' is great but when fan noise goes over 3-4 blocks on the indicator that is too much for me. Full fan has got to be an audible nuisance. The system should go to full fan speed if you hit de defrost button above the airco. Now that is audible..
Appreciate 0
      01-19-2009, 06:13 PM   #15
MEGA
Dieseasal
MEGA's Avatar
United Kingdom
108
Rep
6,849
Posts

 
Drives: LCI E92 335d M-Sport
Join Date: Jan 2009
Location: Harrow, London

iTrader: (2)

Send a message via MSN to MEGA
Right then theres definitely an issue. Cheers for clearing it up, Don't think I need anyone to listen in on the car.
Appreciate 0
      01-20-2009, 04:09 PM   #16
ShereKhan
Captain
ShereKhan's Avatar
United Kingdom
14
Rep
995
Posts

 
Drives: 2010 Skoda Octavia 2.0 TDi SE
Join Date: Sep 2006
Location: Bristol, UK

iTrader: (0)

Garage List
2006 E90 320si  [0.00]
I'd be interested to know what the stealer says is wrong.

I have had some nasty burning smell on my heater but the stealer couldn't smell anything. I've had the same problem that you describe when its on auto setting. When it was very cold out (-4) then it took 10+ mins to warm up.

It seems to take 5 mins or so in the current weather (+5)
__________________
New Company car 2011 BMW F10 520D SE Xirallic Imperial blue/Cinnamon Brown 6FL USB, Front Sports seats, Sports steering wheel, Xenons - Arrived 3rd Dec 2010!
Scrapped RIP 12/08/2010 - E90 320si - Le Mans Blue - Totally standard specification
Long gone - 00 Peugeot 306 2.0 SE Cabriolet, 94 Rover 214 SEi, 91 Fiat Uno 60S Mk2
Appreciate 0
      01-20-2009, 05:13 PM   #17
MEGA
Dieseasal
MEGA's Avatar
United Kingdom
108
Rep
6,849
Posts

 
Drives: LCI E92 335d M-Sport
Join Date: Jan 2009
Location: Harrow, London

iTrader: (2)

Send a message via MSN to MEGA
I have that smell sort of, but don't really care about that. For me, fans don't work at all. Just tested it while installing a Kensington liquidAUX and playing with the iPod. No fans at any speed at any setting auto or not, and no warmth after 10+ minutes as I was stationary. If I Drive, then a small amount of warm comes out the middle vent as its set on red, but thats it. Stationary, absolutely nothing at all.

Its booked in next monday, will keep you updated.
Appreciate 0
      01-20-2009, 06:51 PM   #18
E92 LeMans
Second Lieutenant
E92 LeMans's Avatar
United Kingdom
4
Rep
294
Posts

 
Drives: E92 330d M Sport
Join Date: Dec 2008
Location: London

iTrader: (0)

Garage List
Sorry mate just seen this post if you want me to have a look I can I am only 5 miles away.
__________________
Appreciate 0
      01-21-2009, 03:15 AM   #19
MEGA
Dieseasal
MEGA's Avatar
United Kingdom
108
Rep
6,849
Posts

 
Drives: LCI E92 335d M-Sport
Join Date: Jan 2009
Location: Harrow, London

iTrader: (2)

Send a message via MSN to MEGA
Its cool now, theres definitely a problem with it so will let dealer sort it.

I wish the electronics worked as well as the the car drove Been a pain in the ass so far...
Appreciate 0
      01-21-2009, 04:48 AM   #20
Mud
Captain
United Kingdom
14
Rep
681
Posts

 
Drives: E90 320d
Join Date: Nov 2008
Location: England

iTrader: (0)

Yep there is defo a problem, the fan just like an most cars will make a loud noise at max.

In the older cars (E46 etc) the 'hedgehog' would need changing.
Appreciate 0
      01-21-2009, 05:34 AM   #21
MEGA
Dieseasal
MEGA's Avatar
United Kingdom
108
Rep
6,849
Posts

 
Drives: LCI E92 335d M-Sport
Join Date: Jan 2009
Location: Harrow, London

iTrader: (2)

Send a message via MSN to MEGA
Cheers Mud.

Andy's told me theres a resistor coil basically thats probably gone, I forget the exact words he said. Said it was a very common fault on the E46s and it seems like this is whats happened to my E90 so backs up what your saying as well. However I searched for the Hedgehog problem, and most people tend to say that the fans stay on all the time rather than them not working at all (IE even with engine off and car locked the fans are still going. ) - Might just be a new generation of a similar problem. You the E46 expert though does that sound right?

Its a quick job to repair if its just the resistor, so I hope so. They picking it up morning giving it back before home time I'd rather not be without a car overnight..
Appreciate 0
      01-21-2009, 06:20 AM   #22
Mud
Captain
United Kingdom
14
Rep
681
Posts

 
Drives: E90 320d
Join Date: Nov 2008
Location: England

iTrader: (0)

The FSR (final stage resistor) would typically go mad and stay on full etc even when the car was off, but the opposite is also true, in that the fan could just stop working and it would be that same issue.

Saying that though the FSR would often just freeze and all it sometimes takes is for the fuse to be pulled out and put back after a minute or so and it would kick start the FSR into working again.

Try the fuse first (in the E46 it was a 30amp fuse), if no joy then FSR replacement next.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:15 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST