E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > loss power after installed intake?



Reply
 
Thread Tools Search this Thread
      01-21-2009, 10:24 PM   #1
ah gon
Colonel
ah gon's Avatar
Canada
36
Rep
2,330
Posts

 
Drives: bmw e90
Join Date: Feb 2007
Location: vancouver b.c. canada

iTrader: (12)

loss power after installed intake?

i currently used a simota intake for few weeks and eisenmann race for around year.but today when i drive my car feel loss power,pull hard than usual.and the intake sound r not loud than in usual(mostly sound will loud on almost 3000rpm)but after turn off the car and start again.the car is turn back to normal.all i feel is something like have something blocked the intake,but i believe it's impossible.is anyone have this problem?wish u guys can help.
__________________
Appreciate 0
      01-21-2009, 10:37 PM   #2
pittyinSC
Drives Smart
pittyinSC's Avatar
United_States
26
Rep
2,386
Posts

 
Drives: 2008 BMW M5 SG/Blk 6spd
Join Date: Jan 2007
Location: Charleston, SC

iTrader: (2)

Garage List
2006 330i  [0.00]
Send a message via AIM to pittyinSC
I have had this problem before. Does it feel like the car revs a few hundred rpm by itself and well rev's very slowly as well. Revs a little during shifts 2?
__________________

08 BMW ///M5 Space Gray/Black 6 speed
Engine: RPi GTS exhaust, RPi Scoops, Carbon Filter Delete
Exterior: Glossy Black Kidneys, LUX V3, OEM LED License Plate light, Bruce License Plate Adapter
Appreciate 0
      01-21-2009, 10:44 PM   #3
sirantsE90
Lieutenant Colonel
sirantsE90's Avatar
22
Rep
1,743
Posts

 
Drives: N51 E90
Join Date: Oct 2008
Location: East Northport, LI

iTrader: (13)

Garage List
2008 328i  [0.00]
Quote:
Originally Posted by ah gon View Post
i currently used a simota intake for few weeks and eisenmann race for around year.but today when i drive my car feel loss power,pull hard than usual.and the intake sound r not loud than in usual(mostly sound will loud on almost 3000rpm)but after turn off the car and start again.the car is turn back to normal.all i feel is something like have something blocked the intake,but i believe it's impossible.is anyone have this problem?wish u guys can help.
maf problem?? i dnt have an intake yet but on previous cars of mine that happened with a bad maf sensor? hope it helps gl
__________________
BMW CCA # 473001
Appreciate 0
      01-21-2009, 10:46 PM   #4
ah gon
Colonel
ah gon's Avatar
Canada
36
Rep
2,330
Posts

 
Drives: bmw e90
Join Date: Feb 2007
Location: vancouver b.c. canada

iTrader: (12)

Quote:
Originally Posted by umcool911ok View Post
I have had this problem before. Does it feel like the car revs a few hundred rpm by itself and well rev's very slowly as well. Revs a little during shifts 2?
no.....just feel the rpm not going fast than usual when i rev. my car.also,start drive at 1st gear feel the car loss power.like the air cond. turned on but that's not.forgot to mention,i didn't warm up my car and have a high rev. right after.
__________________
Appreciate 0
      01-22-2009, 03:30 PM   #5
ah gon
Colonel
ah gon's Avatar
Canada
36
Rep
2,330
Posts

 
Drives: bmw e90
Join Date: Feb 2007
Location: vancouver b.c. canada

iTrader: (12)

up.....anyone has this problem?
__________________
Appreciate 0
      01-25-2009, 11:39 AM   #6
chesterfan1230
Colonel
chesterfan1230's Avatar
51
Rep
2,561
Posts

 
Drives: a Bat Mobile :)
Join Date: Apr 2008
Location: NJ

iTrader: (10)

Garage List
2012 335iS  [0.00]
Send a message via AIM to chesterfan1230
Majority of aftermarket Intakes for the n52 show in their DYNO's that there is a slight loss of Engine Horse Power in the lower RPM's. The real gain is in the higher RPM's, so if you wanna feel the power start the car in 1st gear every time and shift at 5k rpm every time. I have had several aftermarket Intakes for the e90 n52, and know exactly what it is lol. If you want sound just get the BMW performance exhaust buddy.
__________________
Current: 2012 335iS
Past: 2006 e90 325xi, 2010 135i
Appreciate 0
      01-25-2009, 12:46 PM   #7
ah gon
Colonel
ah gon's Avatar
Canada
36
Rep
2,330
Posts

 
Drives: bmw e90
Join Date: Feb 2007
Location: vancouver b.c. canada

iTrader: (12)

Quote:
Originally Posted by sirantsE90 View Post
maf problem?? i dnt have an intake yet but on previous cars of mine that happened with a bad maf sensor? hope it helps gl
i found that the connector to the maf senor of the intake they look like not tight.now i used the tape to tight the connector.now i haven't have the problem again for now.my friend told me i maybe in (lim mode?),so the car totally loss power.but they turn back to normal after restart again.
Quote:
Originally Posted by chesterfan1230 View Post
Majority of aftermarket Intakes for the n52 show in their DYNO's that there is a slight loss of Engine Horse Power in the lower RPM's. The real gain is in the higher RPM's, so if you wanna feel the power start the car in 1st gear every time and shift at 5k rpm every time. I have had several aftermarket Intakes for the e90 n52, and know exactly what it is lol. If you want sound just get the BMW performance exhaust buddy.
for my simota,i don't really feel loss power in lower rpm...maybe they loss very little so i can't feel it.
__________________
Appreciate 0
      01-25-2009, 07:36 PM   #8
chesterfan1230
Colonel
chesterfan1230's Avatar
51
Rep
2,561
Posts

 
Drives: a Bat Mobile :)
Join Date: Apr 2008
Location: NJ

iTrader: (10)

Garage List
2012 335iS  [0.00]
Send a message via AIM to chesterfan1230
Yea it's low. But then again
Any time I install my OEM Intake even with a small gap, I feel it lmao.
I guess i"M jt really sensitive.
__________________
Current: 2012 335iS
Past: 2006 e90 325xi, 2010 135i
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:34 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST