E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Car running weird/throwing codes



Reply
 
Thread Tools Search this Thread
      01-25-2009, 11:28 PM   #1
pittyinSC
Drives Smart
pittyinSC's Avatar
United_States
26
Rep
2,386
Posts

 
Drives: 2008 BMW M5 SG/Blk 6spd
Join Date: Jan 2007
Location: Charleston, SC

iTrader: (2)

Garage List
2006 330i  [0.00]
Send a message via AIM to pittyinSC
Exclamation Car running weird/throwing codes

Ok so this could be a big deal or a really small deal. Maybe you people can decide my fate?

First of all here is something that happens....well never, maybe once every month or two. I start up my car and it does not want to rev even sitting in neutral. I let it warm up and the intake/engine becomes very loud while driving, but the car does not want to rev really quick at all.(even floored it takes forever to rev)...then when I shut off my car once or twice it runs like normal and everything is fine.

Recently I have been checking codes everyday on my car just to make sure. My car is not actually throwing any CEL's at all, but it is storing usually about 3 or 4 different codes and sometimes none at all. The code reader says "Fault will not set off CEL" and "Fault not present" everytime.

One of them that scared me was this.

1) Crankshaft exhaust cam correlation ( I am not sure if bad or not, but I am gonna get it checked out)

All the rest dont seem back.

One is E18C reader is bad or something and the is saying something about a MAP position sensor or something.

These codes do not happen every day and nothing pops up. My car runs fine even though it is extremely slow. My head does tick a ton though. I get over 30mpg highway and well I am still not sure about it, but I will write down the codes tomorrow if any are thrown.
__________________

08 BMW ///M5 Space Gray/Black 6 speed
Engine: RPi GTS exhaust, RPi Scoops, Carbon Filter Delete
Exterior: Glossy Black Kidneys, LUX V3, OEM LED License Plate light, Bruce License Plate Adapter
Appreciate 0
      01-26-2009, 03:25 AM   #2
TommyK
Brigadier General
TommyK's Avatar
United_States
51
Rep
3,326
Posts

 
Drives: E90 335i LCI
Join Date: Aug 2008
Location: Orange County, CA

iTrader: (9)

Garage List
2009 BMW 335i LCI  [0.00]
2006 E90 330i  [0.00]
Send a message via AIM to TommyK
Ya ugh no idea. When there's a doubt, just have it checked out. but it doesnt sound good.
Appreciate 0
      01-26-2009, 04:24 AM   #3
heemry328i
Banned
15
Rep
903
Posts

 
Drives: 08' SG E90
Join Date: Jan 2008
Location: SF 415

iTrader: (6)

Send a message via AIM to heemry328i
bring it in to the dealership n get it checked out
Appreciate 0
      02-02-2009, 12:21 AM   #4
Andrew@ET
Brigadier General
73
Rep
4,039
Posts

 
Drives: Red thing
Join Date: May 2007
Location: Earth

iTrader: (9)

take off all intakes and such asap
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:38 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST