E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY - M5 SMG Shift Knob Wiring Retrofit Kit



Reply
 
Thread Tools Search this Thread
      04-07-2009, 10:21 PM   #67
allstar8
Whitney
allstar8's Avatar
United_States
4
Rep
56
Posts

Drives: 2008!
Join Date: Jan 2009
Location: NJ

iTrader: (3)

Okay, I can do the wiring for those of you don't want to make it.

$60 parts + $40 labor =$100 (wiring only)

PM me if interested.

Last edited by allstar8; 04-08-2009 at 11:57 AM.
Appreciate 0
      04-08-2009, 12:36 AM   #68
chrisE92
Brigadier General
chrisE92's Avatar
United_States
93
Rep
4,495
Posts

Drives: Monaco Blue E92
Join Date: Sep 2007
Location: LA to HB

iTrader: (21)

Quote:
Originally Posted by a l l a n View Post
Yep, the wiring is quite simple.

The bushing/pin contacts I have on this DIY already come with the wires. All you need to do is insert the contacts into the appropriate housing and join/connect the wires per the harness connection instructions. No soldering required. These are small wires so twisting them to join them together is more than enough.

This requires a very basic wiring process so you don't need to know much about wiring to do this DIY.
nice! gonna place an order for everything ASAP thank you again
__________________
Appreciate 0
      04-10-2009, 07:54 PM   #69
ChrisMT79
Lieutenant Colonel
ChrisMT79's Avatar
United_States
192
Rep
1,522
Posts

Drives: 2015 F80 M3- Alpine White
Join Date: Sep 2007
Location: Everywhere

iTrader: (6)

Anyone tried this for the new DCT shifter?
Appreciate 0
      04-10-2009, 11:11 PM   #70
phattbam
Major General
phattbam's Avatar
United_States
92
Rep
5,809
Posts

Drives: //M Sport
Join Date: Sep 2007
Location: sf area

iTrader: (21)

Quote:
Originally Posted by Chrisalano22 View Post
Anyone tried this for the new DCT shifter?
I have been busy with that project that I've tried since last year. Lemme try to get the wiring harness done and I'll let you know.

check this out though.

http://www.e90post.com/forums/showthread.php?t=182980

^^ still a work in progress after all this time.
Appreciate 0
      04-22-2009, 04:12 AM   #71
Reggie@MWDesign
Reggie@MWDesign's Avatar
Canada
45
Rep
1,532
Posts

Drives: AW E92 3Twenty8xi
Join Date: Jan 2008
Location: 403 Canada

iTrader: (13)

Garage List
2007 E92 328xi  [0.00]
i am having problems,

when i am sitting in the car and the car is turned off and key is out of the ignition, and the gear selector is in "P" the Arrows & D/S indicators on the knob light up one in a while, and then then when i turn on the dome lights they go off again.

I am wondering if this is normal or is my wiring in correct.

I also can't figure out why when i move the selector to R both the R and N on both the knob and console light up...
Appreciate 0
      04-22-2009, 05:03 AM   #72
Reggie@MWDesign
Reggie@MWDesign's Avatar
Canada
45
Rep
1,532
Posts

Drives: AW E92 3Twenty8xi
Join Date: Jan 2008
Location: 403 Canada

iTrader: (13)

Garage List
2007 E92 328xi  [0.00]
not sure if anyone can remember but does all the led along the door stay on all the time..... cause stays one along with the cig light ring light.
Appreciate 0
      04-22-2009, 05:45 PM   #73
Reggie@MWDesign
Reggie@MWDesign's Avatar
Canada
45
Rep
1,532
Posts

Drives: AW E92 3Twenty8xi
Join Date: Jan 2008
Location: 403 Canada

iTrader: (13)

Garage List
2007 E92 328xi  [0.00]
Appreciate 0
      04-22-2009, 05:57 PM   #74
...
Private
United_States
0
Rep
60
Posts

Drives: a car
Join Date: Jan 2009
Location: Dreamland

iTrader: (1)

Wiring must be wrong, mine never lights up two at once.
Appreciate 0
      04-23-2009, 02:06 AM   #75
absix
Mu mu muh muli, maikouuu!
absix's Avatar
31
Rep
1,283
Posts

Drives: F10 M5; F25 2.0d;
Join Date: Feb 2008
Location: Europe

iTrader: (10)

Reggie, unfortunately you'll have to open it again and check the connectors again. I had the same problem during my install yesterday. Although the connectors were just fine, a little twisting on one of them solved the problem!
__________________
Appreciate 0
      04-23-2009, 02:39 PM   #76
Reggie@MWDesign
Reggie@MWDesign's Avatar
Canada
45
Rep
1,532
Posts

Drives: AW E92 3Twenty8xi
Join Date: Jan 2008
Location: 403 Canada

iTrader: (13)

Garage List
2007 E92 328xi  [0.00]
Quote:
Originally Posted by absix View Post
Reggie, unfortunately you'll have to open it again and check the connectors again. I had the same problem during my install yesterday. Although the connectors were just fine, a little twisting on one of them solved the problem!
what do you mean?

like just move the wires around?

another problem i noticed is that the ambient lighting on the door (orange LED on the E92's) stay on FOREVER and same with the cig light and the audio controls.
Appreciate 0
      04-24-2009, 06:36 AM   #77
absix
Mu mu muh muli, maikouuu!
absix's Avatar
31
Rep
1,283
Posts

Drives: F10 M5; F25 2.0d;
Join Date: Feb 2008
Location: Europe

iTrader: (10)

Yes, move the wires close to connectors around while testing the gears. You'll eventually find the ones causing the trouble.

I have lights package (lightning on the inside of the door) and it's always on?
__________________
Appreciate 0
      04-24-2009, 08:38 PM   #78
a l l a n
Captain
United_States
30
Rep
929
Posts

Drives: E90 2007 328xi
Join Date: Dec 2006
Location: LIC NY / Central NJ

iTrader: (1)

Garage List
2007 E90 328xi  [0.00]
Reggie, you're issue is most likely a wiring issue. You should recheck your connections.

Quote:
Originally Posted by Reggie@MWDesign View Post
i am having problems,

when i am sitting in the car and the car is turned off and key is out of the ignition, and the gear selector is in "P" the Arrows & D/S indicators on the knob light up one in a while, and then then when i turn on the dome lights they go off again.

I am wondering if this is normal or is my wiring in correct.

I also can't figure out why when i move the selector to R both the R and N on both the knob and console light up...
__________________
E90 2007 / Step / Montego Blue / Black Dakota Leather / Premium / Cold Weather
MODS
: Exterior: Blacklines, debadged, HO ceramic 35% tint, Hoen yellow fogs, matte black grille, OEM style splitters, Halogen-to-Xenon Interior: Alum pedals, CF wrapped trim, V1 and Nuvi hardwire, M-Tech tri-stitched wheel, SMG M5 shift knob Performance: AluFelgen CSL 19" 8.5 ET33/9.5 ET30 with 5mm rear spacers | GY Eagle F1 Asym 235/265, KW V3, BMW Perf exhaust+intake
Appreciate 0
      04-24-2009, 08:40 PM   #79
a l l a n
Captain
United_States
30
Rep
929
Posts

Drives: E90 2007 328xi
Join Date: Dec 2006
Location: LIC NY / Central NJ

iTrader: (1)

Garage List
2007 E90 328xi  [0.00]
Quote:
Originally Posted by absix View Post
Reggie, unfortunately you'll have to open it again and check the connectors again. I had the same problem during my install yesterday. Although the connectors were just fine, a little twisting on one of them solved the problem!
Are you using the parts I supplied on this DIY? If yes then you shouldn't be having any loose connections/connectors.

Quote:
Originally Posted by absix View Post
Yes, move the wires close to connectors around while testing the gears. You'll eventually find the ones causing the trouble.
Not quite sure I'm following you.
__________________
E90 2007 / Step / Montego Blue / Black Dakota Leather / Premium / Cold Weather
MODS
: Exterior: Blacklines, debadged, HO ceramic 35% tint, Hoen yellow fogs, matte black grille, OEM style splitters, Halogen-to-Xenon Interior: Alum pedals, CF wrapped trim, V1 and Nuvi hardwire, M-Tech tri-stitched wheel, SMG M5 shift knob Performance: AluFelgen CSL 19" 8.5 ET33/9.5 ET30 with 5mm rear spacers | GY Eagle F1 Asym 235/265, KW V3, BMW Perf exhaust+intake
Appreciate 0
      04-24-2009, 09:46 PM   #80
Reggie@MWDesign
Reggie@MWDesign's Avatar
Canada
45
Rep
1,532
Posts

Drives: AW E92 3Twenty8xi
Join Date: Jan 2008
Location: 403 Canada

iTrader: (13)

Garage List
2007 E92 328xi  [0.00]
Quote:
Originally Posted by a l l a n View Post
Are you using the parts I supplied on this DIY? If yes then you shouldn't be having any loose connections/connectors.
yes 100%.
Appreciate 0
      04-24-2009, 09:51 PM   #81
a l l a n
Captain
United_States
30
Rep
929
Posts

Drives: E90 2007 328xi
Join Date: Dec 2006
Location: LIC NY / Central NJ

iTrader: (1)

Garage List
2007 E90 328xi  [0.00]
My question was for absix thus I quoted him.

Quote:
Originally Posted by Reggie@MWDesign View Post
yes 100%.
__________________
E90 2007 / Step / Montego Blue / Black Dakota Leather / Premium / Cold Weather
MODS
: Exterior: Blacklines, debadged, HO ceramic 35% tint, Hoen yellow fogs, matte black grille, OEM style splitters, Halogen-to-Xenon Interior: Alum pedals, CF wrapped trim, V1 and Nuvi hardwire, M-Tech tri-stitched wheel, SMG M5 shift knob Performance: AluFelgen CSL 19" 8.5 ET33/9.5 ET30 with 5mm rear spacers | GY Eagle F1 Asym 235/265, KW V3, BMW Perf exhaust+intake
Appreciate 0
      04-25-2009, 12:52 AM   #82
absix
Mu mu muh muli, maikouuu!
absix's Avatar
31
Rep
1,283
Posts

Drives: F10 M5; F25 2.0d;
Join Date: Feb 2008
Location: Europe

iTrader: (10)

Quote:
Originally Posted by a l l a n View Post
My question was for absix thus I quoted him.
Yes, but another member here assembled the wiring as per your DIY. I am 100% sure there was a slight problem with one of the connectors causing exactly what Reggie says. Gently "touch" of the cables near the connector solved it for me. Sorry, I can't explain it better, english is not my mother tongue.

Here's what I'd do.... open the center console while you see both R/N lightning up. Start with the connectors and move around the cables on each connector. You'll eventually see when you get to the one causing it.

One thing I could say for sure for my case, the connector was near the knob hardware, the actual hardware that moves the gears and it was touching the connector while changing gears. I had to move it away from it, so it not on the way.
__________________
Appreciate 0
      10-04-2009, 09:55 PM   #83
delmarco
First Lieutenant
delmarco's Avatar
United_States
36
Rep
302
Posts

Drives: 2011 335xi Deep Sea Blue
Join Date: Jul 2009
Location: Westchester County, NY

iTrader: (1)

Reggie any updates on how you solved your problem?
__________________



VISIT MY GARAGE TO SEE MY BMW MODS & PROJECTS:
E90 - http://directory.e46fanatics.com/use...Mod&UcId=20832
Appreciate 0
      10-15-2009, 07:27 PM   #84
exclusivo
Lieutenant Colonel
exclusivo's Avatar
48
Rep
1,822
Posts

Drives: race car
Join Date: Sep 2005
Location: queens, ny

iTrader: (11)

uhhh, how exactly do you replace the shift boot? im staring at my knob right now like wtf...do i cut the existing boot off and zip tie the old one in from the bottom?
Appreciate 0
      10-16-2009, 05:09 PM   #85
zke36
Second Lieutenant
zke36's Avatar
United_States
19
Rep
256
Posts

Drives: '07 Montego 335
Join Date: Sep 2009
Location: Bethesda, MD

iTrader: (1)

what kind of car is this a retrofit for??? (wont work with step will it?)
__________________

Porsche 935DP
'07 Montego E92 335i
BMS CAI - PROcede V4

Appreciate 1
      10-16-2009, 05:42 PM   #86
phattbam
Major General
phattbam's Avatar
United_States
92
Rep
5,809
Posts

Drives: //M Sport
Join Date: Sep 2007
Location: sf area

iTrader: (21)

Quote:
Originally Posted by zke36 View Post
what kind of car is this a retrofit for??? (wont work with step will it?)
it's actually for the step... it's using the ///M DCT (auto) shiftknob to replace the standard auto knob.
Appreciate 0
      10-18-2009, 01:46 PM   #87
Marcumac
Lieutenant Colonel
Marcumac's Avatar
United_States
26
Rep
1,528
Posts

Drives: M Roadster
Join Date: May 2009
Location: Cincinnati

iTrader: (6)

Garage List
Send a message via Skype™ to Marcumac
So is this newer version tried and true now? I've been reading up on the connection issues with ironic's harnesses, but you've made a more reliable version?
__________________

ZSP|ZPP|ZCW|PDC|19x9.5/10.5 Varrstoen ES 1.1.2|OEM Blacklines|LUX 5.1|Rear Euro fogs|Muffler delete|ECS kidneys|Gunsmoke Ambergones|Tinted JLevi sidemarkers|30% Llumar ATX|Corner Delete
Appreciate 0
      10-19-2009, 09:43 PM   #88
a l l a n
Captain
United_States
30
Rep
929
Posts

Drives: E90 2007 328xi
Join Date: Dec 2006
Location: LIC NY / Central NJ

iTrader: (1)

Garage List
2007 E90 328xi  [0.00]
Quote:
Originally Posted by Marcumac View Post
So is this newer version tried and true now? I've been reading up on the connection issues with ironic's harnesses, but you've made a more reliable version?
Been MIA from E90Post for quite a while but logged in so I can answer your question.

Yes, 100% working, no issues whatsoever since I created and installed mine. As long as you follow the directions correctly and use the parts I provided then your kit would be 100% working.
__________________
E90 2007 / Step / Montego Blue / Black Dakota Leather / Premium / Cold Weather
MODS
: Exterior: Blacklines, debadged, HO ceramic 35% tint, Hoen yellow fogs, matte black grille, OEM style splitters, Halogen-to-Xenon Interior: Alum pedals, CF wrapped trim, V1 and Nuvi hardwire, M-Tech tri-stitched wheel, SMG M5 shift knob Performance: AluFelgen CSL 19" 8.5 ET33/9.5 ET30 with 5mm rear spacers | GY Eagle F1 Asym 235/265, KW V3, BMW Perf exhaust+intake
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:02 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST