E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Problem with clutch grinding/rubbing?



Reply
 
Thread Tools Search this Thread
      02-20-2009, 05:09 AM   #1
Blackhawk693
Enlisted Member
 
Blackhawk693's Avatar
 
Drives: 09 328xi Sport, Ipod, HS
Join Date: Feb 2009
Location: Home of the best beer in the world.

Posts: 46
iTrader: (0)

Problem with clutch grinding/rubbing?

My 09 328i xdrive 6mt has about 900 miles on it and it recently started making a rubbing/metalic grind. I notice it after it's sufficiently warmed up and when the car is in neutral at stop lights and such. Only when its in neutral and the clutch pedal is out. It's a quiet and doesnt sound like anything i've heard in other autos. I stopped when i got home last night put it in neutral and stuck my head under the car and its definately coming from the transmission area. Anyone else had this problem? Im hopeing to get help from here rather than take to the dealership. Waste of my time.
__________________
2009 328i XDrive Montego Blue, ZSP, Dark Burl Walnut, heated seats, Black leather, Ipod, 17" wheels.
Blackhawk693 is offline   Germany
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:02 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST