E90Post
 


E92-lighting
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Warning Light - "Engine Malfunction - Reduced Power" - 2009 335i Sedan



Reply
 
Thread Tools Search this Thread
      03-07-2009, 04:16 PM   #1
RiversideE90
Enlisted Member
 
Drives: 2009 e90 335i
Join Date: Nov 2008
Location: Irvine, CA

Posts: 40
iTrader: (0)

Send a message via AIM to RiversideE90
Warning Light - "Engine Malfunction - Reduced Power" - 2009 335i Sedan

It is a nice saturday afternoon here in SoCal so I decided to wash my car. I wash it at my parents house who live about a mile away. I had just come back from the gym - car was fine. I get in to start the car again and I get "Engine Malfunction - Reduced Engine Power" warning. Turn the car off - start it again - warning goes away - car feels fine. Drive over to the parents, wash the car - everything seems good. Turn the car back on to go home and it takes it a second to turn on (cranking)...car starts...im about 1/2 way home and it gets SUPER shaky...light comes back on...

Is this the fuel pump problem showing up in the 09s? Anyone else have this in an 09?

I called the dealer and they of course cannot look at the car till Monday. So at the moment I am super pissed.

I do however have a nice clean, $50k car with less than 5k miles on it to sit in the garage for the weekend. Great.

Last edited by RiversideE90; 03-07-2009 at 05:01 PM.
RiversideE90 is offline   United_States
0
Reply With Quote
      03-07-2009, 04:32 PM   #2
bsamoul
Major General
 
bsamoul's Avatar
 
Drives: E90 325i
Join Date: Feb 2007
Location: Walnut Creek, California

Posts: 7,424
iTrader: (2)

Send a message via AIM to bsamoul
It's the fuel pump.
__________________
-Brian
2X 2006 BMW 325i [Electric Red & Mystic Blue] | ZPP | V1 | Rear Fogs | M3 Lip Spoiler | EAS RemoteKey | BMS Powerbox | Projector90 Headlights w/ LED AE | LED plate lights | OEM Blacklines
http://www.tech-shine.com
bsamoul is offline   No_Country
0
Reply With Quote
      03-07-2009, 04:38 PM   #3
methodtim
Brigadier General
 
methodtim's Avatar
 
Drives: 335i
Join Date: Mar 2007
Location: Darkness there, and nothing more

Posts: 3,636
iTrader: (0)

Garage List
Aw crap, now I'm scared. I have an 09 335i with 4k miles on it sitting in the garage too. I was really hoping that the HPFP issue was resolved some way, some how. Please keep us posted with your progress.
__________________

09 E90 335i |Monaco Blue |Step|ZPP|ZSP|ZCW | L7 | iPod | CA
methodtim is offline   Liechtenstein
0
Reply With Quote
      03-07-2009, 05:08 PM   #4
RiversideE90
Enlisted Member
 
Drives: 2009 e90 335i
Join Date: Nov 2008
Location: Irvine, CA

Posts: 40
iTrader: (0)

Send a message via AIM to RiversideE90
Car is going in Monday morning...I will keep the thread updated.
RiversideE90 is offline   United_States
0
Reply With Quote
      03-07-2009, 05:12 PM   #5
kidcolton
New Member
 
Drives: 2009 335 xdrive MT6
Join Date: Jan 2009
Location: toronto ontario

Posts: 7
iTrader: (0)

my 09 335xi at 2800km started to shake and lose power on the hiway, couldnt get over 3000rpm in any gear. my kids were freaked out. i needed gas at the time, so we stopped at the next station. filled up, started the car, and it was fine, like nothing ever happened. none of the warning lights on the dash came on. its now 6 weeks later, and the car has about 4500km on it and the problem has never reoccurred. thought it was just a computer glitch that needed resetting. for you american guys, thata about 1750miles and 2800 miles.

hope it is not the begginning of fuel pump problems.
kidcolton is offline  
0
Reply With Quote
      03-07-2009, 05:21 PM   #6
RiversideE90
Enlisted Member
 
Drives: 2009 e90 335i
Join Date: Nov 2008
Location: Irvine, CA

Posts: 40
iTrader: (0)

Send a message via AIM to RiversideE90
I just filled up yesterday using 91...about 3/4 a tank left.
RiversideE90 is offline   United_States
0
Reply With Quote
      03-07-2009, 08:01 PM   #7
shaddai
former N54 owner
 
shaddai's Avatar
 
Drives: 2008 Audi S4 DTM
Join Date: Mar 2008
Location: Bay Area, CA

Posts: 608
iTrader: (0)

Garage List
2008 335i  [0.00]
Welcome to HPFP hell.
__________________
+lemon
shaddai is offline   United_States
0
Reply With Quote
      03-07-2009, 09:27 PM   #8
mrbrett
Private First Class
 
mrbrett's Avatar
 
Drives: 2011 335is
Join Date: Oct 2007
Location: SoCal

Posts: 190
iTrader: (0)

I had one replaced, it's not hell anymore, they changed mine out in a few hours. It sucks but it's not that bad. It's a known issue and the dealers stock the HPFP, so they should be able to fix it same day. Mine went bad at like 500 miles, so you got farther than me, lol.
mrbrett is offline   United_States
0
Reply With Quote
      03-07-2009, 10:13 PM   #9
TTG
...
 
TTG's Avatar
 
Drives: 2011 E92 M3
Join Date: Aug 2006
Location: Seattle, WA

Posts: 2,849
iTrader: (2)

Garage List
Wow, it is still happening on the 09's as well.

Please keep us posted.
__________________
Retired: 2011 E92 M3 AW w/ Silver Novillo ZCP, ZTP, ZPP, 494, 6FL, 507, 302 & 415.....ED April 29th, 2010
Retired: 2007 E92 335i -Space Gray, Black Leatherette + Alum, Nav, ZCW, ZSP, PDC, CA & Sunshade.....ED Oct 19th, 2006
TTG is offline   United_States
0
Reply With Quote
      03-08-2009, 12:19 AM   #10
shaddai
former N54 owner
 
shaddai's Avatar
 
Drives: 2008 Audi S4 DTM
Join Date: Mar 2008
Location: Bay Area, CA

Posts: 608
iTrader: (0)

Garage List
2008 335i  [0.00]
Quote:
Originally Posted by cars4lyfe View Post
Is this happening to all turbo bmw cars or just 3 series? The new 7 only offers a turbo v8.
Pay closer attention. They have a slightly different tuned N54 in the 740i.
__________________
+lemon
shaddai is offline   United_States
0
Reply With Quote
      03-08-2009, 02:40 AM   #11
Dark_Sub_Rosa
Captain
 
Dark_Sub_Rosa's Avatar
 
Drives: Not sure
Join Date: May 2008
Location: Nashville, TN

Posts: 674
iTrader: (0)

HPFP. Mine went out at 10k miles. Everybody has theirs replaced.
__________________
R.I.P. Rolf..Ich vermisse dich
Dark_Sub_Rosa is offline   United_States
0
Reply With Quote
      03-08-2009, 10:32 AM   #12
tjnptel1
Cunning Linguist
 
tjnptel1's Avatar
 
Drives: 335i
Join Date: Apr 2007
Location: Norfolk, VA

Posts: 2,219
iTrader: (0)

Garage List
2007 335i  [0.00]
Quote:
Originally Posted by shaddai View Post
Welcome to HPFP hell.
it's not really that bad anymore.

It was hell before because they didn't have 'em in stock and cars had to be in shop ~ 30 days. Now it's just a matter of 1 - 2 work days.
__________________
Bottles are for babies, Real men get blown.
tjnptel1 is offline   United_States
0
Reply With Quote
      03-08-2009, 10:34 AM   #13
acuratech
Enlisted Member
 
Drives: 08 335i 4dr
Join Date: Feb 2009
Location: philadelphia

Posts: 35
iTrader: (1)

Garage List
93 honda delsol  [0.00]
08 335i sedan  [0.00]
nobody beats mine i got my 08 335 on a thursday night went to tint it on friday and it didnt start after getting tinted let it sit for 2 hours started and went to dealer they had my car for a week and i had a hot 335i loaner no regrets beating the hell out of it, oh and i had 78 miles on my car when this all happened
acuratech is offline  
0
Reply With Quote
      03-08-2009, 10:41 AM   #14
tjnptel1
Cunning Linguist
 
tjnptel1's Avatar
 
Drives: 335i
Join Date: Apr 2007
Location: Norfolk, VA

Posts: 2,219
iTrader: (0)

Garage List
2007 335i  [0.00]
Quote:
Originally Posted by acuratech View Post
nobody beats mine i got my 08 335 on a thursday night went to tint it on friday and it didnt start after getting tinted let it sit for 2 hours started and went to dealer they had my car for a week and i had a hot 335i loaner no regrets beating the hell out of it, oh and i had 78 miles on my car when this all happened
mine went in the shop for 30 days, while in the shop the loaner's HPFP went bad and ended up getting an X5 loaner.
__________________
Bottles are for babies, Real men get blown.
tjnptel1 is offline   United_States
0
Reply With Quote
      03-08-2009, 10:46 AM   #15
hanmaas
Lieutenant
 
hanmaas's Avatar
 
Drives: 335i
Join Date: Oct 2008
Location: Europe

Posts: 577
iTrader: (0)

Quote:
Originally Posted by RiversideE90 View Post
I just filled up yesterday using 91...about 3/4 a tank left.
You should NEVER use 91. Might be part of the reason why your pump is failing at this point in time.
__________________
hanmaas is offline   Germany
0
Reply With Quote
      03-08-2009, 10:50 AM   #16
Rando
Lieutenant
 
Drives: BMW
Join Date: Mar 2007
Location: CA

Posts: 486
iTrader: (0)

Yup, my HPFP seems to be at the end of its life too... at 29,800 miles. (I thought I was safe, since my car happened to be built out of BMW's "recall" date ranges.)

Definitely feels like EVERY car is going to have this problem at some point...

One interesting observation though: the wastegate actuators were *just* replaced a week ago... and now the HPFP fails. Coincidence? Or are they related? The engine was definitely a little stonger and lag was a little lower after the fix, so maybe that puts more load on the HPFP? (Completely wild guess on that one.)

Also, yes... it all started with a few engine malfunctions here and there ("Engine malfunction... reduced power" -- but NO "Service Engine Soon" light. Restarting cleared the code and restored the engine. [This was weeks/months ago -- maybe 3 times total.]

Then the engine got weak after some longer (~1 hour) trips... just not pulling properly, definitely reduced torque and HP. Eventually the "Engine malfunction" message came also, but still no "Service Engine Soon" light. [This was a few days ago.]

Then long cranks started... and the dreaded "Service Engine Soon" light came -- sometimes there were harsh engine vibrations, almost like one cylinder was not firing correctly. Sounded like a very old car. I am hoping there is one start left in it to take it to the dealer! [This was yesterday.]

I hope this info helps people identify when their fuel pump is on a bad path...
Rando is offline  
0
Reply With Quote
      03-09-2009, 05:13 PM   #17
RiversideE90
Enlisted Member
 
Drives: 2009 e90 335i
Join Date: Nov 2008
Location: Irvine, CA

Posts: 40
iTrader: (0)

Send a message via AIM to RiversideE90
Just a quick update on my car...

Took it into the dealer this morning...problem is apparently the fuel pump and some cylinder misfiring and they are still working on diagnosing fault codes.

And of course - I ask for a loaner car - "this dealer does not provide loaner cars."

Time to call BMW Corporate I think. This is a $50k car with less than 5k miles on it and now I am having to borrow cars from family members? seriously?
RiversideE90 is offline   United_States
0
Reply With Quote
      03-09-2009, 05:15 PM   #18
methodtim
Brigadier General
 
methodtim's Avatar
 
Drives: 335i
Join Date: Mar 2007
Location: Darkness there, and nothing more

Posts: 3,636
iTrader: (0)

Garage List
Quote:
Originally Posted by RiversideE90 View Post
Just a quick update on my car...

Took it into the dealer this morning...problem is apparently the fuel pump and some cylinder misfiring and they are still working on diagnosing fault codes.

And of course - I ask for a loaner car - "this dealer does not provide loaner cars."

Time to call BMW Corporate I think. This is a $50k car with less than 5k miles on it and now I am having to borrow cars from family members? seriously?
That's outrageous, they should have at least provided you with a rental...
__________________

09 E90 335i |Monaco Blue |Step|ZPP|ZSP|ZCW | L7 | iPod | CA
methodtim is offline   Liechtenstein
0
Reply With Quote
      03-09-2009, 05:31 PM   #19
RiversideE90
Enlisted Member
 
Drives: 2009 e90 335i
Join Date: Nov 2008
Location: Irvine, CA

Posts: 40
iTrader: (0)

Send a message via AIM to RiversideE90
The dealer did offer to split the rental with me. But I do not feel I should have to be out any funds for this car - at this point.

Just called BMW Corporate...they said they can't force the dealer to give me a loaner, as the loaner car program is completely up to the dealers. This is crazy! Felt splitting the rental was reasonable, especially considering I did not buy the car there.

Guess I will see what tomorrow holds....luckily I have family close by that does not need a car beyond getting to and from work - so I get to play taxi in exchange for use of a car. Exactly why I spent $50k on a BMW!
RiversideE90 is offline   United_States
0
Reply With Quote
      03-09-2009, 05:43 PM   #20
nuespeedgti
Captain
 
nuespeedgti's Avatar
 
Drives: E90 M3
Join Date: Feb 2009
Location: Rehoboth, MA

Posts: 761
iTrader: (3)

Quote:
Originally Posted by hanmaas View Post
You should NEVER use 91. Might be part of the reason why your pump is failing at this point in time.
cali doesn't have anything higher, well other then race gas.
nuespeedgti is offline   United_States
0
Reply With Quote
      03-09-2009, 06:54 PM   #21
shaddai
former N54 owner
 
shaddai's Avatar
 
Drives: 2008 Audi S4 DTM
Join Date: Mar 2008
Location: Bay Area, CA

Posts: 608
iTrader: (0)

Garage List
2008 335i  [0.00]
Thumbs down

Quote:
Originally Posted by tjnptel1 View Post
it's not really that bad anymore.

It was hell before because they didn't have 'em in stock and cars had to be in shop ~ 30 days. Now it's just a matter of 1 - 2 work days.
So it's Purgatory then. It's still uncalled for, especially at this price point.
__________________
+lemon
shaddai is offline   United_States
0
Reply With Quote
      03-09-2009, 09:11 PM   #22
tctic
Major
 
Drives: BMW E90
Join Date: Oct 2005
Location: Canada

Posts: 1,238
iTrader: (0)

Quote:
Originally Posted by hanmaas View Post
You should NEVER use 91. Might be part of the reason why your pump is failing at this point in time.
The US has a different rating for Octane. I believe 91 in US=98 in Europe.
tctic is offline   Canada
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:35 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST