E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > KV V3 Problem



Reply
 
Thread Tools Search this Thread
      03-26-2009, 08:17 AM   #45
MrWhite1015
Major General
 
MrWhite1015's Avatar
 
Drives: MINIVAN
Join Date: Aug 2008
Location: Westchester NY

Posts: 6,020
iTrader: (21)

Garage List
Send a message via AIM to MrWhite1015
Quote:
Originally Posted by flem View Post
agreed...


has KW contacted anyone yet?
__________________
MrWhite1015 is offline  
0
Reply With Quote
      03-26-2009, 08:36 AM   #46
Road Cone1
Lieutenant
 
Road Cone1's Avatar
 
Drives: 135i & 325i
Join Date: Sep 2008
Location: Oakville, Ontario

Posts: 504
iTrader: (3)

Did anyone actually contact KW?
From the posts in this thread it sounds like people have only emailed them with their concerns
__________________
2012 White 328i Sportline
2009 135i Silver w/Black (Sold)
2006 325i, AW & BLack, ZSP (Sold)
Lots of Miatas
Road Cone1 is offline  
0
Reply With Quote
      03-26-2009, 09:18 AM   #47
MrWhite1015
Major General
 
MrWhite1015's Avatar
 
Drives: MINIVAN
Join Date: Aug 2008
Location: Westchester NY

Posts: 6,020
iTrader: (21)

Garage List
Send a message via AIM to MrWhite1015
Quote:
Originally Posted by Road Cone1 View Post
Did anyone actually contact KW?
From the posts in this thread it sounds like people have only emailed them with their concerns
orb has taken care of contacting the high ups
__________________
MrWhite1015 is offline  
0
Reply With Quote
      03-26-2009, 09:44 AM   #48
flem
.....
 
flem's Avatar
 
Drives: 08 E92 335xi
Join Date: Jan 2009
Location: Morgantown, WV

Posts: 320
iTrader: (1)

Garage List
2008 335xi  [0.00]
Quote:
Originally Posted by MrWhite1015 View Post


my bad lol... I missed that one post somehow
__________________
flem is offline  
0
Reply With Quote
      03-26-2009, 11:17 PM   #49
M4TW
///M Uber Alles
 
M4TW's Avatar
 
Drives: FS - '07 335xi
Join Date: Dec 2006
Location: GSA

Posts: 1,276
iTrader: (1)

I don't think it's correct to say that all KW3's squeek. Mine don't and they certainly have been getting a good workout lately on our crappy spring roads.
__________________
die Welt ist meine Auster
2015 M4, MW, Black Full Merino, DCT, CCB, Adaptive M Suspension, Premium, Executive. Technology, ConnectedDrive, CF Trim, Convenience Telephony, European Delivery
M4TW is offline   Canada
0
Reply With Quote
      03-27-2009, 12:21 AM   #50
Humtek
Vishnu Powered
 
Humtek's Avatar
 
Drives: 335xi, S1000RR
Join Date: Nov 2007
Location: Proceding

Posts: 2,205
iTrader: (7)

Why do I have to hear about this shit when I just ordered v3's. Hopefully this was a problem in early product release.

Quote:
Originally Posted by Orb View Post
That is about the 10th KW kit I seen do this. I also had this problem with the KW2011 front springs from day one. This noise is the coil clashing and it only happens at certain speed on small expansion joint type bumps. It seems to happen more when it is cold for what ever reason as well. I got rid of those front springs and the noise was gone.

Not much you can do other than clean the coil with the car jacked up and wheel off and lube the coils will dry type silicon or Teflon spray. The coils on the top are what you wat to lube as these are the ones that touch each other when you lower the car. It helps for a month or so but it will come back.


Orb
What about using a rubber hose to insulate the coils? I had a similar problem with my evo 8's stock springs and I put rubber hose on the top half of the spring and the sound went away. I didn't really have the car long enough to see if it ended up tearing up through the rubber though.
__________________
2008 335xi Sedan | Titanium Silver | Black Dakota
PROcede v5 | Vishnu Exhaust | BMS DCI | AR Catless DPs | Helix FMIC | Stett Charge w/ Tial BOV | MORR VS8s | KWv3
Humtek is offline   United_States
0
Reply With Quote
      03-27-2009, 01:35 AM   #51
evoi19
 
Drives: 2007 328i 6 MT
Join Date: Dec 2006
Location: Bay Area

Posts: 16,729
iTrader: (18)

Send a message via AIM to evoi19
i have v3's and mine don't squeak at all.

HOWEVER, on a separate issue the plate that links the bar to the sways does crack and bend with H&R sways. I've seen this on other cars and mine is slightly bent right now too. As Sonic has said, KW is aware of this design flaw and will warranty it out for you. The only thing is that you have to send it in first which means you need to uninstall and reinstall at your expense.
__________________
evoi19 is offline   Mongolia
0
Reply With Quote
      03-27-2009, 04:55 PM   #52
Humtek
Vishnu Powered
 
Humtek's Avatar
 
Drives: 335xi, S1000RR
Join Date: Nov 2007
Location: Proceding

Posts: 2,205
iTrader: (7)

Quote:
Originally Posted by andrew@Karbonwerke View Post
i have v3's and mine don't squeak at all.

HOWEVER, on a separate issue the plate that links the bar to the sways does crack and bend with H&R sways. I've seen this on other cars and mine is slightly bent right now too. As Sonic has said, KW is aware of this design flaw and will warranty it out for you. The only thing is that you have to send it in first which means you need to uninstall and reinstall at your expense.
I thought the H&R sways and the OEM sways are exactly the same except for the thickness. So does that mean the KW's will have a problem with the stock sways as well?
__________________
2008 335xi Sedan | Titanium Silver | Black Dakota
PROcede v5 | Vishnu Exhaust | BMS DCI | AR Catless DPs | Helix FMIC | Stett Charge w/ Tial BOV | MORR VS8s | KWv3
Humtek is offline   United_States
0
Reply With Quote
      03-27-2009, 08:07 PM   #53
Getagrip
Get a grip. Get Xdrive.
 
Getagrip's Avatar
 
Drives: 330xi
Join Date: Jan 2006
Location: Anchorage, Alaska

Posts: 529
iTrader: (0)

Garage List
2006 330xi  [0.00]
2003 330xi  [0.00]
So, I just ran into this thread. My KWv3 have made that squeak noise over sharp small bumps since the day I installed them over a year ago. I never thought anything of it because after all I did introduce aftermarket suspension components onto my car. If there is a solution or cause I'd like to know. If not, I'm used to it now.
__________________
2006 330xi current

Last edited by Getagrip; 03-27-2009 at 08:24 PM.
Getagrip is offline   United_States
0
Reply With Quote
      03-28-2009, 10:35 AM   #54
a l l a n
Captain
 
Drives: E90 2007 328xi
Join Date: Dec 2006
Location: LIC NY / Central NJ

Posts: 929
iTrader: (1)

Garage List
2007 E90 328xi  [0.00]
My KW V3 squeaks as well once in a while from the rear when I hit a bump. I also posted this a few times on past threads. Hopefully this is nothing serious.
__________________
E90 2007 / Step / Montego Blue / Black Dakota Leather / Premium / Cold Weather
MODS
: Exterior: Blacklines, debadged, HO ceramic 35% tint, Hoen yellow fogs, matte black grille, OEM style splitters, Halogen-to-Xenon Interior: Alum pedals, CF wrapped trim, V1 and Nuvi hardwire, M-Tech tri-stitched wheel, SMG M5 shift knob Performance: AluFelgen CSL 19" 8.5 ET33/9.5 ET30 with 5mm rear spacers | GY Eagle F1 Asym 235/265, KW V3, BMW Perf exhaust+intake
a l l a n is offline   United_States
0
Reply With Quote
      03-28-2009, 11:17 AM   #55
l4wr3nc3
The Law.
 
l4wr3nc3's Avatar
 
Drives: BMW
Join Date: Apr 2005
Location: Rowland Heights, CA

Posts: 14,281
iTrader: (17)

Send a message via AIM to l4wr3nc3
fwiw, my v3's dont squeak at all.
__________________

2008 Lotus Exige S240 | 2007 BMW 335i
l4wr3nc3 is offline   Taiwan
0
Reply With Quote
      03-28-2009, 11:19 AM   #56
roller84
Captain
 
roller84's Avatar
 
Drives: E90 335i & E60 550i
Join Date: Dec 2005
Location: NYC

Posts: 714
iTrader: (2)

Quote:
Originally Posted by Orb View Post
Okay, it is installed correctly. This is not a fatigue problem at all.

The only circumstance that will cause this type of failure is when you don’t have enough travel in the roll bar linkage. When you lower the car the possible rotation travel of the linkage is reduced. The KW are shorted struts so when lowered they allow much more travel than the stock system could ever see.

What has most likely happen here is that your car has been lower at 1.25” or more? The available rotational travel of the link hit at top dead center just like piston in it rotation which bind the roll bar links. The result of the binding is what you have shown.

You will need to check the kinematics of the system to see if there is problem first had. This involves removing the spring, bump stop and disconnecting one side of the roll bar links. You will need to push the whole suspension upwards while monitoring the roll bar link rotations. You should be looking for the available sweep of the roll bar link at full bottom out of the suspension. I suspect you will run out of travel.

The OEM bars are identical to the H&R bars in fit and form from what I measured. The comment of the happening because stiffer bar that is only rate 150 lb/in more than the OEM is BS and I would challenge them to explain this in some detail . At that point you should her some silence on the phone. There may be a problem if KW allows so much lowering that the affect the sway bar linkage travel. I think this should be looked at by KW directly

This is correctable with adjustable roll bar links from Turner Motorsport….get the good one with aluminum end bearings.

Orb
thanks for the info. my car was previously lowered almost 1.5in from the maximum height setting on the KW's. Now it is only about .75in. I have had the tabs break in both instances.

The noise i am getting has gotten so frequent and loud. It makes noise over almost any bump. It is quite embarrassing to even drive my car now. This is such a frustrating situation.
__________________
OEM SS Kit & Performance Steering Wheel| Blacklines | HO 30% Tints | Euro Xenons | Lux 5.0 | 6000k Xenons | RD Sport Quad Exhaust | Spearco Intercooler | Procede V3 | MORR VS7 | KW V3 | H&R Sways | Mtech Bodykit | Vorsteiner CF Hood, CSL Trunk & Front Lip | ACS Style Roof Spoiler | Quaife LSD | Rotora BBK | GruppeM Intake | Forge UK DV | AR Design Catted DP's
roller84 is offline  
0
Reply With Quote
      03-30-2009, 03:38 PM   #57
TazioNYC
Lieutenant
 
Drives: BMW 135i
Join Date: Jun 2008
Location: New York, NY

Posts: 464
iTrader: (0)

I have the KW v3s for my 135i, and I've been hearing this same chirp since the winter. It's definitely worse in cold weather, and, for me, it tends to be under compression on small, sharp bumps, pavement junctions and rough pavement. The chirp is annoying, but the mechanical crunch sound it makes when you have the window open is worse. I 100% love the performance of these coilovers and really don't want to put my car back to stock, so I'm hopeful of some solution.

One question -- I'm a bit confused on the other issue that has been raised in this thread about bits snapping off. Is that only when used with H&R sways and/or when lowered below a certain point or is everyone at risk of this?

Thanks.
TazioNYC is offline  
0
Reply With Quote
      03-31-2009, 09:49 PM   #58
MrWhite1015
Major General
 
MrWhite1015's Avatar
 
Drives: MINIVAN
Join Date: Aug 2008
Location: Westchester NY

Posts: 6,020
iTrader: (21)

Garage List
Send a message via AIM to MrWhite1015
anyone hear back from KW ????
__________________
MrWhite1015 is offline  
0
Reply With Quote
      04-03-2009, 08:34 AM   #59
MrWhite1015
Major General
 
MrWhite1015's Avatar
 
Drives: MINIVAN
Join Date: Aug 2008
Location: Westchester NY

Posts: 6,020
iTrader: (21)

Garage List
Send a message via AIM to MrWhite1015
anyone ?
__________________
MrWhite1015 is offline  
0
Reply With Quote
      04-03-2009, 08:54 AM   #60
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,266
iTrader: (5)

Send a message via Yahoo to cn555ic
this is total BS...I feel for you guys and anyone reading these threads from KW should acknowledge the problems and address it, especially when their coilover system is so much more expensive than the competitors
cn555ic is offline   United_States
0
Reply With Quote
      04-03-2009, 09:10 AM   #61
MrWhite1015
Major General
 
MrWhite1015's Avatar
 
Drives: MINIVAN
Join Date: Aug 2008
Location: Westchester NY

Posts: 6,020
iTrader: (21)

Garage List
Send a message via AIM to MrWhite1015
Quote:
Originally Posted by cn555ic View Post
this is total BS...I feel for you guys and anyone reading these threads from KW should acknowledge the problems and address it, especially when their coilover system is so much more expensive than the competitors
thanks
__________________
MrWhite1015 is offline  
0
Reply With Quote
      04-03-2009, 09:16 AM   #62
Bimmer325
Major
 
Bimmer325's Avatar
 
Drives: 2006 E90 325i
Join Date: Apr 2005
Location: MY

Posts: 1,167
iTrader: (1)

i'd better go check on my V2, damn!
__________________
325i Arctics M-Sport, Gray Leather with Alu Trim, ///M DCT Paddleshift, ///M Gear Knob, BBS LM-R 19", Michelin PS2, KW V2, H&R Anti Roll Bars, BMW Performance Air Intake System, 3D Front Lip, ACS Roof Spoiler, OEM Boot Spoiler, Osram 6000K, Brex White Ring, PIAA 6200K HID Fog, PIAA License Plate LED, BMS Powerbox
Bimmer325 is offline  
0
Reply With Quote
      04-03-2009, 10:06 AM   #63
Bimmer325
Major
 
Bimmer325's Avatar
 
Drives: 2006 E90 325i
Join Date: Apr 2005
Location: MY

Posts: 1,167
iTrader: (1)

here's my V2

First pic Right Shock, 2nd pic Left Shock.

So, far travelled 4-5k km on them, no chirp sound heard over bump except the gas compression sound.

Hope it wont break down on me.
Attached Images
  
__________________
325i Arctics M-Sport, Gray Leather with Alu Trim, ///M DCT Paddleshift, ///M Gear Knob, BBS LM-R 19", Michelin PS2, KW V2, H&R Anti Roll Bars, BMW Performance Air Intake System, 3D Front Lip, ACS Roof Spoiler, OEM Boot Spoiler, Osram 6000K, Brex White Ring, PIAA 6200K HID Fog, PIAA License Plate LED, BMS Powerbox
Bimmer325 is offline  
0
Reply With Quote
      04-03-2009, 10:45 AM   #64
JaysBlueE92
Mr. Monaco
 
JaysBlueE92's Avatar
 
Drives: Slow..
Join Date: Sep 2008
Location: New Jersey

Posts: 3,865
iTrader: (9)

Garage List
2007 E92  [2.50]
man I shoulda bought FKs
__________________
JaysBlueE92 is offline   United_States
0
Reply With Quote
      04-03-2009, 11:10 AM   #65
SGxi
Major General
 
Drives: E90 328xi
Join Date: Oct 2006
Location: Toronto

Posts: 6,805
iTrader: (17)

Garage List
2007 328xi  [0.00]
I can't see in that angle, but does is that tab suppose to be straight (ie parallel with the damper) or kind of bent at an angle? (like this picture)



Because the set I got, it's kind of bent already...
__________________
MY07 A22 E90 N52Nxi
SGxi is offline   Canada
0
Reply With Quote
      04-03-2009, 12:11 PM   #66
Humtek
Vishnu Powered
 
Humtek's Avatar
 
Drives: 335xi, S1000RR
Join Date: Nov 2007
Location: Proceding

Posts: 2,205
iTrader: (7)

From those pictures it looks like it should be straight? I just received mine the other day and plan on installing this saturday. When I get home I'll look at mine and see what they look like. IIRC I should have the new improved sway mounts. The problem with them breaking was with H&R sways, not the OEM.
__________________
2008 335xi Sedan | Titanium Silver | Black Dakota
PROcede v5 | Vishnu Exhaust | BMS DCI | AR Catless DPs | Helix FMIC | Stett Charge w/ Tial BOV | MORR VS8s | KWv3
Humtek is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:23 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST