E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Metal shavings on Intercooler... am I in trouble??



Reply
 
Thread Tools Search this Thread
      06-04-2009, 09:50 PM   #1
jaza45
Banned
Colombia
19
Rep
1,123
Posts

 
Drives: 2008 LSB E90 335I
Join Date: Nov 2008
Location: MIAMI

iTrader: (14)

Send a message via AIM to jaza45 Send a message via MSN to jaza45 Send a message via Yahoo to jaza45 Send a message via Skype™ to jaza45
Metal shavings on Intercooler... am I in trouble??

So I got my Stett Intercooler today and since I got off work early I started to take the whole front out to start the installation but I had to stop when I took off the stock intercooler and found oil and metal shavings on the inlet and outlet also there were some in the charge pipe, are the turbos blown?

I do have a 30FF, Exhaust fume turbocharger low side code...

sorry for the crappy pics...


[IMG]http://i6.photobucket.com/albums/y247/******/LSB%20E90/DSCN0872.jpg[/IMG]
[IMG]http://i6.photobucket.com/albums/y247/******/LSB%20E90/DSCN0873.jpg[/IMG]
[IMG]http://i6.photobucket.com/albums/y247/******/LSB%20E90/DSCN0874.jpg[/IMG]
[IMG]http://i6.photobucket.com/albums/y247/******/LSB%20E90/DSCN0877.jpg[/IMG]
[IMG]http://i6.photobucket.com/albums/y247/******/LSB%20E90/DSCN0879.jpg[/IMG]
[IMG]http://i6.photobucket.com/albums/y247/******/LSB%20E90/DSCN0880.jpg[/IMG]
[IMG]http://i6.photobucket.com/albums/y247/******/LSB%20E90/DSCN0881.jpg[/IMG]



I do hear a loud whine but I thought it was because right now Im in the middle of the ****** BOV installation witch Im having problems trying to get it to run right..maybe Im doing something wrong will post pics later...

the whine is kind of like this but I dont have air filters on right now..

Last edited by jaza45; 10-31-2009 at 02:49 PM.
Appreciate 0
      06-04-2009, 10:22 PM   #2
Terrance28
Brigadier General
Terrance28's Avatar
United_States
43
Rep
3,336
Posts

 
Drives: Crimson Red E92
Join Date: Nov 2007
Location: Killeen, TX

iTrader: (17)

Send a message via Yahoo to Terrance28
What problems are you having wiht the ******** I installed mines today and love it? I have no idea about the shavings though, but somebody will chime in soon.
__________________
Mods list got too long, lets just say more than enough.
Appreciate 0
      06-04-2009, 10:29 PM   #3
jaza45
Banned
Colombia
19
Rep
1,123
Posts

 
Drives: 2008 LSB E90 335I
Join Date: Nov 2008
Location: MIAMI

iTrader: (14)

Send a message via AIM to jaza45 Send a message via MSN to jaza45 Send a message via Yahoo to jaza45 Send a message via Skype™ to jaza45
I think I installed it wrong, I was supposed to leave one of the diverteter valves on but it should get fixed tomorrow...
Appreciate 0
      06-04-2009, 10:38 PM   #4
Sniz
Lieutenant General
Sniz's Avatar
190
Rep
10,572
Posts

 
Drives: e92 335 - gone // e36 M3 turbo
Join Date: Mar 2007
Location: Ellicott City, MD

iTrader: (1)

hmmm....well I have never seen shavings like that in any 335 I have dealt with.

I dont know what to tell you man.
__________________
Appreciate 0
      06-04-2009, 10:40 PM   #5
Terrance28
Brigadier General
Terrance28's Avatar
United_States
43
Rep
3,336
Posts

 
Drives: Crimson Red E92
Join Date: Nov 2007
Location: Killeen, TX

iTrader: (17)

Send a message via Yahoo to Terrance28
Yeah leave the rear one on, it works great. Try to find some better hoses than the orange ones that come with the kit. They are ugly and hard to put on and cheap, I had some extra hoses in my garage and I ended up using those.
__________________
Mods list got too long, lets just say more than enough.
Appreciate 0
      06-04-2009, 11:02 PM   #6
jaza45
Banned
Colombia
19
Rep
1,123
Posts

 
Drives: 2008 LSB E90 335I
Join Date: Nov 2008
Location: MIAMI

iTrader: (14)

Send a message via AIM to jaza45 Send a message via MSN to jaza45 Send a message via Yahoo to jaza45 Send a message via Skype™ to jaza45
oh yeah those orange hoses are not coming near my car, I bought some black ones...
[IMG]http://i6.photobucket.com/albums/y247/******/LSB%20E90/DSCN0851-1.jpg[/IMG]
Appreciate 0
      06-05-2009, 12:31 AM   #7
baltik
Lieutenant
7
Rep
407
Posts

 
Drives: porsche 944 turbo
Join Date: Dec 2006
Location: San Francisco

iTrader: (0)

Whatever the issue is - the last thing you need is an aftermarket intercooler, return to stock asap, bring to the dealer and hope they warranty your turbos. Assuming there were no other mods that could have introduced this, mild turbo shearing is the best case scenario
Appreciate 0
      06-05-2009, 12:52 AM   #8
bulldog x6
Major General
65
Rep
5,022
Posts

 
Drives: x6 panzer
Join Date: Oct 2008
Location: probably work

iTrader: (28)

damn.... id get that checked out.. what do you say to the stealer tho?
Appreciate 0
      06-05-2009, 12:57 AM   #9
vase330
Colonel
vase330's Avatar
United_States
37
Rep
2,676
Posts

 
Drives: E92 335i ; 14 RangeRover SSC
Join Date: Jan 2007
Location: Arlington, Va

iTrader: (1)

Put it back to stock, take it in. It definitely looks bad. Hopefully you did not destroy the stock hoses.
__________________
E92 335 | Space Gray | Saddle Brown Dakota | Dark Burl Trim | ZPP | ZSP | AT | Idrive | 6FL | FBO | Dinan CAI | Quaife LSD | STG3 PROCede.
Appreciate 0
      06-05-2009, 01:17 AM   #10
getInline
Lieutenant
getInline's Avatar
Canada
4
Rep
413
Posts

 
Drives: 2008 335 Coupe, c32 AMG
Join Date: Nov 2007
Location: Parts Unknown

iTrader: (1)

Metal shavings are never a good thing but if it's been tuned and pushing some serious PSI, how about instead of getting BMW to foot the bill, look into one of the growing options for having your turbos rebuilt when they eventually pack it in. You'll sleep better at night and have turbos with 50% more capacity to boot. In a few months I think we'll be seeing more and more options in the rebuilt turbo arena. Either way, best of luck and don't sweat it too much, it's only a car.
Appreciate 0
      06-05-2009, 05:56 AM   #11
Bubbles
Brigadier General
Bubbles's Avatar
Cayman Islands
86
Rep
3,560
Posts

 
Drives: Green Bastard
Join Date: Jun 2007
Location: Bishop Bend

iTrader: (3)

OP

I pulled my IC for a cleaning after 30k of running peak boost ~13.6psi.

I had plenty of oil but no metal shavings. No turbo whine, but my turbos were replaced due to wastegate issues ~15k.

I hope that helps.
__________________
Appreciate 0
      06-05-2009, 07:46 AM   #12
roadkillrob
Brigadier General
United_States
58
Rep
3,913
Posts

 
Drives: 2008 335Cic, 2011 X5 35i
Join Date: Jul 2007
Location: Boston

iTrader: (14)

Something is badly wrong no matter what happened, you shouldn't be able to find 1 metal shaving in there, let alone a noticable amount.

The only way that could happen short of someone dumping metal shavings into the intake pipe is one of the turbos contacting the housing, or something bad going through a turbo. Make it stock and go to the dealer - you don't want to be getting the bill for this!
__________________

2008 E93 335i, GIAC Stage 2, HPF IC, Injen Intake, Defective AR Design DP's with useless cats
2014 X3 35i JB Stage 1
Appreciate 0
      06-05-2009, 08:00 AM   #13
Diggy Diggy
First Lieutenant
Diggy Diggy's Avatar
8
Rep
341
Posts

 
Drives: 135i
Join Date: Mar 2009
Location: Kentucky

iTrader: (2)

Garage List
2008 BMW 135i  [0.00]
What tune and psi are you running?
Appreciate 0
      06-05-2009, 08:03 AM   #14
Former_Boosted_IS
Major General
143
Rep
5,179
Posts

 
Drives: 4 Wheels
Join Date: Aug 2007
Location: Planet Earth!

iTrader: (15)

The fact that you are reporting whiring sounds kind of lends itself to turbo issues. At the very least, get it looked at.

That oil residue is a good example of why no one should run the car without an oil catch can.
Appreciate 0
      06-05-2009, 08:36 AM   #15
WhiteSled
Banned
1
Rep
142
Posts

 
Drives: 2009 BMW 135i
Join Date: Apr 2009
Location: East Coast

iTrader: (0)

fuck the turbos, those shavings are now in your engine and oil system...probably screwed up your cylinderwalls and oil pump. AKA good luck
Appreciate 0
      06-05-2009, 08:50 AM   #16
uberschnell
Brigadier General
uberschnell's Avatar
No_Country
71
Rep
3,424
Posts

 
Drives: // 135i //, X5
Join Date: Mar 2007
Location: Bay Area

iTrader: (44)

That exact sound (from your youtube clip) meant excessive play in the turbo shafts of my car, and subsequently new turbos. I guessing that you are shaving down the edges of your blades due to shaft play.

Wonder if those shavings have been making into the engine itself and what that would mean?

__________________
- 08 135i - Wavetrac LSD, AST 4100, Swift springs, Brembo GT brakes, M3 front sway, Meyle HD links, Dinan Camber plates, Whiteline subframe bushings, M3 rear guide and upper link, M3 front control arms, HP custom M3 front Strut brace, Megan rear control arms, F30 brake shields -
Appreciate 0
      06-05-2009, 09:23 AM   #17
Former_Boosted_IS
Major General
143
Rep
5,179
Posts

 
Drives: 4 Wheels
Join Date: Aug 2007
Location: Planet Earth!

iTrader: (15)

Quote:
Originally Posted by MteK View Post
That exact sound (from your youtube clip) meant excessive play in the turbo shafts of my car, and subsequently new turbos. I guessing that you are shaving down the edges of your blades due to shaft play.

Wonder if those shavings have been making into the engine itself and what that would mean?

One easy way to tell, check the charge pipe or check the DVs.
Appreciate 0
      06-05-2009, 09:27 AM   #18
Ilma
Colonel
29
Rep
2,576
Posts

 
Drives: BMW
Join Date: Nov 2008
Location: hometown

iTrader: (0)

Quote:
Originally Posted by MteK View Post
That exact sound (from your youtube clip) meant excessive play in the turbo shafts of my car, and subsequently new turbos. I guessing that you are shaving down the edges of your blades due to shaft play.

Wonder if those shavings have been making into the engine itself and what that would mean?

It's a good point.....gotta wonder why some of the dealer techs are saying not to worry about a small amount of turbo whine.

Seems to me it would be wiser to replace the turbos before they start to disintegrate and then cost way more to repair the subsequent engine damage beyond the turbos themselves.

Did you ever get to see your compressor wheel when your turbos were replaced?
Appreciate 0
      06-05-2009, 09:33 AM   #19
Ilma
Colonel
29
Rep
2,576
Posts

 
Drives: BMW
Join Date: Nov 2008
Location: hometown

iTrader: (0)

Quote:
Originally Posted by ****** View Post
So I got my Stett Intercooler today and since I got off work early I started to take the whole front out to start the installation but I had to stop when I took off the stock intercooler and found oil and metal shavings on the inlet and outlet also there were some in the charge pipe, are the turbos blown?



I do hear a loud whine but I thought it was because right now Im in the middle of the ****** BOV installation witch Im having problems trying to get it to run right..maybe Im doing something wrong will post pics later...

the whine is kind of like this but I dont have air filters on right now..
Can you clarify.....are you stating that you have been running the car without air filters?

If so, you could have ingested something into your compressor turbine.
Appreciate 0
      06-05-2009, 10:28 AM   #20
baltik
Lieutenant
7
Rep
407
Posts

 
Drives: porsche 944 turbo
Join Date: Dec 2006
Location: San Francisco

iTrader: (0)

I give it a 60% chance u dropped a screw or a clip down the piping. last thing you should be doing right now is modding
Appreciate 0
      06-05-2009, 11:15 AM   #21
Alpine 335i
Banned.....not!
Alpine 335i's Avatar
14
Rep
1,023
Posts

 
Drives: Alpine White 335i Sedan
Join Date: Feb 2008
Location: Bakersfield, Cali

iTrader: (1)

Damn that sucks I would get it looked at real quick. I'm afraid to say but I think it maybe a serious issue go to the dealer and good luck.
__________________
JuiceBox3 1.4 Map 5, AR Design CL DPs, BMS Filter, LUX 4.0, 8k HID fogs, Matte Black Grill, Matte Black Badges, Black/White Roundels, Blacklines, Matte Black Finishing Rods, MFD Matte Black Scoops, Amber Overlays, Tinted Sidemarkers, Tinted all around, LED Courtesy Lights
Appreciate 0
      06-05-2009, 12:00 PM   #22
E82tt6
Colonel
E82tt6's Avatar
48
Rep
2,629
Posts

 
Drives: '08 Black Saphire Z4 MC
Join Date: Oct 2007
Location: New Jersey

iTrader: (0)

That does not look good dude.

Just my two cents, but I don't think this is BMW's problem, I'd have it looked at by an independant shop you can tell the whole story to before you decide what to do.
__________________
'08 Black Saphire/Black Z4 M Coupe
RIP Gretta: Blue Water/Lemon 135i. Died to save me.
-ChuckV
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:12 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST