E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > HELP - "Engine Malfunction, Reduced Power"



Reply
 
Thread Tools Search this Thread
      03-29-2009, 04:22 PM   #1
jbm3
Enlisted Member
 
jbm3's Avatar
 
Drives: 2011.5 BMW M3 (e93)
Join Date: Apr 2007
Location: studio city, CA

Posts: 46
iTrader: (0)

Unhappy HELP - "Engine Malfunction, Reduced Power"

Guys,

This is exactly the error message displayed in the idrive display. Also, there is a yellow motor symbol that is half full (thus explaining the half power), and of course the "service engine soon" yellow light.

So this is what popped up yesterday out of nowhere on my 08 335 cab. I have searched here & the owners manual too, but no luck and wondering if anyone else has experienced this???

The car actually drives ok but with no power, so just running smoothly in reg auto mode and it shifts fine & stays in 2500 - 3000 rpm range. If I try to floor it just to see it turbo spools or anything else, it sputters and goes no faster or revs no higher.

then went to turn the car on this morning to see what's new, and first it wouldn't strat without the starter turning for 10 seconds before turning over & then stalled out. The 2nd attempt was les difficult with the engine trying to find a spot to hold & finally did and ran, but sure enough all the lights & warnings came back on. I have not driven it as I fear it could be fuel pump or injection system or worse. Obviously will need to take it in for service, but has anyone seen this or expeirenced this? hoping its a faulty sensor and nothing serious ....

If anyone has any feed back i would appreciate it. many thanks
Jimmy
jbm3 is offline   United_States
0
Reply With Quote
      03-29-2009, 10:30 PM   #2
juicedcubed
Phantom at large
 
juicedcubed's Avatar
 
Drives: 2013 e92 m3
Join Date: Dec 2008
Location: Agoura Hills, CA

Posts: 1,997
iTrader: (0)

Quote:
Originally Posted by jbm3 View Post
Guys,

This is exactly the error message displayed in the idrive display. Also, there is a yellow motor symbol that is half full (thus explaining the half power), and of course the "service engine soon" yellow light.

So this is what popped up yesterday out of nowhere on my 08 335 cab. I have searched here & the owners manual too, but no luck and wondering if anyone else has experienced this???

The car actually drives ok but with no power, so just running smoothly in reg auto mode and it shifts fine & stays in 2500 - 3000 rpm range. If I try to floor it just to see it turbo spools or anything else, it sputters and goes no faster or revs no higher.

then went to turn the car on this morning to see what's new, and first it wouldn't strat without the starter turning for 10 seconds before turning over & then stalled out. The 2nd attempt was les difficult with the engine trying to find a spot to hold & finally did and ran, but sure enough all the lights & warnings came back on. I have not driven it as I fear it could be fuel pump or injection system or worse. Obviously will need to take it in for service, but has anyone seen this or expeirenced this? hoping its a faulty sensor and nothing serious ....

If anyone has any feed back i would appreciate it. many thanks
Jimmy

take off your tune and go to a dealer.
__________________
2008 335i Black Sapphire| Black Interior| Navi| Silver Aluminum Trim |Tint l BMS intake l JB3 l Riss Racing downpipes | Miro Staggered Hyper Silver 19 inch CSL Reps |Nitto 555's ***RIP 2011 335i Jet Black| Red Interior| Bone Stock ***RIP 2013 M3 Space Gray|Carbon Tint| Matte Black Eurotek CSL Wheels| Nokya White Halos| AFE Stage 2 intake| AFE Power Pulley| Reflector Delete|
juicedcubed is offline   United_States
0
Reply With Quote
      03-29-2009, 10:43 PM   #3
possible335i2008
Captain
 
Drives: 335i
Join Date: Mar 2008
Location: united states

Posts: 980
iTrader: (9)

fuel pump...take out all mods if you have any
possible335i2008 is offline  
0
Reply With Quote
      03-29-2009, 10:50 PM   #4
ThorsHammer
Major
 
ThorsHammer's Avatar
 
Drives: '09 BMW 335i Coupe
Join Date: Jan 2009
Location: San Antonio, TX

Posts: 1,389
iTrader: (10)

100% it's the HPFP.

If you have any tunes, you need to remove them. It would also be best to look for any tuner codes with a Bavarian Technic tool, and delete them before taking it in.

But from what you describe, she's on her last leg and it's just a matter a time before you get a complete fail.
__________________
"SYONRA" is for sale! http://www.e90post.com/forums/showthread.php?t=366678 BSM '09 e92 335i | Performance: JB3, RR Catted DP's, INJEN DCI, Britalman Exhst, AA FMIC, FORGE DVs | Suspension: ST-V1 Coils, Hotchkis Chassis Brace & F/R Sways | Wheels: Bremmer Kraft BR03s, Brake Performance Rotors, Cool Carbon Pads, ECS Lines | Exterior: OEM Aero Lip/Rear, ****** CF Trunk Lid, BLUX5 Angels, M-Force M3 Sides | Interior: Passport 9500ci, Black Trim, M3 Wheel
ThorsHammer is offline   United_States
0
Reply With Quote
      03-30-2009, 06:57 AM   #5
jlwM3
Private
 
Drives: '08 335 Coupe, Dinan Stage3
Join Date: Jul 2007
Location: Ponte Vedra, FL

Posts: 73
iTrader: (0)

Dinan

......or, spend a few xtra $$s for Dinan tune and forget about: 1) pulling mods, 2) lying to service managers.
Just a thought
jlwM3 is offline  
0
Reply With Quote
      03-30-2009, 09:25 AM   #6
bulldog x6
Major General
 
Drives: x6 panzer
Join Date: Oct 2008
Location: probably work

Posts: 5,023
iTrader: (28)

Quote:
Originally Posted by jlwM3 View Post
......or, spend a few xtra $$s for Dinan tune and forget about: 1) pulling mods, 2) lying to service managers.
Just a thought
a few extra $$$? more like a few thousand LOL
bulldog x6 is offline  
0
Reply With Quote
      03-30-2009, 09:34 AM   #7
ThorsHammer
Major
 
ThorsHammer's Avatar
 
Drives: '09 BMW 335i Coupe
Join Date: Jan 2009
Location: San Antonio, TX

Posts: 1,389
iTrader: (10)

Quote:
Originally Posted by jlwM3 View Post
......or, spend a few xtra $$s for Dinan tune and forget about: 1) pulling mods, 2) lying to service managers.
Just a thought
Yeah because we all know it's the aftermarket tunes that are causing the fuel pumps to die.
__________________
"SYONRA" is for sale! http://www.e90post.com/forums/showthread.php?t=366678 BSM '09 e92 335i | Performance: JB3, RR Catted DP's, INJEN DCI, Britalman Exhst, AA FMIC, FORGE DVs | Suspension: ST-V1 Coils, Hotchkis Chassis Brace & F/R Sways | Wheels: Bremmer Kraft BR03s, Brake Performance Rotors, Cool Carbon Pads, ECS Lines | Exterior: OEM Aero Lip/Rear, ****** CF Trunk Lid, BLUX5 Angels, M-Force M3 Sides | Interior: Passport 9500ci, Black Trim, M3 Wheel
ThorsHammer is offline   United_States
0
Reply With Quote
      03-30-2009, 09:53 AM   #8
2FST2C
Captain
 
2FST2C's Avatar
 
Drives: 2008 AW E92
Join Date: Sep 2007
Location: Central FL

Posts: 766
iTrader: (2)

Send a message via AIM to 2FST2C
I had the same thing last week. i took my car into the dealer and they replaced INJECTOR #6 same day under warranty.
2FST2C is offline   United_States
0
Reply With Quote
      03-30-2009, 11:24 AM   #9
StrifeM3
Colonel
 
StrifeM3's Avatar
 
Drives: 2013 MCB E92 M3
Join Date: Feb 2008
Location: Walnut/Placentia

Posts: 2,802
iTrader: (16)

Garage List
2013 BMW  [0.00]
Send a message via AIM to StrifeM3
The same problem I am having and it started yesterday also. I plan on taking it to the dealer this week, I'm hearing the same thing its my fuel pump...
__________________
| 2013 M3 Coupe | Individual Monte Carlo Blue | Black Novilla Extended with Tobago Blue Stitching | 6MT | Carbon Fiber Leather Trim |
| BPM Sport Tune | OSS Headlights | HRE590RS | Brembo | Dinan Intake | Dinan Pulley | Dinan Strut Tower | Dinan Midpipe | Akra Slip-on | Valentine 1 Built-in Radar Detector

Quote:
Originally Posted by e1000 View Post
After buying the M, I now consider oil companies drug dealers.
StrifeM3 is offline   United_States
0
Reply With Quote
      03-30-2009, 11:33 AM   #10
RambleJ
Colonel
 
RambleJ's Avatar
 
Drives: F10 535i M-sport
Join Date: Oct 2008
Location: Back in teh so cal

Posts: 2,013
iTrader: (2)

Most likely fuel pump failure. My car has been in the shop recently for its third fuel pump replacement! And those symptoms the OP described are... oh too familiar.
RambleJ is offline   No_Country
0
Reply With Quote
      03-30-2009, 02:02 PM   #11
KkSc
Major General
 
KkSc's Avatar
 
Drives: 12' Q5 2.0T/ 13' FR-S
Join Date: Feb 2007
Location: North Vancouver, BC

Posts: 6,222
iTrader: (10)

fuel pump~~
__________________
2006 E90 Alpine White 330i - Retired
KkSc is offline   Hong Kong
0
Reply With Quote
      03-30-2009, 10:19 PM   #12
2FST2C
Captain
 
2FST2C's Avatar
 
Drives: 2008 AW E92
Join Date: Sep 2007
Location: Central FL

Posts: 766
iTrader: (2)

Send a message via AIM to 2FST2C
OR THE SPARK PLUGS OR ONE OF THE INJECTORS. dont start blaming the fuel pump just yet
2FST2C is offline   United_States
0
Reply With Quote
      03-30-2009, 11:17 PM   #13
diablo2112
14 F30 335i & 14 F31 328d
 
Drives: F30 335i 2014 & F31 328d 2014
Join Date: Dec 2006
Location: USA

Posts: 349
iTrader: (1)

I think it's a perfectly acceptable to blame the fuel pump, and would suspect this every time these symptoms appear. These are known failures, they all eventually go, and that's what's happened here, too. Only a matter of time before the HPFP goes on my 07 335 (22k miles at present).
diablo2112 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:45 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST