E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > BIMMERPOST Universal Forums > Off-Topic Discussions Board > Anyone really good with Macromedia Dreamweaver?



Reply
 
Thread Tools Search this Thread
      07-17-2006, 06:49 PM   #1
deutschmann59
Captain
United_States
31
Rep
735
Posts

 
Drives: 2006 325i
Join Date: Mar 2005
Location: e90post.com

iTrader: (0)

Anyone really good with Macromedia Dreamweaver?

I'm hoping someone can help me out with this. When I'm working on a web page (750 pixels across, centered) everything is fine. But if I do something really simple like change the title of the web page, after I come back into the design view from the code view, the entire web page that I'm working on will shift to the right a good 15 pixels! You can't really notice it in IE, but you definitely can in netscape.

Can anyone explain what is causing this...it's driving me crazy! It makes no sense. I've followed some of dreamweavers advice about turning down hardware acceleration on the video card, etc, but to no avail. Can anyone help? Thanks!
Appreciate 0
      07-17-2006, 08:22 PM   #2
JohnC602
New Member
United_States
0
Rep
29
Posts

 
Drives: e90 330i
Join Date: Jun 2006
Location: Atlanta, GA

iTrader: (0)

Dreamweaver is weird...

about stuff like that. I have been using it for two years now and even the smallest changes cause abnormal things to happen in design view. Check the <table> tag and make sure nothing funny is going on. Often Dreamweaver will insert things there that will result in your tables acting funny.

JohnC
Appreciate 0
      07-17-2006, 09:16 PM   #3
Nikki
Major General
Nikki's Avatar
United_States
213
Rep
6,373
Posts

 
Drives: del Sol VTEC & Sepang Z4MC
Join Date: Aug 2005
Location: OC

iTrader: (9)

Copy and paste the source code. It's easier to find mistakes that way. I hate how Dreamweaver layers things on top of each other, i.e. if you change a color from blue to purple to green it will still keep the blue and purple tags but override them with the green one...ahh it's so stupid. LOl.
__________________
Nikki

Appreciate 0
      07-17-2006, 10:39 PM   #4
Caster
Lieutenant
8
Rep
598
Posts

 
Drives: 06 SG 325i
Join Date: Apr 2006
Location: LA, Cali

iTrader: (0)

Garage List
2006 325i  [0.00]
Send a message via AIM to Caster
Yea paste the code, I could probably help you out. Are you coding by any standards? XHTML? CSS?
__________________
Graphite E90 325i / Navigation / Premium / Xenon / LUX White Rings / 15% Tint / Blackline Tail Lights

Appreciate 0
      07-17-2006, 10:50 PM   #5
tl_boy
Major
tl_boy's Avatar
25
Rep
1,329
Posts

 
Drives: tl
Join Date: Aug 2005
Location: houston

iTrader: (0)

Sharp: When you say title, you mean in the Title metatag? That makes NO sense at all. Like the others said, paste code here.

Now I know why my college professor made us code in NOTEPAD. Yes, Notepad. Guess it paid off (I would have still gladly preferred Textpad). But yeah, these WYSWYG editors like frontpage and dreamweaver often put proprietary shiet in there. Dreamweaver isn't bad actually.

post the code
Appreciate 0
      07-17-2006, 11:09 PM   #6
ages944
Captain
ages944's Avatar
Poland
41
Rep
990
Posts

 
Drives: E90 325i
Join Date: Dec 2005
Location: Chicago 'burbs

iTrader: (0)

they say DW8 is supposed to improve Design View, but like the others have said, copy / paste is prolly the best way to go.

I'll be honest that Design View for me is basically a guideline only thing. I always look at the actual output in the browser, and go off that.

What are you trying to do though? tl_boy's right that changing the title makes no sense? Are you talking about a banner or something? That said, what container elements are you using?
__________________
BMW : Sine qua non

Mods: Blacklines | Rear Seat Power Outlets | Rear Fog Lights | Ashtray Garage Door Opener
Appreciate 0
      07-17-2006, 11:50 PM   #7
deutschmann59
Captain
United_States
31
Rep
735
Posts

 
Drives: 2006 325i
Join Date: Mar 2005
Location: e90post.com

iTrader: (0)

Thanks for the help guys. But I agree, this really makes no sense! Yes, when I go to code view to change the site title (meta tag), or change text in a table, the entire layout shifts.

But this isn't the only time. Listen to this...sometimes the entire layout would shift just by opening the file in dreamweaver! That's right, I would save the file and it would be perfect. Then I'd go to re-open the file and as soon as it opened in dreamweaver, it would shift over those 15 pixels.

I agree with most comments here, I use the code view most of all, because when you screw with design view too much, your code is likely to get bloated. Don't worry, I learned "longhand" HTML almost 10 years ago!

Well, for as strange as this sounds, if I keep both code and design view open, there doesn't seem to be any problems....at least I've been able to make about 3 pages so far without it shifting, so I'm keeping my fingers crossed...

Thanks again guys. If you can think of anything else, let me know
Appreciate 0
      07-17-2006, 11:51 PM   #8
Neil
The Designer
Neil's Avatar
2
Rep
233
Posts

 
Drives: Nissan
Join Date: Dec 2005
Location: CT, USA

iTrader: (0)

Send a message via AIM to Neil Send a message via MSN to Neil
If the problem is noticeable in a browser the problem most likely lies in your code, not dreamweaver. What you see in the design view is almost never a representation of the actual view through a browser, especially with CSS and any includes.

Dreamweaver is a good program as long as you know how to code first, makes troubleshooting so much easier and with no browser standards troubleshooting is way too common.


You should post a bare bones file on the net so we can look at it through our browsers.
Appreciate 0
      07-17-2006, 11:52 PM   #9
deutschmann59
Captain
United_States
31
Rep
735
Posts

 
Drives: 2006 325i
Join Date: Mar 2005
Location: e90post.com

iTrader: (0)

Oh, and about the copy/paste thing, yeah, I've done that. I've taken the "shifted" verson of the code and pasted it into a new blank file and it was still shifted! I'm starting to think something happened to the program itself.
Appreciate 0
      07-17-2006, 11:56 PM   #10
tl_boy
Major
tl_boy's Avatar
25
Rep
1,329
Posts

 
Drives: tl
Join Date: Aug 2005
Location: houston

iTrader: (0)

I think I know whats going on. Okay, first off, I bet its when you change something in the table it shifts, not when you change the metatag, i think you may have gotten mixed up.

You're using layers, aren't you, like you say, this layer is located at 120px and 50px? I've had problems when i used dreamweaver in the past, one layer would nudge another. Are you using layers? if so, do you have to? I don't think those are browser friendly (although, i haven't dealt with browser compatability issues since i was a web dev, which was 3 years ago!).
Appreciate 0
      07-18-2006, 12:19 AM   #11
ages944
Captain
ages944's Avatar
Poland
41
Rep
990
Posts

 
Drives: E90 325i
Join Date: Dec 2005
Location: Chicago 'burbs

iTrader: (0)

Quote:
Originally Posted by Neil
You should post a bare bones file on the net so we can look at it through our browsers.
Good idea. Nothing illegal, is it?
__________________
BMW : Sine qua non

Mods: Blacklines | Rear Seat Power Outlets | Rear Fog Lights | Ashtray Garage Door Opener
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:02 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST