E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > Help with tires and wheels? i hate xi



Reply
 
Thread Tools Search this Thread
      05-26-2009, 02:13 PM   #23
Dubbedoutbimmer
Banned
United_States
21
Rep
1,313
Posts

 
Drives: 335XI Coupe Loaded w/body kit
Join Date: Feb 2008
Location: Boston

iTrader: (-1)

Send a message via AIM to Dubbedoutbimmer
guys I want to 19X9.5 all the way around will that work? I have 08 335xi coupe please no bashing I am just straight out at work with no time to research but I really want that fat lip all around


P.S I am looking at the beyern Mesh black spoke with the polished lip
Appreciate 0
      05-26-2009, 03:01 PM   #24
pdjafari
Colonel
pdjafari's Avatar
43
Rep
2,402
Posts

 
Drives: Axe Murderer with headlights
Join Date: Oct 2007
Location: Earth

iTrader: (5)

Currently running Works

19x8.5 +35
19x10 +25

235/35/19 Falken FK 452
265/30/19 Falken FK 452

Fenders rolled in the rear, no rubbing even with 4 ppl!!!
Appreciate 0
      06-04-2009, 11:07 AM   #25
jpsimon
Team Zissou
jpsimon's Avatar
United_States
164
Rep
9,017
Posts

 
Drives: 2015 STi
Join Date: Dec 2006
Location: CT

iTrader: (6)

i have my wheels on

19x8.5 +32
19x10 +38

235/35/19 toyo T1R
275/30/19 toyo T1R

I am lowered on KWv3 coilovers - there is NO rubbing and I DO NOT have rolled fenders!
__________________
2015 STi / 335xi (solid)
www.datazap.me - fast, free, interactive data log viewing

Appreciate 0
      06-04-2009, 11:13 AM   #26
SpmnE9zero
DENY THE WORLD THAT SURROUNDS YOU
SpmnE9zero's Avatar
United_States
376
Rep
35,576
Posts

 
Drives: JB 33ZERO
Join Date: Nov 2008
Location: City of Champions

iTrader: (14)

Garage List
2006 330xi  [0.00]
Running 19x8.5 in front and 19x9.5 in rear with Falken 452 tires, on stock xi suspension, no rubbing at all. Cant remember my offsets right now, but never had any issues.
Appreciate 0
      06-04-2009, 11:47 AM   #27
TwnTrboCAT1212
The Moose Whisperer
TwnTrboCAT1212's Avatar
United_States
7
Rep
407
Posts

 
Drives: '08 E92 GIAC S1 335xi 6-MT
Join Date: Oct 2008
Location: Massachusetts

iTrader: (2)

Hey guys, I Just put on my new summer wheel set-up and I'm running 19x8.5 / 19x10 with 235/35 - 275/30's with no rubbing whatsoever (stock suspension) I have the Falken 452's...real nice tires / highly recommend them. The tires grip realll nice but I noticed a bit of understeer on off/on-ramps at high speed. I guess thats to be expected running such an aggressive staggered set-up...esp. on Xi. Has anyone with the same set-up had any long-term issues with running this on an Xi? I was told I'm an idiot for getting such an unecessary set-up for an Xi...but I mainly did it not only for the looks (which it gets a LOT of) but because I think its the safest set-up to run in terms of rolling diameter...closest to 0% or whatever, so thats good. I'll try postin some pics asap.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:48 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST