E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > 2007 BMW 335i Valve Problem



Reply
 
Thread Tools Search this Thread
      06-05-2009, 07:43 PM   #1
Wibi.M
Private
5
Rep
53
Posts

 
Drives: BMW 335i
Join Date: Jun 2009
Location: San Francisco, USA

iTrader: (0)

Exclamation 2007 BMW 335i Valve Problem

Hi Guys, just wondering, has anyone had a valve problem before on their 335? or any 3 series car?
While i was driving on the high way last week, the signal "Engine Malfunction, reduced power" came up 3 times; i had to pull over, restart the car -__-. The next few days i brought it to BMW and they told me it was a valve problem.

The guy told me the closing and opening of the valve wasn't right, and could cause severe damage to the engine if not serviced.

any help?

Thanks!
Appreciate 0
      06-05-2009, 07:45 PM   #2
Sparky66
Major
Sparky66's Avatar
Australia
17
Rep
1,232
Posts

 
Drives: 335 E92 Coupe. Jet Black.
Join Date: Feb 2007
Location: Sydney, Australia

iTrader: (0)

Sounds like a Vanos Solenoid control problem. Bring it in to your Service dealer ASAP..
Appreciate 0
      06-05-2009, 08:01 PM   #3
UndergroundEuros
Banned
19
Rep
1,222
Posts

 
Drives: 335I Alphina White
Join Date: May 2009
Location: Florida

iTrader: (9)

i had the same promblem they told me it was my CAI so I took it out and so far crossing my fingers it hasn't happen again.
Appreciate 0
      06-06-2009, 12:42 PM   #4
De90man
First Lieutenant
5
Rep
350
Posts

 
Drives: F30 335i Sedan
Join Date: Feb 2007
Location: Los Angeles

iTrader: (1)

This happened to me two years ago. The tech told me it was a "VANOS Solenoid Failure" and a terminal one at that. So your valve problem is real and BMW knows about it.

After 30 days, they 'lemoned' the car, and told me they were sorry and to come pick out ANY 335i on the lot no matter the options (payment stayed the same). They also told me they would fix my old car a resale it some how.

Disclosure: I ran the JB2 for about 10k miles before the problem. But I don't think this had anything to do with it. Ran the JB2 on my new car and eventually the JB3 with no problems.

Good luck and remember, the dealer should do anything in their power to keep you happy.
Appreciate 0
      06-10-2009, 08:24 PM   #5
Wibi.M
Private
5
Rep
53
Posts

 
Drives: BMW 335i
Join Date: Jun 2009
Location: San Francisco, USA

iTrader: (0)

Quote:
Originally Posted by Sparky66 View Post
Sounds like a Vanos Solenoid control problem. Bring it in to your Service dealer ASAP..
Just got my car back from BMW, yeah, it was the Vanos problem; the person said it was kind of jammed because of some sticky dirts or whatever. After they cleaned them, tested on high ways & cities, it was back to normal. Moreover, i feel the car somehow got a little faster @_@
!!

thanks Sparky!
__________________
Operator, can i have the number for 911?!?! - Homer
Appreciate 0
      06-10-2009, 08:25 PM   #6
Wibi.M
Private
5
Rep
53
Posts

 
Drives: BMW 335i
Join Date: Jun 2009
Location: San Francisco, USA

iTrader: (0)

Quote:
Originally Posted by De90man View Post
This happened to me two years ago. The tech told me it was a "VANOS Solenoid Failure" and a terminal one at that. So your valve problem is real and BMW knows about it.

After 30 days, they 'lemoned' the car, and told me they were sorry and to come pick out ANY 335i on the lot no matter the options (payment stayed the same). They also told me they would fix my old car a resale it some how.

Disclosure: I ran the JB2 for about 10k miles before the problem. But I don't think this had anything to do with it. Ran the JB2 on my new car and eventually the JB3 with no problems.

Good luck and remember, the dealer should do anything in their power to keep you happy.
Thanks! yeah, i just got my car from bmw, it was the Vanos problem; some sticky stuff in there, they cleaned it up, and now its back no normal..
__________________
Operator, can i have the number for 911?!?! - Homer
Appreciate 0
      05-19-2010, 10:53 AM   #7
Tam@SupremePower
BimmerPost Supporting Vendor
Tam@SupremePower's Avatar
United_States
49
Rep
2,087
Posts


 
Drives: BMW
Join Date: Sep 2006
Location: So. Cal

iTrader: (2)

Garage List
2007 e92 335i  [3.50]
Send a message via AIM to Tam@SupremePower
How many miles was on the cars that had the Vanos Solenoid control problem?
__________________
SupremePOWER
1025-B Ortega Way - Placentia CA 92870
714 632 1951 x224 l tam@supremepower.com l www.supremepower.com
Appreciate 0
      05-19-2010, 12:57 PM   #8
fisherbln
Captain
8
Rep
858
Posts

 
Drives: 2007 335i Coupe
Join Date: Sep 2009
Location: USA

iTrader: (1)

My car had 42K when the vanos solenoid had to be cleaned. No problems since (2K miles).
Appreciate 0
      05-19-2010, 02:42 PM   #9
sashah60
Private First Class
sashah60's Avatar
2
Rep
125
Posts

 
Drives: 13 e92 M3
Join Date: Aug 2007
Location: NY

iTrader: (0)

My car had the exact same problem (VANOS Solenoid issue) yesterday while i was driving and the engine malfunction-reduced power light came on. I am supposed to pick up the car today. The dealer said the factory told em to just clean it for now and see if the problem replicates. The SA said they have test driven the car and the problem hasnt come back. Let see. BTW, my car has 23.5K miles (MY08; 335i cp).
Appreciate 0
      05-19-2010, 03:14 PM   #10
mwahlert
Lieutenant Colonel
mwahlert's Avatar
29
Rep
1,559
Posts

 
Drives: 2008 335i
Join Date: Apr 2008
Location: Durham, NC

iTrader: (7)

Garage List
2007 335i  [0.00]
does anyone know how to remove the vanos solenoids? i would like to remove and clean mine.
Appreciate 0
      05-19-2010, 03:32 PM   #11
M3 Eater
Major
M3 Eater's Avatar
United_States
14
Rep
1,057
Posts

 
Drives: 335i Sedan
Join Date: May 2010
Location: Unknown

iTrader: (3)

Garage List
2007 335i  [0.00]
Yes it's easy! Take the engine cover off, and there are two black plugs in the front of the engine, disconnect and remove two screws each. Pop the long tubes out, make sure u have the o ring on both, I don't know how to clean??? Tech never told me how. I just swapped them to see if the problem followed the solenoid. I got the code again later on the same vanos which is odd. There was no visable gunk on mine to clean anyway. Good luck, lot of tuned cars experience this when under heavy boost followed by a cruise. Like if you went to pass someone on the highway and get back in traffic.. I'll say it's a problem alright. Techs aren't allowed to say they know yet I guess as it's not quite a hpfp size issue but is gaining popularity every day!
Appreciate 0
      05-19-2010, 03:37 PM   #12
mwahlert
Lieutenant Colonel
mwahlert's Avatar
29
Rep
1,559
Posts

 
Drives: 2008 335i
Join Date: Apr 2008
Location: Durham, NC

iTrader: (7)

Garage List
2007 335i  [0.00]
is #1 the vanos Solenoid
Appreciate 0
      05-19-2010, 10:25 PM   #13
Perfectus
Major
Perfectus's Avatar
15
Rep
1,240
Posts

 
Drives: e92 335i
Join Date: Jun 2009
Location: NOVA/MD

iTrader: (10)

What codes are thrown when its the valve solenoid?
__________________
2007 e92 335i - Monaco Blue
ZPP, ZSP, iDrive, Comfort Access

Injen DCI w/ Cyba Scoop - M-Tech Rear - ///M3 Rear Lip Spoiler - ///M5 SMG Shift Knob & iDrive Knob - BMW Performance Hand Brake - BMWCCA Member
Appreciate 0
      05-19-2010, 10:34 PM   #14
gerardm
Captain
gerardm's Avatar
United_States
8
Rep
701
Posts

 
Drives: '07 335i Sedan - Alpine White
Join Date: Apr 2009
Location: Rocky Point, NY

iTrader: (5)

Quote:
Originally Posted by M3 Eater View Post
experience this when under boost followed by a cruise. Like if you went to pass someone on the highway and get back in traffic..
exactly... eventually like me it will happen before you are even done with ur pull. mine happens right at the mid/top of third gear as soon as i am starting to let off the throttle. it blows.
Appreciate 0
      05-19-2010, 11:24 PM   #15
cooperlee
Private First Class
5
Rep
159
Posts

 
Drives: 2007 335
Join Date: Sep 2009
Location: L.I.

iTrader: (2)

sounds like many of us are having the same issues. hope the dealer can fix my solenoid issues too next week. Just sucks that i got to remove the JB and other parts before dropping off the car....
Appreciate 0
      05-21-2010, 01:30 PM   #16
Alex@TAG
Alex@TAG's Avatar
United_States
18
Rep
299
Posts

 
Drives: 15 M4, 14 S7, 14 E63 Wagon
Join Date: Oct 2006
Location: San Diego, CA

iTrader: (1)

Send a message via AIM to Alex@TAG
The dealer has replaced mine once already. I ahve been running the GIAC flash for about 8k miles now and been constantly having the same issues. Then they went ahead and replaced 3 injectors and a camshaft lift sensor as the camshaft was grooved (i think) and it still didnt solve the problem.

Ive been driving for about 5k with the ongoing problem and now they have just flashed and updated my ECU. Picked the car back from the dealer and even with the stock file, same issue. They have replaced the vanos once, cleaned it another, and updated the ecu and still no fix...

Does this call for Lemon Law yet? haha
Appreciate 0
      05-21-2010, 02:37 PM   #17
mwahlert
Lieutenant Colonel
mwahlert's Avatar
29
Rep
1,559
Posts

 
Drives: 2008 335i
Join Date: Apr 2008
Location: Durham, NC

iTrader: (7)

Garage List
2007 335i  [0.00]
Quote:
Originally Posted by RE5PEKT View Post
The dealer has replaced mine once already. I ahve been running the GIAC flash for about 8k miles now and been constantly having the same issues. Then they went ahead and replaced 3 injectors and a camshaft lift sensor as the camshaft was grooved (i think) and it still didnt solve the problem.

Ive been driving for about 5k with the ongoing problem and now they have just flashed and updated my ECU. Picked the car back from the dealer and even with the stock file, same issue. They have replaced the vanos once, cleaned it another, and updated the ecu and still no fix...

Does this call for Lemon Law yet? haha
they haven't replaced the camshaft ledges?
Appreciate 0
      05-21-2010, 03:04 PM   #18
raceyBMW
king of the hills
raceyBMW's Avatar
United_States
29
Rep
2,832
Posts

 
Drives: 335i coupe
Join Date: Dec 2006
Location: Denver, CO

iTrader: (1)

Garage List
1994 530i  [4.25]
2007 335i Coupe  [4.07]
I just had the camshaft ledge replacement done on my car (not sure if intake or exhaust cam). I threw a half engine light and reduced power with the vanos code a week ago, which is why they did the repair. Engine always had a rough spot at ~1200 RPM which is now gone after the repair and I got a software update.
Appreciate 0
      05-28-2010, 12:37 PM   #19
Alex@TAG
Alex@TAG's Avatar
United_States
18
Rep
299
Posts

 
Drives: 15 M4, 14 S7, 14 E63 Wagon
Join Date: Oct 2006
Location: San Diego, CA

iTrader: (1)

Send a message via AIM to Alex@TAG
Quote:
Originally Posted by mwahlert View Post
they haven't replaced the camshaft ledges?
Yup they did that already!
Appreciate 0
      05-28-2010, 12:42 PM   #20
joec500
Brigadier General
46
Rep
3,004
Posts

 
Drives: it has 4 wheels
Join Date: Jul 2008
Location: San Francisco

iTrader: (10)

Did they replace the actual cam shaft? That's what they did with my car.
Appreciate 0
      05-28-2010, 05:43 PM   #21
cooperlee
Private First Class
5
Rep
159
Posts

 
Drives: 2007 335
Join Date: Sep 2009
Location: L.I.

iTrader: (2)

Its your VANOS Solenoids that needs to be replaced. I just had mine replaced by the dealer this past week. Car is running strong and clean as ever now. Just a pain in the ass to remove all the mods before dropping off to dealer!!!!!
Appreciate 0
      05-28-2010, 07:01 PM   #22
roadkillrob
Brigadier General
United_States
58
Rep
3,914
Posts

 
Drives: 2008 335Cic, 2011 X5 35i
Join Date: Jul 2007
Location: Boston

iTrader: (14)

There are several things BMW just sucks at making - Vanos Solenoids are one of those things, followed by coils, water pumps and HPFP's, besides the new HPFP, the other 3 things have been breaking for 10 years regularly!
__________________

2008 E93 335i, GIAC Stage 2, HPF IC, Injen Intake, Defective AR Design DP's with useless cats
2014 X3 35i JB Stage 1
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:00 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST