E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > JUST got coilovers but theres a problem



Reply
 
Thread Tools Search this Thread
      06-27-2009, 03:37 PM   #1
cuban335i
Brigadier General
 
cuban335i's Avatar
 
Drives: 535i xdrive
Join Date: Feb 2009
Location: central NJ

Posts: 3,551
iTrader: (18)

JUST got coilovers but theres a problem

hey guys,
i just installed my coilovers but when i turn my wheels a good amount (and ONLY when i turn my wheels a good amount.. not when i'm changing lanes on the highway or something) there is this weird "clank" or "ting" noise and i have no clue what it is.. please help! is it bad?
__________________
Current:
'13 F10 535i xDrive - lightly modded for now
Previous:
'12 e92 M3 Melbourne Red/Bamboo - ADV.1 ADV10, Volk TE37SL, OSS, Innotech F1, Arkym, iND
'09 e92 335i Alpine White/Saddle Brown - fully modded
cuban335i is offline   United_States
0
Reply With Quote
      06-27-2009, 04:23 PM   #2
200Duece
Colonel
 
200Duece's Avatar
 
Drives: '73 2002,'12 X5 35d,'12 335 SL
Join Date: Jan 2007
Location: A Whale's Vagina, Ca

Posts: 2,552
iTrader: (5)

sway bar link?
__________________


1988 E28 535is Euro Conversion --- sold
2009 E90 335 6MT --- sold
200Duece is offline  
0
Reply With Quote
      06-27-2009, 04:29 PM   #3
cuban335i
Brigadier General
 
cuban335i's Avatar
 
Drives: 535i xdrive
Join Date: Feb 2009
Location: central NJ

Posts: 3,551
iTrader: (18)

i'm not sure... all i know its when i turn my wheels a good amount and its sort of a ting or clank or something kind of like that..
__________________
Current:
'13 F10 535i xDrive - lightly modded for now
Previous:
'12 e92 M3 Melbourne Red/Bamboo - ADV.1 ADV10, Volk TE37SL, OSS, Innotech F1, Arkym, iND
'09 e92 335i Alpine White/Saddle Brown - fully modded
cuban335i is offline   United_States
0
Reply With Quote
      06-27-2009, 04:30 PM   #4
iheartsole
Brigadier General
 
iheartsole's Avatar
 
Drives: 08 335i coupe
Join Date: Apr 2007
Location: San Diego

Posts: 4,931
iTrader: (2)

maybe its hitting something. are your fenders rolled?
iheartsole is offline   No_Country
0
Reply With Quote
      06-27-2009, 04:36 PM   #5
cuban335i
Brigadier General
 
cuban335i's Avatar
 
Drives: 535i xdrive
Join Date: Feb 2009
Location: central NJ

Posts: 3,551
iTrader: (18)

its only happening in the front of my car.. its definitely not my fenders.. i was thinking it was that heat shield or whatever it is behind my rotors..
__________________
Current:
'13 F10 535i xDrive - lightly modded for now
Previous:
'12 e92 M3 Melbourne Red/Bamboo - ADV.1 ADV10, Volk TE37SL, OSS, Innotech F1, Arkym, iND
'09 e92 335i Alpine White/Saddle Brown - fully modded
cuban335i is offline   United_States
0
Reply With Quote
      06-27-2009, 05:00 PM   #6
200Duece
Colonel
 
200Duece's Avatar
 
Drives: '73 2002,'12 X5 35d,'12 335 SL
Join Date: Jan 2007
Location: A Whale's Vagina, Ca

Posts: 2,552
iTrader: (5)

you have the car, go pull and tap on the suspension pieces to see if you can replicate the noise. Or take it back to the shop that did the work.

Posting about noises that your car makes and then not investigating for yourself the idea's that people give you is a waste of time.

No one is gunna be able to tell you exactly what the noise is from thousands of miles away, in text, none the less.
__________________


1988 E28 535is Euro Conversion --- sold
2009 E90 335 6MT --- sold
200Duece is offline  
0
Reply With Quote
      06-27-2009, 05:02 PM   #7
cuban335i
Brigadier General
 
cuban335i's Avatar
 
Drives: 535i xdrive
Join Date: Feb 2009
Location: central NJ

Posts: 3,551
iTrader: (18)

well i just went and checked it out and turned my wheels a bunch of times and all that and i don't see anything hitting anything.. so thats why i'm confused.. i also thought someone would have been in this situation already.. so that's why i'm asking..
__________________
Current:
'13 F10 535i xDrive - lightly modded for now
Previous:
'12 e92 M3 Melbourne Red/Bamboo - ADV.1 ADV10, Volk TE37SL, OSS, Innotech F1, Arkym, iND
'09 e92 335i Alpine White/Saddle Brown - fully modded
cuban335i is offline   United_States
0
Reply With Quote
      06-27-2009, 05:44 PM   #8
200Duece
Colonel
 
200Duece's Avatar
 
Drives: '73 2002,'12 X5 35d,'12 335 SL
Join Date: Jan 2007
Location: A Whale's Vagina, Ca

Posts: 2,552
iTrader: (5)

Okay. you just turned your wheels with them on the ground and didn't hear the wheels touch or hit anything. So, becuase you just had your suspension worked on, it's probably related to the work that was done and not the wheels. check all the things that were touched in the installation process for the coil overs
__________________


1988 E28 535is Euro Conversion --- sold
2009 E90 335 6MT --- sold
200Duece is offline  
0
Reply With Quote
      06-27-2009, 06:31 PM   #9
cuban335i
Brigadier General
 
cuban335i's Avatar
 
Drives: 535i xdrive
Join Date: Feb 2009
Location: central NJ

Posts: 3,551
iTrader: (18)

will do.. do you think it can be that the springs are still settling?
__________________
Current:
'13 F10 535i xDrive - lightly modded for now
Previous:
'12 e92 M3 Melbourne Red/Bamboo - ADV.1 ADV10, Volk TE37SL, OSS, Innotech F1, Arkym, iND
'09 e92 335i Alpine White/Saddle Brown - fully modded
cuban335i is offline   United_States
0
Reply With Quote
      06-27-2009, 06:32 PM   #10
uberschnell
Brigadier General
 
uberschnell's Avatar
 
Drives: // 135i //, X5
Join Date: Mar 2007
Location: Bay Area

Posts: 3,368
iTrader: (43)

I've had my AST/swift set up a bit now and it has been totally noise free.
uberschnell is offline   No_Country
0
Reply With Quote
      06-27-2009, 06:38 PM   #11
200Duece
Colonel
 
200Duece's Avatar
 
Drives: '73 2002,'12 X5 35d,'12 335 SL
Join Date: Jan 2007
Location: A Whale's Vagina, Ca

Posts: 2,552
iTrader: (5)

thanks for sharing.^^^

spings shouldn't be making any noise.
__________________


1988 E28 535is Euro Conversion --- sold
2009 E90 335 6MT --- sold
200Duece is offline  
0
Reply With Quote
      06-27-2009, 06:41 PM   #12
CV335
Major
 
CV335's Avatar
 
Drives: '06 MCS
Join Date: Oct 2008
Location: TX

Posts: 1,213
iTrader: (5)

Are you already using spacers for your Vmr wheels (as per your other thread)? Did you try running the car with the stock wheels?
CV335 is offline   United_States
0
Reply With Quote
      06-27-2009, 06:41 PM   #13
cuban335i
Brigadier General
 
cuban335i's Avatar
 
Drives: 535i xdrive
Join Date: Feb 2009
Location: central NJ

Posts: 3,551
iTrader: (18)

damn i guess i'll just take it back to the shop on monday.. they better fix the problem for free too..
__________________
Current:
'13 F10 535i xDrive - lightly modded for now
Previous:
'12 e92 M3 Melbourne Red/Bamboo - ADV.1 ADV10, Volk TE37SL, OSS, Innotech F1, Arkym, iND
'09 e92 335i Alpine White/Saddle Brown - fully modded
cuban335i is offline   United_States
0
Reply With Quote
      06-27-2009, 06:42 PM   #14
cuban335i
Brigadier General
 
cuban335i's Avatar
 
Drives: 535i xdrive
Join Date: Feb 2009
Location: central NJ

Posts: 3,551
iTrader: (18)

and yea i ended up going with 5mm spacers because they gave me enough clearance.. and i don't have the stock rims anymore because i sold them..
__________________
Current:
'13 F10 535i xDrive - lightly modded for now
Previous:
'12 e92 M3 Melbourne Red/Bamboo - ADV.1 ADV10, Volk TE37SL, OSS, Innotech F1, Arkym, iND
'09 e92 335i Alpine White/Saddle Brown - fully modded
cuban335i is offline   United_States
0
Reply With Quote
      06-27-2009, 11:15 PM   #15
Craig@SupremePower
BimmerPost Supporting Vendor

 
Craig@SupremePower's Avatar
 
Drives: '12 Dodge Durango R/T
Join Date: Mar 2008
Location: New Jersey

Posts: 75,000
iTrader: (14)

+1... have em tighten em up!!
Quote:
Originally Posted by 200Duece View Post
sway bar link?
__________________
Craig@SupremePower is offline   United_States
0
Reply With Quote
      06-28-2009, 09:31 AM   #16
cuban335i
Brigadier General
 
cuban335i's Avatar
 
Drives: 535i xdrive
Join Date: Feb 2009
Location: central NJ

Posts: 3,551
iTrader: (18)

ok i just looked at it again.. and raised the car up with the wheels turned and had my hand on the springs while i was raising it and the noise is definitely comming from the springs because when the noise occurs i feel a vibration in the springs themselves.. what do i do to fix that?
__________________
Current:
'13 F10 535i xDrive - lightly modded for now
Previous:
'12 e92 M3 Melbourne Red/Bamboo - ADV.1 ADV10, Volk TE37SL, OSS, Innotech F1, Arkym, iND
'09 e92 335i Alpine White/Saddle Brown - fully modded
cuban335i is offline   United_States
0
Reply With Quote
      06-28-2009, 09:45 AM   #17
I335
Brigadier General
 
I335's Avatar
 
Drives: '08 335i Coupe
Join Date: Jan 2008
Location: New England

Posts: 4,252
iTrader: (11)

Quote:
Originally Posted by cuban335i View Post
ok i just looked at it again.. and raised the car up with the wheels turned and had my hand on the springs while i was raising it and the noise is definitely comming from the springs because when the noise occurs i feel a vibration in the springs themselves.. what do i do to fix that?
You bring it back to the installer and have them fix it. They have the proper tools and lift...
I335 is offline  
0
Reply With Quote
      06-28-2009, 09:54 AM   #18
cuban335i
Brigadier General
 
cuban335i's Avatar
 
Drives: 535i xdrive
Join Date: Feb 2009
Location: central NJ

Posts: 3,551
iTrader: (18)

ok sounds like a plan.. i'll take it tomorrow..
__________________
Current:
'13 F10 535i xDrive - lightly modded for now
Previous:
'12 e92 M3 Melbourne Red/Bamboo - ADV.1 ADV10, Volk TE37SL, OSS, Innotech F1, Arkym, iND
'09 e92 335i Alpine White/Saddle Brown - fully modded
cuban335i is offline   United_States
0
Reply With Quote
      06-29-2009, 03:01 AM   #19
yamazaho
Wang D.D.S.
 
yamazaho's Avatar
 
Drives: 08' E70 X5, 12' E92 335is
Join Date: Jul 2006
Location: Houston, TX

Posts: 6,883
iTrader: (11)

Garage List
2006 325i  [3.88]
Send a message via MSN to yamazaho
Subscribed. I just finish installing my Silverline plus coils tonight and I ran into the problem with front wheel rubbing the coil issue. I am calling SPP tmr to order my spacers to place in the front. I would like to know what other problems there can be with FKs.....
__________________

Last edited by yamazaho; 06-29-2009 at 01:07 PM.
yamazaho is offline   Taiwan
0
Reply With Quote
      06-29-2009, 09:08 AM   #20
uberschnell
Brigadier General
 
uberschnell's Avatar
 
Drives: // 135i //, X5
Join Date: Mar 2007
Location: Bay Area

Posts: 3,368
iTrader: (43)

Springs rotate as they compress, they could be binding. Are you using camber plates? My set up uses thrust sheets to compensate for rotation.

Also, understand some people have experienced a similar clank at full turn coming from the brakes.
uberschnell is offline   No_Country
0
Reply With Quote
      06-29-2009, 09:13 AM   #21
Kevin@AKMotorwerk
General
 
Kevin@AKMotorwerk's Avatar
 
Drives: THE GUY YOU LOVE TO HATE
Join Date: Mar 2009
Location: hillsborough, nj

Posts: 28,154
iTrader: (1)

every car i seen with the fk's rub the lower helper coil!

i doubt your noise is from your spring itself, i would check the sway bar end links and the backing plate on the rotor, but of course bring it back to the installer and make them make it right!
Kevin@AKMotorwerk is offline   United_States
0
Reply With Quote
      06-29-2009, 11:06 AM   #22
CV335
Major
 
CV335's Avatar
 
Drives: '06 MCS
Join Date: Oct 2008
Location: TX

Posts: 1,213
iTrader: (5)

Apparently the FK coilovers' have a wider perch than the KWs; I think that's why we only see FK owners reporting this "issue". With my stock 189 wheels there was not rubbing with the FKs. However, when I switched to 235 19's with ET35 I had to put a 5mm spacers to give enough clearance.
CV335 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:46 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST