E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Lighting System Malfunction



Reply
 
Thread Tools Search this Thread
      06-30-2009, 04:52 PM   #1
Zojirushi
Private First Class
Zojirushi's Avatar
3
Rep
118
Posts

 
Drives: 328i
Join Date: Jun 2009
Location: DFW

iTrader: (0)

Lighting System Malfunction

Hi All,

I'm new to the forums and I would like some help with a problem I'm experiencing. I just recently purchased a 2009 328i and have about 6k miles on it and now I'm getting a lighting system malfunction on my dashboard.

This malfunction happens more and more now. Before it only happens once a week and now it's everytime I turn on the car. When the malfunction error is on, my lowbeam lights turn on and off. So when I did drive at night, it would look like I was flashing my headlights.

Attached you will see a picture of the message. Any help will be appreciated. Thanks in advance.
Attached Images
 
Appreciate 0
      07-01-2009, 06:25 AM   #2
Potty_Pants
Colonel
Potty_Pants's Avatar
United_States
28
Rep
2,191
Posts

 
Drives: 2012 Genesis Sedan Rspec
Join Date: Apr 2007
Location: Southern NJ

iTrader: (0)

I'll be the first...

Take it to the dealer.
__________________
Olds Starfire > Chevy Malibu > Isuzu I-mark RS & Honda Magna 500 > Grand Am GT & YSR50 > Nissan Maxima & Ninja 750 > X-Wife > Hyundai Excel > Honda Prelude > Honda Accord > Honda Prelude & Ninja 250> Infiniti G35 > E90 335i > Hyundai Genesis Rspec, Hyunadai Sonata > Kia Sorento > Honda CRV-EX
Appreciate 0
      07-01-2009, 12:58 PM   #3
Zojirushi
Private First Class
Zojirushi's Avatar
3
Rep
118
Posts

 
Drives: 328i
Join Date: Jun 2009
Location: DFW

iTrader: (0)

I read a few other post and someone mention the casing or housing of the bulb or a burned out bulb. I have some of the same symptoms but not all. So I'm not sure what to do.

I'm scared to go to the dealer. I hear they do more harm than good. If there was a way to skip the dealer and fix it myself I would like to. Has anyone ever seen that message before?
Appreciate 0
      07-01-2009, 11:16 PM   #4
Roowah
Captain
Roowah's Avatar
United_States
15
Rep
810
Posts

 
Drives: 2006 E90 330i 6MT
Join Date: Jan 2007
Location: Cambridge, MA

iTrader: (0)

Sounds like an issue you cannot fix yourself. You'll have to take it to the dealer. Typically, they (and your car) will be fine. Build a positive relationship with your SA, and he or she will do right by you.
__________________

2006 E90 330i 6MT: TiAg|Black Leather|Poplar Trim|Premium Package|Cold Weather Package
2003 E46 325i 5MT: Retired - The beginning of my BMW obsession!
Appreciate 0
      07-02-2009, 01:18 AM   #5
Zojirushi
Private First Class
Zojirushi's Avatar
3
Rep
118
Posts

 
Drives: 328i
Join Date: Jun 2009
Location: DFW

iTrader: (0)

Thanks for the help guys, I'll take it into the dealership.
Appreciate 0
      07-22-2009, 09:03 PM   #6
Zojirushi
Private First Class
Zojirushi's Avatar
3
Rep
118
Posts

 
Drives: 328i
Join Date: Jun 2009
Location: DFW

iTrader: (0)

Just want to give a heads up to whom ever might receive the message in the picture of the OP.

BMW finally found the problem after three days and it was the footwell module. They replaced it and is currently being programmed. I will be able to pick it up tomorrow. Hope this can help someone in the future if they ever receive this
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:48 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST