E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > DSC Light, 4x4 Light, Brake HELP Please



Reply
 
Thread Tools Search this Thread
      03-05-2013, 05:58 PM   #1
FLYT89
New Member
1
Rep
18
Posts

 
Drives: 2009 E90 335i X
Join Date: Nov 2012
Location: Long Island, NY

iTrader: (0)

DSC Light, 4x4 Light, Brake HELP Please

I just bought my certified pre-owned BMW 335i Xdrive back in October 2012. Everyday when i drive it to and from work, I get the following warning lights, 4x4, BRAKE and DSC warning.As well as the following messages on my iDrive, " Chassis Stabilization Malfunction", "DBC Malfucntion" and "Start-Off assistance inactive" as well as the chime. These lights do not go away til after I shut off the car and restart it. However, it literally happens to me everyday if I hit a HARD BUMP or POTHOLE. BUT its EVERYDAY this happens. I brought it to the dealer 3 times, took a ride with the shopforeman and i was told this was normal, as i had upgraded to 18"s when my car only came with 17"s However the 18s i am running are BMW style 193m wheels with 225/40/18 tires in the front and 255/35/18 tires in the rear, which comes standard on the 335m sport even with X drive. I dont think its my steering angle sensor since my signals work fine and shut off right when my steering wheel goes straight. I feel like it might be a bad DSC module or something. I highly doubt its the wheels. Any one have any insight please, its driving me crazy as this happens every single day!
Attached Images
  
Appreciate 0
      03-05-2013, 06:13 PM   #2
FLYT89
New Member
1
Rep
18
Posts

 
Drives: 2009 E90 335i X
Join Date: Nov 2012
Location: Long Island, NY

iTrader: (0)

I forgot to mention, i have a friend who works at the dealership, who was able to read the codes and send them to me, however he has no location to pin point the problem. Heres what it says:
Attached Images
 
Appreciate 0
      03-05-2013, 06:56 PM   #3
LocDawgg
Captain
10
Rep
822
Posts

 
Drives: AW e90
Join Date: Jun 2011
Location: Fort Lauderdale, Florida

iTrader: (5)

Reset steering angle sensor, via dealership or local indie shop. If that doesn't work, then you need to replace the steering column (SZL). Should cost you around 7-900 at a indie shop and 1-1200 at a dealership. This is a common problem on the e9x dont worry you are not the only one.
Appreciate 0
      03-05-2013, 07:05 PM   #4
FLYT89
New Member
1
Rep
18
Posts

 
Drives: 2009 E90 335i X
Join Date: Nov 2012
Location: Long Island, NY

iTrader: (0)

It's not the steering angle sensor. My local indie shop reset it yesterday and its still doing it. No problems with my turn signals or adaptive headlights
Appreciate 0
      03-05-2013, 07:18 PM   #5
FLYT89
New Member
1
Rep
18
Posts

 
Drives: 2009 E90 335i X
Join Date: Nov 2012
Location: Long Island, NY

iTrader: (0)

Most importantly it only happens when I go over bumps or a pothole
Appreciate 0
      03-05-2013, 07:26 PM   #6
LocDawgg
Captain
10
Rep
822
Posts

 
Drives: AW e90
Join Date: Jun 2011
Location: Fort Lauderdale, Florida

iTrader: (5)

Quote:
Originally Posted by FLYT89 View Post
Most importantly it only happens when I go over bumps or a pothole
yes i know it happens to me all the time, like i said if the reset doesn't work then the SZL needs to be replaced.

Once you hit around 50k miles, it just stays on all the time....it wont even turn off when you shut the car on and off.
Appreciate 0
      03-05-2013, 07:33 PM   #7
FLYT89
New Member
1
Rep
18
Posts

 
Drives: 2009 E90 335i X
Join Date: Nov 2012
Location: Long Island, NY

iTrader: (0)

Bought the car certified pre owned only four months ago. Still under warranty. Problem is convincing the dealer there is a problem. They just said its normal since I put bigger wheels on.
Appreciate 0
      03-05-2013, 07:36 PM   #8
FLYT89
New Member
1
Rep
18
Posts

 
Drives: 2009 E90 335i X
Join Date: Nov 2012
Location: Long Island, NY

iTrader: (0)

Bought the car certified pre owned only four months ago. Still under warranty. Car only has 34,000 miles. Problem is convincing the dealer there is a problem. They just said its normal since I put bigger wheels on.
Appreciate 0
      03-06-2013, 06:48 AM   #9
FLYT89
New Member
1
Rep
18
Posts

 
Drives: 2009 E90 335i X
Join Date: Nov 2012
Location: Long Island, NY

iTrader: (0)

BUMP
Appreciate 0
      03-06-2013, 07:00 AM   #10
#Tee
Chronic trollololer level 60
#Tee's Avatar
77
Rep
4,882
Posts

 
Drives: yes
Join Date: Oct 2011
Location: Socal

iTrader: (1)

is this under warranty type of issue? i have the extended warranty to 100k.
__________________

#TeamStretchNpoke IG:Tee212

custom cf rear side diffuser add ons for sale (e9x,M3s,f3x) pm me for details. thread http://www.e90post.com/forums/showthread.php?t=962442
Appreciate 0
      03-06-2013, 10:07 AM   #11
nate5ks
Captain
United_States
8
Rep
621
Posts

 
Drives: 2006 BMW 330xi
Join Date: Nov 2011
Location: Jacksonville Beach, FL

iTrader: (0)

Put the old wheels back in if you still have them then take it to the dealer.
Appreciate 0
      03-06-2013, 06:16 PM   #12
FLYT89
New Member
1
Rep
18
Posts

 
Drives: 2009 E90 335i X
Join Date: Nov 2012
Location: Long Island, NY

iTrader: (0)

I dont have the old wheels. But why should it matter going from 17s to 18s as long as i keep the tire diameter the same?
Appreciate 0
      03-07-2013, 07:18 PM   #13
nate5ks
Captain
United_States
8
Rep
621
Posts

 
Drives: 2006 BMW 330xi
Join Date: Nov 2011
Location: Jacksonville Beach, FL

iTrader: (0)

It shouldn't I was just saying to do that so your dealer can't use some lame excuse to not service your car.
Appreciate 0
      08-10-2014, 05:50 PM   #14
new0rder
Lowlife Republic
0
Rep
97
Posts

 
Drives: 06 325XI Monaco Blue
Join Date: Sep 2005
Location: NYC

iTrader: (0)

Garage List
2006 325xi  [0.00]
Interesting topic, I got the same damn issue, for me it started 2 month ago, the weather got hot above 85 degrees, and I had AC blasted, I hit a bump and all lights came on, I can still drive but when I come to a slow stop the car's system turn off ( nothing work all electrical are out ) its like a reset, everything will come back after 1-2 min, so far happen to me few times. day to day driving no issue only if I hit a hard bump. I will try to clean / Reset steering angle sensor first see how that goes.

I have a 2006 325XI. 85,000 miles on it.
__________________
06 Monaco Blue Metallic 325xi
Appreciate 0
      08-10-2014, 06:57 PM   #15
gtaccord
Major
United_States
14
Rep
1,102
Posts

 
Drives: 2009 BMW 335xi
Join Date: Feb 2012
Location: Maryland

iTrader: (7)

Garage List
Take it to a different dealer or get BMW NA involved. The dealer is blowing smoke. The change in wheel size has nothing to do with it. You have warranty. Find someone that will let you use it.
Appreciate 0
      08-10-2014, 08:28 PM   #16
N54CherryHill
bOrN To DiE
2
Rep
253
Posts

 
Drives: 2007 335i E92
Join Date: Apr 2013
Location: South Jersey

iTrader: (0)

I bet its the battery
Appreciate 0
      09-10-2014, 10:43 AM   #17
new0rder
Lowlife Republic
0
Rep
97
Posts

 
Drives: 06 325XI Monaco Blue
Join Date: Sep 2005
Location: NYC

iTrader: (0)

Garage List
2006 325xi  [0.00]
Quote:
Originally Posted by N54CherryHill View Post
I bet its the battery
The battery I replaced last year, so its new, anyway I did try the Steering angle fix, just the optical disc part, use some air can to blow the dust away, not the soldering part. anyway wasn't that hot of day 75 degree temp, I drove around for 20 miles, the problem came back when I hit a bump so the xmas light went up and I have pull to the side, my car lost the power too dangerous
the car eventually came back with power after 1-2 min reset. what to do...
__________________
06 Monaco Blue Metallic 325xi
Appreciate 0
Reply

Bookmarks

Tags
4x4 malfunction, dbc, dsc, x drive

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:13 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST