E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Engine faulty reducing power again!!!!



Reply
 
Thread Tools Search this Thread
      06-21-2009, 07:04 AM   #1
Elie335
ايلي ٣٣٥ هاهاها
 
Elie335's Avatar
 
Drives: Vorsteiner e92
Join Date: Jun 2009
Location: Leb

Posts: 1,445
iTrader: (1)

Question Engine faulty reducing power again!!!!

Well, i got that error message on my 07 bmw 335i, i contacted the bmw support, and i was reading on the forum about that problem its the fuel pump. It was changed and replaced though, the car worked fine for 1 week, and the light came up again, i noticed that the lights comes when i turn on the car and i faslty kick down, after 30 seconds that light comes up, and i noticed that the car power is not like before, from 0 to 2000 RPM the car isn't like before, there's no power untill it reach 3000 RPM and it goes fine. any help guys?
Elie335 is offline   St Pierre and Miquelon
0
Reply With Quote
      06-21-2009, 07:38 AM   #2
Elie335
ايلي ٣٣٥ هاهاها
 
Elie335's Avatar
 
Drives: Vorsteiner e92
Join Date: Jun 2009
Location: Leb

Posts: 1,445
iTrader: (1)

i though so, can it be something beside the fuel pump maybe?
Elie335 is offline   St Pierre and Miquelon
0
Reply With Quote
      06-21-2009, 07:59 AM   #3
Elie335
ايلي ٣٣٥ هاهاها
 
Elie335's Avatar
 
Drives: Vorsteiner e92
Join Date: Jun 2009
Location: Leb

Posts: 1,445
iTrader: (1)

Quote:
Originally Posted by coldasicex5 View Post
tons of things yes, but more than likely sounds like the pump again
alright, can you give me some major problems that might be beside the fuel pump? so i can tell the bmw company to bypass on those things too... thanks in advance
__________________
Elie335 is offline   St Pierre and Miquelon
0
Reply With Quote
      06-21-2009, 09:22 AM   #4
Elie335
ايلي ٣٣٥ هاهاها
 
Elie335's Avatar
 
Drives: Vorsteiner e92
Join Date: Jun 2009
Location: Leb

Posts: 1,445
iTrader: (1)

hm, thanks, "cam shafts" i'm worried already now lol

Is there any visible further can i notice before the car is scanned? like white smoke or something? if it was a cam shaft problem...

Last edited by Elie335; 06-21-2009 at 09:46 AM.
Elie335 is offline   St Pierre and Miquelon
0
Reply With Quote
      06-21-2009, 11:50 AM   #5
Ferre86
Captain
 
Ferre86's Avatar
 
Drives: E93 M3/H2/SL350/Panamera 4/
Join Date: Mar 2009
Location: Turkey

Posts: 948
iTrader: (0)

http://www.e90post.com/forums/showthread.php?t=273373

in my post i have the same sign, i dont think its HPFP though, car becomes normal when you stop and started again , it comes up when i go over 240km ))
__________________
http://www.youtube.com/user/Ferre86

| e93 M-DCT ESS VT2-625 | Akra Slip-on | Challenge Race Catless x-pipe | Challenge front lip | Challenge Diffuser | Carbon front grilles | defi gauges control unit | Macht Schnell gauge panel | E93 M3 trunk Spoiler | IND Carbon Fiber Side Markers |
Ferre86 is offline   Turkey
0
Reply With Quote
      06-21-2009, 12:19 PM   #6
vladster
Private First Class
 
vladster's Avatar
 
Drives: BMW 335 ci
Join Date: Mar 2007
Location: Slovenia

Posts: 190
iTrader: (0)

I had this issue for 20000 km, my dealer couldn't find what was wrong and finally last week they found corrosion on a (NOC-sensor) wires. Now the car runs perfectly.


sorry for the bad english
__________________
vladster is offline   Slovenia
0
Reply With Quote
      06-21-2009, 12:40 PM   #7
vase330
Colonel
 
vase330's Avatar
 
Drives: E92 335i ; 14 RangeRover SSC
Join Date: Jan 2007
Location: Arlington, Va

Posts: 2,675
iTrader: (1)

He is in Lebanon, I don't know if they are having HPFP failures over there, but it also seems a lot of 07 have failures around 8,000 miles - 17,000 miles. He is 12,000 km so he is in the lower range of normal HPFP failures. But again, I thought this was a US-only problem due to ethanol in our gas?
__________________
E92 335 | Space Gray | Saddle Brown Dakota | Dark Burl Trim | ZPP | ZSP | AT | Idrive | 6FL | FBO | Dinan CAI | Quaife LSD | STG3 PROCede.
vase330 is offline   United_States
0
Reply With Quote
      06-21-2009, 01:26 PM   #8
Ferre86
Captain
 
Ferre86's Avatar
 
Drives: E93 M3/H2/SL350/Panamera 4/
Join Date: Mar 2009
Location: Turkey

Posts: 948
iTrader: (0)

we also have in here HPFP i had mine, 13.000km
__________________
http://www.youtube.com/user/Ferre86

| e93 M-DCT ESS VT2-625 | Akra Slip-on | Challenge Race Catless x-pipe | Challenge front lip | Challenge Diffuser | Carbon front grilles | defi gauges control unit | Macht Schnell gauge panel | E93 M3 trunk Spoiler | IND Carbon Fiber Side Markers |
Ferre86 is offline   Turkey
0
Reply With Quote
      07-24-2009, 02:33 AM   #9
Elie335
ايلي ٣٣٥ هاهاها
 
Elie335's Avatar
 
Drives: Vorsteiner e92
Join Date: Jun 2009
Location: Leb

Posts: 1,445
iTrader: (1)

Updated:
No more limp mode, no more engine reducing power thing the dealer said the ex owner of the car was using a bad quality of engine oil, they changed the oil with filer, and there was some oil leak on the " boost sensor " it wasn't working properly, and it was the HPFP too... so they all got replaced now here's some pics of the old sensor, old fuel pump, and the oil i recently used.


boost sensor

Hope those info would help some ppl looking forward for that engine faulty thing troubleshooting.
Elie335 is offline   St Pierre and Miquelon
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:05 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST