E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Serious malfunction after JB+ and DCI reinstall



Reply
 
Thread Tools Search this Thread
      07-21-2009, 08:46 PM   #1
cougfan335
First Lieutenant
 
cougfan335's Avatar
 
Drives: 335i Coupe MT, Montego/Saddle
Join Date: Mar 2007
Location: Reno, NV

Posts: 326
iTrader: (6)

Serious malfunction after JB+ and DCI reinstall

My car was running great a week ago. I took it in to the dealership for minor stuff and removed my beloved JB+ and BMS DCI. Days later I decide I need the extra power back. I put the ECU in sleep mode by leaving it hood up and doors locked for at least half an hour and easily reinstall the chip and intake. Then I start the car and after a few seconds get the limp home mode. Then that turns off and all that remains is the check engine light. Through various restarts and checking of all connections these lights are intermittent with seemingly no rhyme or reason. Then all seems clear until a brief drive brings them back and now neither will go away. Any advice is greatly appreciated.
__________________
e92 335i: Montego, Saddle Brown, Burl Walnut, MT, Sport, Prem, CW, PDC, Rear Shade. Mods: JB4, BMS Dual Intake, Cyba Scoops, Beyern Mesh Chrome 19" wheels, 15% F1 tint, LeatherZ weighted shift knob, body color reflectors, Matte black grill with Montego surround, middle lower grill removed, left and right lower grills painted black.
cougfan335 is offline   United_States
0
Reply With Quote
      07-21-2009, 08:49 PM   #2
Mike@N54Tuning.com
BimmerPost Supporting Vendor

 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

Posts: 14,287
iTrader: (86)

As always contact BMS

You may want to check the pins on the JB+ to ensure they weren't recessed or damaged during the install.

Mike
Mike@N54Tuning.com is offline   Canada
0
Reply With Quote
      07-21-2009, 09:50 PM   #3
cougfan335
First Lieutenant
 
cougfan335's Avatar
 
Drives: 335i Coupe MT, Montego/Saddle
Join Date: Mar 2007
Location: Reno, NV

Posts: 326
iTrader: (6)

I pulled some wires from the male connector on the JB+. Got it hooked up without the Juice and all thats left is a CEL. Apparently autozone has readers and can clear it right up now. Thanks to Terry and Mike for the great service.
__________________
e92 335i: Montego, Saddle Brown, Burl Walnut, MT, Sport, Prem, CW, PDC, Rear Shade. Mods: JB4, BMS Dual Intake, Cyba Scoops, Beyern Mesh Chrome 19" wheels, 15% F1 tint, LeatherZ weighted shift knob, body color reflectors, Matte black grill with Montego surround, middle lower grill removed, left and right lower grills painted black.
cougfan335 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:07 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST