E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Dead/Intermittent rear sunshade



Reply
 
Thread Tools Search this Thread
      08-03-2009, 11:57 PM   #1
MMachines
BMW Owner
Canada
7
Rep
429
Posts

 
Drives: 2006 330i, 2008 M3
Join Date: Mar 2009
Location: Downtown Toronto

iTrader: (1)

Dead/Intermittent rear sunshade

On my 2006 330i my rear sunshade works intermittently. It's not worked for the last little while now at all (not that I try it often). I can however here a slight "click click" when I push the button (when the car is off so I can hear it) but nothing moves back there. I did a search and found nothing. I can't be the only one, can I?
__________________
2006 330i & 2008 M3
Appreciate 0
      08-04-2009, 12:53 PM   #2
fnckr
Second Lieutenant
fnckr's Avatar
2
Rep
243
Posts

 
Drives: 2006 330i 6mt
Join Date: Feb 2009
Location: Parsippany, NJ

iTrader: (0)

You're going to hate reading this... My sunshade did the same thing for nearly one month. When I finally went to the dealer the SA got in the car, pushed the button, and it "magically" went up. I haven't had an issue since.....

He did say that the track is sensitive and a minor bump can jostle it into just the right position to freeze it and that an equally minor bump can get it unstuck. I think it's similar to a folding ladder. If you push just one leg it'll never close, but apply even pressure to both legs and it folds like it's greased with warm butter.

I would tap it right or left a little and try the button again. If that doesn't work, leave the pulling and prying for the SA. My SA said he was ready to replace the whole thing if it didn't begin working. Oh, and they did lube it after they got it up. Don't know about any DIY solutions though.
Appreciate 0
      08-04-2009, 08:14 PM   #3
MMachines
BMW Owner
Canada
7
Rep
429
Posts

 
Drives: 2006 330i, 2008 M3
Join Date: Mar 2009
Location: Downtown Toronto

iTrader: (1)

Thanks. Good to see I'm not alone though. I'll just keep trying and if it goes up I'll see about lubing it. It really doesn't seem to try at all though. I'm out of bumper to bumper warranty.
__________________
2006 330i & 2008 M3
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:25 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST