E90Post
 


Bimmertech
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > P2096 code thrown......



Reply
 
Thread Tools Search this Thread
      08-05-2009, 07:40 PM   #1
cstmx_ryder
Colonel
 
cstmx_ryder's Avatar
 
Drives: A metal box with a roundel
Join Date: Jul 2007
Location: Portland, OR

Posts: 2,734
iTrader: (2)

Send a message via AIM to cstmx_ryder Send a message via MSN to cstmx_ryder
Angry P2096 code thrown......

The SES light came on as I was driving home this afternoon. I used my c-reader to see what the code was and it said

P2096: Post catalyst fuel trim bank 1 system too lean.

Huh??!! How should I go about troubleshooting this? ANY input or suggestion please??

TIA
__________________

'08 AW E90 335i
PROcede V5 | BMS DCI | RR DPs | ETS FMIC | FORGE DVs | Stett CP | Vanguard | PSS10
cstmx_ryder is offline   United_States
0
Reply With Quote
      08-05-2009, 07:49 PM   #2
TheAcAvenger
Brigadier General
 
TheAcAvenger's Avatar
 
Drives: 2007 E92 335i
Join Date: Apr 2006
Location: 757, VA

Posts: 3,088
iTrader: (1)

I throw that code every once in a while, usually after I've been driving a long time. I just assumed it had to do with the DPs. Usually the O2 sim covers it, but you should be able to clear it and have it not show up again for a while.
__________________
2007 E92 335i - TC Kline DA Coilovers, HPA M3 Suspension Retrofit, Quaife LSD, Stoptech 6/4 BBK, Volk TE-37s, AR Downpipes, RDSport Quads, Forge DVs, Stett OC, RB Turbos, Procede V5, PWM Meth, Helix IC, EAS DCI, Rixster VEI, M-Tech Sides, OEM Aero Lip, Rieger Spoiler, Vorsteiner V-35 Hood, Performance Steering Wheel, Anthracite Headliner, OSS Headlights
TheAcAvenger is offline   United_States
0
Reply With Quote
      08-05-2009, 09:12 PM   #3
cstmx_ryder
Colonel
 
cstmx_ryder's Avatar
 
Drives: A metal box with a roundel
Join Date: Jul 2007
Location: Portland, OR

Posts: 2,734
iTrader: (2)

Send a message via AIM to cstmx_ryder Send a message via MSN to cstmx_ryder
Uhhh......isn't that suppose to NOT happen?! It MUST be telling me something's not right......lol.

Anyone else??

TIA
__________________

'08 AW E90 335i
PROcede V5 | BMS DCI | RR DPs | ETS FMIC | FORGE DVs | Stett CP | Vanguard | PSS10
cstmx_ryder is offline   United_States
0
Reply With Quote
      08-05-2009, 10:19 PM   #4
TheAcAvenger
Brigadier General
 
TheAcAvenger's Avatar
 
Drives: 2007 E92 335i
Join Date: Apr 2006
Location: 757, VA

Posts: 3,088
iTrader: (1)

Quote:
Originally Posted by cstmx_ryder View Post
Uhhh......isn't that suppose to NOT happen?! It MUST be telling me something's not right......lol.

Anyone else??

TIA
I mean, it's not SUPPOSED to happen because an O2 sim is supposed to adjust for it.


Apparently, it means that your sim is too STRONG. I had assumed that it meant it was too weak. I'm going to try 85% and see how that goes.

http://www.e90post.com/forums/showth...ighlight=p2096
__________________
2007 E92 335i - TC Kline DA Coilovers, HPA M3 Suspension Retrofit, Quaife LSD, Stoptech 6/4 BBK, Volk TE-37s, AR Downpipes, RDSport Quads, Forge DVs, Stett OC, RB Turbos, Procede V5, PWM Meth, Helix IC, EAS DCI, Rixster VEI, M-Tech Sides, OEM Aero Lip, Rieger Spoiler, Vorsteiner V-35 Hood, Performance Steering Wheel, Anthracite Headliner, OSS Headlights
TheAcAvenger is offline   United_States
0
Reply With Quote
      08-06-2009, 12:12 AM   #5
cstmx_ryder
Colonel
 
cstmx_ryder's Avatar
 
Drives: A metal box with a roundel
Join Date: Jul 2007
Location: Portland, OR

Posts: 2,734
iTrader: (2)

Send a message via AIM to cstmx_ryder Send a message via MSN to cstmx_ryder
Quote:
Originally Posted by TheAcAvenger View Post
I mean, it's not SUPPOSED to happen because an O2 sim is supposed to adjust for it.


Apparently, it means that your sim is too STRONG. I had assumed that it meant it was too weak. I'm going to try 85% and see how that goes.

http://www.e90post.com/forums/showth...ighlight=p2096
I don't have Rev.II, I have Rev.I with RR O2 SIM and extra resistors.

I think I'll try taking off the resistors and see if the SES light goes away, and stays away. I may just have to clear it manually if it doesn't go away by itself.
__________________

'08 AW E90 335i
PROcede V5 | BMS DCI | RR DPs | ETS FMIC | FORGE DVs | Stett CP | Vanguard | PSS10
cstmx_ryder is offline   United_States
0
Reply With Quote
      08-06-2009, 01:43 AM   #6
Blk07335i
Captain
 
Blk07335i's Avatar
 
Drives: 2012 Alpine White e93 Msport
Join Date: Mar 2007
Location: Orange County

Posts: 918
iTrader: (4)

Send a message via AIM to Blk07335i
Quote:
Originally Posted by cstmx_ryder View Post
I don't have Rev.II, I have Rev.I with RR O2 SIM and extra resistors.

I think I'll try taking off the resistors and see if the SES light goes away, and stays away. I may just have to clear it manually if it doesn't go away by itself.
Yep O2 sim is too strong. Had the same problem reduced the strength and everything is fine.
Blk07335i is offline   United_States
0
Reply With Quote
      08-06-2009, 05:26 PM   #7
cstmx_ryder
Colonel
 
cstmx_ryder's Avatar
 
Drives: A metal box with a roundel
Join Date: Jul 2007
Location: Portland, OR

Posts: 2,734
iTrader: (2)

Send a message via AIM to cstmx_ryder Send a message via MSN to cstmx_ryder
Funny, this morning when I started the car, the SES light was gone..........

But I went ahead and took the resistors off the SIM anyway. Hope this cures the problem, if it comes back again, I won't know what to do......Maybe just upgrade to Rev.II? I really don't feel like installing/uninstalling the resistors. lol
__________________

'08 AW E90 335i
PROcede V5 | BMS DCI | RR DPs | ETS FMIC | FORGE DVs | Stett CP | Vanguard | PSS10
cstmx_ryder is offline   United_States
0
Reply With Quote
      08-06-2009, 08:56 PM   #8
Nyulak
Captain
 
Nyulak's Avatar
 
Drives: 2009 BMW 535xi
Join Date: Feb 2007
Location: SheffVill, OH

Posts: 950
iTrader: (4)

Garage List
2009 BMW 535xi  [0.00]
I had the same issue; it started coincidentally after having my MT replaced. Dealership stated no new software was installed. Sometimes the light would go away on its own, but would come back after a couple of hundred miles of driving.

About three weeks ago I Sea Foamed my car, and the light has yet to return. Maybe that did the trick or I just jinxed myself.
Nyulak is offline   United_States
0
Reply With Quote
      08-06-2009, 09:04 PM   #9
Dr.phuOnger?
*BluRp*
 
Dr.phuOnger?'s Avatar
 
Drives: Blurple
Join Date: Jul 2007
Location: *NorCal Mobile Installer*

Posts: 10,369
iTrader: (4)

Send a message via AIM to Dr.phuOnger?
Quote:
Originally Posted by cstmx_ryder View Post
Funny, this morning when I started the car, the SES light was gone..........

But I went ahead and took the resistors off the SIM anyway. Hope this cures the problem, if it comes back again, I won't know what to do......Maybe just upgrade to Rev.II? I really don't feel like installing/uninstalling the resistors. lol
you should just do the 02 sim mod on the proceede itself. I havent had any problems with my dp's since
__________________
Blurple has her own Facebook page! Follow her for updates and photos!
www.facebook.com/SEBlurple
Dr.phuOnger? is offline   United_States
0
Reply With Quote
      08-06-2009, 09:19 PM   #10
cstmx_ryder
Colonel
 
cstmx_ryder's Avatar
 
Drives: A metal box with a roundel
Join Date: Jul 2007
Location: Portland, OR

Posts: 2,734
iTrader: (2)

Send a message via AIM to cstmx_ryder Send a message via MSN to cstmx_ryder
If I can find a used Rev.II then I'll upgrade and use the PROcede's O2 SIM feature.......lol.
__________________

'08 AW E90 335i
PROcede V5 | BMS DCI | RR DPs | ETS FMIC | FORGE DVs | Stett CP | Vanguard | PSS10
cstmx_ryder is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:08 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST