E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > gas smell coming from the back of the car



Reply
 
Thread Tools Search this Thread
      08-17-2009, 05:38 PM   #1
Z22Z
Lieutenant
 
Z22Z's Avatar
 
Drives: WRX
Join Date: Dec 2008
Location: Glendale, CA

Posts: 536
iTrader: (0)

gas smell coming from the back of the car

now i have searched for this and cant find a similar case. my car smells of gas right by the fuel tank every couple of days. it usually happens if the car is in lower gears for a while. i took it in to the dealer worried and the service manager said it was the fumes coming due to the hot weather outside (currently in vegas) and he claimed it was common in all cars. now my dad's benz does not smell at all nor does my uncle's 745. im taking it in for a pressure check tomorrow. any idea what it could be?
Z22Z is offline   Armenia
0
Reply With Quote
      08-17-2009, 06:51 PM   #2
Z22Z
Lieutenant
 
Z22Z's Avatar
 
Drives: WRX
Join Date: Dec 2008
Location: Glendale, CA

Posts: 536
iTrader: (0)

anyone?
Z22Z is offline   Armenia
0
Reply With Quote
      08-18-2009, 02:42 AM   #3
oddjob2021
ASR Turbos+LSD+Meth= :D
 
oddjob2021's Avatar
 
Drives: E92 335i
Join Date: May 2007
Location: Miami, FL

Posts: 1,517
iTrader: (0)

Garage List
2007 E92 335i  [0.00]
since no one has any ideas, maybe this:

my car once threw a strange code. for a gas tank ventilation pump "too high voltage". luckily we knew where that was, on the opposite side of the car then the gas tank/line to fill. the problem was the vent pump was broken. i bought a new one and installed it and the code stopped popping up.

so the long of the short of it is although it should have thrown a code, this could be the problem.
__________________

2007 335i Coupe
Mods: Check the Garage
oddjob2021 is offline  
0
Reply With Quote
      08-18-2009, 03:48 AM   #4
Z22Z
Lieutenant
 
Z22Z's Avatar
 
Drives: WRX
Join Date: Dec 2008
Location: Glendale, CA

Posts: 536
iTrader: (0)

i dont have any codes but the problem is fumes. gas consumption is normal and i dont have any leaks. maybe its not working at full potential? thanks for the response ill see how it goes with the sa and ask him about it.
Z22Z is offline   Armenia
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:21 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST