E90Post
 


Bimmertech
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > New & Preowned BMW Ordering / Pricing / Tracking Information Forum (including European Delivery) > BMW Dealer Reviews + Ratings Forum > Devon Hill BMW



Reply
 
Thread Tools Search this Thread
      04-12-2013, 08:03 PM   #1
petapotamus
New Member
 
petapotamus's Avatar
 
Drives: E82 2009 128i
Join Date: Apr 2013
Location: Filthadelphia

Posts: 12
iTrader: (0)

Devon Hill BMW

Hi all,

Based upon my most recent experience I felt obligated to share it with others in the hope that you might be able to avoid something similar happening to you.

About a month or so ago when the winter weather was still plaguing the Philadelphia area, my drivers side window froze up one night and didn't retract when I went to warm the car up prior to departing for work the next morning. I figured it would thaw out by the time I went out for lunch but alas, this was wishful thinking. Since the dealer where I purchased my car roughly 8 months prior is only a few miles away I figured I'd swing by over my lunch break and see if they could take a look at it. Since the car was sold to me as CPO with over a year left of factory coverage before the CPO warrantee went into effect, I expected everything would be taken care of.

They took it in said it would take a while and offered me a loaner. Perfect. While they had it they wanted to do some maintenance things no problem, they would call me when it was finished. Again, perfect. I picked the car up the next morning and off I went a happy customer, or so I thought.

Fast forward a few weeks and the weather warmed up enough at Easter weekend that I was fairly confident that no more snow would fall; so off came the snows. The wheels were not touched since at Devon Hill and quite to my surprise not only were the bolts not consistently tightened, about half were only on HAND TIGHT! I know the wheels were removed while at the dealer because on the release paperwork were measurements of the rotors and it stated the brake pad sensors were re-set.

Since I was about 300 miles or so out of my 40k service I decided to wait to bring this up with the dealer until then. The Service Advisor who I dealt with the first time was the same guy I spoke with upon my second trip in. I let him know about the wheel bolts and he appeared shocked and glad that I had mentioned it to him. He vowed he would get to the bottom of it and I believed him. Perfect.

He set me up with my loaner (F30 328i xdrive) and off I went to work. I got a call around 1:00 the car was done, so I stopped by after work to pick it up. After I completed the paperwork and payed for my inspection I stopped in to say thank you to him for his continued help, shook his hand, and off I went. I open my trunk to put in my laptop and such and notice that both the gas struts that help lift the trunk lid were broken off at the mounts. I went back in and asked him to take a look at something with me, which he did and apologized. He then brought the tech out for an awkward exchange where he said he had no idea how it happened. I reiterated my frustration the SA that this was twice now that I had dropped the car off to the dealer, from which I purchased it, and botched it. They did not have the struts so they ordered them and sent me back home in the F30.

Around noon the next day I received a call from someone else at the dealer inquiring about my experience to which I responded honestly and explained what I said above. I must give credit where credit is due I genuinely think the SA was helpful, sincere, and a pleasure to work with, but unless he starts working on my car personally I have very little faith in their quality of work. Her response was "oh, well I guess we really screwed up huh?" "Well, I just would like to ask you to give us another chance, and we'll do better next time." THAT'S IT!?! We'll do better next time?! YOU ARE BMW!

So I stopped by later that day and picked up the car, both the SA and the service manager assured me that I wouldn't have any other issues and they personally would see to it. Again, genuine. Struts were fixed off I went again. On my way home I turned the radio on as every dealer seems to always turn it off, and I noticed that half the pixels were not visible (quite warm that day). I did not have time to return so I sent an email with a picture directly to the SA explaining it and asking to contact me with what he needed to rectify it. The next day it returned to normal; until it got hot and happened again. I sent a follow up email and let him know that I thought it was heat related and asked if he had seen this before.

No response. Day and a half goes by, still no response. So, I called Devon Hill today and asked for him. Got his voice mail, but no follow up by close of business. So, here I am a very annoyed, and disappointed customer that this is the level of professionalism I have to expect out of one of the premier auto manufacturers in the world. I will not be returning, and unfortunately have heard horror stories from the next two adjacent dealers (otto's, and main line) so who knows where I'll go. If you have a suggestion in the greater Philadelphia area I'd love to hear it.

Hope this saves someone else some hardship, sorry for the short novel. Salute.
__________________
'09 E82 Space Gray 128i - N51 - BMW Performance SSK
petapotamus is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:20 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST