E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Car won't start!! Help!



Reply
 
Thread Tools Search this Thread
      12-02-2016, 04:10 PM   #1
sd_luis
Captain
sd_luis's Avatar
Germany
56
Rep
885
Posts

Drives: 2006 BMW 325I
Join Date: May 2013
Location: Germany

iTrader: (0)

Car won't start!! Help!

So a week ago my car started acting really weird. It would idle super crazy and I noticed a huge acceleration loss! I called my mechanic and he said to drop it off the next morning. The next morning my car was acting just fine and the check engine light came on, so I decided to wait a little while just to make sure. It started doing it randomly and same, it would start doing it and then stop and be normal. I saw online that it could be multiple things from the exhaust camshaft sensor to the eccentric shaft sensor. I checked both and the exhaust one was fine and the eccentric had oil in it so I figured I found the problem. I plugged it back in and when I tried starting the car I noticed it took forever to turn on. It would sound like it was about to shut down but it turned back on. I then went back to the sensor to see wth I did wrong for the car to do that. I went back and the car wouldnt turn on at all!. I couldnt figure out what happened. I tried jump starting and nothing. So I took it to the mechanic. After a week there he said that he thinks its the starter but he is not 100% sure and that he also thinks it might be the key, because he said he got a lot of codes for the key, I noticed that during the tow, the car wouldnt give me the key back I had to pull it hard to get it out(stupid mistake) he said maybe that activated the alarm and broke the key. Has anyone experienced something similar? Its a $600 charge for the starter and $200 for the key. I rather not pay $800 for nothing. Thanks
__________________
Check out my built thread of my white beauty! http://www.e90post.com/forums/showthread.php?t=1045460
Follow me on Instagram! l_gomez1215
Appreciate 0
      12-11-2016, 11:36 AM   #2
Chriztofor
Colonel
Chriztofor's Avatar
United_States
60
Rep
2,771
Posts

Drives: '06 325i and '13 X5
Join Date: Feb 2010
Location: Chicago Burbs

iTrader: (1)

What code is it throwing? Go to Autozone and have them check it for free. You really should invest in a peake research tool, see my sig.. Edit: Since your car doesn't start get the peake tool.

If I had to guess, intake camshaft sensor.

By the way, you can't tell if a sensor is bad just by looking at it.
__________________
If no codes are being thrown use Chevron Techron fuel injector cleaner (concentrate). It solves rpm fluctuating upon cold start-up. Also, for most BMW problems start off by scanning your car with the Peake Research Tool. It contains the actual BMW codes. If you want to register a newly installed battery for free (just buy a $10 cable) and google/download BMWLogger
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:18 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST