E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > 29E0 feul mixture control



Reply
 
Thread Tools Search this Thread
      10-29-2009, 11:50 AM   #23
thwgw24
Major
thwgw24's Avatar
Taiwan
13
Rep
1,060
Posts

 
Drives: RB PWRED E90 N54 6MT
Join Date: Aug 2006
Location: Bellevue, WA

iTrader: (19)

Garage List
07' E90 335i  [0.00]
Quote:
Originally Posted by GeorgeSmooth View Post
The Voltages are correct for idle. Did you check them whilst the misfire happens? Mine would misfire and then there would be compensation via ECU, there is a reading for that on the BT tool. Once the car realizes there is a problem it will idle correctly and the lambda will show the correct voltage. Make sure the readings are correct during the misfire. If they are then you must look somewhere else for the problem.
I only got the misfire once while I was on dyno. I just checked the voltage again this morning while driving. The front two reading range from 1.70 to 2.3 and the back two read from 0.03 to 0.8
Do they seem right?
__________________
RB Turbo/Procede V5/Vishnu PWM Meth Injection Kit/Vishnu DCI/AR Catless DP/AE Performance Exhaust(Sold)/Helix FMIC/Forge DVs/Rixster Vent Boost Gauge/Wavetrac LSD/KW V3/ACT Street Clutch Kit
Appreciate 0
      10-29-2009, 02:47 PM   #24
GeorgeSmooth
Lieutenant
GeorgeSmooth's Avatar
12
Rep
568
Posts

 
Drives: 2008 E90 335i AT
Join Date: Feb 2008
Location: South Africa

iTrader: (0)

Quote:
Originally Posted by thwgw24 View Post
I only got the misfire once while I was on dyno. I just checked the voltage again this morning while driving. The front two reading range from 1.70 to 2.3 and the back two read from 0.03 to 0.8
Do they seem right?

They do seem fine. In my case one was 4.00 and the other zero. And it would then intermitently shoot to 2.0 and the other would match it.
__________________
08 E90 335i AT RB Turbos -NX Wet Kit - Chiplogic Flash or Procede V5- M3 Diff - AE Exhaust- Forge Dv's - Helix Intercooler - AR DP's - P3 Boost Gauge - Vishnu Meth- Stett Chargepipe and CAI
09 C63
Appreciate 0
      10-29-2009, 03:17 PM   #25
thwgw24
Major
thwgw24's Avatar
Taiwan
13
Rep
1,060
Posts

 
Drives: RB PWRED E90 N54 6MT
Join Date: Aug 2006
Location: Bellevue, WA

iTrader: (19)

Garage List
07' E90 335i  [0.00]
Oh well, then I guess it's not the sensors then.
I'll still have someone to check the sensors for me this weekend just to make sure.
__________________
RB Turbo/Procede V5/Vishnu PWM Meth Injection Kit/Vishnu DCI/AR Catless DP/AE Performance Exhaust(Sold)/Helix FMIC/Forge DVs/Rixster Vent Boost Gauge/Wavetrac LSD/KW V3/ACT Street Clutch Kit
Appreciate 0
      11-09-2009, 01:41 AM   #26
thwgw24
Major
thwgw24's Avatar
Taiwan
13
Rep
1,060
Posts

 
Drives: RB PWRED E90 N54 6MT
Join Date: Aug 2006
Location: Bellevue, WA

iTrader: (19)

Garage List
07' E90 335i  [0.00]
I just brought my car to my friend's house this afternoon and found out that the code I got (29E0) is translated into P0171 (System too lean bank 1)with his OBD tool.
That tells me that there are nothing wrong with the O2 sensors.
It is either a bad TMAP sensor (since no MAF sensor on a 335i) or a vacuum leak.
In this case, should I just remove my Vishnu DCI and send the car back to dealer?
__________________
RB Turbo/Procede V5/Vishnu PWM Meth Injection Kit/Vishnu DCI/AR Catless DP/AE Performance Exhaust(Sold)/Helix FMIC/Forge DVs/Rixster Vent Boost Gauge/Wavetrac LSD/KW V3/ACT Street Clutch Kit
Appreciate 0
      05-05-2010, 08:00 PM   #27
import36
Burrito bowl connoisseur
import36's Avatar
United_States
44
Rep
3,438
Posts

 
Drives: E92 335i MT, E46 M3 SMG
Join Date: Feb 2008
Location: Seven Cities

iTrader: (1)

Garage List
2008 BMW 335i Coupe  [4.50]
2005 BMW M3  [5.00]
i just got my BT cable today so i could scan my car and determine what codes i had thrown. only one i had was the 29E0. i just finished installing catless dps and exhaust last friday...drove around all weekend no problems...then on my way to work monday i get a SES light.

i read a couple of the threads on here about this code...nothing really definitive. so i just decided to clear the code and see if it comes back. keepin my fingers crossed.
__________________
Mods: Procede Rev3 9-10|AE Catless Dual Exhaust|AR Design Catless DPs|AMS FMIC|Stett Charge Pipe w/Tial BOV|Stett CAI|BMS OCC|BMS CDV|Volk TE37 SLs|KW V2 Coilovers|Cusco OS Strut Brace|Macht Schnell Stud Conversion|Work RS-R Lugnuts|Gloss Black Roof|Matte Black Kidney Grills|UED Lower Bumper Grills|OEM Aero Lip and Painted Reflectors|M3 Sideskirts| VRS Decklid Aero Spoiler|Gloss Black Roof|M Peformance Alcantara Steering Wheel(blue)|OSS V2.0 LED Angel Eyes|8000k HID Fog Lights|8000k MTEC Xenons
Appreciate 0
      05-05-2010, 08:27 PM   #28
cstmx_ryder
Colonel
cstmx_ryder's Avatar
United_States
36
Rep
2,764
Posts

 
Drives: A metal box with a roundel
Join Date: Jul 2007
Location: Portland, OR

iTrader: (2)

Send a message via AIM to cstmx_ryder Send a message via MSN to cstmx_ryder
Quote:
Originally Posted by thwgw24 View Post
I just brought my car to my friend's house this afternoon and found out that the code I got (29E0) is translated into P0171 (System too lean bank 1)with his OBD tool.
That tells me that there are nothing wrong with the O2 sensors.
It is either a bad TMAP sensor (since no MAF sensor on a 335i) or a vacuum leak.
In this case, should I just remove my Vishnu DCI and send the car back to dealer?
It might be the precursor to your hpfp going out. I got the bank 1/2 too lean code before mine went, and nothing I did really fixed it until the hpfp got replaced, FWIW.
__________________

'08 AW E90 335i
PROcede V5 | BMS DCI | RR DPs | ETS FMIC | FORGE DVs | Stett CP | Vanguard | PSS10
Appreciate 0
      05-05-2010, 08:28 PM   #29
cstmx_ryder
Colonel
cstmx_ryder's Avatar
United_States
36
Rep
2,764
Posts

 
Drives: A metal box with a roundel
Join Date: Jul 2007
Location: Portland, OR

iTrader: (2)

Send a message via AIM to cstmx_ryder Send a message via MSN to cstmx_ryder
Quote:
Originally Posted by import36 View Post
i just got my BT cable today so i could scan my car and determine what codes i had thrown. only one i had was the 29E0. i just finished installing catless dps and exhaust last friday...drove around all weekend no problems...then on my way to work monday i get a SES light.

i read a couple of the threads on here about this code...nothing really definitive. so i just decided to clear the code and see if it comes back. keepin my fingers crossed.
I'm assuming you already have the O2 SIM installed, or a Procede Rev II?
__________________

'08 AW E90 335i
PROcede V5 | BMS DCI | RR DPs | ETS FMIC | FORGE DVs | Stett CP | Vanguard | PSS10
Appreciate 0
      05-06-2010, 06:02 AM   #30
import36
Burrito bowl connoisseur
import36's Avatar
United_States
44
Rep
3,438
Posts

 
Drives: E92 335i MT, E46 M3 SMG
Join Date: Feb 2008
Location: Seven Cities

iTrader: (1)

Garage List
2008 BMW 335i Coupe  [4.50]
2005 BMW M3  [5.00]
Quote:
Originally Posted by cstmx_ryder View Post
I'm assuming you already have the O2 SIM installed, or a Procede Rev II?
yeah...O2 sim is already installed. according to the instructions, the 29E0 code is not mentioned in warranting an adjustment on the O2 sim.
__________________
Mods: Procede Rev3 9-10|AE Catless Dual Exhaust|AR Design Catless DPs|AMS FMIC|Stett Charge Pipe w/Tial BOV|Stett CAI|BMS OCC|BMS CDV|Volk TE37 SLs|KW V2 Coilovers|Cusco OS Strut Brace|Macht Schnell Stud Conversion|Work RS-R Lugnuts|Gloss Black Roof|Matte Black Kidney Grills|UED Lower Bumper Grills|OEM Aero Lip and Painted Reflectors|M3 Sideskirts| VRS Decklid Aero Spoiler|Gloss Black Roof|M Peformance Alcantara Steering Wheel(blue)|OSS V2.0 LED Angel Eyes|8000k HID Fog Lights|8000k MTEC Xenons
Appreciate 0
      05-06-2010, 10:25 AM   #31
themyst
Major General
themyst's Avatar
South Korea
86
Rep
6,602
Posts

 
Drives: E90 335i LCI
Join Date: Feb 2009
Location: NYC

iTrader: (8)

Send a message via AIM to themyst
Quote:
Originally Posted by goff View Post
injectors are clogged with carbon. new part number along with a set of plugs should take care of it.

for reference, plugs from a 135i with the same faults at 6000 miles:
Damn!! Ugly looking plugs for 6000 miles. My car has 19.5k miles and I have yet to get a misfire and I've been tuned since 1000 miles. After seeing how bad those plugs look, I'll be swapping my plugs out around 23k miles.
__________________
E90 LCI N54 6AT
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:26 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST