E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > HPFP failure FAQ!



Reply
 
Thread Tools Search this Thread
      04-20-2010, 06:31 PM   #265
Quisp
Does not play well with others
 
Drives: BMW
Join Date: Apr 2007
Location: Arizona

Posts: 1,791
iTrader: (4)

Gizmo, whether you purchsed a warranty or not the pump is covered under the original factory warranty for 10 years or 120,000 miles so you should not even have to screw around with any aftermarket warranty paperwork. That should be done by the dealer with no hassle(hoffs).
__________________
Quisp is offline   United_States
0
Reply With Quote
      04-20-2010, 11:08 PM   #266
gizmo335i
Colonel
 
gizmo335i's Avatar
 
Drives: 08 JB E92 335i 6MT
Join Date: Oct 2009
Location: San Antonio

Posts: 2,907
iTrader: (50)

Garage List
2008 E92 335i  [4.73]
Yeah, I know. But you have a 4 year/50,000 mile warranty right? Well, I only get a 2 year here in Germany. So it could be that the 10/120 doesn't apply here. That's what I said in my earlier post. I called a couple people over here that I thought may know about this issue but they didn't. The guy that I talked to that supposedly knew everything here had never heard of this warranty extension. But believe me, if they hadn't come back and told me that my warranty extension that I am in now didn't cover it, I would have screamed to somebody at BMW about this. Either way, I guess I'll find out today sometime what they end up doing. It's hard to get into this much detail where I live in a coversation. They can speak limited English here and understand most of it. But even the best English speaking Germans that I work with had no idea what I was saying when I said HPFP.
__________________
JB4 | Vanguard/Quad burnt tips | Linea Corse | Mtech Front/rear | AFE DCI | H&R Sport + Koni yellow | Umnitza Full LED Angels | Akyrm lip/quad diffuser | Alpine CSL CF Trunklid
See Garage for more
gizmo335i is offline   United_States
0
Reply With Quote
      04-21-2010, 12:18 AM   #267
Zippy7575
Enlisted Member
 
Zippy7575's Avatar
 
Drives: '07 E90 335i
Join Date: Apr 2010
Location: Arizona

Posts: 34
iTrader: (0)

So how's K-Town these days? When I was stationed there in the '70s I had a '63 VW Beetle. What a treat it would be to drive a 335 on the Autobahn! I can understand the frustration some are feeling with BMW right now, but I'm sure loving the '07 335i I just bought. I'd probably feel differently after a couple HPFP failure, but man, what a sweet driving car! I just hope mine has the 943 HPFP.


Last edited by Zippy7575; 04-21-2010 at 12:40 AM.
Zippy7575 is offline   United_States
0
Reply With Quote
      04-21-2010, 01:01 AM   #268
gizmo335i
Colonel
 
gizmo335i's Avatar
 
Drives: 08 JB E92 335i 6MT
Join Date: Oct 2009
Location: San Antonio

Posts: 2,907
iTrader: (50)

Garage List
2008 E92 335i  [4.73]
Well, I live about 200 miles North of K-town. But I am down there quite often. I will be there this weekend playing in a softball tourney (on kapaun actually). It's funny cause I was on the phone with Pentagon BMW (which is right outside the Ramstein gate) yesterday and that lady convinced me to come in and look at new 335's. I will just go look because I am VERY happy with my 08 and even a newer one could have the same problem anyway. Plus it would have to have EVERY option possible for me to even consider trading in right now. It is awesome to drive this car on the autobahn. I live in a pretty remote area. The A46 is about ten minutes from my house. It starts right here and if I want to just ride down there and get on it for a few minutes or whatever...it's always traffic free.

There's no way you have the 943 unless you bought it used and maybe someone else had it replaced recently.

I'm happy with this car even with this problem. I've had a couple other things too...but I don't start disliking a car just because of a few problems. I can deal with having to take it in as long as I love the car otherwise. Now, if it were to start dying on me..that would probably piss me off....
__________________
JB4 | Vanguard/Quad burnt tips | Linea Corse | Mtech Front/rear | AFE DCI | H&R Sport + Koni yellow | Umnitza Full LED Angels | Akyrm lip/quad diffuser | Alpine CSL CF Trunklid
See Garage for more
gizmo335i is offline   United_States
0
Reply With Quote
      04-21-2010, 09:08 AM   #269
gizmo335i
Colonel
 
gizmo335i's Avatar
 
Drives: 08 JB E92 335i 6MT
Join Date: Oct 2009
Location: San Antonio

Posts: 2,907
iTrader: (50)

Garage List
2008 E92 335i  [4.73]
I've been trying to search like crazy to see if there was a link to any kind of OFFICIAL letter from BMW about the 943. Is there anything like this that I can take to the dealership here just in case they end up putting the 881 in there? The guy called me today and said they replaced it but he didn't know the part number. I tried to get him to give it to me but I don't think he's understanding what the hell I'm talking about.
__________________
JB4 | Vanguard/Quad burnt tips | Linea Corse | Mtech Front/rear | AFE DCI | H&R Sport + Koni yellow | Umnitza Full LED Angels | Akyrm lip/quad diffuser | Alpine CSL CF Trunklid
See Garage for more
gizmo335i is offline   United_States
0
Reply With Quote
      04-21-2010, 11:07 AM   #270
gizmo335i
Colonel
 
gizmo335i's Avatar
 
Drives: 08 JB E92 335i 6MT
Join Date: Oct 2009
Location: San Antonio

Posts: 2,907
iTrader: (50)

Garage List
2008 E92 335i  [4.73]
Yeah, I figured as much. I was just hoping that mabye there was some "formal" release about the 943 somewhere that I could at least show them here.....
__________________
JB4 | Vanguard/Quad burnt tips | Linea Corse | Mtech Front/rear | AFE DCI | H&R Sport + Koni yellow | Umnitza Full LED Angels | Akyrm lip/quad diffuser | Alpine CSL CF Trunklid
See Garage for more
gizmo335i is offline   United_States
0
Reply With Quote
      04-21-2010, 11:15 AM   #271
AlbinoSnail
n00bie
 
AlbinoSnail's Avatar
 
Drives: three.thirty.five.i.
Join Date: Apr 2009
Location: DFdub

Posts: 1,046
iTrader: (0)

Barely made it past 4K RPM on the highway yesterday and went into Limp Mode. Restarted the engine; car's drivable but of course the service engine light's on now.

In essence-- the "ECU service patch" placed a month ago = FAIL.
__________________
The SNAIL: Alpine White | Beige Dakota | 6MT | ZMP | ZZP | Navi | Logic7 | CA R.I.P The TANK '96-'09
AlbinoSnail is offline   United_States
0
Reply With Quote
      04-21-2010, 11:38 AM   #272
John 070
Lieutenant General
 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

Posts: 11,409
iTrader: (0)

Quote:
Originally Posted by AlbinoSnail View Post
Barely made it past 4K RPM on the highway yesterday and went into Limp Mode. Restarted the engine; car's drivable but of course the service engine light's on now.

In essence-- the "ECU service patch" placed a month ago = FAIL.
I have to ask why you and others have to beta test the patch? It should have been tested in Munich before being released. Hopefully you don't have the 943 pump....
John 070 is offline  
0
Reply With Quote
      04-21-2010, 11:54 AM   #273
AlbinoSnail
n00bie
 
AlbinoSnail's Avatar
 
Drives: three.thirty.five.i.
Join Date: Apr 2009
Location: DFdub

Posts: 1,046
iTrader: (0)

Quote:
Originally Posted by John 070 View Post
I have to ask why you and others have to beta test the patch? It should have been tested in Munich before being released. Hopefully you don't have the 943 pump....
I think it was an excuse for them to delay the inevitable. So now we'll take it back to the dealer's yet again and see what they have to say now.

Has anyone else not received a BMW loaner from dealership when y'all put your cars in for HPFP? My dealership let me drive out in a Prius last time.
__________________
The SNAIL: Alpine White | Beige Dakota | 6MT | ZMP | ZZP | Navi | Logic7 | CA R.I.P The TANK '96-'09
AlbinoSnail is offline   United_States
0
Reply With Quote
      04-21-2010, 01:42 PM   #274
phistyle
Lieutenant
 
Drives: 2007 BMW e92 335i
Join Date: Jan 2010
Location: Dallas, TX

Posts: 562
iTrader: (1)

think my car is about to fail....is this the HPFP going bad if my car is like kind of sputtering/stuttering/shaking every couple of seconds...it does this while idle and while driving...
phistyle is offline   United_States
0
Reply With Quote
      04-21-2010, 02:31 PM   #275
AlbinoSnail
n00bie
 
AlbinoSnail's Avatar
 
Drives: three.thirty.five.i.
Join Date: Apr 2009
Location: DFdub

Posts: 1,046
iTrader: (0)

Quote:
Originally Posted by phistyle View Post
think my car is about to fail....is this the HPFP going bad if my car is like kind of sputtering/stuttering/shaking every couple of seconds...it does this while idle and while driving...
Those are the symptoms I had. Then took it to the dealer where they "updated my ECU; patching how my fuel pumps worked.. blah blah blah".

Now a month later, went into LIMP mode twice yesterday on the highway & ... well, still waiting a call to take the car in from the dealership today.
__________________
The SNAIL: Alpine White | Beige Dakota | 6MT | ZMP | ZZP | Navi | Logic7 | CA R.I.P The TANK '96-'09
AlbinoSnail is offline   United_States
0
Reply With Quote
      04-21-2010, 03:02 PM   #276
phistyle
Lieutenant
 
Drives: 2007 BMW e92 335i
Join Date: Jan 2010
Location: Dallas, TX

Posts: 562
iTrader: (1)

Quote:
Originally Posted by AlbinoSnail View Post
Those are the symptoms I had. Then took it to the dealer where they "updated my ECU; patching how my fuel pumps worked.. blah blah blah".

Now a month later, went into LIMP mode twice yesterday on the highway & ... well, still waiting a call to take the car in from the dealership today.
man that does not sounds promising...I have an appointment for my 34k service so I guess I'll tell them about it and see what they do...
phistyle is offline   United_States
0
Reply With Quote
      04-21-2010, 06:13 PM   #277
phistyle
Lieutenant
 
Drives: 2007 BMW e92 335i
Join Date: Jan 2010
Location: Dallas, TX

Posts: 562
iTrader: (1)

bleh spoke too soon....on my way home today....1/2 engine light went on, slow acceleration, shaky idle, and service engine soon light went on....great!!
phistyle is offline   United_States
0
Reply With Quote
      04-22-2010, 07:49 AM   #278
gizmo335i
Colonel
 
gizmo335i's Avatar
 
Drives: 08 JB E92 335i 6MT
Join Date: Oct 2009
Location: San Antonio

Posts: 2,907
iTrader: (50)

Garage List
2008 E92 335i  [4.73]
Well, I got mine back. I had to ask them for the paperwork on what they did. I was sitting down with my co-worker here translating and the first page there was stuff about low pressure gas sensor replaced, programming the engine, compressor intake, adjusting active steering, sunroof, window initialized...so I'm assuming that this stuff was when they did the flashes. I guess I can put the numbers from the sheet on here and maybe someone can tell me WTF....

We get to the second page and we realize that the only part that was put in was what I said originally, the Sensor - part number 13537547883. He called the guy at the dealer and that's what he told him.

So all this stress about the HPFP and it wasn't even replaced. I'm thinking that either 1. Maybe mine is good and I just coincidentally had other problems what looked like this could be the problem...especially after reading all the problems on here. After all, I never had any long cranks or other symptoms. <<<I hope to God that's it. OR 2. They just don't know about the problem over here/maybe didn't do enough testing and/or are just mistaken. I tried like hell to explain about this problem to them but they just looked at me like I was crazy. I did get them to look up the 943 and they finally saw it...and they said "no, we didn't replace the pump." BTW, I did see a couple of pimped out AC Schnitzer 335's there with some sweet wheels and flush as hell.

Anyway, I'll keep post whoring this thread if anything else happens.

The only thing I can think is maybe in the homeland of BMW, they know something they don't in the states, lol....but it'd be funny if the guys at this particular place were able to fix the problem. I did call another guy at a dealer yesterday and he said he hasn't heard of this happening over here. I mean, aren't the Euro versions of the 335i the same motor?

Here's all the numbers listed in the column on the paperwork..

6100009
1353594
6100811
6100850
3210506
3452900
6100830
6120908
6131996

13537547883
11617547242

Don't know if the above ones mean anything....but the rest is in Deutche....so....

It took them more than 48 hours to do all this...and no loaner
__________________
JB4 | Vanguard/Quad burnt tips | Linea Corse | Mtech Front/rear | AFE DCI | H&R Sport + Koni yellow | Umnitza Full LED Angels | Akyrm lip/quad diffuser | Alpine CSL CF Trunklid
See Garage for more
gizmo335i is offline   United_States
0
Reply With Quote
      04-22-2010, 08:33 AM   #279
gizmo335i
Colonel
 
gizmo335i's Avatar
 
Drives: 08 JB E92 335i 6MT
Join Date: Oct 2009
Location: San Antonio

Posts: 2,907
iTrader: (50)

Garage List
2008 E92 335i  [4.73]
OK....could be good for me I guess. So does it sound like they did some software updates?
__________________
JB4 | Vanguard/Quad burnt tips | Linea Corse | Mtech Front/rear | AFE DCI | H&R Sport + Koni yellow | Umnitza Full LED Angels | Akyrm lip/quad diffuser | Alpine CSL CF Trunklid
See Garage for more
gizmo335i is offline   United_States
0
Reply With Quote
      04-22-2010, 08:55 AM   #280
fruition3000
Captain
 
fruition3000's Avatar
 
Drives: Down Ocean Drive
Join Date: Apr 2010
Location: Le-Bron Town

Posts: 769
iTrader: (0)

I didnt know the m package was so popular. Everyone seems to have it now!
fruition3000 is offline   United_States
0
Reply With Quote
      04-22-2010, 09:06 AM   #281
gizmo335i
Colonel
 
gizmo335i's Avatar
 
Drives: 08 JB E92 335i 6MT
Join Date: Oct 2009
Location: San Antonio

Posts: 2,907
iTrader: (50)

Garage List
2008 E92 335i  [4.73]
Quote:
Originally Posted by fruition3000 View Post
I didnt know the m package was so popular. Everyone seems to have it now!
??????
__________________
JB4 | Vanguard/Quad burnt tips | Linea Corse | Mtech Front/rear | AFE DCI | H&R Sport + Koni yellow | Umnitza Full LED Angels | Akyrm lip/quad diffuser | Alpine CSL CF Trunklid
See Garage for more
gizmo335i is offline   United_States
0
Reply With Quote
      04-22-2010, 11:22 AM   #282
shifterboy45
Major
 
shifterboy45's Avatar
 
Drives: 2009 335i Coupe
Join Date: Feb 2009
Location: North by Northwest

Posts: 1,180
iTrader: (0)

Quote:
Originally Posted by gizmo335i View Post
Well, I got mine back. I had to ask them for the paperwork on what they did. I was sitting down with my co-worker here translating and the first page there was stuff about low pressure gas sensor replaced, programming the engine, compressor intake, adjusting active steering, sunroof, window initialized...so I'm assuming that this stuff was when they did the flashes. I guess I can put the numbers from the sheet on here and maybe someone can tell me WTF....

We get to the second page and we realize that the only part that was put in was what I said originally, the Sensor - part number 13537547883. He called the guy at the dealer and that's what he told him.

So all this stress about the HPFP and it wasn't even replaced. I'm thinking that either 1. Maybe mine is good and I just coincidentally had other problems what looked like this could be the problem...especially after reading all the problems on here. After all, I never had any long cranks or other symptoms. <<<I hope to God that's it. OR 2. They just don't know about the problem over here/maybe didn't do enough testing and/or are just mistaken. I tried like hell to explain about this problem to them but they just looked at me like I was crazy. I did get them to look up the 943 and they finally saw it...and they said "no, we didn't replace the pump." BTW, I did see a couple of pimped out AC Schnitzer 335's there with some sweet wheels and flush as hell.

Anyway, I'll keep post whoring this thread if anything else happens.

The only thing I can think is maybe in the homeland of BMW, they know something they don't in the states, lol....but it'd be funny if the guys at this particular place were able to fix the problem. I did call another guy at a dealer yesterday and he said he hasn't heard of this happening over here. I mean, aren't the Euro versions of the 335i the same motor?

Here's all the numbers listed in the column on the paperwork..

6100009
1353594
6100811
6100850
3210506
3452900
6100830
6120908
6131996

13537547883
11617547242

Don't know if the above ones mean anything....but the rest is in Deutche....so....

It took them more than 48 hours to do all this...and no loaner
6100009 work time for electrical troubleshooting
1353594 replace low pressure sensor
6100811 programming/encoding control units
6100850 setting compressor inlet
3210506 adjustment of active steering
3452900 perform DSC adjustment
6100830 intitializing sunroof and power windows
6120908 performing battery power reset
6131996 performing steering angle adjustment

13537547883 sensor for low pressure
11617547242 set of profile gaskets

HTH
shifterboy45 is offline  
0
Reply With Quote
      04-22-2010, 01:08 PM   #283
gizmo335i
Colonel
 
gizmo335i's Avatar
 
Drives: 08 JB E92 335i 6MT
Join Date: Oct 2009
Location: San Antonio

Posts: 2,907
iTrader: (50)

Garage List
2008 E92 335i  [4.73]
Damn, thanx....they did all that? Is that normal?
__________________
JB4 | Vanguard/Quad burnt tips | Linea Corse | Mtech Front/rear | AFE DCI | H&R Sport + Koni yellow | Umnitza Full LED Angels | Akyrm lip/quad diffuser | Alpine CSL CF Trunklid
See Garage for more
gizmo335i is offline   United_States
0
Reply With Quote
      04-22-2010, 01:14 PM   #284
shifterboy45
Major
 
shifterboy45's Avatar
 
Drives: 2009 335i Coupe
Join Date: Feb 2009
Location: North by Northwest

Posts: 1,180
iTrader: (0)

thats a normal set of operations -- no worries !!
shifterboy45 is offline  
0
Reply With Quote
      04-23-2010, 08:45 AM   #285
AlbinoSnail
n00bie
 
AlbinoSnail's Avatar
 
Drives: three.thirty.five.i.
Join Date: Apr 2009
Location: DFdub

Posts: 1,046
iTrader: (0)

HPFP replaced @ 10,000 miles w/ the 943 pump. Here's to crossing fingers!
__________________
The SNAIL: Alpine White | Beige Dakota | 6MT | ZMP | ZZP | Navi | Logic7 | CA R.I.P The TANK '96-'09
AlbinoSnail is offline   United_States
0
Reply With Quote
      04-23-2010, 06:41 PM   #286
phistyle
Lieutenant
 
Drives: 2007 BMW e92 335i
Join Date: Jan 2010
Location: Dallas, TX

Posts: 562
iTrader: (1)

do your dealership or SA ever call you guys to update on the status of your car or do they only call when the repair is complete? I brought in my car this morning and my SA told me that it may take more than a day to do my HPFP, but assured me it will probably be done today. So I'm sitting here and they still haven't called me or anything and the service department is closed and their service department doesn't open on weekends.
phistyle is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:18 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST