E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > HPFP failure FAQ!



Reply
 
Thread Tools Search this Thread
      05-05-2012, 12:10 PM   #1123
Verbatim
Colonel
 
Verbatim's Avatar
 
Drives: 2008 335i
Join Date: Sep 2010
Location: at the repair shop

Posts: 2,555
iTrader: (0)

Garage List
2008 BMW 335i  [5.00]
Quote:
Originally Posted by Scottycs View Post
So the turbo/wastegate are warranted to 5 years/62k miles?
what ever it says in the document. i think till 82k miles...
they added it to the 70k mile emissions warranty
__________________

2008 BMW 335i Sedan | Sparkling Graphite | Sport | Premium | Navigation | Comfort Access | Logic7
Golf Tee | M3 Spoiler | LED Angel Eyes | 5000k Fogs | Resonator Delete | Black Kidney Grills | Black Finisher Rods | 35%/18% Tint |12mm/20mm (F/R) Spacers | Black Lines


Verbatim is offline   United_States
0
Reply With Quote
      05-23-2012, 08:10 PM   #1124
n54noob
Enlisted Member
 
n54noob's Avatar
 
Drives: 2008 335xi
Join Date: Sep 2011
Location: USA

Posts: 30
iTrader: (0)

Garage List
2008 BMW 335xi  [0.00]
My HPFP was replaced today, and on the way home during full throttle acceleration it threw a code and went into limp mode... where should I begin to look next, injectors?
__________________
don't take yourself too seriously, I don't take you too seriously...
n54noob is offline  
0
Reply With Quote
      05-23-2012, 09:21 PM   #1125
Mspeed_1
First Lieutenant
 
Mspeed_1's Avatar
 
Drives: Car
Join Date: Mar 2009
Location: GTA

Posts: 336
iTrader: (8)

my engine light came on as I floored it getting on the highway, said engine malfunction, power reduced. Once I got home and shut the car off, the next day, started up with no issues. Took it to the dealership, and they said it's not the HPFP, but it's the solenoid i have to replace, anyone heard of this before? I lost some power, it went to limp mode, but my car didn't shake or had a hard start or anything like that as some of the others described here.

Last edited by Mspeed_1; 05-23-2012 at 09:29 PM.
Mspeed_1 is offline   Canada
0
Reply With Quote
      06-08-2012, 09:56 PM   #1126
phil.
Private
 
phil.'s Avatar
 
Drives: E90 2009 335i
Join Date: Apr 2010
Location: san francisco bay area

Posts: 58
iTrader: (1)

Quote:
Originally Posted by joegeeZe View Post
Do we know if this replacement has been effective? Im going to look at a 08 335i and I want to make sure they have the correct part.
I got this part # installed 5/25/11 on my 09 E90. It failed 2 days ago, replaced under warranty yesterday with the same part number.
__________________
E90 2009 335i
retired: E21 1983 320is, E36/7 2000 M Roadster, E39 2000 540iA
phil. is offline   United_States
0
Reply With Quote
      06-09-2012, 06:07 PM   #1127
GarySL
First Lieutenant
 
GarySL's Avatar
 
Drives: 335xi E90
Join Date: Mar 2008
Location: Humboldt Co., CA

Posts: 385
iTrader: (0)

Quote:
Originally Posted by phil. View Post
I got this part # installed 5/25/11 on my 09 E90. It failed 2 days ago, replaced under warranty yesterday with the same part number.
?What part #?
__________________
'08 335xi (E90), 6MT, Arctic/Black, ZPP, ZSP (18"s), ZCW, CA, PDC, i-Pod
Ordered-March 7, 2008, Shipped via Graceful Leader-March 21, 2008,
Arrived Port Hueneme-April 11, 2008, Delivered-April 21, 2008
GarySL is offline  
0
Reply With Quote
      06-09-2012, 06:44 PM   #1128
phil.
Private
 
phil.'s Avatar
 
Drives: E90 2009 335i
Join Date: Apr 2010
Location: san francisco bay area

Posts: 58
iTrader: (1)

Oops 13-51-7-616-446
__________________
E90 2009 335i
retired: E21 1983 320is, E36/7 2000 M Roadster, E39 2000 540iA
phil. is offline   United_States
0
Reply With Quote
      06-12-2012, 03:46 PM   #1129
ace1eleven
New Member
 
Drives: 335is
Join Date: Feb 2012
Location: United States

Posts: 15
iTrader: (0)

HPFP dead at 24K on a 2011 335is. Way to go BMW. I will check replacement part number and post later. Rep said it was the new/better pump. We'll see how long it lasts.
ace1eleven is offline   United_States
0
Reply With Quote
      06-12-2012, 04:21 PM   #1130
ragingclue
One cam is enough
 
ragingclue's Avatar
 
Drives: VF
Join Date: Oct 2008
Location: mulletville

Posts: 6,774
iTrader: (1)

Quote:
Originally Posted by ace1eleven View Post
HPFP dead at 24K on a 2011 335is. Way to go BMW. I will check replacement part number and post later. Rep said it was the new/better pump. We'll see how long it lasts.
Yeah they'll keep saying that, it's been the tag line for ages. Whatever they did made the system less prone to failure, but it will keep happening, albeit at a seemingly much lower frequency.

That being said, I've got a -446 (I think, it was either that or -443) that looks like it's failing. Sputtering and wildly varying idle on startup, almost stalling.... Same as the last few times. That will be pump #5 for me, but the important thing to note is that this one has lasted much longer than the previous ones. This one has gone 25k+. Something about my car or habits tears these up, but the latest one they put in definitely showed a marked improvement.
ragingclue is offline  
0
Reply With Quote
      09-17-2012, 10:08 PM   #1131
M3fan
New Member
 
Drives: G35
Join Date: Mar 2008
Location: Brooklyn, NY

Posts: 19
iTrader: (0)

Is this still a huge problem? i'm considering buying the e90. But this damn fuel problem isn't helping me to decide on the car. Did they release new fuel pumps yet that actually last for much longer time? Thanks for the help.
M3fan is offline  
0
Reply With Quote
      09-18-2012, 06:08 AM   #1132
straightcashhomie
Lieutenant
 
straightcashhomie's Avatar
 
Drives: 335i
Join Date: Aug 2012
Location: home

Posts: 545
iTrader: (1)

Quote:
Originally Posted by M3fan View Post
Is this still a huge problem? i'm considering buying the e90. But this damn fuel problem isn't helping me to decide on the car. Did they release new fuel pumps yet that actually last for much longer time? Thanks for the help.
some people will tell you yes and some will say no. BMW has extended it to 10 years 120k so I wouldnt worry bout HPFP
straightcashhomie is offline  
0
Reply With Quote
      09-19-2012, 02:24 PM   #1133
ragingclue
One cam is enough
 
ragingclue's Avatar
 
Drives: VF
Join Date: Oct 2008
Location: mulletville

Posts: 6,774
iTrader: (1)

Quote:
Originally Posted by M3fan View Post
Is this still a huge problem? i'm considering buying the e90. But this damn fuel problem isn't helping me to decide on the car. Did they release new fuel pumps yet that actually last for much longer time? Thanks for the help.
The failures still happen, but at a much more reasonable rate. Like others have mentioned, the warranty on the parts has been extended, but more importantly the problem seems to have been addressed to a level where it's not worth freaking out about.
ragingclue is offline  
0
Reply With Quote
      09-28-2012, 07:05 AM   #1134
jt335i
Second Lieutenant
 
jt335i's Avatar
 
Drives: 2010 E92 335i Monaco blue
Join Date: Jan 2010
Location: Tampa, Fl

Posts: 282
iTrader: (0)

Bought my 2010 335i new and have not had one HPFP failure. Brought it in for the HPFP recall/replacement last year and so far no issues whatsoever.
__________________
2010 BMW 335i: Monaco blue metallic/Premium+Sport package/Auto-STEPTRONIC shift
2005 Mustang GT: Redfire metallic/5-spd/Ford Racing (Axle backs, silver Bullitt wheels)/K&N CAI/ Diablo Sport Predator Tuner
1997 Toyota Corolla
1983 Mercedes Benz 380SL Roadster
jt335i is offline  
0
Reply With Quote
      10-10-2012, 08:03 PM   #1135
jasonn
JDM Slut
 
jasonn's Avatar
 
Drives: 07 e90 335i
Join Date: Feb 2006
Location: CA

Posts: 4,233
iTrader: (12)

Garage List
Bought mine 6/24/2007 no issues got my HPFP replaced under recall in 2011. Now I'm getting 1/2 engine lights, service engine soon, long cranks, super rough idle...

sigh...it was good for 48k miles
__________________

2013 991 (mod diary)
2007 335i (sold)
2004 745i (sold)
jasonn is offline   United_States
0
Reply With Quote
      10-27-2012, 10:01 AM   #1136
AlpineWeiss335i
Private
 
Drives: 335i
Join Date: May 2005
Location: Columbia, SC

Posts: 80
iTrader: (0)

Garage List
2008 BMW 335  [0.00]
I have an 08 335i and am getting long cranks and today got a 2fbf fault and a misfiring on cylinder 2. Took it into BMW today but have to wait until Tuesday for an appointment, they told me my vin number did not qualify under the warrany?

I do have a JB4 but it is turned off.

Is this true does anyone have a list for numbers that should be covered, I plan on calling BMW NA if they try and tell me it is not covered because of the VIN?
__________________
2008 E90 335i
AW, Terra, Auto, CA, ZSP, ZCW
ACS Front, OEM Spoiler, ACS Pedals
AlpineWeiss335i is offline   United_States
0
Reply With Quote
      10-31-2012, 10:44 PM   #1137
Fitz335
Private First Class
 
Fitz335's Avatar
 
Drives: 2007 335i Black
Join Date: Oct 2012
Location: Sicily

Posts: 178
iTrader: (0)

Garage List
2007 335i  [0.00]
So about an hour ago I decided I was hungry and need some Taco Bell. Accelerating on the highway, BOOM check engine light comes up, car goes limp, vibrates excessively when accelerated over 3k RPM. Got off the highway and begin to make the slow trek home when it goes off just as suddenly and power returns. Got my Taco Bell and went home.

Assuming HPFP? Guess I'll be stopping by the dealer tomorrow. 69k miles.
Fitz335 is offline  
0
Reply With Quote
      11-01-2012, 02:04 PM   #1138
chromisdesigns
Lieutenant Colonel
 
Drives: 2008 BMW 335i sedan
Join Date: Jan 2010
Location: San Francisco

Posts: 1,754
iTrader: (0)

Quote:
Originally Posted by Fitz335 View Post
So about an hour ago I decided I was hungry and need some Taco Bell. Accelerating on the highway, BOOM check engine light comes up, car goes limp, vibrates excessively when accelerated over 3k RPM. Got off the highway and begin to make the slow trek home when it goes off just as suddenly and power returns. Got my Taco Bell and went home.

Assuming HPFP? Guess I'll be stopping by the dealer tomorrow. 69k miles.
Likely, but there are a couple other things that can cause this, including vacuum hose collapse and valve gear issues. It will have thrown a code that tells the dealer what is going on, though. I had the vacuum hose problem once while the car was still in warranty. Same symptoms as yours, traced to crimped hoses.
chromisdesigns is offline  
0
Reply With Quote
      11-08-2012, 08:44 PM   #1139
Eric335
Colonel
 
Eric335's Avatar
 
Drives: 2007 E92 SG 335i 6MT
Join Date: Apr 2011
Location: SW Florida

Posts: 2,493
iTrader: (0)

Garage List
2007 BMW 335i  [3.83]
Car has been taking longer than usual to start up lately, sometimes its very noticeable, other times not... I have also been getting pretty bad misfires at WOT.

Im replacing the sparkplugs this weekend to take care of the misfires, but i hope that it will also help with the long cranks....?
__________________
Eric335 is offline   United_States
0
Reply With Quote
      11-08-2012, 11:54 PM   #1140
VNeBLOB42
Lieutenant Colonel
 
VNeBLOB42's Avatar
 
Drives: 14' GMC Terrain SLT-2
Join Date: May 2011
Location: Folsom, Ca

Posts: 1,679
iTrader: (0)

Garage List
007 335i E92  [3.83]
Send a message via Skype™ to VNeBLOB42
Quote:
Originally Posted by Eric335 View Post
Car has been taking longer than usual to start up lately, sometimes its very noticeable, other times not... I have also been getting pretty bad misfires at WOT.

Im replacing the sparkplugs this weekend to take care of the misfires, but i hope that it will also help with the long cranks....?
Have you tried swapping the coils first? And see if the misfire follows? Are you running E85? That may contribute to your extra cranking cold starts.
__________________

SOLD:: PTF Pro eTune by Dzenno / COBB S1+ E50
Alpina B3 Flash / ETS FMIC / ER CP / CPE DCI
VNeBLOB42 is offline   United_States
0
Reply With Quote
      11-09-2012, 08:38 AM   #1141
Eric335
Colonel
 
Eric335's Avatar
 
Drives: 2007 E92 SG 335i 6MT
Join Date: Apr 2011
Location: SW Florida

Posts: 2,493
iTrader: (0)

Garage List
2007 BMW 335i  [3.83]
Quote:
Originally Posted by VNeBLOB42
Quote:
Originally Posted by Eric335 View Post
Car has been taking longer than usual to start up lately, sometimes its very noticeable, other times not... I have also been getting pretty bad misfires at WOT.

Im replacing the sparkplugs this weekend to take care of the misfires, but i hope that it will also help with the long cranks....?
Have you tried swapping the coils first? And see if the misfire follows? Are you running E85? That may contribute to your extra cranking cold starts.
no E85. im replacing all the plugs and then ill re-log and see if the misfires continue. if they do, ill swap some coils.

are long-cranks enough to get the dealer to replace my hpfp
__________________
Eric335 is offline   United_States
0
Reply With Quote
      11-11-2012, 10:23 AM   #1142
VNeBLOB42
Lieutenant Colonel
 
VNeBLOB42's Avatar
 
Drives: 14' GMC Terrain SLT-2
Join Date: May 2011
Location: Folsom, Ca

Posts: 1,679
iTrader: (0)

Garage List
007 335i E92  [3.83]
Send a message via Skype™ to VNeBLOB42
Quote:
Originally Posted by Eric335 View Post
no E85. im replacing all the plugs and then ill re-log and see if the misfires continue. if they do, ill swap some coils.

are long-cranks enough to get the dealer to replace my hpfp
Replacing the SP, are not necessary, unless they are due. Really swapping the coils is a much easier diagnostic. But either way you can't loose.

Longs cranks may be tough, I think the HPFP will have to fail. But check with your SA.
__________________

SOLD:: PTF Pro eTune by Dzenno / COBB S1+ E50
Alpina B3 Flash / ETS FMIC / ER CP / CPE DCI
VNeBLOB42 is offline   United_States
0
Reply With Quote
      11-11-2012, 04:58 PM   #1143
Eric335
Colonel
 
Eric335's Avatar
 
Drives: 2007 E92 SG 335i 6MT
Join Date: Apr 2011
Location: SW Florida

Posts: 2,493
iTrader: (0)

Garage List
2007 BMW 335i  [3.83]
Quote:
Originally Posted by VNeBLOB42 View Post
Replacing the SP, are not necessary, unless they are due. Really swapping the coils is a much easier diagnostic. But either way you can't loose.

Longs cranks may be tough, I think the HPFP will have to fail. But check with your SA.
Replaced all 6 plugs, all misfires solved The next thing to go will probably be coils or HPFP
__________________
Eric335 is offline   United_States
0
Reply With Quote
      11-15-2012, 07:12 PM   #1144
Fitz335
Private First Class
 
Fitz335's Avatar
 
Drives: 2007 335i Black
Join Date: Oct 2012
Location: Sicily

Posts: 178
iTrader: (0)

Garage List
2007 335i  [0.00]
My code ended up being a low pressure fuel sensor, easy fix!
Fitz335 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:27 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST