E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > HPFP failure FAQ!



Reply
 
Thread Tools Search this Thread
      11-27-2012, 12:47 PM   #1145
Aguas
New Member
 
Aguas's Avatar
 
Drives: Artic 08 E90 335i
Join Date: Nov 2012
Location: VA

Posts: 6
iTrader: (0)

how come i can only see up to page 52
Aguas is offline   United_States
0
Reply With Quote
      01-05-2013, 05:20 PM   #1146
electrojolt
New Member
 
Drives: 2007 335xi
Join Date: Dec 2010
Location: NJ

Posts: 5
iTrader: (0)

I took my 2007 335xi to get the Fuel pump recall done and the dealer messed up my radio (no reception) WTF... one week later, and they still don't know what's wrong.. getting pissed off...
electrojolt is offline  
0
Reply With Quote
      01-08-2013, 01:20 AM   #1147
chromisdesigns
Lieutenant Colonel
 
Drives: 2008 BMW 335i sedan
Join Date: Jan 2010
Location: San Francisco

Posts: 1,754
iTrader: (0)

Quote:
Originally Posted by electrojolt View Post
I took my 2007 335xi to get the Fuel pump recall done and the dealer messed up my radio (no reception) WTF... one week later, and they still don't know what's wrong.. getting pissed off...
It can happen when they reprogram the car -- tell them to do a full reprogram again. When I got mine replaced the second time, it wiped out BMW assist and they had to do it over.

In any case, you'll have to reset all your preferences -- full reprogram sets them all back to default.
chromisdesigns is offline  
0
Reply With Quote
      01-08-2013, 07:39 PM   #1148
electrojolt
New Member
 
Drives: 2007 335xi
Join Date: Dec 2010
Location: NJ

Posts: 5
iTrader: (0)

they tried to re-program with no luck... replaced the radio 2 times and finaly got it working but they scratched the Temperature control panel. grrrrr but they said they are going to replace it... waiting for it.
electrojolt is offline  
0
Reply With Quote
      01-15-2013, 07:50 AM   #1149
Jme_be
Enlisted Member
 
Jme_be's Avatar
 
Drives: E92 N53 330i M-Sport auto
Join Date: Dec 2012
Location: North Bucks

Posts: 31
iTrader: (0)

Quote:
Originally Posted by Chopstick217 View Post
My car is at 600 miles and I am bringing it in today for a service appointment, I get 4-5 second cranks on a regular basis
The rule of thumb used to be that brandnew cars are as likely to fail as worn things. i.e. defects will appear quickly, and once addressed, should then be reliable until they fail due to wear and tear. ..of course, having said that, the coilpack and high pressure fuelpump/injector issue seems to occur at any stage! From what I've read, it seems that the permanent (or most reliable fix) for the coilpack issue is to replace all + perform software update at the same time. Just hypothesising, but maybe the failing/out of spec coilpacks could be causing the fuelpump failure and vis-versa?
Jme_be is offline   United Kingdom
0
Reply With Quote
      01-20-2013, 07:24 AM   #1150
John 070
Lieutenant General
 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

Posts: 11,409
iTrader: (0)

Quote:
Originally Posted by electrojolt View Post
they tried to re-program with no luck... replaced the radio 2 times and finaly got it working but they scratched the Temperature control panel. grrrrr but they said they are going to replace it... waiting for it.
That's so stupid....replace software driven parts without correcting the software. Imagine they do that out of warranty on the customer's dime. Probably charged BMW for the unit and never really replaced anything.
John 070 is offline  
0
Reply With Quote
      01-20-2013, 07:07 PM   #1151
electrojolt
New Member
 
Drives: 2007 335xi
Join Date: Dec 2010
Location: NJ

Posts: 5
iTrader: (0)

Tell me about it. They did replace the radio, but in the process they left marks on my dash and scratched the heat/AC control panel. also broke a clip under the hood.

At least the Service Advisor was very good and took care of the problem.

they replaced the Heat/AC control panel and the broken clip under the hood.

I'm still left with some minor screw driver like marks on the bezel around the Heat/AC panel and Radio.

I'm hoping this is the last time I take the car to the dealer. I usually say: if you want it done right do it your self.
electrojolt is offline  
0
Reply With Quote
      01-25-2013, 02:05 PM   #1152
300zx2e90
Private
 
Drives: 2007 BMW 335i
Join Date: Feb 2012
Location: San Antonio

Posts: 62
iTrader: (0)

Help with hpfp failing

Hi everyone,
My 335i just got out of its CPO warranty 2 weeks ago. My car which has run like a champ started running rough throwing cels etc. I took it to a nearby shop that works on BMWs and that I trust. They worked on it yesterday and ran diagnostics and have determined it is the fuel pump. They are getting this to me in writing and I have set an appointment with BMW. Will bmw try to charge me for anything else like their own $250 diagnostics etc? Curious if anyone has had an independent shop recommend the hpfp be replaced an BMW do it.
__________________
1994 Nissan 300ZX NA > 2005 Subaru Legacy GT > 1993 300ZX Nissan Twin Turbo > 2007 BMW 335I
300zx2e90 is offline  
0
Reply With Quote
      01-26-2013, 02:11 PM   #1153
dandog
New Member
 
Drives: e93 335i m sport convert 07
Join Date: Nov 2012
Location: london, uk

Posts: 19
iTrader: (0)

Hi all,

was there ever a time when your hpfp failed without the engine warning light coming on?
dandog is offline  
0
Reply With Quote
      02-01-2013, 08:21 PM   #1154
AlexCarFL
New Member
 
Drives: E92 335i
Join Date: Jan 2013
Location: Tampa FL

Posts: 9
iTrader: (0)

bump

bump
AlexCarFL is offline  
0
Reply With Quote
      02-02-2013, 10:26 AM   #1155
flybyknight
New Member
 
Drives: Black 08 335i
Join Date: Dec 2012
Location: Willow grove pa

Posts: 6
iTrader: (0)

Send a message via AIM to flybyknight Send a message via Skype™ to flybyknight
I have a question...

Hello and good morning all, I am fairly new to the site and wanted to ask a few questions. I guess ill start by asking, what is the time to get my account on here approved so i can post? Thats really not the issue tho, I live in willow grove pa, and i have a 08 335i. Its stock for the most part tho i have exhaust intake and jb4, the only thing that is installed right now is the jb4, as it is the easiest to take out for warranty work:-/. Now i have it set to boost on gas gauge, and it seems to be at about 16psi on map 1 is that normal? Also every so often(last night) i was omw to philly and i was messing with a worked s2k. He didnt stand a chance, as i see him trying to keep up in my rear view, but i get to about 135 mph and it throws a soft cel, where it is the pic of the motor, not the service engine soon. When i came down to 100mph it went out and every thing was fine, as the s2k starts to advance he gets on the left of me and we do a pull from about 60,i get on it in 3rd and destroyed him up to 145 (no cel) i know its just a s2k but they move and this one had exhaust if nothing more, black slammed on what looked to be bbs. So is there any recommendations as to why this happens. On map 0 i can pull up to 155 no problem multiple times no light. Soon as i go map 1 and do an aggressive pull it does this, but again its not all the time it happens randomly and idk the issue. I have taken it in for warranty work, its gotten injectors, vanos replace, among other things and i dont think the hpfp is bad, anyone have any ideas? Im sorry if i posted this in the wrong place, i am a noop in the regard. but my previous car was an e46 m3, i have had 5, and 3 series, and mom has a 7 so i am no stranger to some of the issues these cars have, but again if anyone had any input it would be greatly appreciated
flybyknight is offline   United_States
0
Reply With Quote
      02-06-2013, 11:00 AM   #1156
deeebo8452
Private
 
Drives: BMW E92 320d M Sport Coupe
Join Date: Feb 2013
Location: London

Posts: 79
iTrader: (0)

Had a similar issue.
deeebo8452 is offline   United Kingdom
0
Reply With Quote
      03-16-2013, 02:04 PM   #1157
Chris_506
RIP Paul Walker; True Enthusiast
 
Chris_506's Avatar
 
Drives: 2007 335i
Join Date: Oct 2012
Location: SCar

Posts: 2,465
iTrader: (13)

question about this, my car is having most of these symptoms at times and it is about to hit 120k..i know the pump has been replaced and when i took it to the dealership they told me i had to pay for the checkup out of pocket which runs around $150. I consider that kind of hefty to get the car checked for having symptoms of an internationally addressed recall so is that about correct? should i pay for the car to be checked for a recall?
__________________
Chris_506 is offline   Costa Rica
0
Reply With Quote
      04-08-2013, 01:59 AM   #1158
thetedderbear
A weirdo but I'm real though
 
thetedderbear's Avatar
 
Drives: 2Fast2Furious
Join Date: Jan 2011
Location: Arr-can-saw

Posts: 620
iTrader: (1)

Quote:
Originally Posted by Fitz335
So about an hour ago I decided I was hungry and need some Taco Bell. Accelerating on the highway, BOOM check engine light comes up, car goes limp, vibrates excessively when accelerated over 3k RPM. Got off the highway and begin to make the slow trek home when it goes off just as suddenly and power returns. Got my Taco Bell and went home.

Assuming HPFP? Guess I'll be stopping by the dealer tomorrow. 69k miles.
I had something similar to this tonight. Going on a spirited drive them boom, car wouldn't rev up very much, was vibrating. Had this happen before but just turned off car and restarted and was fine, assumed it was a time issue. Anyways, tonight it definitely didn't go away. When I restarted the car the vibration was worse, the throttle was not just seeming to hit a limiter and be slightly underpowered, it was full on mushy and lifeless. Reset tune, set stock maps, tried again. Same. Tried driving a bit to see if I could lump it home. Got a little ways with much effort, then half engine light and the throttle quit working. All power stayed on but the engine cut. It stayed running but just dropped to idle and the pedal was useless. Rough idle still. Restarted the car and went back to the mushy but limpable mode, then half engine and pedal cutting out. Repeated till I got it the few miles to home. My indy shop pulled codes a while back that indicated that my fuel pump may be on the way out but nothing serious, but this was a fairly sudden and catastrophic failure. It makes sense that it's the fuel pump, but can anyone chime in with an experience like this?
__________________
"When the fear of death outweighs the thrill of speed, brake"

Stuff - stuff - bits - things - stuff - stuff - parts - stuff
thetedderbear is offline   United_States
0
Reply With Quote
      04-16-2013, 11:35 AM   #1159
Ken07335i
Private First Class
 
Drives: 2007 335i Silver Coupe 6 MT
Join Date: Oct 2011
Location: Charleston, SC

Posts: 103
iTrader: (1)

Took my 2007 335i to an Indy yesterday for brake squeak and lots of hesitation when accelerating. He said "no codes show, but it's shuttering under load or boost". Says it's
probably hpfp and says I ought to take it to the Dealer. I'm thinking I should wait until it throws a code or they won't do anything - right? Maybe I'll take it out and force it to go into limp mode and maybe show a code, but I hate doing that. Any ideas?
Ken07335i is online now  
0
Reply With Quote
      05-30-2013, 05:18 PM   #1160
JS335iOwner
Registered
 
Drives: 2007 335i Coupe
Join Date: May 2013
Location: Dallas, TX

Posts: 2
iTrader: (0)

Good thing BMW extended the warranty for this. I've had to replace it twice already.
JS335iOwner is offline  
0
Reply With Quote
      05-31-2013, 04:06 PM   #1161
Centex Hokie
Private First Class
 
Centex Hokie's Avatar
 
Drives: BMW E93
Join Date: Dec 2010
Location: Central Texas

Posts: 120
iTrader: (0)

#3 Today

I drive about 5K miles per year and have had the car for 3 years. Today makes #3 for me. Do you think BMW will ever really find a solution for this other than replacing it on a routine basis?
__________________
CPO Sparkling Graphite 335i Convertible -|- Premium -|- CA -|- Heated Seats/Steering Wheel -|- Sport Package -|- Navigation -|- Logic7 -|-Installed -|- ModMyNav Backup Camera -|- XM Radio -|- Racing Brake 2 Piece Rotors w/ET500 -|- Injen SP-Series Cold Air Intake -| - M3 Replica from Modprojekt-| - Cobb Accessport-| - ETS FMIC -|
Centex Hokie is offline   United_States
0
Reply With Quote
      06-01-2013, 04:30 PM   #1162
onezoso
Registered
 
Drives: 2011 BMW 335i E90
Join Date: Apr 2013
Location: United States

Posts: 2
iTrader: (0)

HPFP & BMW bought back my car! :)

I had a 2008 535i w/the bad pump.

I had numerous repairs done (under warranty) as a result of the pump.

I did NOT go through a law firm to initiate the buy back from BMW.

I simply called BMW NA and told them of my issues. They reviewed my repair orders and long story short...they repurchased my car and wrote me a check for everything I paid into the car including interest on the loan!

Check total was $29,850.00!!

I turned right around and got a SWEET 2011 (staying away from the N54! In 2011 they switched to the N55 w/no pump issues) 335i E90!

Put 14 grand down on the car and using some of the leftover cash for some sweet mods, like lowering springs, killer wheels and tires, Remus exhaust etc.

Cheers,
Lo
onezoso is offline   United_States
0
Reply With Quote
      06-13-2013, 12:48 PM   #1163
Tashii_CakezZ
Enlisted Member
 
Tashii_CakezZ's Avatar
 
Drives: 335i 'vert <3
Join Date: Jun 2013
Location: Smallbany

Posts: 43
iTrader: (0)

Thumbs up HPFP

WOW!

Thanks so much for all this info! I've e=been racking my mind trying to sort out this issue.
Tashii_CakezZ is offline  
0
Reply With Quote
      07-08-2013, 10:59 AM   #1164
nitrojunky
New Member
 
Drives: C6Z, 330ci, 335i
Join Date: Feb 2013
Location: ATX

Posts: 21
iTrader: (0)

Quote:
Originally Posted by Aguas View Post
how come i can only see up to page 52
we call them 'ghost pages' in my other forums. common issue with very long threads. think it has something to do with forum software and deleted posts. as in, if no posts had been deleted, the thread would be 57 pages long and the software still thinks this is the case. but since there are only 52 pages of surviving posts, you get 52 pages when you to to 'last'. what you see on page 52 (presently) are the most recent posts.
nitrojunky is offline  
0
Reply With Quote
      08-16-2013, 03:15 PM   #1165
iknowitsfast
Private First Class
 
iknowitsfast's Avatar
 
Drives: E90 335xi
Join Date: Jul 2013
Location: Chicago, IL

Posts: 163
iTrader: (0)

Do 335 owners who have had their fuel pumps replaced usually experience pump failure twice? I just got a history run on my car and it was replaced already by the previous owner. How likely are these to fail multiple times?
__________________
Monaco Blue 335xi
iknowitsfast is offline  
0
Reply With Quote
      08-16-2013, 03:24 PM   #1166
onezoso
Registered
 
Drives: 2011 BMW 335i E90
Join Date: Apr 2013
Location: United States

Posts: 2
iTrader: (0)

HPFP issue

If you have the N54, it is highly likely.

I had the 2008 535i and the pump went out 3 times.

In California that qualified it for the Lemon Law.

I called BMW North America, told them of the issue, they reviewed my repair history and within 4 weeks wrote me a check for everything I paid on the car including interest on my loan.

The check was for $32k.

I could have walked away but then got a sweet 2011 335i and I love this car!

Cheers!
onezoso is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:41 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST