E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Whoops! Broke some bumper clips...



Reply
 
Thread Tools Search this Thread
      01-18-2010, 10:34 AM   #1
BMWBen
New Member
 
Drives: 330d Msport
Join Date: Jan 2010
Location: UK

Posts: 11
iTrader: (0)

Whoops! Broke some bumper clips...

Removed my rear bumper cover yesterday to fit a towbar - on one side when removing it I broke several of the tab holes (as you are warned about on every bumper removal thread!)

On the other side I only broke one, but anyway, is it going to be ok going back on? Haven't finished the job yet, and now I'm worrying about it.

On another note, I finally got TIS working on my PC (after removing the bumper) and it says you should pull straight back and not out. Does this actually work? Looking at the clips I can't see how...
BMWBen is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:14 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST