E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > 2FBF Fuel pressure injector release



Reply
 
Thread Tools Search this Thread
      02-06-2010, 12:30 PM   #1
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: The Coding Guy
Join Date: Jun 2007
Location: Call 917-939-4980

Posts: 18,227
iTrader: (5)

Send a message via Yahoo to cn555ic
2FBF Fuel pressure injector release

Car is running fine and haven't exhibited not one cold start....Datalogs show the car is performing perfectly....I scanned the car for codes last night not expecting to see any since the car is running so great. To my surprise I definitely didn't think that I would show up with a 2FBF code because of how the car is running....I cleared the code and drove the car around but the code didn't appear again....I know this is related to a HPFP issues, but I have not exhibited one long crank or stutter, bad idling, anything....What do you guys think, is this a pending failure?? Could there be anything else that would trigger this? Maybe a firmware update?

Last edited by cn555ic; 02-06-2010 at 12:36 PM.
cn555ic is offline   United_States
0
Reply With Quote
      02-06-2010, 03:53 PM   #2
awei130
Banned
 
Drives: E46, E92, 987
Join Date: Jun 2008
Location: SOCAL

Posts: 2,494
iTrader: (19)

You should have left the code there and brought it to the dealership as they would have replaced your HPFP regardless.
awei130 is offline   United_States
0
Reply With Quote
      02-06-2010, 04:13 PM   #3
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: The Coding Guy
Join Date: Jun 2007
Location: Call 917-939-4980

Posts: 18,227
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by awei130 View Post
You should have left the code there and brought it to the dealership as they would have replaced your HPFP regardless.
these cars are very finicky when it comes to codes and errors with the DME...I understand bringing it to the dealer if the HPFP is showing signs of failure, but read what I stated, the car is running perfect with no other codes besides that...Usually when its the fuel pump there will be other codes along with it and also rough idles and sputtering with long cranks....My car has shown none of this and runs really really strong....I cleared the one code and it hasn't come back, if it was indeed a failing pump the code will come back...Just wondering if anyone else encountered just this one code and have their fuel pump fail based on this one code
cn555ic is offline   United_States
0
Reply With Quote
      02-06-2010, 05:08 PM   #4
kodarren
Private First Class
 
Drives: E90 328xi, 335i
Join Date: Jul 2007
Location: usa(Hong Kong)

Posts: 148
iTrader: (0)

I will just leave the codes there and let the dealersip figures it out.
kodarren is offline   Hong Kong
0
Reply With Quote
      02-06-2010, 05:26 PM   #5
DJKhan85
Major
 
DJKhan85's Avatar
 
Drives: 2011 4dr 6mt Golf GTI
Join Date: Jun 2009
Location: Boston Massachusetts

Posts: 1,188
iTrader: (1)

I would have left the code and just driven for a few more weeks. That way if problems do show up, you know they will do something about it. Check again in a few days and see if the code comes back.

This reminds me that I should scan my car soon to see what could be lurking around the corner.
__________________
2011 VW GTI 4dr-6mt-Sunroof-Nav-Xenons
OLD:
08 335i AW/CR/Poplar 6mt-ZSP-ZPP-ZCW-iPod-iDrive-PDC-Style 230s w/FK 452-Dinan LSD
DJKhan85 is offline   Trinidad_and_tobago
0
Reply With Quote
      02-06-2010, 05:51 PM   #6
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: The Coding Guy
Join Date: Jun 2007
Location: Call 917-939-4980

Posts: 18,227
iTrader: (5)

Send a message via Yahoo to cn555ic
Guys....please....I want to know what the code means specifically? Please I already know I can take it to the dealership, I am not asking for advise!! lol
cn555ic is offline   United_States
0
Reply With Quote
      02-06-2010, 06:02 PM   #7
enrita
Major General
 
enrita's Avatar
 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

Posts: 7,316
iTrader: (0)

Normally this is a sign that your pump is starting to give up. Could also be the high/low pressure sensors faulty? In any case if you can (i know you are fully modded so it sucks to remove everything...) you could get the newest pump version on warranty.
__________________
07 335i AT - TD St.2 Turbos - COBB (Custom Cobb mapping by http://www.protuningfreaks.com/) - JB4G5 ISO - Okada Coils - NGK 5992 Plugs - E85 Walbro - Injen Intake - Helix IC - Snow Stg. 3 - Stett CP - AR DPs - midpipes 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - Level 10 AT upgrade - Alpina AT Flash
enrita is offline   Sweden
0
Reply With Quote
      02-06-2010, 06:31 PM   #8
scalbert
Major General
 
scalbert's Avatar
 
Drives: '08 E90 M3, '13 Volt, '08 Ody
Join Date: Feb 2007
Location: Woodstock, GA

Posts: 5,697
iTrader: (7)

Was there a single event or multiple? If single, I would clear and see if it comes back. All too often a code can be falsely triggered for a multitude of reasons. Repeatability of an issue is when to take it into the delaer IMO.
scalbert is offline  
0
Reply With Quote
      02-06-2010, 06:44 PM   #9
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: The Coding Guy
Join Date: Jun 2007
Location: Call 917-939-4980

Posts: 18,227
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by scalbert View Post
Was there a single event or multiple? If single, I would clear and see if it comes back. All too often a code can be falsely triggered for a multitude of reasons. Repeatability of an issue is when to take it into the delaer IMO.
Thanks...I don't have BT cable but used the Procede Reader to see the code so I don't know if its multiple....But I cleared it and will see if it comes back....Going to drive the car hard to see if it comes back
cn555ic is offline   United_States
0
Reply With Quote
      02-06-2010, 06:57 PM   #10
bulldog x6
Major General
 
Drives: x6 panzer
Join Date: Oct 2008
Location: probably work

Posts: 5,017
iTrader: (28)

I have been getting this code ever since I got my car.... I just clear it
bulldog x6 is offline  
0
Reply With Quote
      02-06-2010, 07:02 PM   #11
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: The Coding Guy
Join Date: Jun 2007
Location: Call 917-939-4980

Posts: 18,227
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by turkish335 View Post
I have been getting this code ever since I got my car.... I just clear it
Great....This is what I wanted to here feedback from someone that has this code but nothing else! Is your car running normal...Once you cleared it, does the code keeps coming back? So far mine hasn't come back, but then again I still haven't driven the car hard since I cleared it....Car starts up normal, not one long crank at all..Thanks
cn555ic is offline   United_States
0
Reply With Quote
      02-06-2010, 07:06 PM   #12
RevC
Lieutenant General
 
RevC's Avatar
 
Drives: a couple fast toys
Join Date: Jun 2009
Location: Voorhees+cherry hill,NJ

Posts: 11,761
iTrader: (26)

you think this is related to hpfp? i didn't recieve any of these codes before mine failed. think it could be your injectors though, the dealer said there have been tons coming in for injector issues.
__________________
-Rev


SGM e92 335xi|Helix|AFE|AWE|PROCEDE|SYNAPSE|ER|OSS|BMW PERFORMANCE|P3|always growing..
RevC is offline  
0
Reply With Quote
      02-06-2010, 07:48 PM   #13
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: The Coding Guy
Join Date: Jun 2007
Location: Call 917-939-4980

Posts: 18,227
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by RevC View Post
you think this is related to hpfp? i didn't recieve any of these codes before mine failed. think it could be your injectors though, the dealer said there have been tons coming in for injector issues.
The car is running perfect and there seems to be nothing wrong with the car...If I would have not updated my firmware and check for codes, I would never in my wildest dreams think there would be even an issue since the car is running better than ever...I cleared the one code that I had, and will check to see if it comes back....Turkish u said you had this code since the first day you got the car and you cleared it, does it come back all the time???

Last edited by cn555ic; 02-06-2010 at 07:57 PM.
cn555ic is offline   United_States
0
Reply With Quote
      02-06-2010, 08:04 PM   #14
Bimmer This
Major General
 
Drives: 2007 BMW 335i
Join Date: Nov 2008
Location: Westminster

Posts: 6,477
iTrader: (3)

I always have this code in my car ever since I've had mine tuned. Car always drives perfectly and I haven't noticed any symptoms of HPFP failure as of yet. I've even taken it into the dealer and they tell don't ever do anything about it. It funny because it never throws a check engine lamp nor do I get limp modes. It runs perfectly
well with this current code set.
Bimmer This is offline  
0
Reply With Quote
      02-06-2010, 08:18 PM   #15
FLA 335
Captain
 
Drives: 2009 335i (SOLD) !!!!!
Join Date: Sep 2009
Location: Miami Fl

Posts: 746
iTrader: (7)

i had worse and worse cranks and this code showed up... car just wouldnt start before 10 seconds of cranking... i called roadside service and towed car to dealer... not sure what will be replaced but seeing as how it says injector release either fuel isnt getting to injectors or injector has gone bad is the way i see it...

i agree... i wouldnt have cleared the code... it could be the begining of something happening??
__________________
2009 BMW 335i Sedan / Auto / Paddles / Sport / BMW Assist / Heated seats / JB Matte Black Grill / Tischer First Aid Kit w\Triangle / Tischer Hood Pad / "Custom" rear fog switch <---- SOLD!!!!
FLA 335 is offline  
0
Reply With Quote
      02-06-2010, 08:21 PM   #16
shiv@vishnu
 
shiv@vishnu's Avatar
 
Drives: PROcede v5
Join Date: Sep 2006
Location: SF Bay, CA

Posts: 17,609
iTrader: (0)

It's pretty simple. If the code keeps coming back, take it to the dealership. Better than having your hpfp suddenly die on you in the middle of the desert.
shiv@vishnu is offline   United_States
0
Reply With Quote
      02-06-2010, 08:21 PM   #17
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: The Coding Guy
Join Date: Jun 2007
Location: Call 917-939-4980

Posts: 18,227
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by Bimmer This View Post
I always have this code in my car ever since I've had mine tuned. Car always drives perfectly and I haven't noticed any symptoms of HPFP failure as of yet. I've even taken it into the dealer and they tell don't ever do anything about it. It funny because it never throws a check engine lamp nor do I get limp modes. It runs perfectly
well with this current code set.
Hmmm thats two people that have this code and not a single problem with their cars....I did a search and it seems it is related to HPFP, but with other members on the board that had their pumps go out on them, the 2FBF code was accompanied by various other codes...Right now I am just getting this one code like you...Have you ever tried to clear the 2fbf code???
cn555ic is offline   United_States
0
Reply With Quote
      02-06-2010, 09:23 PM   #18
FLA 335
Captain
 
Drives: 2009 335i (SOLD) !!!!!
Join Date: Sep 2009
Location: Miami Fl

Posts: 746
iTrader: (7)

Quote:
Originally Posted by shiv@vishnu View Post
It's pretty simple. If the code keeps coming back, take it to the dealership. Better than having your hpfp suddenly die on you in the middle of the desert.
__________________
2009 BMW 335i Sedan / Auto / Paddles / Sport / BMW Assist / Heated seats / JB Matte Black Grill / Tischer First Aid Kit w\Triangle / Tischer Hood Pad / "Custom" rear fog switch <---- SOLD!!!!
FLA 335 is offline  
0
Reply With Quote
      02-06-2010, 10:09 PM   #19
bulldog x6
Major General
 
Drives: x6 panzer
Join Date: Oct 2008
Location: probably work

Posts: 5,017
iTrader: (28)

Quote:
Originally Posted by cn555ic View Post
Great....This is what I wanted to here feedback from someone that has this code but nothing else! Is your car running normal...Once you cleared it, does the code keeps coming back? So far mine hasn't come back, but then again I still haven't driven the car hard since I cleared it....Car starts up normal, not one long crank at all..Thanks
seems to be fine, Ive got the occasional limp mode from overboost on jb3 1.4 due to the cold climate here. i have probably got the code 3 times total, including today. car has long cranks but always starts up, the longer cranks are due to the cold weather I guess, but its never limped on startup. otherwise car is working as expected.
bulldog x6 is offline  
0
Reply With Quote
      02-06-2010, 10:32 PM   #20
Bimmer This
Major General
 
Drives: 2007 BMW 335i
Join Date: Nov 2008
Location: Westminster

Posts: 6,477
iTrader: (3)

Quote:
Originally Posted by cn555ic View Post
Hmmm thats two people that have this code and not a single problem with their cars....I did a search and it seems it is related to HPFP, but with other members on the board that had their pumps go out on them, the 2FBF code was accompanied by various other codes...Right now I am just getting this one code like you...Have you ever tried to clear the 2fbf code???
yes, I hav cleared it. Several times. It just keeps
coming back with no peformance problems with the vehicle. The funny thing is, this code is always current. Last time I went into BMW, I told them about the code and they did bot do anything.
Bimmer This is offline  
0
Reply With Quote
      02-07-2010, 01:25 AM   #21
stevetx77
Private
 
Drives: 2009 BMW 335i E92
Join Date: Aug 2009
Location: Houston area...TX

Posts: 75
iTrader: (0)

Send a message via Yahoo to stevetx77
Quote:
Originally Posted by Bimmer This View Post
yes, I hav cleared it. Several times. It just keeps
coming back with no peformance problems with the vehicle. The funny thing is, this code is always current. Last time I went into BMW, I told them about the code and they did bot do anything.
I have this same code. car is a 05/09 build. No problems ever until about xmas time when I started getting long cranks. Removed JB3 and problem still exist. I did not clear the code and will take it in this week to get my HPFP/injectors/whatever fixed. I have 2 instances of this code showing up but nothing in the past 500 miles. Still, it's there, and I have long cranks. Car runs fine other than that.
stevetx77 is offline   United_States
0
Reply With Quote
      02-07-2010, 01:39 AM   #22
Nick.CBR
Lieutenant Colonel
 
Drives: BMW
Join Date: Feb 2008
Location: USA

Posts: 1,635
iTrader: (6)

Same thing here. I got that exact code and when the car was in for an oil change, they scanned it and put a new pump in the car. I didn't know it even had the code (Rev 1 at the time) - I had to ask what prompted them to replace the pump. I was having ZERO issues - the car was running very strong (I was on 7-29 v3 code at the time). I would have done the same thing you did; clear it and see what happens (esp. since I have the Rev 2 box now).

The only reason they put a pump in the car was because it was already sitting there. I wouldn't have brought it in for that specific code; it never threw a light or anything... Sometimes it's a lot more of a hassle than it's worth. If it didn't throw a light, the DME obviously took note but didn't care. We have the luxury of scanning codes now so we're just that more "in the know" about our cars - nobody else would have brought their car in for this (because they wouldn't have known it was even there!!)

I'd say just let it go and keep an eye on it...

Nick
Nick.CBR is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:28 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST