E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Parrot Mki9100



Reply
 
Thread Tools Search this Thread
      10-15-2010, 08:16 PM   #23
Tomz_M3
Lieutenant Colonel
 
Drives: 08 Jet Black E90 M3
Join Date: Jul 2010
Location: Queens, NY

Posts: 1,761
iTrader: (11)

^^Thanks for the info. Do you remember which of the Canbus wires is Hi, and Low?
Tomz_M3 is offline   United_States
0
Reply With Quote
      10-16-2010, 03:56 AM   #24
DAN
Private First Class
 
Drives: E90 320d
Join Date: Oct 2008
Location: UK

Posts: 112
iTrader: (0)

On my photo of the canbus wires the one on the left is can low and on the right is can high. Not sure if all brands of harness have the same colours though... Look at one of the links in my last post - the PDF files show exactly where on the plugs the required pin numbers are, then you can follow back to the wires & tap into them...
DAN is offline  
0
Reply With Quote
      10-16-2010, 05:27 PM   #25
Tomz_M3
Lieutenant Colonel
 
Drives: 08 Jet Black E90 M3
Join Date: Jul 2010
Location: Queens, NY

Posts: 1,761
iTrader: (11)

Great......I have everything installed thanks to your guidance, but have one remaining problem. I used pin 9 for the Can high and Pin 11 for the Can Low.

BUT I dont have the mute lead connected to anything (pin 10 on my harness is empty, so I could not tap into it). Should I run the yellow mute in there?

If not, I will have to ask around because I need the yellow mute wire from the MKi to get the steering wheel interface to work - the manual says the steering wheel controls will default to radio mode if the mute is not activated by the Parrot.

Maybe you can show where the SOT harness is located??

Last edited by Tomz_M3; 10-16-2010 at 05:41 PM.
Tomz_M3 is offline   United_States
0
Reply With Quote
      10-16-2010, 06:45 PM   #26
DAN
Private First Class
 
Drives: E90 320d
Join Date: Oct 2008
Location: UK

Posts: 112
iTrader: (0)

You mean there is no cable leading from pin 10 on your sot-976 harness/lead at all?? That's odd - mine even had an in-line push-pull break connector in it so the parrot mute lead just pushed in... Do you definitely have the correct harness?? Does pin 10 on the connector at least have a pin on it that makes contact with the back of the radio? If so, I suppose you could solder your own cable on. If not, that could be a tricky problem to get around couldn't it....
DAN is offline  
0
Reply With Quote
      10-16-2010, 10:18 PM   #27
Tomz_M3
Lieutenant Colonel
 
Drives: 08 Jet Black E90 M3
Join Date: Jul 2010
Location: Queens, NY

Posts: 1,761
iTrader: (11)

^^^No, no cable leading in. It looks identical to your harness, but it is missing all of the speaker wires you have, and also the mute wire in. But it does have the pin, so I will try to solder the mute directly in. Since you have a fiber optic in like mine, I figure the wiring should be similar, I'll find out.

The mute button on mine happens to have a clip on it that will probably fit right over the pin, so I will try that tomorrow. Now, time to go out wife wifey tonite, so Ill post tomorrow on the results!
Tomz_M3 is offline   United_States
0
Reply With Quote
      10-17-2010, 02:19 PM   #28
Tomz_M3
Lieutenant Colonel
 
Drives: 08 Jet Black E90 M3
Join Date: Jul 2010
Location: Queens, NY

Posts: 1,761
iTrader: (11)

MUTE NOW WORKS WITH LOGIC 7!!!!

I had to solder a lead onto pin 10 and it worked like a charm. So for anyone that has Logic 7, you CAN tap into mute! Almost every response on the forum was a negative, so I am glad I did the necessary comparison and trial and error.

Last problem - the Unika interface seems to have accepted the Canbus protocols and the light changes color on the Unika interface when I touch a steering wheel button but the buttons still dont work. I think that's an issue I have to talk to Parrot directly about....and it doesnt look like its compatible with our cars from what I've been reading. Anyway, thanks for all the guidance Dan!

Edit: I needed a new screen, seems the old screens arent compatible with Unika and will not allow the Unika to function. Parrot sent me one free of charge within a few days, and now everything works perfectly. You can also do continuous updates to the Parrot via the USB line in.

Last edited by Tomz_M3; 03-04-2011 at 01:33 PM.
Tomz_M3 is offline   United_States
0
Reply With Quote
      10-17-2010, 06:33 PM   #29
DAN
Private First Class
 
Drives: E90 320d
Join Date: Oct 2008
Location: UK

Posts: 112
iTrader: (0)

That's ok, glad I was of some help. I can only suggest resetting the unika or updating software on the mki... The parrot forums might be of some use as well perhaps? Would be interested what you think about the unika controls when you get it working...

Out of interest, how did you route the parrot's speaker outputs all the way to the boot? Do you have fold-down back seats? I'm wanting to route a switched ignition feed to the boot for a gps tracker but it seems like a real pain. My seats don't fold down...

Dan

Last edited by DAN; 10-18-2010 at 04:23 AM.
DAN is offline  
0
Reply With Quote
      10-20-2010, 11:22 AM   #30
setzer715
New Member
 
Drives: 2007 328i
Join Date: Oct 2010
Location: Arizona, USA

Posts: 5
iTrader: (0)

Hey DAN,
Thank you for the write up, I'm using to put a mki9200 in my wife's 07 328. Anyways, my question is, where did you get the new grill and speaker bracket for the center speaker? My car has idrive so I know the grill will be different but I was just wondering if you purchased online or at your local dealer/car shop. Thanks!
setzer715 is offline  
0
Reply With Quote
      10-20-2010, 03:16 PM   #31
DAN
Private First Class
 
Drives: E90 320d
Join Date: Oct 2008
Location: UK

Posts: 112
iTrader: (0)

I just got the cowl with the speaker grill from a BMW dealer at the parts desk (had to wait a couple of days for it). The i-drive version is a slightly different shape I think (more curved).

On my car, there was already a place to drop the speaker into under the cowl. You could screw it into the holes provided but the weight of the speaker keeps it sat there just fine. I used a couple of blobs of blue-tac instead of screws - lazy, I know. I can't remember the speaker size, but I just measured the placeholder & bought the correct sized speaker from maplin (or radio shack in the US I guess). I don't know what it would be like on an i-drive model. The cover just pops off on mine with a bit of force upwards towards the windscreen at the edge nearest to the back of the car, so you could have a go yourself and see...
DAN is offline  
0
Reply With Quote
      10-20-2010, 08:04 PM   #32
setzer715
New Member
 
Drives: 2007 328i
Join Date: Oct 2010
Location: Arizona, USA

Posts: 5
iTrader: (0)

Thanks for the response! With a little more research i found out that that speaker is a 4" and the grill is different for iDrive (bought the car used, strange previous owner would invest in iDrive but not Bluetooth or iPod connections). I ordered the grill from getbmwparts.com for $25. Ordered the speaker from amazon.com (cheap 3.5" for $4) and got the mki9200 on ebay for $190. Will report back with pictures once everything arrives and I put it in!
setzer715 is offline  
0
Reply With Quote
      10-26-2010, 11:35 AM   #33
setzer715
New Member
 
Drives: 2007 328i
Join Date: Oct 2010
Location: Arizona, USA

Posts: 5
iTrader: (0)

Hey DAN, got another question for you. We're you able to pull both switched and constant power off the radio harness or did you have to run something to the fuse box? Thanks.
setzer715 is offline  
0
Reply With Quote
      10-27-2010, 05:15 PM   #34
DAN
Private First Class
 
Drives: E90 320d
Join Date: Oct 2008
Location: UK

Posts: 112
iTrader: (0)

No, only the permanent 12v is on the harness.

I had to get the switched 12v feed from the fusebox. I wrapped a wire around a blade of the fuse that feeds the 12v cigarette lighter sockets, and shoved the fuse back in. If I could get hold of a proper fuse tap I'd have done that, but I can't seem to find them in the UK. That wire then leads straight to the parrot's labelled 12v ignition input on the in-line fuse.
DAN is offline  
0
Reply With Quote
      10-28-2010, 12:40 AM   #35
setzer715
New Member
 
Drives: 2007 328i
Join Date: Oct 2010
Location: Arizona, USA

Posts: 5
iTrader: (0)

Well, I got it all installed. Took me forever to figure out which setting sends audio over the line level instead of speaker outputs but now I only have audio on the right channel. Don't know if I did a poor soldering job or if the cable I used is just old and wore out. Troubleshoot that tomorrow.

Phone audio is as you said, perfectly adequate with the one speaker in the dash. Here are a few pics I took, not too many, sorry, was just trying to get it done.

First pic is of where I placed the Parrot. Took me a minute to figure out that with iDrive the Temp controls are ABOVE the Radio controls. Perfect place for the Parrot. Second Pic is of the Parrot with the Radio Back in. Third is the Mic (I know visor doesn't look best but sounds best). Fourth is the Display location. Fifth is the Aux In connector.










Last edited by setzer715; 10-28-2010 at 12:46 AM.
setzer715 is offline  
0
Reply With Quote
      10-30-2010, 11:37 AM   #36
DAN
Private First Class
 
Drives: E90 320d
Join Date: Oct 2008
Location: UK

Posts: 112
iTrader: (0)

Here's where I put my mic - haven't really had any complaints from the other end...
Attached Images
  
DAN is offline  
0
Reply With Quote
      11-03-2010, 02:47 PM   #37
Tomz_M3
Lieutenant Colonel
 
Drives: 08 Jet Black E90 M3
Join Date: Jul 2010
Location: Queens, NY

Posts: 1,761
iTrader: (11)

[quote=setzer715;8236009]Well, I got it all installed. Took me forever to figure out which setting sends audio over the line level instead of speaker outputs but now I only have audio on the right channel. Don't know if I did a poor soldering job or if the cable I used is just old and wore out. Troubleshoot that tomorrow.

[quote=setzer715;8236009]

I believe you need to go into the audio settings and adjust so that muting is off when streaming music. Then you will be able to hear on the Aux line (full stereo) instead of the 1 speaker.

BTW Dan, completed the Unika install - everything works as advertised, and no complaints. I was even able to put away the controller!
Tomz_M3 is offline   United_States
0
Reply With Quote
      11-06-2010, 08:32 PM   #38
DAN
Private First Class
 
Drives: E90 320d
Join Date: Oct 2008
Location: UK

Posts: 112
iTrader: (0)

Others have complained about the up & down controls on the unika being the opposite to the menu system on the parrot and that the volume changes the parrot AND the head unit at the same time. Have you found these problems at all?

Last edited by DAN; 11-06-2010 at 08:40 PM.
DAN is offline  
0
Reply With Quote
      11-19-2010, 06:55 PM   #39
setzer715
New Member
 
Drives: 2007 328i
Join Date: Oct 2010
Location: Arizona, USA

Posts: 5
iTrader: (0)

[quote=tomz_335i;8272457][quote=setzer715;8236009]Well, I got it all installed. Took me forever to figure out which setting sends audio over the line level instead of speaker outputs but now I only have audio on the right channel. Don't know if I did a poor soldering job or if the cable I used is just old and wore out. Troubleshoot that tomorrow.

Quote:
Originally Posted by setzer715 View Post

I believe you need to go into the audio settings and adjust so that muting is off when streaming music. Then you will be able to hear on the Aux line (full stereo) instead of the 1 speaker.

BTW Dan, completed the Unika install - everything works as advertised, and no complaints. I was even able to put away the controller!
Thanks, it actually turned out to be a bad cable. Soldered in a new cable and bam, everything is working fine. Thanks for great write up Dan!
setzer715 is offline  
0
Reply With Quote
      11-22-2010, 10:15 AM   #40
scubasteve2365
Private First Class
 
Drives: 07 328xi
Join Date: Jun 2010
Location: Louisville, Ky

Posts: 119
iTrader: (0)

Is the parrot Mki9100 capable of sending the voice-call out the aux line as well? I currently have an aftermarket bluetooth solution so I leave my radio on "Aux" 99% of the time, the only downside is that I have no way of integrating the factory steering wheel controls with it. I'm interested in the parrot with a unika but would rather not use the mute and simply direct both A2DP music and Voice calls out the aux line.
scubasteve2365 is offline  
0
Reply With Quote
      03-04-2011, 08:40 AM   #41
rogerdiaz
Lieutenant
 
Drives: 2011 335d
Join Date: Sep 2010
Location: Durham,NC

Posts: 524
iTrader: (2)

Do you see caller information displayed on bmw professional radio? Parrot plus unika
rogerdiaz is offline   United_States
0
Reply With Quote
      03-04-2011, 01:27 PM   #42
Tomz_M3
Lieutenant Colonel
 
Drives: 08 Jet Black E90 M3
Join Date: Jul 2010
Location: Queens, NY

Posts: 1,761
iTrader: (11)

No. The Parrot does tell you the name of the person that is calling though, if they are stored in the phone book. Otherwise it just calls out the digits one by one.
Tomz_M3 is offline   United_States
0
Reply With Quote
      03-04-2011, 01:31 PM   #43
Tomz_M3
Lieutenant Colonel
 
Drives: 08 Jet Black E90 M3
Join Date: Jul 2010
Location: Queens, NY

Posts: 1,761
iTrader: (11)

Quote:
Originally Posted by DAN View Post
That's ok, glad I was of some help. I can only suggest resetting the unika or updating software on the mki... The parrot forums might be of some use as well perhaps? Would be interested what you think about the unika controls when you get it working...

Out of interest, how did you route the parrot's speaker outputs all the way to the boot? Do you have fold-down back seats? I'm wanting to route a switched ignition feed to the boot for a gps tracker but it seems like a real pain. My seats don't fold down...

Dan
Yeah, I went into the trunk and routed the wires from the dash all the way back to the amp in the trunk. A bit of work but really the only way to do it right.
Tomz_M3 is offline   United_States
0
Reply With Quote
      03-09-2012, 11:17 AM   #44
Hrato
Private
 
Drives: BMW 318d 2009
Join Date: Jul 2011
Location: Europe

Posts: 52
iTrader: (0)

Hello.
This is an old post, but i tough about try it anyway.
I have installed a Parrot Mki9100 plus Unika steering wheel adapter for BMW.
All installed with a Audio2Car harness.
All works ok, except for the fact that when the car goes to sleep, upon unlocking, one alarm comes up on car dash ( car being lifted up ), for about 3 seconds, and it disappears.
I have tried to have just the Parrot without the Unika, and the alarm goes away.
My car BMW e90, NO NAVI, with Professional CD.
As anyone had something like this, or knows what can cause this type of alarm?
Thanks.
Hrato is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:05 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST