E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > CC-ID 29



Reply
 
Thread Tools Search this Thread
      02-14-2010, 12:22 AM   #1
flipdsm
Private First Class
 
flipdsm's Avatar
 
Drives: 2007 335i Coupe
Join Date: Feb 2010
Location: Orange County

Posts: 108
iTrader: (1)

CC-ID 29

Well, I was having some fun today and went WOT in 2nd gear, near redline, the check engine light(yellow half lit engine) came on and I let off. I checked it and it said CC-ID 29, I don't have IDrive, does anybody know what this is? I turned off the car and let it sit for 2 hours and upon startup, the light disappeared. Even when the light came on, the car ran great, nothing abnormal. Any help would be appreciated, thanks.
flipdsm is offline  
0
Reply With Quote
      02-14-2010, 06:43 AM   #2
flipdsm
Private First Class
 
flipdsm's Avatar
 
Drives: 2007 335i Coupe
Join Date: Feb 2010
Location: Orange County

Posts: 108
iTrader: (1)

Anybody know the code?
flipdsm is offline  
0
Reply With Quote
      02-14-2010, 09:21 AM   #3
forza1976
Brigadier General
 
forza1976's Avatar
 
Drives: 2014 A6
Join Date: Aug 2007
Location: Denver CO

Posts: 4,539
iTrader: (11)

Garage List
2014 Audi A6  [5.00]
you might give this a look.
http://www.e90post.com/forums/showthread.php?t=178622
forza1976 is offline   United_States
0
Reply With Quote
      02-14-2010, 04:13 PM   #4
flipdsm
Private First Class
 
flipdsm's Avatar
 
Drives: 2007 335i Coupe
Join Date: Feb 2010
Location: Orange County

Posts: 108
iTrader: (1)

Hmm, I'm not sure if it's the fuel pump because it was replaced about 500 miles ago.
flipdsm is offline  
0
Reply With Quote
      02-14-2010, 06:48 PM   #5
._.
Colonel
 
._.'s Avatar
 
Drives: BMW
Join Date: Jun 2009
Location: Miami

Posts: 2,357
iTrader: (15)

Quote:
Originally Posted by flipdsm View Post
Hmm, I'm not sure if it's the fuel pump because it was replaced about 500 miles ago.
LOL, from what can be read in this forum it wouldn't be unlikely.
._. is offline  
0
Reply With Quote
      02-15-2010, 01:14 AM   #6
flipdsm
Private First Class
 
flipdsm's Avatar
 
Drives: 2007 335i Coupe
Join Date: Feb 2010
Location: Orange County

Posts: 108
iTrader: (1)

So should I bring it to the dealer ASAP or just wait until it happens again. Because I no longer have the OEM warranty and the car runs great now.
flipdsm is offline  
0
Reply With Quote
      06-24-2011, 08:48 PM   #7
Paul Stig
New Member
 
Drives: E92 335I
Join Date: Jun 2011
Location: Taiwan

Posts: 22
iTrader: (0)

Any update now? I got it too.....
Paul Stig is offline   Taiwan
0
Reply With Quote
      06-24-2011, 09:17 PM   #8
aandrew325
Lieutenant
 
Drives: e92 335i
Join Date: Sep 2010
Location: Valley, 818

Posts: 442
iTrader: (2)

your fuel pump has a 120k warranty on it, so if it is indeed that, then take it in, it will be covered, and more then likely the code has been stored in the memory of the car so even if the light went away, they will still be able to look it up and replace it.
__________________
aandrew325 is offline  
0
Reply With Quote
      06-27-2011, 07:27 AM   #9
Paul Stig
New Member
 
Drives: E92 335I
Join Date: Jun 2011
Location: Taiwan

Posts: 22
iTrader: (0)

Share my experience, please check vacuum tubes conditions.
I got same error code and dealer said the presure is not enough, we found my tubes crack, after changing it, it ok, and get power back.
Paul Stig is offline   Taiwan
0
Reply With Quote
      06-27-2011, 08:47 AM   #10
XJS
Private First Class
 
Drives: 335iM
Join Date: Feb 2010
Location: Sweden

Posts: 112
iTrader: (0)

Check and see if you can't borrow (or even better, buy one) a BT cable and check the real error codes yourself. This way you won't have to pay the dealer $$$ everytime you have a problem with your car and they charge you one hour labor just to check the code (which takes about as long time as starting up a laptop does). Chances are they will check your code, say something like "we cleared the error code, it wasn't anything major" and send you on your way.
XJS is offline  
0
Reply With Quote
      03-06-2012, 01:37 PM   #11
scflaw
Lieutenant
 
Drives: E93 3'r
Join Date: Jan 2011
Location: HKG

Posts: 502
iTrader: (1)

Sorry to bring this back from the dead but i just recieved a CC ID 29 and i checked the error codes and recieved a P30FE from the Cobb. Could it be a wastegate issue?
scflaw is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:37 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST