E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Cruise Control Malfunction



Reply
 
Thread Tools Search this Thread
      04-26-2010, 08:12 PM   #1
PaulBailey@ltbmw
General
 
PaulBailey@ltbmw's Avatar
 
Drives: 2-325 330 2-335 2-Z4 2-135 X5d
Join Date: Mar 2007
Location: Huntington Beach, CA

Posts: 26,758
iTrader: (34)

Garage List
Send a message via AIM to PaulBailey@ltbmw
Exclamation Cruise Control Malfunction

So yesterday after work i'm drown the freeway and try to use my Cruise Control as I do every time i'm doing freeway driving and all that shows up is ---
I know this happens if the DCT/DSC is off... But has anyone had it happen for no apparent reason?
About 10 minutes after repeatedly trying to get it to work an Error popped up on the iDrive screen saying Cruise Control Malfunction.
I'll attach a pic of what the symbol looks like.
Today when I got to work I tried to turn my car off, after pushing the button once the engine turns off and when I push it twice to completely turn off the car, the engine would turn right back on! This usually only happens when the brake is applied but for some reason this time it just kept restarting the engine... I do have comfort access, which is the reason I have to push the button twice to completely turn off the car as opposed to just pulling the key out.
I set up an appointment for tomorrow morning but just gauging to see how common this is because I've been on this forum for a while now and haven't heard of anyone else having this problem...
Starting to get a little sick of making service appointments for this car...
Hmm....



EDIT:
Just searched and realized others have been lucky enough to experience something like this.
this car <3
Attached Images
 
PaulBailey@ltbmw is offline   Italy
0
Reply With Quote
      04-26-2010, 08:14 PM   #2
BMWinNorthdakota
Banned
 
Drives: 2007 bmw 335i e90
Join Date: Jun 2009
Location: Fargo ND

Posts: 1,109
iTrader: (0)

Do you have a 6MT?

I have had something similar happen to my cruise. A simple depression of the clutch followed by a shift to neutral then back into gear mended the problem... I didnt think much of it...
BMWinNorthdakota is offline  
0
Reply With Quote
      04-26-2010, 08:23 PM   #3
Kevin Harney
Captain
 
Drives: 2009 335i Convertible
Join Date: Jan 2010
Location: Herndon, VA

Posts: 767
iTrader: (0)

I get the same 3 dashes if I am trying to set the cruise control before I get to the minimum speed. They are just telling that it can not set for some reason. Do you have Active Cruise? If so the sensor in front may need cleaning if it is seeing a smashed bug on there it might think you can not set it or something like that ?!?!?!?!
Kevin Harney is offline  
0
Reply With Quote
      04-26-2010, 08:56 PM   #4
chromisdesigns
Lieutenant Colonel
 
Drives: 2008 BMW 335i sedan
Join Date: Jan 2010
Location: San Francisco

Posts: 1,754
iTrader: (0)

Your brake (light) switch is broken. This is the switch that detects pedal pressure on the brake. If it isn't working, cruise will be screwed up, and given your description of the "restart" every time you push the button, it's probably stuck closed, so the car thinks you are stepping on the brake pedal.

I had one stick open on my old M3, and when THAT happens, when you step on the brake in cruise mode, the cruise control doesn't know it, and tries to speed the car up to compensate for the braking slowdown! Takes you by surprise for a few seconds, too -- step on the brake and the dang car speeds up!
chromisdesigns is offline  
0
Reply With Quote
      04-27-2010, 03:33 PM   #5
PaulBailey@ltbmw
General
 
PaulBailey@ltbmw's Avatar
 
Drives: 2-325 330 2-335 2-Z4 2-135 X5d
Join Date: Mar 2007
Location: Huntington Beach, CA

Posts: 26,758
iTrader: (34)

Garage List
Send a message via AIM to PaulBailey@ltbmw
Quote:
Originally Posted by chromisdesigns View Post
Your brake (light) switch is broken. This is the switch that detects pedal pressure on the brake. If it isn't working, cruise will be screwed up, and given your description of the "restart" every time you push the button, it's probably stuck closed, so the car thinks you are stepping on the brake pedal.

I had one stick open on my old M3, and when THAT happens, when you step on the brake in cruise mode, the cruise control doesn't know it, and tries to speed the car up to compensate for the braking slowdown! Takes you by surprise for a few seconds, too -- step on the brake and the dang car speeds up!
This makes perfect sense but...
I just got a call from my SA, who has traditionally been great, telling me that this was cause by aftermarket equipment... Something about wires wrapped around the brake pedal and them needing $160 to put it right.... The only thing I can think of the located around there is my boost gauge.
sounds like to me but we'll see.
PaulBailey@ltbmw is offline   Italy
0
Reply With Quote
      04-27-2010, 05:41 PM   #6
chromisdesigns
Lieutenant Colonel
 
Drives: 2008 BMW 335i sedan
Join Date: Jan 2010
Location: San Francisco

Posts: 1,754
iTrader: (0)

Could be the harness was loose from installing the boost gage, and wiring slipped down around pedal, insulation got worn, you have a short in the wiring to the brake switch. It would behave the same as a stuck closed switch.
chromisdesigns is offline  
0
Reply With Quote
Reply

Bookmarks

Tags
control, cruise, error, malfunction

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:10 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST