E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Guide to Reset the E90/E91/E92/E93 Service Indicator Lights



Reply
 
Thread Tools Search this Thread
      11-17-2011, 02:36 AM   #45
mapleridge
Banned
 
Drives: E90 N52 AT
Join Date: Apr 2011
Location: Vancouver, BC

Posts: 2,681
iTrader: (4)

did you hold the bc button to reset? I never saw the checkmark that appears after resetting.
mapleridge is offline  
0
Reply With Quote
      11-17-2011, 10:28 AM   #46
jaredlevy
Private First Class
 
Drives: 2006 325i
Join Date: Oct 2011
Location: Long Island, New York

Posts: 196
iTrader: (0)

Quote:
Originally Posted by mapleridge View Post
did you hold the bc button to reset? I never saw the checkmark that appears after resetting.
Yes I held it down until the blank dashes and micro filter icon came back on.
jaredlevy is offline  
0
Reply With Quote
      11-17-2011, 05:41 PM   #47
mapleridge
Banned
 
Drives: E90 N52 AT
Join Date: Apr 2011
Location: Vancouver, BC

Posts: 2,681
iTrader: (4)

at 1:13 in the op's video you see a check mark and the word reset. Did you get that when you tried to reset?
mapleridge is offline  
0
Reply With Quote
      11-17-2011, 06:16 PM   #48
jaredlevy
Private First Class
 
Drives: 2006 325i
Join Date: Oct 2011
Location: Long Island, New York

Posts: 196
iTrader: (0)

Quote:
Originally Posted by mapleridge View Post
at 1:13 in the op's video you see a check mark and the word reset. Did you get that when you tried to reset?

I did not get a check mark when I tried to reset. I would get the clock icon circling around (as if it was working), and then it would at the end go back to the dashes and the micro filter icon in yellow.
jaredlevy is offline  
0
Reply With Quote
      11-22-2011, 01:36 PM   #49
Modmike
Private First Class
 
Drives: BLack 2008 335i
Join Date: Apr 2010
Location: Montreal

Posts: 104
iTrader: (0)

Wil this reset the check engine light or is this only for service lights? (not sure if they are one and the same).

Also it seems that resetting the break wear indicators will mean you will need to change them prematurely. Is this correct? If that is the case you need to be really careful.

My check engine light is on because my daughter forgot to screw on the gas cap. Which option should I reset for this? I had a mechanic change the oil with oil purchased from BMW, should I assume I need to reset that as well?

Thanks.
__________________
2008 E90 335i Jet Black Black Dakota Brushed Aluminum
Steptronic Cold Premium Sport Comfort Nav Logic 7

How to import a BMW into Canada without getting rear ended
Modmike is offline  
0
Reply With Quote
      11-24-2011, 09:16 PM   #50
mrhud
Registered
 
Drives: 2007 BMW 323i
Join Date: Nov 2011
Location: Montreal, QC

Posts: 3
iTrader: (0)

Garage List
2007 BMW 323i  [0.00]
Thanks a lot Dimsum
mrhud is offline   Canada
0
Reply With Quote
      11-26-2011, 09:31 AM   #51
jaredlevy
Private First Class
 
Drives: 2006 325i
Join Date: Oct 2011
Location: Long Island, New York

Posts: 196
iTrader: (0)

Quote:
Originally Posted by jaredlevy View Post
I did not get a check mark when I tried to reset. I would get the clock icon circling around (as if it was working), and then it would at the end go back to the dashes and the micro filter icon in yellow.
Still having difficulty. Question...I have a dynavin installed. Is not having the stock HU hooked up to the car causing this error for me?
jaredlevy is offline  
0
Reply With Quote
      11-26-2011, 03:18 PM   #52
DimSum
Banned
 
Drives: SLOW
Join Date: May 2008
Location: LITTLEBIMMER.COM

Posts: 2,743
iTrader: (10)

Quote:
Originally Posted by jaredlevy View Post
Still having difficulty. Question...I have a dynavin installed. Is not having the stock HU hooked up to the car causing this error for me?
nope shouldn't be any problem...
DimSum is offline   Canada
0
Reply With Quote
      11-26-2011, 06:43 PM   #53
jaredlevy
Private First Class
 
Drives: 2006 325i
Join Date: Oct 2011
Location: Long Island, New York

Posts: 196
iTrader: (0)

Quote:
Originally Posted by DimSum View Post
nope shouldn't be any problem...
For the record, after ~4 weeks of trying the service reset, I manned up and put my stock headunit back into the car, did the reset, drove around. After about 2 miles the microfilter finally reset to 32000k.

For those with Dynavin units, please be aware of this.
jaredlevy is offline  
0
Reply With Quote
      12-28-2011, 12:03 AM   #54
matt33
Registered
 
Drives: 2011 328i Sedan/2001 Z3 2.5i
Join Date: Dec 2011
Location: Portland, OR

Posts: 1
iTrader: (0)

Oil Filter Cap Torque

Quote:
Originally Posted by azzurribaggio View Post
Awesome Blossom!!!!
Saved myself labor charges on my first out of warranty oil change for my 2006 E90!! BMW got smart and replaced the 27mm bolt for the oil filter and made the whole cap the top huh...bastards! Turnermotor sports has a tool to remove this for $26: http://www.turnermotorsport.com/p-13...lter-tool.aspx, anyone else sell it cheaper? Luckily I had a strap wrench, but how do you know how tight to close the oil filter top? I guess as long as there is no oil leaking from there then I'm good?
My 2011 came with a green mark on the side of the filter housing closest to the engine that crosses from the cap to the housing. I use the strap wrench to tighten until the mark on the cap lines back up with the housing. My mark appears to have been hand placed by a meticulous German, so no reason you can't put one on yourself or use blue painters tape each time if you don't want anything permanent.

You'll know if you went to tight next time you change the oil if it doesn't come off. You'll know it's too loose if oil blows out the front of your hood the first time you go up a steep hill with a warm engine.

And a big thanks to DimSum for the how to!
matt33 is offline  
0
Reply With Quote
      12-29-2011, 07:40 PM   #55
SneakyDeeky
Lieutenant Colonel
 
SneakyDeeky's Avatar
 
Drives: '07 E90 335i 6MT
Join Date: Feb 2011
Location: Redondo Beach, CA

Posts: 1,527
iTrader: (5)

Garage List
2007 BMW 335i E90  [4.85]
2014 Audi SQ5  [5.00]
Quote:
Originally Posted by Chriztofor View Post
You must change out the sensor. Did my rear brakes yesterday and it reset to 49000 miles.
+1 It's the sensors. Make sure you replace both front and rear. I thought I could get away with re-using them, but sure enough I got the service light (car on a red lift) when I tried to reset the service with the old sensors still installed. I bought new ones, installed them yesterday and the service light is gone.
__________________

6MT | FBO + E60 | Spec2+ | ER Dual Oil Coolers | 3.46 Wavetrac LSD | StopTech BBK | KW V1 | M3 Bits | Advan RS | LS3 AEs | Dyno Results | Pics
SneakyDeeky is offline   United_States
0
Reply With Quote
      12-30-2011, 12:26 PM   #56
misterba
Milan
 
misterba's Avatar
 
Drives: 2007 E90 328i
Join Date: Feb 2010
Location: Oceanside, California

Posts: 158
iTrader: (2)

Send a message via Skype™ to misterba
Quote:
Originally Posted by SneakyDeeky View Post
+1 It's the sensors. Make sure you replace both front and rear. I thought I could get away with re-using them, but sure enough I got the service light (car on a red lift) when I tried to reset the service with the old sensors still installed. I bought new ones, installed them yesterday and the service light is gone.
Haha. I did make same mistake, I've thought I can use old sensor after replacing front pads and now I'm driving with BRAKE warning on all the time. I had bought sensors for $15 from FCP, dealer wanted $33 for sensor and $3.50 for the metal clip. STEALERS. So within few days I will install rear pads and both sensors. Fortunately the brake job is the easiest on BMW, I did Hondas and other cars, BMW is the easiest. The sensors MUST be replaced when doing brake job.
misterba is offline   United_States
0
Reply With Quote
      04-10-2012, 12:45 PM   #57
hobo mofo
Lieutenant
 
Drives: 2007 325i e90
Join Date: Apr 2012
Location: London

Posts: 537
iTrader: (1)

Great guide! I just reset my service light after it came on less than 4k after its service.
hobo mofo is offline   England
0
Reply With Quote
      05-11-2012, 07:33 AM   #58
nelnelxd
Second Lieutenant
 
Drives: 328i
Join Date: Nov 2008
Location: brooklyn

Posts: 207
iTrader: (0)

Send a message via AIM to nelnelxd
i wanted to reset my sparkplugs since i jsut repalced them but the icon does not show up like it does in the video. I dont see the a/c one either. Does my car not have the option to reset these? It is an 2008 e90 328i

Last edited by nelnelxd; 05-11-2012 at 12:29 PM.
nelnelxd is offline   United_States
0
Reply With Quote
      04-01-2013, 07:14 AM   #59
phrozen06
NA V8
 
phrozen06's Avatar
 
Drives: 01 330ci, 08 M3 DCT, 08 VW R32
Join Date: Jan 2006
Location: 3927'33"N 7758'04"W W. Virgina, Kansas

Posts: 1,486
iTrader: (1)

worked perfect. thanks
__________________
phrozen06 is offline  
0
Reply With Quote
      04-02-2013, 06:40 AM   #60
sfin
New Member
 
Drives: e92 320d
Join Date: Mar 2013
Location: Ireland

Posts: 13
iTrader: (0)

Thanks!, just reset mine after pad replacement, seems to be a different procedure American Vs European.
sfin is offline  
0
Reply With Quote
      04-02-2013, 08:45 PM   #61
PA66400
Private First Class
 
Drives: 2008 335i Sedan
Join Date: Oct 2011
Location: Calgary, AB

Posts: 114
iTrader: (0)

Quote:
Originally Posted by nelnelxd View Post
i wanted to reset my sparkplugs since i jsut repalced them but the icon does not show up like it does in the video. I dont see the a/c one either. Does my car not have the option to reset these? It is an 2008 e90 328i
If your dealer has updated your DME software, the latest verion deletes these from the CBS indicator. I suspect it has something to do with no longer covering these in the future under the factory maintenance. Not sure, though.
PA66400 is offline   Canada
0
Reply With Quote
      04-21-2013, 03:26 AM   #62
Dazzaharv
Registered
 
Drives: E92 320i msport coupe
Join Date: Apr 2013
Location: Wigan

Posts: 1
iTrader: (0)

Hi
This reset didn't work on my uk e92 320 coupe

Anyone know the uk sequence ?
Cheers
Dazzaharv is offline  
0
Reply With Quote
      06-21-2013, 09:58 AM   #63
monstar3
New Member
 
Drives: BMW 323I
Join Date: Apr 2011
Location: Singapore

Posts: 16
iTrader: (0)

Am interested in euro rides sequence too...
Anyone??
monstar3 is offline  
0
Reply With Quote
      06-27-2013, 06:57 PM   #64
Jz
Colonel
 
Jz's Avatar
 
Drives: '08 E90 335i / '14 F10 535i
Join Date: Dec 2008
Location: Socal

Posts: 2,020
iTrader: (18)

this should be stickied
__________________
Jz is offline  
0
Reply With Quote
      08-24-2014, 05:00 PM   #65
AndyW
Captain Slow
 
AndyW's Avatar
 
Drives: 2008 335i Convertible
Join Date: Feb 2012
Location: Georgia

Posts: 87
iTrader: (0)

Thx for this but it doesn't work for my 2008 E93. I get the "car on a lift" symbol(which I think is the inspection interval) but the stalk operations do nothing. and pressing the BC button does nothing to reset the service inspection interval either. I recall I did this last year when I did my brakes but for the life of me I cannot figure out why it isn't working now. The only difference I can think of is that this is a different key because the other one was lost. Thx for any help anyone can provide.

EDIT: Nervermind. I am an idiot. Figured out what I was doing wrong.
__________________
Best,

Andy


Last edited by AndyW; 08-24-2014 at 05:17 PM. Reason: Stupidity
AndyW is offline   United_States
0
Reply With Quote
      08-27-2014, 11:09 AM   #66
stL325
New Member
 
Drives: 2006 325i 6MT
Join Date: Oct 2013
Location: St.Louis, MO

Posts: 10
iTrader: (1)

I have had that red tire pressure light after I upgraded from my stock wheels to the sport package wheels. (My car is a 2006, no TPMS). Tried resetting the light with the method above and it didn't work..any ideas? I know my tires are not losing pressure
stL325 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:04 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST