E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > "Service Engine Soon" warning light -- what could it be?



Reply
 
Thread Tools Search this Thread
      10-07-2008, 11:58 AM   #1
skim7x
Use it or Lose it
 
skim7x's Avatar
 
Drives: 335i e92
Join Date: Sep 2006
Location: Clifton, NJ

Posts: 2,461
iTrader: (4)

Garage List
2007 335i  [5.00]
"Service Engine Soon" warning light -- what could it be?

Hey guys,

Yesterday, out of nowhere, my "Service Engine Soon" light came up on my dash. I have a 335i coupe with the Dinan Flash Stage II.

Anyone know what the 3-4 most common causes of a "Service Engine Soon" light to be triggered? Anyone with this experience?

I have an appointment scheduled for Thursday, but just wanted to get some feedback before I go in... just in case I shouldn't be driving with the warning light on.

Thanks!
__________________
'07 Space Gray 335i coupe w/ Sports Package | Comfort Access

Cobb S1+ | PTF e30 custom tune | AMS | CP-e | BMS OCC | Quaife
[Newark Photoshoot #1]
skim7x is offline   United_States
0
Reply With Quote
      10-07-2008, 01:53 PM   #2
Socom
Major General
 
Drives: 2010 335D
Join Date: May 2005
Location: Atl.

Posts: 5,189
iTrader: (0)

BMWNA detected a mod on your car var the key fob and is requesting you come in so they can take a picture of you and the car for their "Mod of Shame"
Socom is offline  
0
Reply With Quote
      10-07-2008, 01:59 PM   #3
skim7x
Use it or Lose it
 
skim7x's Avatar
 
Drives: 335i e92
Join Date: Sep 2006
Location: Clifton, NJ

Posts: 2,461
iTrader: (4)

Garage List
2007 335i  [5.00]
^ur hilarious

...
__________________
'07 Space Gray 335i coupe w/ Sports Package | Comfort Access

Cobb S1+ | PTF e30 custom tune | AMS | CP-e | BMS OCC | Quaife
[Newark Photoshoot #1]
skim7x is offline   United_States
0
Reply With Quote
      10-07-2008, 02:11 PM   #4
Richwm
Captain
 
Richwm's Avatar
 
Drives: 06 E90 330i 6MT, 01 E46 330i
Join Date: May 2006
Location: Canyon Country, CA.

Posts: 870
iTrader: (0)

Garage List
Maybe a loose Gas cap.
__________________
Mar 05 Build date,2006 E90 330i, Sport Package, Premium Package, TR MT-1's . V-1 Hard-wired power with custom V-1 Concealment Display . Rear fogs, Rear power outlet's, M short shifter knob, BlackLines, BMW Strut tower bar, CDV Delete, M3 wishbones + tension struts, BMW Performance shocks and springs, BMW Performance Brake kit F&R, OEM short shift kit.
177K miles.
Richwm is offline   United_States
0
Reply With Quote
      10-07-2008, 02:14 PM   #5
skim7x
Use it or Lose it
 
skim7x's Avatar
 
Drives: 335i e92
Join Date: Sep 2006
Location: Clifton, NJ

Posts: 2,461
iTrader: (4)

Garage List
2007 335i  [5.00]
Quote:
Originally Posted by Richwm View Post
Maybe a loose Gas cap.
Yeah, the SA asked me about that... but I haven't filled up since last week and the warning just came on yesterday.

I'll be sure to check when I get back to the car later today...

Thanks
__________________
'07 Space Gray 335i coupe w/ Sports Package | Comfort Access

Cobb S1+ | PTF e30 custom tune | AMS | CP-e | BMS OCC | Quaife
[Newark Photoshoot #1]
skim7x is offline   United_States
0
Reply With Quote
      10-07-2008, 02:17 PM   #6
535desire
Private First Class
 
Drives: MB & VW diesels
Join Date: Dec 2007
Location: San Antonio, TX

Posts: 162
iTrader: (0)

doesn't "Service Engine Soon" just indicate that you are due for regular scheduled maintenance? Or is it a check engine light/MIL? If it is the latter, then you would need to scan for codes to determine whey the indicator came on.
535desire is offline  
0
Reply With Quote
      10-08-2008, 11:40 AM   #7
ENINTY
Banned
 
Drives: 2006 325i Sport
Join Date: Jun 2006
Location: Virginia

Posts: 3,415
iTrader: (0)

Quote:
Originally Posted by Richwm View Post
Maybe a loose Gas cap.
It's not the gas cap. There is a icon that comes up if the gas cap is loose. It looks like a giant light bulb above the right fender. The SEL is probaly a misfire or something. Have the dealer check it. Dinan shouldn't void the warranty.
ENINTY is offline  
0
Reply With Quote
      10-08-2008, 11:45 AM   #8
skim7x
Use it or Lose it
 
skim7x's Avatar
 
Drives: 335i e92
Join Date: Sep 2006
Location: Clifton, NJ

Posts: 2,461
iTrader: (4)

Garage List
2007 335i  [5.00]
So, after reading Richwm's reply and listening to my SA, I checked my gas cap yesterday evening, and it was locked in place... but I took it off and secured it back in place again just in case.

This morning, the SEL went away... whether this was because it was a misfire (as ENINTY said) or if my gascap was somehow loose or the gascap sensor failed to detect the gascap for some reason, I don't know...

well, it's fixed for now...

Thanks for the input, guys!
__________________
'07 Space Gray 335i coupe w/ Sports Package | Comfort Access

Cobb S1+ | PTF e30 custom tune | AMS | CP-e | BMS OCC | Quaife
[Newark Photoshoot #1]
skim7x is offline   United_States
0
Reply With Quote
      10-10-2008, 04:30 AM   #9
ENINTY
Banned
 
Drives: 2006 325i Sport
Join Date: Jun 2006
Location: Virginia

Posts: 3,415
iTrader: (0)

There are a lot of codes that will reset after a few dirve cycles. I misfire will reset. If the gas cap was loose you'd get the icon is spoke about. Last summer a mouse chew a hole in one of the vapor canister lines, which triggered the gas cap icon on my car . The '06 manual does not show what the icon looks like; it only mentions it.
ENINTY is offline  
0
Reply With Quote
      07-18-2009, 10:04 PM   #10
GrandMaster_B
-
 
GrandMaster_B's Avatar
 
Drives: '10 E90 335i
Join Date: Oct 2008
Location: Philly

Posts: 58
iTrader: (0)

I'd take it in anyway. The first time me SES light came on and went off by itself, I thought nothing of it. Turned out to be some serious misfiring. Better off getting it checked out. It should save any codes it threw.
__________________
'10 E90 335i / Le Mans / Saddle / Aluminum / 6MT / M Sport / Premium / Navigation / Logic7 / Heated Seats
GrandMaster_B is offline   United_States
0
Reply With Quote
      07-19-2009, 11:05 AM   #11
ron1
Registered
 
Drives: 335i coupe
Join Date: Jul 2009
Location: maryland

Posts: 1
iTrader: (0)

i have the same problem came up i have no mods done (e92 335i coupe) . mine is worse my whole engine ratles and shakes and when i try to give a gas power comes after some delay and fellowed by thick smoke from car pipes can't drive it have to tow it to dealer i will know by tommrow whats worng hopefully . but you guyz have any idea what it should be.
ron1 is offline  
0
Reply With Quote
      07-19-2009, 11:32 AM   #12
jmd_forest
Enlisted Member
 
Drives: 2008 328xi
Join Date: Jun 2009
Location: South NJ

Posts: 45
iTrader: (0)

Service engine soon?

Mine came on due to exceeding the coolant input temp threshold (92 degrees I believe), but not classic overheating. Can't quite figure out why its running too warm. May be just the sensor, may be the fan is not coming on soon enough. Thermo is new.

jmd_forest
jmd_forest is offline  
0
Reply With Quote
      10-06-2009, 09:52 AM   #13
javier33
Registered
 
Drives: 06 E90 Sedan 325i
Join Date: Oct 2009
Location: Maryland

Posts: 1
iTrader: (0)

e90 sedan hesitating under accelertionw/ SES light

did anyone ever find out the issue when the SES light is on and there is misfiring occurring? I have a 2006 325i that had slight mis firing yesterday and this morning. I filled up the tank with 93 octane and immediately it got worse. I jumped on the highway and the SES light came on along with serious misfiring/vibration under acceleration only. Car has 48k miles and has been serviced regularly. I stopped at the parts store and put 2 bottles of drygas and a bottle of Techron FI cleaner, but to no avail. I also removed the gas gap and put it back making sure it is secure. any ideas would be greatly appreciated.
javier33 is offline  
0
Reply With Quote
      05-25-2010, 08:30 AM   #14
thefox456
New Member
 
Drives: M3 E93
Join Date: Feb 2008
Location: CASABLANCA

Posts: 16
iTrader: (0)

I had the same thing with my e92 335i and the solution is check your 6 sparks and you probably need to change them, that will fix the problem and nore engine service soon light believe me.
thefox456 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:18 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST