E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Stuttering, Misfiring, Stumbling--Fixed!



Reply
 
Thread Tools Search this Thread
      07-18-2010, 08:34 PM   #45
lawwailok
Lieutenant Colonel
 
lawwailok's Avatar
 
Drives: E90 335i, E70 X5
Join Date: Aug 2009
Location: Sacramento, CA

Posts: 1,917
iTrader: (18)

Garage List
man, it's so hot to step out under the sun at 105F, but i just cranked it up, no strange idle, no warning lights or nothing... so i guess it's good to go... thanks for the help guys

edit: just scanned, came out some weird throttle plate error code and the butterfly valve code from BT, cleared them, all good now
but this is one good experience to me... really scare the shit out of me.. hahahaha
__________________
-eric
E90 335i TiAg *STOCK* see my garage for mod list..
E70 X5 SGM *try to stay stock* :/

Last edited by lawwailok; 07-18-2010 at 08:52 PM.
lawwailok is offline   United_States
0
Reply With Quote
      07-19-2010, 12:54 PM   #46
bkrM3
Major
 
bkrM3's Avatar
 
Drives: E90 M3
Join Date: Apr 2010
Location: Main Line

Posts: 1,380
iTrader: (9)

Garage List
2009 BMW M3  [4.75]
Quote:
Originally Posted by Jed View Post
My car is 100% stock and I've been having the same issues as you. Under WOT at low rpms in higher gears, I get the stuttering thing happening-past 2.5K rpms it's fine.

Brought it in for the dealership to look at and now it's stumbling at higher rpms. This afternoon, I was on the highway and passed someone and the SES light comes on and the motor's shaking at 3K rpms. I downshift so that I am at 4K and it's smoother.

Decided to bring it to the dealer and when I got to a stoplight, engine smoothed out and the SES light went off.

ARGH!!!! Hopefully they can get this resolved. I got my car brand new and it's now got ~74K miles and I've had no real issues with this car with the exception of wastegate rattle (had turbos replaced)!
I know this is somewhat tangential for this thread since the OP was discussing resets by BT and troubleshooting while tuned - however, I just wanted to chime in quickly. My car had been doing this exact thing - low RPMs, high boost, stutter, stutter SES light...crazy vibration, then eventually SES goes off by itself. Today I took it into the dealer and I got it to do it just before pulling in - drove into the service bay with a really obvious misfire. Got my SA to take a ride with me and the SES light stayed on the whole time (so maybe this actually gets worse after you make it do it 15 times like I have...). Car is at the dealer now and I have a 535 GT loaner (ugly looking thing, but nice to drive...).

Before this weird SES problem my car has been bone stock (although I had a DCI on for like a week and removed it when this stupid problem started happening - definitely not related to the DCI, it turns out) and has had all injectors changed, plugs changed, coils changed. Last week the dealer tried to address SES thing but read a VANOS code, "fixed" that, then gave it back to me without testing the SES issue I reported at full operating temperature. Will keep you guys posted on how (err....if...) they fix it.
__________________
E90 M3 Space/Fox/6MT
E92 335i BSM/Saddle/6MT - Sold
bkrM3 is offline   United_States
0
Reply With Quote
      07-19-2010, 03:52 PM   #47
Jed
IN THE KNOW!!!!!!!
 
Jed's Avatar
 
Drives: 1994 E36 325is; 2007 E92 335i
Join Date: Dec 2006
Location: MD

Posts: 428
iTrader: (1)

Quote:
Originally Posted by joec500 View Post
Mine does the same thing, but very intermittently, let me know your findings. Also did you try pulling your codes? Because when I get home to pull the codes none exist. Both Shadow and normal codes....strange stuff
Quote:
Originally Posted by bkr335 View Post
I know this is somewhat tangential for this thread since the OP was discussing resets by BT and troubleshooting while tuned - however, I just wanted to chime in quickly. My car had been doing this exact thing - low RPMs, high boost, stutter, stutter SES light...crazy vibration, then eventually SES goes off by itself. Today I took it into the dealer and I got it to do it just before pulling in - drove into the service bay with a really obvious misfire. Got my SA to take a ride with me and the SES light stayed on the whole time (so maybe this actually gets worse after you make it do it 15 times like I have...). Car is at the dealer now and I have a 535 GT loaner (ugly looking thing, but nice to drive...).

Before this weird SES problem my car has been bone stock (although I had a DCI on for like a week and removed it when this stupid problem started happening - definitely not related to the DCI, it turns out) and has had all injectors changed, plugs changed, coils changed. Last week the dealer tried to address SES thing but read a VANOS code, "fixed" that, then gave it back to me without testing the SES issue I reported at full operating temperature. Will keep you guys posted on how (err....if...) they fix it.
Dealer just called me-my car is ready. According to the SA, it was the low pressure fuel pump.

I'll be picking it up in an hour and see if these symptoms are gone.

And bkr335? Not a fan of the 535GT? Try rocking a 128i convertible with an automatic... I would've rather had the E91 328i.
__________________

2007 Jet Black 335i Coupe: Saddle Brown interior | ZSP | ZCP | ZPP | iPod integration.
1994 Hellrot 325is: Sport Package | PSS9 Coilover | AutoThority chip | AutoThority CF Intake | UUC pullies | Dinan HiFlo Throttle Body | UUC StrutBarbarian | UUC Evo II SSK | BMW Motorsports X Brace | Rogue Engineering DMS exhaust | Kumho Ecsta V700 R Comps |
Jed is offline   United_States
0
Reply With Quote
      07-19-2010, 04:00 PM   #48
bkrM3
Major
 
bkrM3's Avatar
 
Drives: E90 M3
Join Date: Apr 2010
Location: Main Line

Posts: 1,380
iTrader: (9)

Garage List
2009 BMW M3  [4.75]
Quote:
Originally Posted by Jed View Post
Dealer just called me-my car is ready. According to the SA, it was the low pressure fuel pump.

I'll be picking it up in an hour and see if these symptoms are gone.

And bkr335? Not a fan of the 535GT? Try rocking a 128i convertible with an automatic... I would've rather had the E91 328i.
Ha - don't get me wrong, the 535GT is great to drive, but the looks of it haven't yet grown on me (not sure they will). I just got a call from my SA, who says they found a bad coil. Why a bad coil would act up only at full temp, and only at low RPM/high boost is beyond me.

To me it felt much more like a fuel pump problem when it was happening. They're keeping mine overnight to let the shop manager drive it home and back to test it.

And re: loaners....trust me I know your agony - I felt lucky to get the GT today, I usually get a non-sport 328i convertible. Yuck.
__________________
E90 M3 Space/Fox/6MT
E92 335i BSM/Saddle/6MT - Sold
bkrM3 is offline   United_States
0
Reply With Quote
      07-19-2010, 04:17 PM   #49
Jed
IN THE KNOW!!!!!!!
 
Jed's Avatar
 
Drives: 1994 E36 325is; 2007 E92 335i
Join Date: Dec 2006
Location: MD

Posts: 428
iTrader: (1)

Yeah, that's strange that there are 2 different explanations for similar conditions. I guess I'll find out shortly what the deal is...

EDIT: Update. SA just called me back and said that when they just road tested the car, the issue came back again-replacing the LPFP didn't fix it. So they are keeping it for another day.

I might have to start driving the E36 again.
__________________

2007 Jet Black 335i Coupe: Saddle Brown interior | ZSP | ZCP | ZPP | iPod integration.
1994 Hellrot 325is: Sport Package | PSS9 Coilover | AutoThority chip | AutoThority CF Intake | UUC pullies | Dinan HiFlo Throttle Body | UUC StrutBarbarian | UUC Evo II SSK | BMW Motorsports X Brace | Rogue Engineering DMS exhaust | Kumho Ecsta V700 R Comps |
Jed is offline   United_States
0
Reply With Quote
      07-19-2010, 11:38 PM   #50
addicted2drums
Second Lieutenant
 
addicted2drums's Avatar
 
Drives: e90
Join Date: Apr 2008
Location: California

Posts: 213
iTrader: (1)

if you disconnect the battery will it do the same thing as you are doing with the scanner?
__________________
"No matter what side of the argument you are on, you always find people on your side you wish were on the other." - Jascha Heifetz
addicted2drums is offline   United_States
0
Reply With Quote
      07-20-2010, 03:29 AM   #51
lawwailok
Lieutenant Colonel
 
lawwailok's Avatar
 
Drives: E90 335i, E70 X5
Join Date: Aug 2009
Location: Sacramento, CA

Posts: 1,917
iTrader: (18)

Garage List
Quote:
Originally Posted by lawwailok View Post
man, it's so hot to step out under the sun at 105F, but i just cranked it up, no strange idle, no warning lights or nothing... so i guess it's good to go... thanks for the help guys

edit: just scanned, came out some weird throttle plate error code and the butterfly valve code from BT, cleared them, all good now
but this is one good experience to me... really scare the shit out of me.. hahahaha
from my previous post, today i drove the car long enough, obviously it doesn't help the idle problem.. next i'll give the plugs a try........ man... that shudder really annoys me....
__________________
-eric
E90 335i TiAg *STOCK* see my garage for mod list..
E70 X5 SGM *try to stay stock* :/
lawwailok is offline   United_States
0
Reply With Quote
      07-20-2010, 07:39 AM   #52
bkrM3
Major
 
bkrM3's Avatar
 
Drives: E90 M3
Join Date: Apr 2010
Location: Main Line

Posts: 1,380
iTrader: (9)

Garage List
2009 BMW M3  [4.75]
Quote:
Originally Posted by Jed View Post
Yeah, that's strange that there are 2 different explanations for similar conditions. I guess I'll find out shortly what the deal is...

EDIT: Update. SA just called me back and said that when they just road tested the car, the issue came back again-replacing the LPFP didn't fix it. So they are keeping it for another day.

I might have to start driving the E36 again.
Your SA should coordinate with my SA hahaha. No word yet on whether mine is fixed, but I'm going to "road test" it myself pretty thoroughly before I leave the vicinity of the dealer...To my knowledge, they've only changed the "bad" coil so far. Will keep you posted


*****EDIT******
Picked up car - yesterday they told me it was a bad coil but today my documentation read a bit different: "Check engine light on - Fault 29CE misfire cylinder 2; Ran test plan, says to program vehicle - also followed bulletin 120610. Programmed vehicle per test plan. Swapped injector 2 to 5 and replaced seals per bulletin."

Parts - 2x part number 13-53-7-584-315 - Gasket Ring

I tested the hell out of it. Full temp (a whisker under 250), gears 3, 4, 5 and 6 from various low RPMs. Problem *seems* to be fixed.
__________________
E90 M3 Space/Fox/6MT
E92 335i BSM/Saddle/6MT - Sold

Last edited by bkrM3; 07-20-2010 at 03:11 PM.
bkrM3 is offline   United_States
0
Reply With Quote
      07-20-2010, 05:14 PM   #53
Jed
IN THE KNOW!!!!!!!
 
Jed's Avatar
 
Drives: 1994 E36 325is; 2007 E92 335i
Join Date: Dec 2006
Location: MD

Posts: 428
iTrader: (1)

Quote:
Originally Posted by bkr335 View Post
Your SA should coordinate with my SA hahaha. No word yet on whether mine is fixed, but I'm going to "road test" it myself pretty thoroughly before I leave the vicinity of the dealer...To my knowledge, they've only changed the "bad" coil so far. Will keep you posted


*****EDIT******
Picked up car - yesterday they told me it was a bad coil but today my documentation read a bit different: "Check engine light on - Fault 29CE misfire cylinder 2; Ran test plan, says to program vehicle - also followed bulletin 120610. Programmed vehicle per test plan. Swapped injector 2 to 5 and replaced seals per bulletin."

Parts - 2x part number 13-53-7-584-315 - Gasket Ring

I tested the hell out of it. Full temp (a whisker under 250), gears 3, 4, 5 and 6 from various low RPMs. Problem *seems* to be fixed.
Sounds like I may be going down the same path with the injectors. SA called me and confirmed that replacing the LPFP didn't do anything-it was still misfiring. So tomorrow, they're going to look at the injectors.

Glad your situation worked out! No more 535 GT!
__________________

2007 Jet Black 335i Coupe: Saddle Brown interior | ZSP | ZCP | ZPP | iPod integration.
1994 Hellrot 325is: Sport Package | PSS9 Coilover | AutoThority chip | AutoThority CF Intake | UUC pullies | Dinan HiFlo Throttle Body | UUC StrutBarbarian | UUC Evo II SSK | BMW Motorsports X Brace | Rogue Engineering DMS exhaust | Kumho Ecsta V700 R Comps |
Jed is offline   United_States
0
Reply With Quote
      07-20-2010, 05:21 PM   #54
bkrM3
Major
 
bkrM3's Avatar
 
Drives: E90 M3
Join Date: Apr 2010
Location: Main Line

Posts: 1,380
iTrader: (9)

Garage List
2009 BMW M3  [4.75]
FYI - http://www.bmwtis.com/tsb/bulletins/...p/B120610g.htm

July 2010 TSB - N54 - Misfire Faults, Diagnosis with ISTA D
__________________
E90 M3 Space/Fox/6MT
E92 335i BSM/Saddle/6MT - Sold
bkrM3 is offline   United_States
0
Reply With Quote
      07-20-2010, 06:19 PM   #55
joec500
Brigadier General
 
Drives: it has 4 wheels
Join Date: Jul 2008
Location: San Francisco

Posts: 3,004
iTrader: (10)

Quote:
Originally Posted by bkr335 View Post
FYI - http://www.bmwtis.com/tsb/bulletins/...p/B120610g.htm

July 2010 TSB - N54 - Misfire Faults, Diagnosis with ISTA D
Nice to see the updated Diag Tree...I love the note about modded cars.
joec500 is offline  
0
Reply With Quote
      07-20-2010, 06:31 PM   #56
lawwailok
Lieutenant Colonel
 
lawwailok's Avatar
 
Drives: E90 335i, E70 X5
Join Date: Aug 2009
Location: Sacramento, CA

Posts: 1,917
iTrader: (18)

Garage List
Quote:
Originally Posted by joec500 View Post
Nice to see the updated Diag Tree...I love the note about modded cars.
LOL, that's really sucks. what if the owner has PE but no prove of installed by a bmw dealer?
__________________
-eric
E90 335i TiAg *STOCK* see my garage for mod list..
E70 X5 SGM *try to stay stock* :/
lawwailok is offline   United_States
0
Reply With Quote
      07-20-2010, 06:45 PM   #57
joec500
Brigadier General
 
Drives: it has 4 wheels
Join Date: Jul 2008
Location: San Francisco

Posts: 3,004
iTrader: (10)

Quote:
Originally Posted by lawwailok View Post
LOL, that's really sucks. what if the owner has PE but no prove of installed by a bmw dealer?
Considering if you have to get the DME coded for the PE kit, this data would be entered in the National BMW system. I don't think an independent shop can encode the DME for the PE kit.
joec500 is offline  
0
Reply With Quote
      07-20-2010, 08:27 PM   #58
lawwailok
Lieutenant Colonel
 
lawwailok's Avatar
 
Drives: E90 335i, E70 X5
Join Date: Aug 2009
Location: Sacramento, CA

Posts: 1,917
iTrader: (18)

Garage List
Quote:
Originally Posted by joec500 View Post
Considering if you have to get the DME coded for the PE kit, this data would be entered in the National BMW system. I don't think an independent shop can encode the DME for the PE kit.
i mean the performance exhaust
__________________
-eric
E90 335i TiAg *STOCK* see my garage for mod list..
E70 X5 SGM *try to stay stock* :/
lawwailok is offline   United_States
0
Reply With Quote
      07-20-2010, 10:19 PM   #59
joec500
Brigadier General
 
Drives: it has 4 wheels
Join Date: Jul 2008
Location: San Francisco

Posts: 3,004
iTrader: (10)

Quote:
Originally Posted by lawwailok View Post
i mean the performance exhaust
Ahhh got it..my bad
joec500 is offline  
0
Reply With Quote
      07-22-2010, 04:13 PM   #60
Jed
IN THE KNOW!!!!!!!
 
Jed's Avatar
 
Drives: 1994 E36 325is; 2007 E92 335i
Join Date: Dec 2006
Location: MD

Posts: 428
iTrader: (1)

Quote:
Originally Posted by Jed View Post
Sounds like I may be going down the same path with the injectors. SA called me and confirmed that replacing the LPFP didn't do anything-it was still misfiring. So tomorrow, they're going to look at the injectors.

Glad your situation worked out! No more 535 GT!
Hmmmm... Techs have ruled out the injectors and now are doing a carbon buildup clean out to see if that's what causing it. Ugh!
__________________

2007 Jet Black 335i Coupe: Saddle Brown interior | ZSP | ZCP | ZPP | iPod integration.
1994 Hellrot 325is: Sport Package | PSS9 Coilover | AutoThority chip | AutoThority CF Intake | UUC pullies | Dinan HiFlo Throttle Body | UUC StrutBarbarian | UUC Evo II SSK | BMW Motorsports X Brace | Rogue Engineering DMS exhaust | Kumho Ecsta V700 R Comps |
Jed is offline   United_States
0
Reply With Quote
      07-22-2010, 04:18 PM   #61
bkrM3
Major
 
bkrM3's Avatar
 
Drives: E90 M3
Join Date: Apr 2010
Location: Main Line

Posts: 1,380
iTrader: (9)

Garage List
2009 BMW M3  [4.75]
Quote:
Originally Posted by Jed View Post
Hmmmm... Techs have ruled out the injectors and now are doing a carbon buildup clean out to see if that's what causing it. Ugh!
Hey - at least they're trying to fix the problem and not trying to tell you it was VANOS sticking!

Hope they figure it out soon - keep us updated. This is a great thread I think because there are so many odd glitches with the N54 and most threads just get destroyed by people going "ohhhh! sounds like HPFP to me!"
__________________
E90 M3 Space/Fox/6MT
E92 335i BSM/Saddle/6MT - Sold
bkrM3 is offline   United_States
0
Reply With Quote
      07-23-2010, 12:29 AM   #62
lawwailok
Lieutenant Colonel
 
lawwailok's Avatar
 
Drives: E90 335i, E70 X5
Join Date: Aug 2009
Location: Sacramento, CA

Posts: 1,917
iTrader: (18)

Garage List
i think i did the reset right this time, while the car is running, and obviously each reset took a while to finish in order to proceed to another one, so far a 20 mins driving and testing it out, no stumbling, and each traffic light i stopped, the idle seems pretty sweet, no studder or vibrate so far. i'll give it a few more days to see.
__________________
-eric
E90 335i TiAg *STOCK* see my garage for mod list..
E70 X5 SGM *try to stay stock* :/
lawwailok is offline   United_States
0
Reply With Quote
      07-23-2010, 07:45 PM   #63
markham335i
Lieutenant
 
markham335i's Avatar
 
Drives: 07 335i
Join Date: May 2010
Location: Toronto, Markham

Posts: 537
iTrader: (0)

thank you for the post mr. 5...

i have a small review.. i did exactly what the post told me to do and when i started the car for the first time i threw a throttle adjustment code and the car sounded horrrrrrrrrrrrrrrriiiiiiibbbbbbbble it sounded like it was coughing jumping rev spikes like crazy... i got scared and shut the car off... turned it back on and it happend again, so i shut the car off and plugged the scan tool cleared the code and rest it... and it started fine everything is ok just a small scare lol will edit post tomorrow after testing on a cold start!
__________________
Upgrades: <JB4, DCI, BMS downpipes, ER charge pipe, Forge DV, bbs ch-r, 30%tint all around, bmw performance exhaust, umnitza V4 angel eyes,Alpina Trans flash>.....Next upgrades (I would like):intercooler, BBK, turbo upgrade....etc....

Last edited by markham335i; 07-25-2010 at 08:23 PM.
markham335i is offline  
0
Reply With Quote
      08-07-2010, 03:21 PM   #64
ETS Michael
 
ETS Michael's Avatar
 
Drives: 335i
Join Date: May 2009
Location: Vancouver, WA

Posts: 1,160
iTrader: (4)

Send a message via AIM to ETS Michael
http://www.bmwtis.com/tsb/bulletins/...p/B120610g.htm

Sounds exactly like the problem i'm having. I can't wait to get my car back. Thanks for posting this up.
ETS Michael is offline   United_States
0
Reply With Quote
      08-07-2010, 03:28 PM   #65
joec500
Brigadier General
 
Drives: it has 4 wheels
Join Date: Jul 2008
Location: San Francisco

Posts: 3,004
iTrader: (10)

Mr.5 you should add this to your original post. I am not sure how necessary it is to follow this procedure after re-setting adaptations, but BMW probably noted this for a reason...

Readapting the DME by means of a short test drive is recommended:

* Bring the engine to the normal operating temperature.

* Drive the vehicle at a speed of between 50-60 mph and engine speeds of 2,000-3,000 rpm for approximately 3 minutes (use manual gear shifting, if needed).

* Let the engine idle for approximately 5 minutes.
joec500 is offline  
0
Reply With Quote
      09-07-2010, 05:34 PM   #66
AltecBX
Colonel
 
AltecBX's Avatar
 
Drives: BMW 335xi Sedan
Join Date: Nov 2007
Location: NYC

Posts: 2,636
iTrader: (0)

Very good info here.
__________________
335xi Sedan 6AT | Weather(70-85°F) | N54 Tune Comparison Chart || N54 Turbo Upgrade Comparison Chart
-PROcede Rev. 2.5 ~ v5 (3/17 maps) / JB4 (8/21 maps) / COBB (Stg2+FMIC LT Aggressive maps)
†Procede Map2(UT 45 - IGN 40) Aggression Target 2.0 | 0-60 in 4.0sec || †Cobb E30 LT (35% Ethanol/65% 93 Octane) | 0-60 in 3.9sec
AR Design Catless DP | BMS DCI + OCC | ETS 5 FMIC | Alpina B3 Trans Flash |235/265 19" Michelin PSS
AltecBX is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:32 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST