E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Wash, Wax, Detailing and Cosmetic protection/repairs > rust spots on wheels



Reply
 
Thread Tools Search this Thread
      05-01-2010, 07:36 PM   #1
brocklanders
Captain
 
brocklanders's Avatar
 
Drives: the uno, mineral white
Join Date: Mar 2010
Location: houston

Posts: 937
iTrader: (1)

Garage List
06 325  [0.00]
rust spots on wheels

i have breytons with polished lips, so i had bought meguiars hot rims mag and aluminum polish, and a mothers cone polishing pad for a drill. i have applied this twice so far and it really makes the lips shine, but today as i was washing my car i noticed tiny rust spots on the lips. this stuff says good on all metals but do not use on clearcoat, my wheels are matte black with polished lips and i dont think there is any clearcoat on them at all. some expert advice would be appreciated, do you think the buffer pad is too corse or the polish is tearing up the metal.
brocklanders is offline  
0
Reply With Quote
      05-19-2010, 01:08 AM   #2
e92sf
Second Lieutenant
 
Drives: E92 space grey stock
Join Date: Aug 2009
Location: San Francisco

Posts: 198
iTrader: (5)

bump!

Im in the same boat as you. Got some matte black VMR rims with a chrome lip. I apply mothers chrome wax on it and it shines but there seems to be some swirl marks and little rust here and there.

For some reason the matte black on the spokes, looks like it has dried water marks on it, after I dry them with a cloth. I really don't know why it looks like that up close, but far away you can't really tell. Do you have that same issue as well?

Some expert advice would be great!
e92sf is offline  
0
Reply With Quote
      05-19-2010, 06:58 AM   #3
zaxjax
Major
 
Drives: 2008 Crimson Red 335i
Join Date: Sep 2008
Location: Annapolis

Posts: 1,210
iTrader: (2)

Garage List
2008 335i  [4.50]
NevrDull wadding polish works really well.

It may not be rust but fallout
__________________
zaxjax is offline  
0
Reply With Quote
      05-21-2010, 05:36 PM   #4
Kroon78
New Member
 
Kroon78's Avatar
 
Drives: 2007 335i
Join Date: Jan 2010
Location: Delaware

Posts: 20
iTrader: (0)

I swear I was about to say the same thing! Seriously!
Kroon78 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:19 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST