E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Failing Bluetooth interface?



Reply
 
Thread Tools Search this Thread
      03-24-2010, 12:34 AM   #1
andy92782
Private First Class
andy92782's Avatar
United_States
2
Rep
156
Posts

 
Drives: '07 335i, '04 4Runner 4x4 V8
Join Date: Feb 2007
Location: OC, CA

iTrader: (0)

Failing Bluetooth interface?

More and more lately every time I make or receive a call via Bluetooth in my car, the audio quality has a ton of static. It's as if voices cut in and out. The caller on the other end complains about the same from my voice. It didn't used to be like this; it's as if the performance of the Bluetooth module is deteriorating over time. It's not specific to my particular phone or my phone company either. You can pair another phone to the car and it will sound lousy as well, even with full signal strength. Anyone else noticed this or had to have the BT module replaced under warranty?
Appreciate 0
      03-24-2010, 11:18 AM   #2
deanmc
Captain
deanmc's Avatar
United_States
24
Rep
877
Posts

 
Drives: 2006 325i
Join Date: Jun 2009
Location: Orange County, CA

iTrader: (15)

Garage List
2006 325i  [5.00]
That's the EXACT same problem that I've been having. Mine's gotten so bad that if I move the phone around the cabin, it'll lost bluetooth connection.

It's most likely the Bluetooth TCU in the trunk. When I was testing mine out, I put the phone in the trunk right next to the TCU unit, got back in the car, and was able to make crystal clear calls. My guess is that you have the same issue. I'm taking it in for service next week at Irvine BMW, so hopefully it'll get resolved.

I'm guessing your BMW assist isn't working either, then?
Appreciate 0
      03-24-2010, 07:04 PM   #3
andy92782
Private First Class
andy92782's Avatar
United_States
2
Rep
156
Posts

 
Drives: '07 335i, '04 4Runner 4x4 V8
Join Date: Feb 2007
Location: OC, CA

iTrader: (0)

Let me know what the outcome is from your dealer visit. I never use BMW Assist so I wouldn't know about that, but I use the Bluetooth phone function all the time and it's almost unusable now!
Appreciate 0
      03-24-2010, 07:34 PM   #4
deanmc
Captain
deanmc's Avatar
United_States
24
Rep
877
Posts

 
Drives: 2006 325i
Join Date: Jun 2009
Location: Orange County, CA

iTrader: (15)

Garage List
2006 325i  [5.00]
I'll keep you posted!
Appreciate 0
      03-26-2010, 02:57 AM   #5
vadim
Lieutenant
vadim's Avatar
United_States
5
Rep
425
Posts

 
Drives: '08 E92 335i MT
Join Date: Nov 2007
Location: Ashburn, VA

iTrader: (0)

Quote:
Originally Posted by deanmc View Post
That's the EXACT same problem that I've been having. Mine's gotten so bad that if I move the phone around the cabin, it'll lost bluetooth connection.

It's most likely the Bluetooth TCU in the trunk. When I was testing mine out, I put the phone in the trunk right next to the TCU unit, got back in the car, and was able to make crystal clear calls. My guess is that you have the same issue. I'm taking it in for service next week at Irvine BMW, so hopefully it'll get resolved.

I'm guessing your BMW assist isn't working either, then?
The TCU is in the trunk indeed, but the BT antenna is in the steering column area. So putting the phone in the trunk actually worsened the BT signal, if anything. There is no need to put the phone that close, anyway. You can have it anywhere inside the cabin.
__________________
vadim
'08 E92 335i MT / Space Gray / Coral Red / Aluminum / ZSP / ZPP / iPod+USB / Heated seats
+ OEM alarm / 330i SSK / M3 shifter knob / M-Tech steering wheel / BPS Motorsports aluminum pedals + M3 footrest/ RE 12mm spacers / Euro split-view mirrors / Manual rear shade
Appreciate 0
      03-26-2010, 04:14 AM   #6
sillygoat
Captain
20
Rep
794
Posts

 
Drives: 335i tiag
Join Date: May 2006
Location: las vegas, nv

iTrader: (11)

Send a message via AIM to sillygoat
Having the same problem sometimes. If u have an iPhone try putting the connection to the phone then back to Bluetooth and see if it clears up. My BMW assist doesn't work anymore when I press it, it just says connecting and never connects.
__________________
Appreciate 0
      03-26-2010, 08:14 AM   #7
lesliew
Private
0
Rep
69
Posts

 
Drives: E92 328i Sports+Premium
Join Date: Jan 2010
Location: FL

iTrader: (0)

The BT antenna is in the trim, just above the foot rest on the drivers side.
__________________
2007 328i Coupe Auto | Monaco Blue | Cream Dakota | Premium | Sports | CIC retrofit | 6FL Retrofit | Logic 7 Retrofit
Appreciate 0
      03-26-2010, 07:46 PM   #8
jimk
Captain
jimk's Avatar
United_States
11
Rep
735
Posts

 
Drives: 2011 E90 M3 M/T
Join Date: Jun 2009
Location: Denver, CO

iTrader: (5)

Quote:
Originally Posted by vadim View Post
The TCU is in the trunk indeed, but the BT antenna is in the steering column area. So putting the phone in the trunk actually worsened the BT signal, if anything. There is no need to put the phone that close, anyway. You can have it anywhere inside the cabin.
Right, that most likely means that the antenna or the antenna cable is bad.
__________________
Appreciate 0
      03-29-2010, 09:03 AM   #9
ydrive55
Private
ydrive55's Avatar
1
Rep
91
Posts

 
Drives: 2007 BMW 335i
Join Date: May 2009
Location: New York

iTrader: (1)

God!

I have been having the same problem with my Blue tooth since I upgraded to i Phone 3gs from the original. I am on Day 3 of my car in service and they will not upgrade the blue tooth programing claiming that there is no diagnosable problem.

GRRR....

Any thoughts?
Appreciate 0
      03-29-2010, 09:58 PM   #10
baltik
Lieutenant
7
Rep
407
Posts

 
Drives: porsche 944 turbo
Join Date: Dec 2006
Location: San Francisco

iTrader: (0)

I believe this is a known issue with latest iphone firmware...
Appreciate 0
      03-31-2010, 09:05 AM   #11
ydrive55
Private
ydrive55's Avatar
1
Rep
91
Posts

 
Drives: 2007 BMW 335i
Join Date: May 2009
Location: New York

iTrader: (1)

So I got my car back after 4 days in service and got the "it's a known issue with this version of the iPhone software."

Does anyone know of any workarounds until either BMW or Apple get off their butts and fix the issue?

I cannot believe that in a day where I can stream just about anything to my phone, that I cannot get the my car's blue-tooth to work with my phone?
Appreciate 0
      03-31-2010, 09:49 AM   #12
baltik
Lieutenant
7
Rep
407
Posts

 
Drives: porsche 944 turbo
Join Date: Dec 2006
Location: San Francisco

iTrader: (0)

only known way is to jailbreak your phone and roll it back 3 versions.. sucks I've been battling the same issues
Appreciate 0
      04-01-2010, 12:33 PM   #13
andy92782
Private First Class
andy92782's Avatar
United_States
2
Rep
156
Posts

 
Drives: '07 335i, '04 4Runner 4x4 V8
Join Date: Feb 2007
Location: OC, CA

iTrader: (0)

deanmc, any updates on this?

FYI, I have a Blackberry Curve 8330, not an iPhone. There were no firmware updates anywhere to anything, just steady degradation of the audio performance over time.

One other quirk I've noticed: while driving down the road minding my own business, the car/phone combo will suddenly mute the stereo and initiate a call to a random number in my phone book. WTF?!?! This has happened a couple times in recent months.
Appreciate 0
      04-01-2010, 01:29 PM   #14
deanmc
Captain
deanmc's Avatar
United_States
24
Rep
877
Posts

 
Drives: 2006 325i
Join Date: Jun 2009
Location: Orange County, CA

iTrader: (15)

Garage List
2006 325i  [5.00]
Andy, sorry, not yet. I was hoping to take my car in for service this week, but wasn't able to. I'll probably bring it in next week. BTW, I don't have an iphone either, so it's not a phone related problem.

What dealership to you usually go to for service?
Appreciate 0
      04-01-2010, 04:06 PM   #15
andy92782
Private First Class
andy92782's Avatar
United_States
2
Rep
156
Posts

 
Drives: '07 335i, '04 4Runner 4x4 V8
Join Date: Feb 2007
Location: OC, CA

iTrader: (0)

Quote:
Originally Posted by deanmc View Post
Andy, sorry, not yet. I was hoping to take my car in for service this week, but wasn't able to. I'll probably bring it in next week. BTW, I don't have an iphone either, so it's not a phone related problem.

What dealership to you usually go to for service?
Cool, no problem. I've been taking my car to Crevier.
Appreciate 0
      04-01-2010, 10:03 PM   #16
rg87
Lieutenant
rg87's Avatar
16
Rep
498
Posts

 
Drives: E90
Join Date: Jun 2007
Location: Bay Area, CA

iTrader: (1)

i thought i was the only one with this problem! its driving me nuts!

my dad & i share the car... i have an iphone, my dad has a blackberry... the blackberry connects sometimes to the bluetooth in the car, but then the connection gets lost. the iphone doesn't pick up the bluetooth signal anymore.

if anyone gets an answer to this issue, would like to hear what happens! i need my bluetooth! lol
__________________
'06 E90 330I // 6spd // M3 Style Full Body Kit // Simota CF CAI // 19'' Avant Garde M368 // Bilstein PSS9
Appreciate 0
      04-03-2010, 09:37 AM   #17
tomtom
Captain
tomtom's Avatar
Canada
18
Rep
986
Posts

 
Drives: e92 335i
Join Date: Jan 2008
Location: ontario

iTrader: (4)

wasnt this addressed with this:

SI B 84 08 09
Communication Systems May 2009
Technical Service

SUBJECT
Telephone: Poor Voice Quality at Landside End


MODEL
E60, E61 (5 Series)

E63, E64 (6 Series)

E82, E88 (1 Series)

E90, E91, E92, E93 (3 Series)

F01, F02 (7 Series)

Vehicles produced from 2/28/07 to 2/27/09 equipped with ZPP (Premium Package) or SA 639 (BMW Assist™)


SITUATION
The person on the landline hears an echo and reverberation when the customer makes a hands-free call from the vehicle. The voice quality on the landline is generally poor (low volume or interference). This situation affects all phones except the Apple iPhone 3G. Refer to SI B84 04 09 for information about the Apple iPhone 3G.

CAUSE
A very sensitive audio algorithm in the TCU (Telematics Control Unit) has caused a signal overload. The interaction with other audio components results in the situation described above.

PROCEDURE
Perform diagnosis using ISTA, and work through any test modules for any related faults.

Program the vehicle with the latest version of ISTA/P. The problem was corrected with the release of ISTA/P 2.33.0. For information on programming and coding with ISTA/P, refer to CenterNet – Aftersales Portal – Service-Workshop Technology – Vehicle Programming.

WARRANTY INFORMATION
Covered under the terms of the BMW New Vehicle Limited Warranty.

Defect Code: 84 11 21 39 00

Labor Operation: Labor Allowance: Description:
Refer to KSD Refer to KSD Refer to KSD


For iPhone


SI B 84 04 09
Communication Systems June 2009
Technical Service

This Service Information bulletin supersedes SI B84 04 09 dated March 2009.

designates changes to this revision

SUBJECT
The Landside Person Finds the Caller Speaking from an iPhone 3G Hard to Understand


MODEL
E82, E88 (1 Series)

E90, E91, E92, E93 (3 Series)

E60, E61 (5 Series)

E63, E64 (6 Series)

F01, F02 (7 Series)

E70 (X5)

E71 (X6)

Vehicles produced from 2/28/07 to 8/30/09 equipped with ZPP (Premium Package) or SA 639 (BMW Assist™)


SITUATION
The person on the landside cannot hear the driver speaking, or can only hear him or her very faintly or poorly.

Sometimes the driver may only be heard intermittently. An Apple iPhone 3G with software 2.2 or 2.2.1 is used.

CAUSE
Apple iPhone software Bluetooth handling

PROCEDURE
Do not replace any parts or update the vehicle software.

Update the Apple iPhone software to OS 3.0 (available from Apple).

After the phone software update, it may be necessary to delete the iPhone paired to the vehicle and then pair it again, in order for the phone to operate properly.
Appreciate 0
      04-03-2010, 07:27 PM   #18
DJKhan85
Major
DJKhan85's Avatar
Trinidad_and_tobago
11
Rep
1,188
Posts

 
Drives: 2011 4dr 6mt Golf GTI
Join Date: Jun 2009
Location: Boston Massachusetts

iTrader: (1)

Takl about coincidence. My iPhone 3g AND blackBerry cure 8320 both stopped connecting to the car today. I did have an alignment done today........but they shouldn't have messed with any of this.
__________________
2011 VW GTI 4dr-6mt-Sunroof-Nav-Xenons
OLD:
08 335i AW/CR/Poplar 6mt-ZSP-ZPP-ZCW-iPod-iDrive-PDC-Style 230s w/FK 452-Dinan LSD
Appreciate 0
      04-07-2010, 09:17 AM   #19
ydrive55
Private
ydrive55's Avatar
1
Rep
91
Posts

 
Drives: 2007 BMW 335i
Join Date: May 2009
Location: New York

iTrader: (1)

So I heard back from my Service Adviser yesterday and they still have no fix for this issue. I BEGGED them to reprogram my TCU, but since the second part of that service bulletin says not to, they will not do it. So I am playing the waiting game.

I have called BMW customer support to register a complaint and suggest that any of users that are experiencing these issues do so, especially since the iphone 3gs is listed as one of the supported phones. I think the best bet is sending as much noise up the chain as possible, since the squeaky wheel always gets the oil, and having working in the retail automotive business for many years, I know that the factory does take these complaints seriously.

I am going to make yet anouther call today and just keep putting pressure on the issue until they resolve it.
Appreciate 0
      04-07-2010, 09:05 PM   #20
deanmc
Captain
deanmc's Avatar
United_States
24
Rep
877
Posts

 
Drives: 2006 325i
Join Date: Jun 2009
Location: Orange County, CA

iTrader: (15)

Garage List
2006 325i  [5.00]
YES!!!!

So I figured out what the problem was. You won't believe this, but turns out that the mechanic working on my car last time FORGOT TO PLUG THE BLUETOOTH ANTENNA BACK IN!

I didn't get a chance to take it in, but after reading the above post that the antenna was located somewhere near the steering column, I looked around on the internet and found out that the antenna is actually on the lower driver's side kick panel. The kick panel was easy to open, three torx screws, and lo and behold, the antenna was unplugged. I had a brake pedal and steering column issues the last time I took the car in, and I guess the @#$!@ guy working on my car forgot to plug the BT antenna back in when he reattached the panel.

I hope this is your fix too, Andy!

BTW, if you take the kick panel out, make sure you slide it back into the tab near the top by the accelerator side. Thanks for all your input, and good luck everyone.
Attached Images
 
Appreciate 0
      04-09-2010, 10:44 AM   #21
andy92782
Private First Class
andy92782's Avatar
United_States
2
Rep
156
Posts

 
Drives: '07 335i, '04 4Runner 4x4 V8
Join Date: Feb 2007
Location: OC, CA

iTrader: (0)

Great news, thanks for the update! I'll check the connector in my car although there was never any work done in and around the steering column so I don't have any reason to suspect it'll be loose... I have a feeling I'm going to wind up with one of those things that clips on the sun visor, just like the rest of the "unsophisticated masses". :P
Appreciate 0
      04-13-2010, 04:46 PM   #22
DazJ
New Member
0
Rep
13
Posts

 
Drives: E91 320D Le Mans Blue
Join Date: Feb 2010
Location: UK

iTrader: (0)

Bluetooth - when it pairs - sounds like a Dalek!

My car (E91) went in to have the rear load cover actuator replaced. Everything bluetooth wise working fine untill I pick it back up - now, my phone won't pair, neither will two others unless it is in the centre console pocket forward of the arm rest (this is the one position I've found) If it does manage to pair, it looses connection if moved, it has even shown some random device names on both the phone name and the BMW ##### device name. If when connected Itry to make a call, it's like a brief episode of Dr Who with the Daleks... So, does anyone know if the TCU? is near the right hand rear quarter panel area, does the antenna run from there on E91's? I seem to live at the dealer since owning the car, this is yet another problem.

Edit: - Just had a look around the passenger side footwell, looks like they've had trim removed from there - I know as the havn't bothered putting it back properly, I had clipped it in once before when I first had the car, so I know it was fitted correctly. Two bluetooth devives have been connected that are nothing to do with me, and weren't there previous to taking car in and also, there's a fibre optic cable complete with cover hanging down under the glove box - I'm not best pleased with them..

Last edited by DazJ; 04-13-2010 at 05:52 PM. Reason: Updated info...
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:35 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST