E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > 335i - Auto transmission won't engage sport mode



Reply
 
Thread Tools Search this Thread
      08-24-2010, 10:36 AM   #1
Hillstreet
meow
 
Drives: BMW335iAT
Join Date: Jan 2007
Location: Sweden

Posts: 36
iTrader: (0)

335i - Auto transmission won't engage sport mode

My 2007 335i suddenly wont engage sport mode. When i try to shift manually it engages the M1, M2, M3 etc but then resets to Drive again after a few seconds.

Anyone else had this problem?
__________________
'07 335iAM Touring Black Sapphire/Dacota
Hillstreet is offline  
0
Reply With Quote
      08-24-2010, 10:49 AM   #2
Saint330i
Private
 
Drives: Dinan3
Join Date: Jul 2009
Location: Texas

Posts: 56
iTrader: (1)

Recently my 2006 330i steptronic would not shift manually. My dealership replaced my shifter, luckily under extended warranty. Works great now.
My guess is yours is the shifter.
Saint330i is offline  
0
Reply With Quote
      11-16-2010, 06:40 PM   #3
cgnahc
Major
 
cgnahc's Avatar
 
Drives: TiAg E90 ZSP
Join Date: Dec 2006
Location: Westlake Village, CA

Posts: 1,258
iTrader: (9)

I'm having the same problem on 2006 325i just this week. No DS and no M1-6. Very Strange! How to fix???
__________________
9/2011 Need someone to install angle eye bulbs.
9/2011 WTB: an OEM 17" front rim.

Last edited by cgnahc; 11-16-2010 at 06:45 PM.
cgnahc is offline   United_States
0
Reply With Quote
      11-17-2010, 01:58 AM   #4
Hillstreet
meow
 
Drives: BMW335iAT
Join Date: Jan 2007
Location: Sweden

Posts: 36
iTrader: (0)

It was the shifter in my case, just like Saint330i said.
100% sure you have the same problem.

If you use sport or manual mode alot some wires get bent and finally snap.
The wires cant be replaced so they have to replace the whole thing.
__________________
'07 335iAM Touring Black Sapphire/Dacota

Last edited by Hillstreet; 11-17-2010 at 02:03 AM.
Hillstreet is offline  
0
Reply With Quote
      11-18-2010, 02:14 PM   #5
cgnahc
Major
 
cgnahc's Avatar
 
Drives: TiAg E90 ZSP
Join Date: Dec 2006
Location: Westlake Village, CA

Posts: 1,258
iTrader: (9)

You're right I use DS at every use. Wires Snap?? That's very poor engineering. I'd never would have thought I wore out the shifter. That's like wearing out the accelerator pedal.

Thanks for the diagnosis. Is this as simple as replacing the shifter or if there is a wiring harness to replace also?
__________________
9/2011 Need someone to install angle eye bulbs.
9/2011 WTB: an OEM 17" front rim.
cgnahc is offline   United_States
0
Reply With Quote
      11-18-2010, 04:03 PM   #6
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
Quote:
Originally Posted by cgnahc View Post
You're right I use DS at every use. Wires Snap?? That's very poor engineering. I'd never would have thought I wore out the shifter. That's like wearing out the accelerator pedal.

Thanks for the diagnosis. Is this as simple as replacing the shifter or if there is a wiring harness to replace also?
I would assume you need to replace the whole shifter assembly....like not just the cover with the lights, but the whole shifter going down to the transmission.
fdriller9 is offline   United_States
0
Reply With Quote
      11-20-2010, 04:22 PM   #7
samchoi604
Colonel
 
Drives: black on black
Join Date: Mar 2009
Location: Burnaby, BC

Posts: 2,316
iTrader: (3)

Have you tried resetting the transmission (the manual shows how to do it, I forgot how).

In any case, this sounds very bad. Good thing I don't use DS very often.
samchoi604 is offline  
0
Reply With Quote
      12-29-2010, 07:19 PM   #8
cgnahc
Major
 
cgnahc's Avatar
 
Drives: TiAg E90 ZSP
Join Date: Dec 2006
Location: Westlake Village, CA

Posts: 1,258
iTrader: (9)

The fix is installing a new gear shift assembly.
Similar to item number 25167548037, but will depend on your specific year and model. check on realoem.com
__________________
9/2011 Need someone to install angle eye bulbs.
9/2011 WTB: an OEM 17" front rim.
cgnahc is offline   United_States
0
Reply With Quote
      01-20-2011, 02:33 AM   #9
kash_0
Private
 
Drives: F30 328 MSport
Join Date: Feb 2007
Location: Sydney

Posts: 93
iTrader: (0)

hi guys,

might be having the same problem, car won't engage sport mode. Is the following repair cheap if it is indeed the gear selector, car is out of warranty.
kash_0 is offline   Australia
0
Reply With Quote
      01-20-2011, 12:00 PM   #10
Autobahn335i
Lieutenant Colonel
 
Autobahn335i's Avatar
 
Drives: E92 335i
Join Date: Mar 2009
Location: Luxembourg

Posts: 1,590
iTrader: (5)

I have the same problem. Any fix besided replacing the whole gear assembly?
__________________
Performance Seats, Exhaust, Splitters, Pedals, Steering Wheel / RB Turbos / M3 CF Roof / Brembo GT BBK 355/345 / Rollcage / Forge FMIC / Quaife LSD / Íhlins Road & Track / M3 Suspension Parts / Powerflex Bushings / Vorshlag Camberplates / Megan Racing Toe Links / LeatherZ Gauges / Extended M3 DCT Paddles / ER Sports OC / AR OC / Aux Radiator / AR DPs / Alpina TCU / COBB Pro-Tune
Autobahn335i is offline   Luxembourg
0
Reply With Quote
      03-02-2011, 06:36 PM   #11
Bash
First Lieutenant
 
Bash's Avatar
 
Drives: E92-335i
Join Date: Jan 2011
Location: Beirut

Posts: 395
iTrader: (0)

I had the same problem, so my cousin and I took the console out covering the gear knob and then turned the car on and starting switching back and forth.
Turned out to be broken cable from the back behind D position, fixed all good now. Try it out it might be the same I just saved 500$
Bash is offline  
0
Reply With Quote
      06-18-2011, 09:15 PM   #12
Kodak
The Law
 
Kodak's Avatar
 
Drives: 06 325xi, 4dr, Alpine
Join Date: Apr 2008
Location: Bronx, NYC

Posts: 327
iTrader: (0)

Damaged/Repaired M/S mode ??

Damn, that some major headache if so many people are having the same problems using their shifts, so if you use the Manual/Sport mode you'll damage it, leave it alone and your ok. Maybe if more members complain about it, BMW "might" offer some type of updated repairs.

Quote:
Originally Posted by Hillstreet View Post
It was the shifter in my case, just like Saint330i said.
100% sure you have the same problem.

If you use sport or manual mode alot some wires get bent and finally snap.
The wires cant be replaced so they have to replace the whole thing.
__________________
2006 Alpine ,325xi sedan,Terra, steptronic,Xenon,heated seats,Premium package
Kodak is offline   United_States
0
Reply With Quote
      06-19-2011, 10:35 AM   #13
335i Pal
Second Lieutenant
 
335i Pal's Avatar
 
Drives: 335i Sedan
Join Date: Oct 2010
Location: Ohio

Posts: 284
iTrader: (1)

I had the same problem, but luckily had it replaced under warranty. If not it would have been over $800!!!! And the same as everyone else the whole gear shift assembly had to be replaced because the solenoid that engages sport mode was busted.
__________________
335i E90 | BMS DCI | Black Matte Grill | JB4 | Logic 7 | Sport | Premium | Cold |
335i Pal is offline   United_States
0
Reply With Quote
      06-19-2011, 12:23 PM   #14
Chriztofor
Colonel
 
Chriztofor's Avatar
 
Drives: '06 325i Auto
Join Date: Feb 2010
Location: Chicago Burbs

Posts: 2,702
iTrader: (1)

I thought i saw a post that only a wire was broken in the shift assembly and the whole thing did not need to be replaced. Do a search and see if you can find it.
__________________
If no codes are being thrown use Chevron Techron fuel injector cleaner (concentrate). It solves rpm fluctuating upon cold start-up. Also, for most BMW problems start off by scanning your car with the Peake Research Tool. It contains the actual BMW codes. If you want to register a newly installed battery for free (just buy a $10 cable) and google/download BMWLogger
Chriztofor is offline   United_States
0
Reply With Quote
      06-19-2011, 12:23 PM   #15
Chriztofor
Colonel
 
Chriztofor's Avatar
 
Drives: '06 325i Auto
Join Date: Feb 2010
Location: Chicago Burbs

Posts: 2,702
iTrader: (1)

Duh, post 11 above!
__________________
If no codes are being thrown use Chevron Techron fuel injector cleaner (concentrate). It solves rpm fluctuating upon cold start-up. Also, for most BMW problems start off by scanning your car with the Peake Research Tool. It contains the actual BMW codes. If you want to register a newly installed battery for free (just buy a $10 cable) and google/download BMWLogger
Chriztofor is offline   United_States
0
Reply With Quote
      08-13-2011, 01:18 PM   #16
ronn16E90
Major
 
ronn16E90's Avatar
 
Drives: E90 N52 & E92 m3
Join Date: Apr 2008
Location: Sacramento

Posts: 1,201
iTrader: (4)

Garage List
2006 325i  [4.50]
I just replaced my shift assembly and still didnt work
__________________
ronn16E90 is offline   Philippines
0
Reply With Quote
      08-13-2011, 01:21 PM   #17
tibra1
Banned
 
Drives: 2011 ZCP M3 - 2007 335i crashd
Join Date: Apr 2009
Location: NYC

Posts: 6,777
iTrader: (4)

MT...FTW!!
tibra1 is offline   No_Country
0
Reply With Quote
      08-14-2011, 12:14 AM   #18
ronn16E90
Major
 
ronn16E90's Avatar
 
Drives: E90 N52 & E92 m3
Join Date: Apr 2008
Location: Sacramento

Posts: 1,201
iTrader: (4)

Garage List
2006 325i  [4.50]
Quote:
Originally Posted by tibra1 View Post
MT...FTW!!
SERIOUSLY bro. I will never get a Steptronic sports car
__________________
ronn16E90 is offline   Philippines
0
Reply With Quote
      09-02-2011, 02:53 PM   #19
lookin4e90
Second Lieutenant
 
lookin4e90's Avatar
 
Drives: e90
Join Date: Jun 2009
Location: so cal

Posts: 229
iTrader: (4)

This just happened to me this morning. Anyone with this problem have any updates? (estimates, repairs $$$, DIY, dealer or indy shop)
lookin4e90 is offline  
0
Reply With Quote
      09-10-2011, 07:26 PM   #20
Me_Hi
Major
 
Me_Hi's Avatar
 
Drives: *
Join Date: Jun 2009
Location: *

Posts: 1,491
iTrader: (13)

Dude, it took me 20 minutes to fix
You just need basic tools and electric tape
__________________
Me_Hi is offline   No_Country
0
Reply With Quote
      09-13-2011, 08:27 PM   #21
First VR4
Enlisted Member
 
Drives: 2006 330xi
Join Date: Oct 2008
Location: Pine Bush, NY

Posts: 38
iTrader: (0)

Me Hi, Do you have any instructions or pictures?
First VR4 is offline  
0
Reply With Quote
      11-04-2011, 10:00 AM   #22
dlira
Registered
 
Drives: 2008 328xit
Join Date: Aug 2011
Location: Delaware

Posts: 1
iTrader: (0)

I have the same problem with a 328xi wagon. I used the DS mode a lot (because I loved the way it drove).My BMW fixers says to replace the whole shifter to the tune of some $900.
dlira is offline  
0
Reply With Quote
Reply

Bookmarks

Tags
335i automatic sport mode

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:39 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST