E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > 335i - Auto transmission won't engage sport mode



Reply
 
Thread Tools Search this Thread
      01-12-2014, 07:42 PM   #45
DetectiveLoki
First Lieutenant
DetectiveLoki's Avatar
3
Rep
304
Posts

 
Drives: 2008 BMW 335i Convertible
Join Date: Jan 2012
Location: Orange County - SOCAL

iTrader: (4)

So I opened up my center dash today and was able to repair the broken wires. I am able to shift again!!
Attached Images
    
Appreciate 0
      02-17-2014, 11:12 AM   #46
83k
Private First Class
83k's Avatar
1
Rep
185
Posts

 
Drives: 2008 335xi
Join Date: Apr 2011
Location: NYC

iTrader: (1)

i follow the steps and did checked all wires for any damages. None found. I lost my DS mode after i installed a new transmission, the light still comes on when I pull the knob to DS mode, but no response on the dash. Would this be a coding issue instead?
Appreciate 0
      02-18-2014, 02:19 AM   #47
DetectiveLoki
First Lieutenant
DetectiveLoki's Avatar
3
Rep
304
Posts

 
Drives: 2008 BMW 335i Convertible
Join Date: Jan 2012
Location: Orange County - SOCAL

iTrader: (4)

I believe I read somewhere that you need to update software after installing a new transmission. I could be wrong.
Appreciate 0
      02-24-2014, 12:45 PM   #48
njboy732
Private
0
Rep
54
Posts

 
Drives: 2008 335xi coupe
Join Date: Mar 2013
Location: San Antonio Texas

iTrader: (1)

check out this video


Appreciate 0
      02-27-2014, 03:39 PM   #49
igor_ki
Major
igor_ki's Avatar
United_States
12
Rep
1,261
Posts

 
Drives: A LIL BIMMER
Join Date: Jan 2013
Location: Sacramento, CA

iTrader: (6)

what if my car won't go into DS and paddles don't work either? could that be the same thing? broken wires?
__________________
PRESENT: 2010 E90 335XI, 2008 e92 6AT,

HISTORY: 2008 e92xi 6MT, 2009 e90 6AT, 2008 E90 6MT, 2011 E90 6AT, and 2 Hondas
Appreciate 0
      02-27-2014, 10:25 PM   #50
igor_ki
Major
igor_ki's Avatar
United_States
12
Rep
1,261
Posts

 
Drives: A LIL BIMMER
Join Date: Jan 2013
Location: Sacramento, CA

iTrader: (6)

bump!!!! can someone help out? i checked all my wires and they're good, also tried replacing the top PRND plastic and it didn't help, but also my paddle shifters don't work...
__________________
PRESENT: 2010 E90 335XI, 2008 e92 6AT,

HISTORY: 2008 e92xi 6MT, 2009 e90 6AT, 2008 E90 6MT, 2011 E90 6AT, and 2 Hondas
Appreciate 0
      12-10-2014, 05:32 PM   #51
Husky
Enlisted Member
Husky's Avatar
0
Rep
36
Posts

 
Drives: E91 Touring
Join Date: Jun 2006
Location: Australia

iTrader: (0)

Thanks so much to all who contributed to this thread; in particular…. ‘LaLakers91tc’, ‘njboy732’ & ‘DetectiveLoki’ ….you are the people who make this forum and community such a valuable resource. Well Done and thanks again!!
__________________
06 323i Touring | Alpine White | Panorama Glass Roof | Sports Seats | Sports Wheel |
Appreciate 0
      12-10-2014, 06:04 PM   #52
dbudh001
Lieutenant
6
Rep
494
Posts

 
Drives: 2007 bmw 3351
Join Date: May 2010
Location: miami

iTrader: (1)

Just had this problem pull off the cover and the trim. Look for broken wires. Splice and add length to the wires and the sauder them. I can't recall what gauge wire I used. I'll let you know later. Then use the plastic tubing that you can heat shrink wrap around the wires and bam it's fixed
Appreciate 0
      12-10-2014, 06:06 PM   #53
dbudh001
Lieutenant
6
Rep
494
Posts

 
Drives: 2007 bmw 3351
Join Date: May 2010
Location: miami

iTrader: (1)

Quote:
Originally Posted by igor_ki
bump!!!! can someone help out? i checked all my wires and they're good, also tried replacing the top PRND plastic and it didn't help, but also my paddle shifters don't work...
You may want to really pull it apart like u see in the pics above. The first time I looked I didn't see it either I had to remove that nasty sticky wrap to see it
Appreciate 0
      12-24-2014, 08:18 AM   #54
SlimE92
Private First Class
2
Rep
179
Posts

 
Drives: E92 N54
Join Date: Apr 2014
Location: Queens NY

iTrader: (0)

Quote:
Originally Posted by DetectiveLoki
I believe I read somewhere that you need to update software after installing a new transmission. I could be wrong.
Can anyone confirm this?
Appreciate 0
Reply

Bookmarks

Tags
335i automatic sport mode

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:16 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST