E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > 335i - Auto transmission won't engage sport mode



Reply
 
Thread Tools Search this Thread
      01-12-2014, 08:42 PM   #45
DetectiveLoki
First Lieutenant
DetectiveLoki's Avatar
3
Rep
313
Posts

Drives: 2008 BMW 335i Convertible
Join Date: Jan 2012
Location: Orange County - SOCAL

iTrader: (4)

So I opened up my center dash today and was able to repair the broken wires. I am able to shift again!!
Attached Images
    
Appreciate 0
      02-17-2014, 12:12 PM   #46
83k
Private First Class
83k's Avatar
1
Rep
184
Posts

Drives: 2008 335xi
Join Date: Apr 2011
Location: NYC

iTrader: (1)

i follow the steps and did checked all wires for any damages. None found. I lost my DS mode after i installed a new transmission, the light still comes on when I pull the knob to DS mode, but no response on the dash. Would this be a coding issue instead?
Appreciate 0
      02-18-2014, 03:19 AM   #47
DetectiveLoki
First Lieutenant
DetectiveLoki's Avatar
3
Rep
313
Posts

Drives: 2008 BMW 335i Convertible
Join Date: Jan 2012
Location: Orange County - SOCAL

iTrader: (4)

I believe I read somewhere that you need to update software after installing a new transmission. I could be wrong.
Appreciate 0
      02-24-2014, 01:45 PM   #48
njboy732
Private
0
Rep
57
Posts

Drives: 2008 335xi coupe
Join Date: Mar 2013
Location: San Antonio Texas

iTrader: (1)

check out this video


Appreciate 0
      02-27-2014, 04:39 PM   #49
IK6SPEED
Major
IK6SPEED's Avatar
United_States
26
Rep
1,451
Posts

Drives: A LIL BIMMER
Join Date: Feb 2013
Location: Sacramento, CA

iTrader: (8)

what if my car won't go into DS and paddles don't work either? could that be the same thing? broken wires?
__________________
"Sure it works in practice, but what about in theory?"

2014 F30 328i Glacier Silver (mine)
2011 E90 335xi 6mt Jet Black (mine)
2011 E90 328i Vermillion Red (her)
Appreciate 0
      02-27-2014, 11:25 PM   #50
IK6SPEED
Major
IK6SPEED's Avatar
United_States
26
Rep
1,451
Posts

Drives: A LIL BIMMER
Join Date: Feb 2013
Location: Sacramento, CA

iTrader: (8)

bump!!!! can someone help out? i checked all my wires and they're good, also tried replacing the top PRND plastic and it didn't help, but also my paddle shifters don't work...
__________________
"Sure it works in practice, but what about in theory?"

2014 F30 328i Glacier Silver (mine)
2011 E90 335xi 6mt Jet Black (mine)
2011 E90 328i Vermillion Red (her)
Appreciate 0
      12-10-2014, 06:32 PM   #51
Husky
Enlisted Member
Husky's Avatar
0
Rep
36
Posts

Drives: E91 Touring
Join Date: Jun 2006
Location: Australia

iTrader: (0)

Thanks so much to all who contributed to this thread; in particular…. ‘LaLakers91tc’, ‘njboy732’ & ‘DetectiveLoki’ ….you are the people who make this forum and community such a valuable resource. Well Done and thanks again!!
__________________
06 323i Touring | Alpine White | Panorama Glass Roof | Sports Seats | Sports Wheel |
Appreciate 0
      12-10-2014, 07:04 PM   #52
dbudh001
Lieutenant
6
Rep
485
Posts

Drives: 2007 bmw 3351
Join Date: May 2010
Location: miami

iTrader: (1)

Just had this problem pull off the cover and the trim. Look for broken wires. Splice and add length to the wires and the sauder them. I can't recall what gauge wire I used. I'll let you know later. Then use the plastic tubing that you can heat shrink wrap around the wires and bam it's fixed
Appreciate 0
      12-10-2014, 07:06 PM   #53
dbudh001
Lieutenant
6
Rep
485
Posts

Drives: 2007 bmw 3351
Join Date: May 2010
Location: miami

iTrader: (1)

Quote:
Originally Posted by igor_ki
bump!!!! can someone help out? i checked all my wires and they're good, also tried replacing the top PRND plastic and it didn't help, but also my paddle shifters don't work...
You may want to really pull it apart like u see in the pics above. The first time I looked I didn't see it either I had to remove that nasty sticky wrap to see it
Appreciate 0
      12-24-2014, 09:18 AM   #54
SlimE92
Second Lieutenant
4
Rep
259
Posts

Drives: E92 N54
Join Date: Apr 2014
Location: Queens NY

iTrader: (0)

Quote:
Originally Posted by DetectiveLoki
I believe I read somewhere that you need to update software after installing a new transmission. I could be wrong.
Can anyone confirm this?
Appreciate 0
      03-05-2015, 06:15 PM   #55
2fast4
Private First Class
2fast4's Avatar
1
Rep
122
Posts

Drives: 2008 BMW 335i
Join Date: Sep 2013
Location: Phoenix, Azz

iTrader: (0)

Fixed!!!

Thanks guys, and DetectiveLoki. I had the same problem Loki had with PURPLE wire broken. It happened yesterday and got it fixed today.

In manual mode, it will upshift w/o a problem but wouldn't downshift.

I see other wires wiring sheath also broken too. I pulled on them to see if it breaks off. They didn't. So I just soldered the purple wire together, put some electrical tapes on couple a places for reenforcement, straightened out the wiring loom, took it off the loop tab, tons of slack now. DONE!

I saved hundred$$$. Took me about 3.5 hours. Cheers
Appreciate 0
      03-20-2015, 11:22 AM   #56
rscs
Registered
0
Rep
1
Posts

Drives: 2007 328xi
Join Date: Mar 2015
Location: New York

iTrader: (0)

Thumbs up Thank you!

I'd like to give a big thanks to LaLakers91tc, DetectiveLoki, njboy732, and anyone else I missed for the detailed information, photos, videos, and instructions about the wiring issue.

I, too, have been a victim of this poor engineering. A few months back, I noticed that some of my orange PRND lights on the shift indicator bezel stopped working. I didn't think much of it because it was just a cosmetic issue.

Then, earlier this week, my DS mode stopped working and I immediately noticed since I use DS mode every time I drive. I'm so used to downshifting this way that it's "driven" me crazy not having it.

After some basic Internet searching, I came across the threads on this site relating to the wiring issue. Thanks to the previous posters, I was able to open everything up, re-splice the wires, and everything is back to normal again. All but two of my wires were completely cut and the two that weren't were very stressed so I cut them myself and re-spliced.

I started with these instructions for removing the shift knob, boot, and bezel:

http://www.pelicanparts.com/BMW/tech...eplacement.htm

Then a lot of your photos of the wiring issues helped, but this video was especially helpful:

Appreciate 0
Reply

Bookmarks

Tags
335i automatic sport mode

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:53 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST