E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Canada > Navi problems



Reply
 
Thread Tools Search this Thread
      09-23-2010, 10:59 PM   #1
BRAISKI
Colonel
BRAISKI's Avatar
Canada
93
Rep
2,499
Posts

Drives: '11 335xi e92 M-Pak
Join Date: Mar 2009
Location: GTA/KW, Canada

iTrader: (3)

Garage List
2011 BMW 335xi  [3.50]
Angry Navi problems

For the folks that have the iDrive, do you have guys any issues with it? Maybe specifically the 2011, I am not sure about the pre-LCI

I have the 2011 and it seems that my Navi is giving me wrong directions. When I drove from Waterloo to Oshawa. The iDrive tells me to turn to 427 or exit to 403 or side roads, so I ignored all of them since I know how to get to my mom's place, 401 all the way! So going back to Waterloo I tried to follow it just to see what happens while I am at the 401 it told to go to 427N then it asked me to exit then go back again to 427S then back to the 401! WTF!

Same thing happened again to today when I was going to downtown Toronto it wants me to go to 427 so I skipped it and again to 400 then ask me to exit at at Bathurst or something. However this time I brought my Tom Tom One GPS just to see if there is any difference but there is.

Does the iDrive come with a automatic traffic detector or something? This is really annoying since I don't really trust the iDrive Navi right now. I look like an idiot using my Tom Tom One GPS and my car comes with Navi!

I tried all the settings...

Fastest route
Shortest route
Efficient route


Here are some pics how it goes crazy...




Last edited by BRAISKI; 01-08-2011 at 02:16 AM. Reason: Pics
Appreciate 0
      09-23-2010, 11:31 PM   #2
the_doctor
Private First Class
the_doctor's Avatar
United_States
4
Rep
109
Posts

Drives: 2011 AW E92 335xi 6MT
Join Date: Jun 2010
Location: GA

iTrader: (0)

Yes I have a similar problem; actually I have noticed about 4 issues with the 2011 iDrive system within my 4.5 months of ownership:

1) If I ever need to pass through the 401/427 juncture (say going west) and I've preset the nav, it would give me some weird route such as exit to 409W, then 427S, then back on 401. If you ignore it and keep driving, it would tell you to exit on Dixon and somehow get back on Hwy 27 and 401. Doesn't really make you feel confident if you're actually taking the car to another city now does it??!!

2) If I'm driving on Wellington Street (d/t Toronto) going west, it has 2x thought I was driving in the middle of Lake Ontario. Go figure! But then it would fix itself in a few minutes; I'm thinking it probably has to do with the tall buildings interfering with the satellite signal?

3) You know the two translucent boxes on the top right hand corner (showing bluetooth connection and media) and the bottom right hand corner (showing GPS destination info)? Sometimes those boxes disappear for no apparent reason. But then it would come back the next time you restart the car.

4) Point of interest listing does not include Fallsview Casino. But it contains Casino Niagara ... no comment!
Appreciate 0
      09-23-2010, 11:57 PM   #3
BRAISKI
Colonel
BRAISKI's Avatar
Canada
93
Rep
2,499
Posts

Drives: '11 335xi e92 M-Pak
Join Date: Mar 2009
Location: GTA/KW, Canada

iTrader: (3)

Garage List
2011 BMW 335xi  [3.50]
Hmmmm I was thinking of contacting BMW assist if then can do something or update the map.

I have a feeling the new iDrive doesnt like 401 lol

I haven' really used much my iDrive but when I was using my Tom Tom One in DT TO, it goes crazy and I think its because of the tall buildings too so the satellite can't pin point the car accurately.

I have to check he others.
Appreciate 0
      09-24-2010, 01:11 AM   #4
R_Mak
New Member
Canada
0
Rep
19
Posts

Drives: E93 335i E70 4.8i
Join Date: Mar 2007
Location: Toronto

iTrader: (0)

3) You know the two translucent boxes on the top right hand corner (showing bluetooth connection and media) and the bottom right hand corner (showing GPS destination info)? Sometimes those boxes disappear for no apparent reason. But then it would come back the next time you restart the car.

Just press the iDrive knob to toggle the display on & off.
Appreciate 0
      09-24-2010, 01:24 AM   #5
bunnn
Colonel
bunnn's Avatar
50
Rep
2,266
Posts

Drives: like a grandma
Join Date: May 2009
Location: Toronto

iTrader: (12)

PRE LCI has this issue too... I get really annoyed with the Navi on my 2009 Idrive(i'm assuming 2009-2011 is same though) ...better to have a quick look on google maps before you head out.
__________________
Cheers
Ben
Appreciate 0
      09-24-2010, 01:19 PM   #6
2kaccordocoupe
Brigadier General
2kaccordocoupe's Avatar
Canada
264
Rep
3,651
Posts

Drives: MY2017 M4
Join Date: Nov 2008
Location: The Six

iTrader: (2)

After you start the guidance go back and check the route information, it will give you 3 route options that you can choose from. Preview the one you want and select it.

You may have also turned on some avoidances like toll roads, ferry etc... Double check that.
Appreciate 0
      09-24-2010, 02:30 PM   #7
MMachines
BMW Owner
Canada
9
Rep
462
Posts

Drives: 2008 M3, 2009 G37x
Join Date: Mar 2009
Location: Downtown Toronto

iTrader: (1)

Mine is a 2006 and it's no less reliable than my Garmin. (Hope I didn't jinx it)
Appreciate 0
      09-24-2010, 02:49 PM   #8
BRAISKI
Colonel
BRAISKI's Avatar
Canada
93
Rep
2,499
Posts

Drives: '11 335xi e92 M-Pak
Join Date: Mar 2009
Location: GTA/KW, Canada

iTrader: (3)

Garage List
2011 BMW 335xi  [3.50]
Quote:
Originally Posted by 2kaccordocoupe View Post
After you start the guidance go back and check the route information, it will give you 3 route options that you can choose from. Preview the one you want and select it.

You may have also turned on some avoidances like toll roads, ferry etc... Double check that.
I checked those and the avoidance is only "Toll roads"
Appreciate 0
      09-24-2010, 03:06 PM   #9
2kaccordocoupe
Brigadier General
2kaccordocoupe's Avatar
Canada
264
Rep
3,651
Posts

Drives: MY2017 M4
Join Date: Nov 2008
Location: The Six

iTrader: (2)

Quote:
Originally Posted by BRAISKI View Post
I checked those and the avoidance is only "Toll roads"
Nice,
I find the idrive does come up with some strange routes every now and then, use the preview option and alternative route options to pick the best option for you.
Appreciate 0
      09-24-2010, 03:18 PM   #10
BRAISKI
Colonel
BRAISKI's Avatar
Canada
93
Rep
2,499
Posts

Drives: '11 335xi e92 M-Pak
Join Date: Mar 2009
Location: GTA/KW, Canada

iTrader: (3)

Garage List
2011 BMW 335xi  [3.50]
Quote:
Originally Posted by 2kaccordocoupe View Post
Nice,
I find the idrive does come up with some strange routes every now and then, use the preview option and alternative route options to pick the best option for you.
Hmmmm thats not really reassuring. I will try to contact BMW assist if they can update my map again.
Appreciate 0
      09-24-2010, 03:59 PM   #11
604 Dude
New Member
0
Rep
7
Posts

Drives: Nissan Altima SER 2005
Join Date: Sep 2010
Location: Vancouver

iTrader: (0)

When you were buying the car, how did you decide on whether to go with NAVI or not? I am torn.

Pros with navi:
- maps & directions
- iDrive
- seems popular

On the other hand:

- Dashboard looks neat and clean without Navi
- In a few years, the car without Navi will look just as clean and the one with the Navi will be outdated once new designs come out.


Tough call for me!

On a 70k car, 2k isn't exactly much, so I don't see Navi as a financial decision but an aesthetic one.

How did you decide on the Navi?
Appreciate 0
      09-24-2010, 04:04 PM   #12
BRAISKI
Colonel
BRAISKI's Avatar
Canada
93
Rep
2,499
Posts

Drives: '11 335xi e92 M-Pak
Join Date: Mar 2009
Location: GTA/KW, Canada

iTrader: (3)

Garage List
2011 BMW 335xi  [3.50]
Quote:
Originally Posted by 604 Dude View Post
When you were buying the car, how did you decide on whether to go with NAVI or not? I am torn.

Pros with navi:
- maps & directions
- iDrive
- seems popular

On the other hand:

- Dashboard looks neat and clean without Navi
- In a few years, the car without Navi will look just as clean and the one with the Navi will be outdated once new designs come out.


Tough call for me!

On a 70k car, 2k isn't exactly much, so I don't see Navi as a financial decision but an aesthetic one.

How did you decide on the Navi?
It was an easy decision for me I wanted the navi since I use the GPS a lot and it looks a lot better than the portable GPS. You also get other benefits or convenience from the iDrive.

Well I figure I will spend already $70 ~$72k might as well get the stuff I wanted so that I will not regret it.
Appreciate 0
      09-24-2010, 04:11 PM   #13
604 Dude
New Member
0
Rep
7
Posts

Drives: Nissan Altima SER 2005
Join Date: Sep 2010
Location: Vancouver

iTrader: (0)

Quote:
Originally Posted by BRAISKI View Post
It was an easy decision for me I wanted the navi since I use the GPS a lot and it looks a lot better than the portable GPS. You also get other benefits or convenience from the iDrive.

Well I figure I will spend already $70 ~$72k might as well get the stuff I wanted so that I will not regret it.
Oh I am totally with you, spending 70k+ on a car, I better get EXACTLY what I want . But I hardly ever use the GPS and have it on iPhone, iPad as well as portable navigation unit on my old car!

I'll have to check them side by side at the dealer.
Appreciate 0
      09-24-2010, 04:43 PM   #14
PiperD
Clutch pedal >> Dead pedal
Canada
13
Rep
709
Posts

Drives: '11 e92 335is 6MT
Join Date: Sep 2006
Location: GTA

iTrader: (0)

Garage List
Just a +1 on the routing issues. Last one I noticed was around 401/427 - same problem as the_doctor.
__________________
In my garage: '11 e92 335is 6MT (05/10) SpGrey/CoralRed/GlacSlvr ExecPkg/NavPkg/19" 225M
Retired: '07 e92 335i 6MT (12/06) SpklgGrpht/CoralRed/GreyPoplar
Retired: '04 330Ci M-Sport 6MT SilverGrey/NaturalTan/MyrtleWood
Retired: '00 328Ci 5MT SteelGrey/Grey/MyrtleWood
Retired: '87 Pontiac Grand-Am 3AT White/Grey
Appreciate 0
      09-25-2010, 11:27 AM   #15
the_doctor
Private First Class
the_doctor's Avatar
United_States
4
Rep
109
Posts

Drives: 2011 AW E92 335xi 6MT
Join Date: Jun 2010
Location: GA

iTrader: (0)

Quote:
Originally Posted by R_Mak View Post
3) You know the two translucent boxes on the top right hand corner (showing bluetooth connection and media) and the bottom right hand corner (showing GPS destination info)? Sometimes those boxes disappear for no apparent reason. But then it would come back the next time you restart the car.

Just press the iDrive knob to toggle the display on & off.
Oh that's brilliant! All this time I thought it was a defect ... haha ... thanks!
Appreciate 0
      09-25-2010, 01:01 PM   #16
BRAISKI
Colonel
BRAISKI's Avatar
Canada
93
Rep
2,499
Posts

Drives: '11 335xi e92 M-Pak
Join Date: Mar 2009
Location: GTA/KW, Canada

iTrader: (3)

Garage List
2011 BMW 335xi  [3.50]
Quote:
Originally Posted by R_Mak View Post
3) You know the two translucent boxes on the top right hand corner (showing bluetooth connection and media) and the bottom right hand corner (showing GPS destination info)? Sometimes those boxes disappear for no apparent reason. But then it would come back the next time you restart the car.

Just press the iDrive knob to toggle the display on & off.
Lol this just happened to me yesterday and I was like WTF!

I think there are so many features that we don't know.
Appreciate 0
      09-25-2010, 01:03 PM   #17
BRAISKI
Colonel
BRAISKI's Avatar
Canada
93
Rep
2,499
Posts

Drives: '11 335xi e92 M-Pak
Join Date: Mar 2009
Location: GTA/KW, Canada

iTrader: (3)

Garage List
2011 BMW 335xi  [3.50]
Quote:
Originally Posted by PiperD View Post
Just a +1 on the routing issues. Last one I noticed was around 401/427 - same problem as the_doctor.
Hmmmm I wonder whats going with 401/427 problem.

Also last time, it says something like "limited access ahead".


Is the car equip with traffic warning?
Appreciate 0
      09-25-2010, 07:56 PM   #18
quantuz
zzz
Canada
0
Rep
33
Posts

Drives: 2009 e93 335i
Join Date: Nov 2009
Location: Oakville, Ontario, Canada

iTrader: (0)

Quote:
Originally Posted by BRAISKI View Post
Hmmmm I wonder whats going with 401/427 problem.

Also last time, it says something like "limited access ahead".


Is the car equip with traffic warning?
Limited Access Ahead - try taking the West Bound 401 off the 404 and take the express exit off the 404... Limited access comes up.

I just had the 401/427 / Dixon road issue come up again and again.
Appreciate 0
      09-27-2010, 06:28 AM   #19
Andy M
Canada
42
Rep
1,208
Posts

Drives: 09 BMW 335i xdrive
Join Date: Mar 2008
Location: Toronto

iTrader: (5)

Quote:
Originally Posted by the_doctor View Post
2) If I'm driving on Wellington Street (d/t Toronto) going west, it has 2x thought I was driving in the middle of Lake Ontario. Go figure! But then it would fix itself in a few minutes; I'm thinking it probably has to do with the tall buildings interfering with the satellite signal?
Depends on your signal lock. I get that too on a cold startup (I live near where you are having the problem). GPS requires clear line of sight with at least 3 satellites to work and more to get a good lock. Tall buildings + GPS = inaccuracies.
Appreciate 0
      09-27-2010, 07:19 PM   #20
commie
Second Lieutenant
11
Rep
206
Posts

Drives: 335i
Join Date: Jun 2008
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by the_doctor View Post

1) If I ever need to pass through the 401/427 juncture (say going west) and I've preset the nav, it would give me some weird route such as exit to 409W, then 427S, then back on 401. If you ignore it and keep driving, it would tell you to exit on Dixon and somehow get back on Hwy 27 and 401. Doesn't really make you feel confident if you're actually taking the car to another city now does it??!!
Same thing happening to me with the 2009 iDrive. For whatever reason, iDrive wants me to use Hwy27 instead of taking the 401 to 427..

Example: I want to drive to Niagara Falls, and I am on the 401.....Normally, I would take the 401 W all the way to the 427 S and then take the QEW from there. Thats how I drove without GPS's, and thats how Garmin and TomTom would route it.
But the iDrive tells me to first take the 409E exit, then take local for a bit to get onto the HWY27S then QEW....If I ignore the 409 exit, then it will tell me to take Dixon, then 27 south.

Perhaps HWY 27 is the fastest route? and we need to select the routing preference for the most logical not the fastest??
Appreciate 0
      10-05-2010, 08:55 PM   #21
tolkino
Captain
tolkino's Avatar
16
Rep
821
Posts

Drives: '09 BSM E92 328i xDrive
Join Date: Oct 2008
Location: Toronto, ON

iTrader: (1)

Mine also goes crazy at 401/427, I just ignore it..
Appreciate 0
      10-06-2010, 11:58 AM   #22
t7n7
CYNOSURE
t7n7's Avatar
Canada
4
Rep
216
Posts

Drives: Tesla ModelS - waiting...
Join Date: Jul 2010
Location: DT Toronto/Markham/Ajax

iTrader: (0)

never had a problem with my navi..... 09' ... my favourite part is the integration with the HUD.... i don't look at the screen or the speedometer anymore... it's even smart enough to tell me the limits...

would be nice to have real time traffic though... was very disappointed after purchasing that it wasn't available in Canada... (same situation with my 10' TL A-Spec)...The 401 is the most congested highway in the continent and yet we can't get traffic updates.. SUCKS!
__________________
09' X650i loaded hud/comfort/sports/premium/audio/coldweather/power - the beast / 03' G35c electrochromic tints - www.youtube.com/wisht7n7 - the baby / 02' TL internet/satTV/massage seats - the entertainer / 10' TSX - currently modding - Go kart / TESLA MODEL S - Signature Edition #73 2012
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:17 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST