E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > My car was service for HPFP, now it drives like a truck. WTF????



Reply
 
Thread Tools Search this Thread
      09-24-2010, 08:53 PM   #1
mylydiamy
Lieutenant
14
Rep
512
Posts

 
Drives: 2008 335i e93 convertible
Join Date: Apr 2009
Location: New Jersey

iTrader: (1)

Send a message via Yahoo to mylydiamy
Angry My car was service for HPFP, now it drives like a truck. WTF????

My 2008 e93 335i (Jan production) was in for service for a few problems including my favorite long cranks in the morning. When my SA was filling out the form I noticed that he put down something about software update. I told him that I heard bad things about software update and I rather not go for it. He said:

"Don't worry, you will like it. Also your problem is not hardware, it is software".

Although I didn't believe him I did not argue. Today I picked my car. Man, what a disappointment. The shift (AT) is worse than any other car I have ever driven including Crown Victoria. You feel the rough shift at any gear.

AND this is not the worst part. Turbo lag is beyond any imagination. When I step on the gas it takes good 1-2 seconds to get any response from the car.

AND the car feels like it has less power.

WTF??? The receipt says:

C/S THERE IS RECALL TO PROGRAM DME FOR EXTENDED CRANK
CAUSE : F
0059613 PROGRAM
41209 WW1
FC : 0013950100


So, I am really upset. There is no way I can continue driving the car like this.

I am thinking about calling them and tell then to uninstall whatever they installed.

Any one has any idea what the hell they did to my car? Any knowledge/suggestion is appreciated.

Thanks
Appreciate 0
      09-24-2010, 09:08 PM   #2
Express
Major General
Express's Avatar
Israel
129
Rep
8,701
Posts

 
Drives: 06 330i
Join Date: Dec 2008
Location: The Promise Land

iTrader: (17)

Garage List
2006 BMW 330i  [4.15]
why wouldn't you just wait for the 1/2 engine light to replace the pump?
Appreciate 0
      09-24-2010, 09:23 PM   #3
mylydiamy
Lieutenant
14
Rep
512
Posts

 
Drives: 2008 335i e93 convertible
Join Date: Apr 2009
Location: New Jersey

iTrader: (1)

Send a message via Yahoo to mylydiamy
Quote:
Originally Posted by express705 View Post
why wouldn't you just wait for the 1/2 engine light to replace the pump?
Well, I just did not want to take a risk of braking down in the middle of nowhere...
Appreciate 0
      09-24-2010, 09:27 PM   #4
John 070
Lieutenant General
157
Rep
11,508
Posts

 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

iTrader: (0)

It really is a frustrating experience, it'll drive you crazy. Better to just find some other way of diverting your attention. It seems like it takes months going back and forth with the dealership to get a 335 into driveable condition. When you call BMWNA some 22 y.o. intern will call you and leave a voicemail that there's nothing they can do and "we are not trained," so contact your service manager. Are you kidding me? I'd love to see BMWNA's welcome package for new hires. I bet their benefits s***! LOL
Appreciate 0
      09-24-2010, 09:30 PM   #5
mylydiamy
Lieutenant
14
Rep
512
Posts

 
Drives: 2008 335i e93 convertible
Join Date: Apr 2009
Location: New Jersey

iTrader: (1)

Send a message via Yahoo to mylydiamy
I just drove it one more time just make sure that I am not delusional.

It felt even worse. I feel like putting "For Sale" sign on the car tomorrow morning.

Is there a way to uninstall whatever they install???
Appreciate 0
      09-24-2010, 09:57 PM   #6
John 070
Lieutenant General
157
Rep
11,508
Posts

 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

iTrader: (0)

Quote:
Originally Posted by mylydiamy View Post
I just drove it one more time just make sure that I am not delusional.

It felt even worse. I feel like putting "For Sale" sign on the car tomorrow morning.

Is there a way to uninstall whatever they install???
The way I look at it is that the car is complicated, and BMW is unwilling to authorize the dealership to fix it on your first visit. It's as if you have to go back and put your fist down.

The new software is better in theory. People used to ask how they could get it if there's nothing wrong with their car. Now, it's the opposite--if your car is running fine, you don't want it touched.

After mine got updated to 35.4, it was slower, got worse mpgs, but it sure looked good parked and the roundel offered me increased status when compared to those reliable Japanese cars.
Appreciate 0
      09-24-2010, 10:04 PM   #7
mylydiamy
Lieutenant
14
Rep
512
Posts

 
Drives: 2008 335i e93 convertible
Join Date: Apr 2009
Location: New Jersey

iTrader: (1)

Send a message via Yahoo to mylydiamy
Quote:
Originally Posted by John 070 View Post
The way I look at it is that the car is complicated, and BMW is unwilling to authorize the dealership to fix it on your first visit. It's as if you have to go back and put your fist down.

The new software is better in theory. People used to ask how they could get it if there's nothing wrong with their car. Now, it's the opposite--if your car is running fine, you don't want it touched.

After mine got updated to 35.4, it was slower, got worse mpgs, but it sure looked good parked and the roundel offered me increased status when compared to those reliable Japanese cars.
I personally prefer a reliable car even though it may give me less status.
Appreciate 0
      09-24-2010, 10:11 PM   #8
fdsasdasdf
Captain
fdsasdasdf's Avatar
30
Rep
779
Posts

 
Drives: 330Ci ZHP 6sp
Join Date: Apr 2009
Location: Raleigh, NC

iTrader: (0)

They removed your chassis and replaced it with a Chevy, then put an E92 body kit on it.

You've been had, son.
Appreciate 0
      09-24-2010, 10:15 PM   #9
ska///235i
***** noob
ska///235i's Avatar
United_States
194
Rep
9,210
Posts

 
Drives: M235i
Join Date: Sep 2005
Location: Boston

iTrader: (32)

Garage List
2006 325xi  [0.00]
No class action on this?
Appreciate 0
      09-25-2010, 12:54 AM   #10
mylydiamy
Lieutenant
14
Rep
512
Posts

 
Drives: 2008 335i e93 convertible
Join Date: Apr 2009
Location: New Jersey

iTrader: (1)

Send a message via Yahoo to mylydiamy
Quote:
Originally Posted by Zell View Post
They removed your chassis and replaced it with a Chevy, then put an E92 body kit on it.

You've been had, son.
You forgot to mentioned that they replaced the engine with 1998 Ford Taurus engine
Appreciate 0
      09-25-2010, 02:48 AM   #11
samchoi604
Colonel
28
Rep
2,320
Posts

 
Drives: black on black
Join Date: Mar 2009
Location: Burnaby, BC

iTrader: (3)

Quote:
Originally Posted by mylydiamy View Post
I just drove it one more time just make sure that I am not delusional.

It felt even worse. I feel like putting "For Sale" sign on the car tomorrow morning.

Is there a way to uninstall whatever they install???
That would be awesome. Just like Windows 7. It creates a restore point for every update so you can revert back.
Appreciate 0
      09-25-2010, 03:32 AM   #12
A4rings
First Lieutenant
6
Rep
354
Posts

 
Drives: 07 Space 335i
Join Date: Jan 2010
Location: SBizzle

iTrader: (0)

there is a service bulletin about people complaining about the lag with the new software. go back to the dealership and ask for the "wastegate valve conversion" also know as lag fix setting.

print this out and take it to the dealership http://www.bmwtis.com/tsb/bulletins/...p/B111307g.htm
Appreciate 0
      09-25-2010, 07:32 AM   #13
Rustang Cobra
Private First Class
2
Rep
105
Posts

 
Drives: like a Masshole
Join Date: Feb 2010
Location: Boston, MA

iTrader: (3)

Has anyone had any luck in telling them to NOT install the software update and ONLY install a new HPFP?

I have 12,000 miles on my 2007 with no HPFP problems.

I refuse to let them make my car into a laggy piece of S#IT when the problem occurs on my car.
Appreciate 0
      09-25-2010, 09:10 AM   #14
mylydiamy
Lieutenant
14
Rep
512
Posts

 
Drives: 2008 335i e93 convertible
Join Date: Apr 2009
Location: New Jersey

iTrader: (1)

Send a message via Yahoo to mylydiamy
Quote:
Originally Posted by A4rings View Post
there is a service bulletin about people complaining about the lag with the new software. go back to the dealership and ask for the "wastegate valve conversion" also know as lag fix setting.

print this out and take it to the dealership http://www.bmwtis.com/tsb/bulletins/...p/B111307g.htm
Thanks. It mentions about turbo lag but applies to cars until Sep 2007. Mine is Jan 2008. I am not sure if it will work.

I just call head SA. He was not in and I did not want to waste my time talking to someone who has no idea about the problem. I lest a very nasty voice mail since he was the who suggested the software upgrade.

I am dedicated to get my old car back. If they refuse, I am going to park my car rigth at the entrance of the service dept, block it completely. They walk into the show room and tell everyone how their service sucks.

I am determined. There is no way I can drive the car like this. I did not spent +60K $ to drive a car like this

Anyone had any luck convenience them to uninstall???
Appreciate 0
      09-25-2010, 10:01 AM   #15
jmsent
Second Lieutenant
2
Rep
266
Posts

 
Drives: BMW 335i Coupe
Join Date: Jun 2006
Location: Chicago

iTrader: (0)

I've had my HPFP replaced recently and they did some kind of software update which primes the pump when you open the door or unlock the car. My car runs just fine. Take it back and explain the problem. If that doesn't work, find another dealer. I'd also suggest that taking an antagonistic position with your SA and threatening to embarrass the dealership is not productive towards solving your problem. Calm down.
Appreciate 0
      09-25-2010, 07:38 PM   #16
mylydiamy
Lieutenant
14
Rep
512
Posts

 
Drives: 2008 335i e93 convertible
Join Date: Apr 2009
Location: New Jersey

iTrader: (1)

Send a message via Yahoo to mylydiamy
Quote:
Originally Posted by jmsent View Post
I've had my HPFP replaced recently and they did some kind of software update which primes the pump when you open the door or unlock the car. My car runs just fine. Take it back and explain the problem. If that doesn't work, find another dealer. I'd also suggest that taking an antagonistic position with your SA and threatening to embarrass the dealership is not productive towards solving your problem. Calm down.
Thanks. Valid point. I am really upset. Let's see what he is going to say on Monday.

Still wondering if anyone was able to solve this problem after software update...
Appreciate 0
      09-25-2010, 10:22 PM   #17
chromisdesigns
Lieutenant Colonel
21
Rep
1,754
Posts

 
Drives: 2008 BMW 335i sedan
Join Date: Jan 2010
Location: San Francisco

iTrader: (0)

Quote:
Originally Posted by mylydiamy View Post
Thanks. It mentions about turbo lag but applies to cars until Sep 2007. Mine is Jan 2008. I am not sure if it will work.
The bulletin is wrong -- the problem software was installed into a bunch of 2008 models, as well, up to April/May 2008 build date. I know -- I had one of them, problem software level identified easily by key-read. They updated it to eliminate the lag.

However, if you got the most recent update, you shouldn't have any lag problems, particularly in comparison to that horrible 29.xxxxx level from 07-08.

Take it back to the dealer and have them try again. I have the latest level as of about 6 months ago and the car drives fine.
Appreciate 0
      09-26-2010, 07:51 PM   #18
mylydiamy
Lieutenant
14
Rep
512
Posts

 
Drives: 2008 335i e93 convertible
Join Date: Apr 2009
Location: New Jersey

iTrader: (1)

Send a message via Yahoo to mylydiamy
Quote:
Originally Posted by chromisdesigns View Post
The bulletin is wrong -- the problem software was installed into a bunch of 2008 models, as well, up to April/May 2008 build date. I know -- I had one of them, problem software level identified easily by key-read. They updated it to eliminate the lag.

However, if you got the most recent update, you shouldn't have any lag problems, particularly in comparison to that horrible 29.xxxxx level from 07-08.

Take it back to the dealer and have them try again. I have the latest level as of about 6 months ago and the car drives fine.
OK. I will mention it to the delaer.

Thanks
Appreciate 0
      09-26-2010, 08:35 PM   #19
be1ieve1111
Thread Killer
United_States
9
Rep
921
Posts

 
Drives: 2011 E92 335i
Join Date: May 2010
Location: Indiana

iTrader: (9)

Send a message via AIM to be1ieve1111 Send a message via Yahoo to be1ieve1111 Send a message via Skype™ to be1ieve1111
Software update also deletes all the adaptions. So take into consideration that the car needs to learn your habits over time.
Appreciate 0
      09-27-2010, 09:51 AM   #20
brocken
Captain
7
Rep
605
Posts

 
Drives: 335i
Join Date: Nov 2006
Location: Seattle, WA

iTrader: (5)

Those saying they have software from 6 months ago... it's TOTALLY different than the most recent one (July, I believe).
I've been through the long start, surging, bogging, limp mode, you name it for the last year and a half.
The update I got in August has made the car even more of a terd. I'm having the same issues as the OP AND I still have long cranks!
I have massive lag and the car does a really bad stutter/hesitation when I accelerate.
My car drives WORSE than a truck now.

p.s. I'm not shouting, just emphasizing.
Appreciate 0
      09-27-2010, 10:51 AM   #21
PsychoSlug
Lieutenant
PsychoSlug's Avatar
United_States
9
Rep
563
Posts

 
Drives: E90
Join Date: May 2009
Location: Nowhere

iTrader: (0)

I just had the software update earlier this month, and have had no issues with it. The car drives just as well as it did before the update.

Sorry to hear of everyone's problems. Just keep going back to the dealer until it is right.
Appreciate 0
      09-27-2010, 01:44 PM   #22
Blubaron79
Colonel
Blubaron79's Avatar
25
Rep
2,022
Posts

 
Drives: '14 435 XDrive
Join Date: May 2009
Location: PA

iTrader: (0)

Have them reprogram. They re-programmed mine, and the only difference was the auto-tranny had to re-learn my driving style. Other than that, the car felt the same.
__________________
'14 435 XDrive: Mineral Grey, MSport, 19's, Coral Leather, Alum. Trim, Every option (except Active Cruise), MPPK, black grille, clear bra.

335 xDrive on order. (needed a 4 door for work..)
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:42 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST