E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > How do i get this light off on my dash



Reply
 
Thread Tools Search this Thread
      09-30-2010, 08:26 AM   #1
ac09lude
Private First Class
ac09lude's Avatar
2
Rep
175
Posts

 
Drives: 335i
Join Date: Jul 2010
Location: Long Island

iTrader: (2)

How do i get this light off on my dash

The air pressure light came on yesterday morning. I stoped and check my tire pressure and i had 36lbs in the rear tires. i have been driving for 1 day and the light has not gone off. Can anyone help me out?

http://www.e90post.com/forums/attach...1&d=1285852856
Attached Images
 
__________________
2007 335i e92 /// JB3 /// BMS DCI /// H&R Sport Springs
Appreciate 0
      09-30-2010, 08:29 AM   #2
xquizitdjx
Private First Class
xquizitdjx's Avatar
2
Rep
110
Posts

 
Drives: 335i
Join Date: Sep 2010
Location: Central Florida

iTrader: (0)

Sounds like you need to replace a TPS. I would search tire pressure sensor and see what you find on the forums to help you figure it out.
Appreciate 0
      09-30-2010, 08:33 AM   #3
wrickem
doesn't really care
wrickem's Avatar
25
Rep
2,302
Posts

 
Drives: what he wants to
Join Date: Mar 2006
Location: lambertville nj

iTrader: (0)

Did you "reset" the tire pressure monitoring system? You have to do that after you check the pressure.
__________________
______________________________________________
'14 528-xdrive - daily driver/winter beater, '06 Boxster - for fun, '07 M6- for even more fun.
Appreciate 0
      09-30-2010, 08:51 AM   #4
ac09lude
Private First Class
ac09lude's Avatar
2
Rep
175
Posts

 
Drives: 335i
Join Date: Jul 2010
Location: Long Island

iTrader: (2)

Quote:
Originally Posted by wrickem View Post
Did you "reset" the tire pressure monitoring system? You have to do that after you check the pressure.
i did, and i got the check mark. whats my next step?
__________________
2007 335i e92 /// JB3 /// BMS DCI /// H&R Sport Springs
Appreciate 0
      09-30-2010, 08:56 AM   #5
F32Fleet
BMWCCA since '03
F32Fleet's Avatar
United_States
69
Rep
5,338
Posts

 
Drives: 2015 435i
Join Date: May 2005
Location: Atlanta (Vinings)

iTrader: (0)

Did you check the tire pressure first?
Appreciate 0
      09-30-2010, 09:03 AM   #6
ac09lude
Private First Class
ac09lude's Avatar
2
Rep
175
Posts

 
Drives: 335i
Join Date: Jul 2010
Location: Long Island

iTrader: (2)

Quote:
Originally Posted by Socom View Post
Did you check the tire pressure first?
yes, i checked tire pressure then i reset the system. this morning i stated the car all the lights came on i stated driving and the yellow tire light went off and then it came back on 30 sec later.
__________________
2007 335i e92 /// JB3 /// BMS DCI /// H&R Sport Springs
Appreciate 0
      09-30-2010, 09:39 AM   #7
cb1111
I ask the questions you're afraid to ask.
cb1111's Avatar
27
Rep
2,489
Posts

 
Drives: 335xi
Join Date: Sep 2009
Location: DC

iTrader: (2)

Quote:
Originally Posted by ac09lude View Post
yes, i checked tire pressure then i reset the system. this morning i stated the car all the lights came on i stated driving and the yellow tire light went off and then it came back on 30 sec later.

Did you check your tire pressure today? Maybe you are losing air.
Appreciate 0
      09-30-2010, 11:42 AM   #8
ac09lude
Private First Class
ac09lude's Avatar
2
Rep
175
Posts

 
Drives: 335i
Join Date: Jul 2010
Location: Long Island

iTrader: (2)

Quote:
Originally Posted by cb1111 View Post
Did you check your tire pressure today? Maybe you are losing air.
thats the funny thing, when the light came on i went to get air and before i put air in i checked the pressure and i had 36lbs. do you guys think it the sensor? my warrenty just came up last week also.
__________________
2007 335i e92 /// JB3 /// BMS DCI /// H&R Sport Springs
Appreciate 0
      09-30-2010, 11:50 AM   #9
SpmnE9zero
DENY THE WORLD THAT SURROUNDS YOU
SpmnE9zero's Avatar
United_States
376
Rep
35,576
Posts

 
Drives: JB 33ZERO
Join Date: Nov 2008
Location: City of Champions

iTrader: (14)

Garage List
2006 330xi  [0.00]
just trade it in!
__________________
Eurocharged V5 | ROW's / CC Delete | K&N's | H&R Springs | Single Fin G.B. Grill | Mode Carbon Diffuser | JBSpeed CF Spoiler |
Arkym Style CF Splitter | CF Mirror Caps | 5% Tints | 12mm Spacers |
Appreciate 0
      09-30-2010, 11:54 AM   #10
wrickem
doesn't really care
wrickem's Avatar
25
Rep
2,302
Posts

 
Drives: what he wants to
Join Date: Mar 2006
Location: lambertville nj

iTrader: (0)

I'd try the cheap and easy way out first, and try resetting it again. And make sure that when you do the reset that you're not moving until it reads "resetting", I made that mistake once and couldn't figure out why it didn't reset.
__________________
______________________________________________
'14 528-xdrive - daily driver/winter beater, '06 Boxster - for fun, '07 M6- for even more fun.
Appreciate 0
      10-03-2010, 08:09 PM   #11
hipnotic
Major General
hipnotic's Avatar
United_States
76
Rep
6,574
Posts

 
Drives: e92 335i
Join Date: Oct 2007
Location: So. Cal

iTrader: (6)

Garage List
2008 335i coupe  [3.50]
reset it
Appreciate 0
      10-03-2010, 08:56 PM   #12
m1tal1k
Private
2
Rep
86
Posts

 
Drives: BMW 328xi black sedan 07
Join Date: Aug 2010
Location: Colorado Springs, Colorado

iTrader: (0)

Check your tire for a severe looking "fracture" in the natrual rubber. That may be it as well.
Appreciate 0
      10-04-2010, 05:48 PM   #13
iflyjetzzz
First Lieutenant
11
Rep
320
Posts

 
Drives: 2008 328i
Join Date: Sep 2010
Location: Tucson, AZ

iTrader: (0)

I've had the occasional faulty low tire pressure indication on my left front since I put on new (non-RFT) tires. I've reset the system 2 or 3 times so far. I figure it's probably the TPMS going bad. I'll continue to reset it unless it starts coming on more frequently than every other week.
Appreciate 0
      10-09-2010, 09:28 PM   #14
enycerz
Private First Class
enycerz's Avatar
United_States
1
Rep
194
Posts

 
Drives: E92 M3
Join Date: Jun 2009
Location: NY Flushing

iTrader: (7)

try to correct the tire pressure in the morning or when the tire is cold then reset it.
Appreciate 0
      10-09-2010, 11:48 PM   #15
Alpine3
Lieutenant Colonel
Alpine3's Avatar
United_States
38
Rep
1,663
Posts

 
Drives: E92 328i
Join Date: Sep 2009
Location: East Coast

iTrader: (2)

Why when i have low pressure , the computer doesn't tell me which tire it is, but just tells me a tire is low? got a base e92 328
__________________
E9X Picture Game: 8 points: (High visibility jacket; Strip Club; Pizzeria; Sobriety Test; E9x dressed for Halloween, Billiards, Oil Change, Orange Cone)
Appreciate 0
      10-11-2010, 02:01 PM   #16
iflyjetzzz
First Lieutenant
11
Rep
320
Posts

 
Drives: 2008 328i
Join Date: Sep 2010
Location: Tucson, AZ

iTrader: (0)

Quote:
Originally Posted by Alpine3 View Post
Why when i have low pressure , the computer doesn't tell me which tire it is, but just tells me a tire is low? got a base e92 328
Alpine3, I've got the nav system installed and there's a screen for TPMS. It displays the low tire on it. I don't know how it works for non-nav system BMWs.
Appreciate 0
      10-14-2010, 12:18 PM   #17
WannaBModder328i
Second Lieutenant
3
Rep
200
Posts

 
Drives: E90
Join Date: Oct 2010
Location: Palm Beach Gardens,Florida

iTrader: (1)

i have this same problem, had it reset at bmw too, still on, tires are fine, reset and reset it everyday. nothing works. i think mine is a sensor i'll have them check when i get my rims on
Appreciate 0
      10-17-2010, 02:34 AM   #18
ERSTD
Private
1
Rep
93
Posts

 
Drives: E92 335xi
Join Date: Aug 2006
Location: Boston Area

iTrader: (0)

Quote:
Originally Posted by Alpine3 View Post
Why when i have low pressure , the computer doesn't tell me which tire it is, but just tells me a tire is low? got a base e92 328
i believe you need a software update...
i used to have just low tire icon yellow or red (!) and nothing else, and it meant that i would have to check all four tires before finding the one that is low. But after software update that i received due to warranty work, now car shows exactly which tire is low...
Appreciate 0
      11-24-2010, 03:25 PM   #19
KL07RPH
Private First Class
Philippines
1
Rep
125
Posts

 
Drives: '07 E92 328i; '10 E70 3.0
Join Date: Apr 2007
Location: Diamond Bar, Los Angeles

iTrader: (1)

Garage List
2007 E92  [0.00]
2010 E70 3.0  [0.00]
Send a message via Yahoo to KL07RPH
Quote:
Originally Posted by ERSTD View Post
i believe you need a software update...
i used to have just low tire icon yellow or red (!) and nothing else, and it meant that i would have to check all four tires before finding the one that is low. But after software update that i received due to warranty work, now car shows exactly which tire is low...
For the longest, I couldn't figure out why all of a sudden I was being informed of which tire(s) were low on air, especially since my car only showed a red/yellow (!) symbol in the past 3 years of ownership. Then I stumbled on this thread and realized my software was updated...
Appreciate 0
      02-27-2011, 01:19 PM   #20
Alex
Mom says I'm a catch
United_States
0
Rep
69
Posts

 
Drives: 2007 E90 335i; 2000 E46 323i
Join Date: Oct 2009
Location: P1

iTrader: (4)

Is there a way to know what sensor needs replacing?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:56 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST