E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > 2011 335 Check Engine light



Reply
 
Thread Tools Search this Thread
      10-28-2010, 06:01 PM   #1
NetCat
Registered
 
Drives: 2011 335 E90
Join Date: Jul 2010
Location: Austin, Tx

Posts: 3
iTrader: (0)

2011 335 Check Engine light

So.. I am a little frustrated with the dealer so I thought I would ask here.

Anyone have a 2011 335 with the Check Engine light on?

Mine turned on almost immediately after purchase (End of May). The dealer ordered a new mass airflow meter after checking the codes. When the part arrived they found a tech update that declared the issue a software problem. They thought the new release would be ready in September.

I have been trying to follow up with the Service Adviser but he isn't returning my emails or calls.

So .. Does anyone know if this software update has been released?

Thanks
Chad
NetCat is offline  
0
Reply With Quote
      10-28-2010, 07:06 PM   #2
FrankiE90
Major General
 
FrankiE90's Avatar
 
Drives: Krooked Sk8board
Join Date: Feb 2008
Location: Pasadena, Ca

Posts: 8,625
iTrader: (11)

Send a message via Skype™ to FrankiE90
Quote:
Originally Posted by NetCat View Post
So.. I am a little frustrated with the dealer so I thought I would ask here.

Anyone have a 2011 335 with the Check Engine light on?

Mine turned on almost immediately after purchase (End of May). The dealer ordered a new mass airflow meter after checking the codes. When the part arrived they found a tech update that declared the issue a software problem. They thought the new release would be ready in September.

I have been trying to follow up with the Service Adviser but he isn't returning my emails or calls.

So .. Does anyone know if this software update has been released?

Thanks
Chad
welcome to the forum.
sucks to hear about your new bimmer acting up like that already.
Just make sure the dealer gives you a loaner until the problem is fixed.

what bmw dealership you going to?

-call another SA there at the dealership to get your answer if your current SA isn't returning your calls.
__________________
FrankiE90 AKA:.[The TANK] *CLICK THE SIG
2011 335 E90 MTECH 6MT KW V3 INJEN Intake Berk 4" DP Vanguard V2 exhaust Procede V5 Stoptech BBK RPI Scoops Karbonwerk CSL Trunk LUX H8 19" BBS LM 18" BBS GT4
FrankiE90 is offline   United_States
0
Reply With Quote
      10-28-2010, 09:03 PM   #3
Iceberg4
Lieutenant
 
Iceberg4's Avatar
 
Drives: 2014 AW 435i M Sport
Join Date: Jun 2009
Location: The city that never sleeps!

Posts: 475
iTrader: (1)

Quote:
Originally Posted by NetCat View Post
So.. I am a little frustrated with the dealer so I thought I would ask here.

Anyone have a 2011 335 with the Check Engine light on?

Mine turned on almost immediately after purchase (End of May). The dealer ordered a new mass airflow meter after checking the codes. When the part arrived they found a tech update that declared the issue a software problem. They thought the new release would be ready in September.

I have been trying to follow up with the Service Adviser but he isn't returning my emails or calls.

So .. Does anyone know if this software update has been released?

Thanks
Chad
Yup, mine came on yesterday for no reason. It's weird because the car runs just fine since I bought it in June. My SA called me and told me that the low pressor sensor was failing and throwing a code but they checked the fuel system and it's working perfectly

Last edited by Iceberg4; 10-29-2010 at 11:23 AM.
Iceberg4 is offline   Dominica
0
Reply With Quote
      10-28-2010, 09:54 PM   #4
scrufy
Zoom Zoom This
 
scrufy's Avatar
 
Drives: The Short Bus
Join Date: Jul 2010
Location: So. Cal.

Posts: 691
iTrader: (0)

Check engine light? Oh that thing is on all the time. I thought it was the auto map light.
Welcome to the forum.
Seriously though, I have a lot of issues with my car but there are some on here that have relatively trouble free experiences...and I hate every one of them! LoL
Oh and if a SA didnt return my call after the next afternoon, time for a new dealer. Its funny how some of them think they are so important..lmao
scrufy is offline   United_States
0
Reply With Quote
      10-29-2010, 03:22 AM   #5
John 070
Lieutenant General
 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

Posts: 11,424
iTrader: (0)

My car was not new, it was 34 mos. old when it suddenly died while I was driving. I wanted to think it was a fluke, but logically, how could it be? What was surprising at the time was a) how the dealership didn't take it seriously b) how the SES lamp meant nothing, because it was on, then it was off. One time it was on for 4 days, and when I got to the dealership, it was off, and they said vehicle performing as designed.

I was one of those people who thought the DME stored the reason for what happened, regardless of if the lamp were lit or not. But then again, this is my first BMW, and my first go around of spending a lot of money to be treated like second class.

That first SES was the beginning of a 6 mo. journey into total breakdown land. Again, the only hint that the problem would be fixed would be the PUMA case after 10X shutting down in the middle of traffic. There are no flukes with BMW. The only thing that are certain are my local income taxes and BMWs unwillingness to fix anything until you get upset and intolerable of their attitude.
John 070 is offline  
0
Reply With Quote
      10-29-2010, 12:14 PM   #6
Php
Captain
 
Drives: CaymanS, used to be e92 335
Join Date: Feb 2010
Location: Atlanta, GA

Posts: 631
iTrader: (0)

man this is messed up, for a car that new, and it's already having sensor failures?
Php is offline   United_States
0
Reply With Quote
      10-29-2010, 12:19 PM   #7
RickC
Private
 
Drives: 335xi Coupe and Z4
Join Date: Apr 2010
Location: Upstate NY USA

Posts: 75
iTrader: (0)

My 2008 335 has had no check engine light issues. My wifes 2009 Jeep Grand Cherokee V8 has been in 3 times for check engine lights with a different O2 sensor each time. Hope you get it resolved
RickC is offline   United_States
0
Reply With Quote
      11-02-2010, 12:00 AM   #8
NetCat
Registered
 
Drives: 2011 335 E90
Join Date: Jul 2010
Location: Austin, Tx

Posts: 3
iTrader: (0)

Answers- At least it looks like it.

So.. Just to be clear..

My car has always run just fine it just had the annoying check engine light on. I was more annoyed with the Service Adviser at my local Austin dealer not returning my calls and emails over the past couple of months.

Maybe he just doesn't like answering when he doesn't have good news. He finally answered this morning and apparently BMW has released a new software update last Friday. So we will see if this fixes it. I will update this thread when I know.

An update for others that might have the issue. My problem seems to go away when the air temperature is lower. Since it has been cooler down here the light has been turning off for some periods of time and then turning back on when warmer weather returns.

Thanks
Chad
NetCat is offline  
0
Reply With Quote
      11-02-2010, 02:39 AM   #9
FrankiE90
Major General
 
FrankiE90's Avatar
 
Drives: Krooked Sk8board
Join Date: Feb 2008
Location: Pasadena, Ca

Posts: 8,625
iTrader: (11)

Send a message via Skype™ to FrankiE90
Quote:
Originally Posted by NetCat View Post
So.. Just to be clear..

My car has always run just fine it just had the annoying check engine light on. I was more annoyed with the Service Adviser at my local Austin dealer not returning my calls and emails over the past couple of months.

Maybe he just doesn't like answering when he doesn't have good news. He finally answered this morning and apparently BMW has released a new software update last Friday. So we will see if this fixes it. I will update this thread when I know.

An update for others that might have the issue. My problem seems to go away when the air temperature is lower. Since it has been cooler down here the light has been turning off for some periods of time and then turning back on when warmer weather returns.

Thanks
Chad
that makes no sense.
let us know what u find out.
__________________
FrankiE90 AKA:.[The TANK] *CLICK THE SIG
2011 335 E90 MTECH 6MT KW V3 INJEN Intake Berk 4" DP Vanguard V2 exhaust Procede V5 Stoptech BBK RPI Scoops Karbonwerk CSL Trunk LUX H8 19" BBS LM 18" BBS GT4
FrankiE90 is offline   United_States
0
Reply With Quote
      11-02-2010, 03:38 AM   #10
John 070
Lieutenant General
 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

Posts: 11,424
iTrader: (0)

Quote:
Originally Posted by FrankiE90 View Post
that makes no sense.
let us know what u find out.
That's the BMW SA way of responding to a customer complaint, all kidding aside.

Something is wrong, so take it to the dealership to log it. Don't ignore it, because even a wasted visit to the dealership, is one visit closer to resolution.
John 070 is offline  
0
Reply With Quote
      11-02-2010, 03:49 AM   #11
persian54
Lieutenant General
 
persian54's Avatar
 
Drives: SL550. Prev: E93 M3/335i/Z435i
Join Date: Jun 2009
Location: The Valley, SoCal

Posts: 15,766
iTrader: (291)

try a new dealer?
persian54 is offline   United_States
0
Reply With Quote
      11-02-2010, 04:22 AM   #12
John 070
Lieutenant General
 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

Posts: 11,424
iTrader: (0)

Seriously, a SES is not a fluke. And I have seen mine turn off on its own as well. It was a precursor to many a time where the vehicle shut off unexpectedly, and there was, of course, something wrong. Just took 4 visits for any resolution, over a 6 mo. period.

Trying another dealership is not a bad idea, don't feel obligated to go to the one where the vehicle was purchased.
John 070 is offline  
0
Reply With Quote
      11-02-2010, 12:33 PM   #13
NetCat
Registered
 
Drives: 2011 335 E90
Join Date: Jul 2010
Location: Austin, Tx

Posts: 3
iTrader: (0)

Quote:
Originally Posted by FrankiE90 View Post
that makes no sense.
let us know what u find out.
I am curious as to why you think that it doesn't make sense. I am always looking to learn a little.

Here is why I think it does make sense:

The issue with my car is that the computer thinks that Mass Air Flow sensor is not working correctly. I believe the Mass Air Flow sensor is what tells the ECU how much air is entering the car so that the correct fuel can be injected to match the air...

Since Air density changes with temperature then why couldn't the formula for higher temps be off and cause the error light? It isn't like Germany has to deal with Texas temps very often.

My car seems to run a bit rich (dark tail pipes) and that might be a result of the incorrect ECU code.

Anyway . .. my 2 cents
Chad
NetCat is offline  
0
Reply With Quote
      11-02-2010, 01:53 PM   #14
Iceberg4
Lieutenant
 
Iceberg4's Avatar
 
Drives: 2014 AW 435i M Sport
Join Date: Jun 2009
Location: The city that never sleeps!

Posts: 475
iTrader: (1)

Ok guys, I just got my car serviced yesterday and apparently it was a software update that was necessary AND a DTML pump that had to be replaced. It's some kind of pump that is related to the gas tank
It didn't affect the drivability of the car though and I'm trying to get in touch with my SA to get more info for everyone. So far the car's throttle response is much better, but I think that might me due to the reprogramming with the HPA drop-in filter. I can't wait for my ProCede to arrive!!

PS: disconnecting the exhaust valve actuator (the connection in the trunk) for the golf tee mod is a big NO NO for the N55!
Iceberg4 is offline   Dominica
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:07 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST