E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > engine "shaking" during startup



Reply
 
Thread Tools Search this Thread
      10-13-2010, 05:32 PM   #1
c_jeong89
Banned
United_States
27
Rep
2,097
Posts

 
Drives: E90 TiAg
Join Date: Feb 2009
Location: Irvine/Bay Area

iTrader: (16)

engine "shaking" during startup

I don't really know how to explain it other than it feels like when I first start up the car it feels as if the engine is shaking or so for 3 seconds where I can feel it when sitting down. It feels like it's moving left to right for a few seconds and just stops. I recently put back my stock intake and it started happening. Anybody know what could be wrong? I am 99% sure everything is installed right tubes are all on tight and everything.
Appreciate 0
      10-13-2010, 11:03 PM   #2
AlpineSwift
Colonel
AlpineSwift's Avatar
United_States
26
Rep
2,110
Posts

 
Drives: 2008 335Xi Coupé
Join Date: Feb 2010
Location: Castle Rock, CO

iTrader: (3)

I had a similar problem and it turned out to be a bad starter motor. Covered under warranty thank god.
__________________
E92 '08 335Xi 6AT - Cobb AP V2, ar design DP's, Race Cats in the mids, Stock cans, VRSF CP w/Tial BOV, VRSF 7" FMIC, BMS DCI, BMS Cowl, H&R Coilovers, Renn Motorsport RS-51's, Alpina TCU Flash, Turner Boost Gauge, Fully Coded.
Best 1/4mi: 13.201 @ 106.93 / 2.0 60' / DA=9300ft

Tanya: The Build Thread
Appreciate 0
      10-13-2010, 11:20 PM   #3
c_jeong89
Banned
United_States
27
Rep
2,097
Posts

 
Drives: E90 TiAg
Join Date: Feb 2009
Location: Irvine/Bay Area

iTrader: (16)

hmm alrite thanks. I'll get it checked out.
Appreciate 0
      10-15-2010, 04:51 AM   #4
xxx7
>>
xxx7's Avatar
1
Rep
69
Posts

 
Drives: E90/E60
Join Date: Sep 2010
Location: Sydney, Australia

iTrader: (1)

Quote:
Originally Posted by c_jeong89 View Post
hmm alrite thanks. I'll get it checked out.
I have exactly the same problem..

Left the car at the local BMW service centre for a bunch of tests to diagnose the problem but they couldn't tell me why the car shook upon start up!

Please let us know how you resolve it, thanks.
Appreciate 0
      10-15-2010, 02:52 PM   #5
TommyK
Brigadier General
TommyK's Avatar
United_States
51
Rep
3,326
Posts

 
Drives: E90 335i LCI
Join Date: Aug 2008
Location: Orange County, CA

iTrader: (9)

Garage List
2009 BMW 335i LCI  [0.00]
2006 E90 330i  [0.00]
Send a message via AIM to TommyK
happens to me. im not too worried. the car has made weird noises since i bought it but its never let me down.
especially after how the car makes that grinding sound during start up some times i just accept the fact that shaking is probably normal too. :/ w/e lol
Appreciate 0
      10-15-2010, 03:17 PM   #6
rambalu80
Captain
rambalu80's Avatar
United_States
11
Rep
987
Posts

 
Drives: 2007 BMW 328i
Join Date: Apr 2007
Location: Lake Jackson TX

iTrader: (2)

Garage List
2007 328i  [0.00]
I had a similar problem and it turned out to be due to a missing rubber boot in the engine bay. Boot was replaced under warranty.
__________________
Alpine White/Terra | 6MT | Navi | Premium Package | OEM Chrome Tips | HO C30 Tint | OEM Aluminum Pedals | Rear Fogs Enabled | 17" OEM Style 159 Wheels | Hella Whitelines | USDM Bi-xenons w/ 4300k D1S HID Bulbs

Appreciate 0
      10-15-2010, 03:43 PM   #7
c_jeong89
Banned
United_States
27
Rep
2,097
Posts

 
Drives: E90 TiAg
Join Date: Feb 2009
Location: Irvine/Bay Area

iTrader: (16)

the shaking is gone now. which is good i guess lol.
Appreciate 0
      10-15-2010, 09:54 PM   #8
fdriller9
Banned
United_States
101
Rep
7,090
Posts

 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

iTrader: (4)

Garage List
2006 330xi  [3.22]
Have your knock adaptation reset...had this problem with my 330 and it helped abit...cleaning the MAF fixed it.

I reset mine with my BT Tool...if you don't have one, you'll probably have to have take it to a dealer.
Appreciate 0
      05-20-2011, 02:14 PM   #9
krnboy817
Major
krnboy817's Avatar
South Korea
13
Rep
1,012
Posts

 
Drives: 2008 328i coupe
Join Date: Oct 2010
Location: DFW texas

iTrader: (3)

Quote:
Originally Posted by c_jeong89 View Post
the shaking is gone now. which is good i guess lol.
how did you get your engine shaking to go away??
__________________

driving is poetry in motion.
Appreciate 0
      05-20-2011, 04:42 PM   #10
fdriller9
Banned
United_States
101
Rep
7,090
Posts

 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

iTrader: (4)

Garage List
2006 330xi  [3.22]
Quote:
Originally Posted by krnboy817 View Post
how did you get your engine shaking to go away??
Another problem that can causes this is a sticking vanos solenoid.....I had code 2A98 being thrown in my car and I would get intermittent jerks (side to side) at start up.

If you know how, remove the solenoids and blow compressed air through them.

You car will throw a code if it detects a sticking vanos solenoid.....2A98 and 2A99 I beleive. One is for intake other is for exhaust side.
Appreciate 0
      05-20-2011, 05:16 PM   #11
krnboy817
Major
krnboy817's Avatar
South Korea
13
Rep
1,012
Posts

 
Drives: 2008 328i coupe
Join Date: Oct 2010
Location: DFW texas

iTrader: (3)

im wondering if i can just go to local autozone and have them read any codes (if its throwing them) and go on from there???
__________________

driving is poetry in motion.
Appreciate 0
      05-22-2011, 12:04 PM   #12
Neutrino45
Major
Neutrino45's Avatar
25
Rep
1,446
Posts

 
Drives: XXX
Join Date: Aug 2008
Location: milky way

iTrader: (2)

Krn,

Yeah, you should do that. It doesn't hurt. It's a free service.
__________________
Appreciate 0
      05-24-2011, 05:13 PM   #13
CEVMAN
Enlisted Member
United_States
0
Rep
32
Posts

 
Drives: 2006 325xi
Join Date: May 2011
Location: Ma

iTrader: (0)

engine shake

mine did it to. it ended up being a fan blade was broken. just make sure you look over that area near the fan.
Appreciate 0
      05-24-2011, 09:25 PM   #14
krnboy817
Major
krnboy817's Avatar
South Korea
13
Rep
1,012
Posts

 
Drives: 2008 328i coupe
Join Date: Oct 2010
Location: DFW texas

iTrader: (3)

Quote:
Originally Posted by Neutrino45 View Post
Krn,

Yeah, you should do that. It doesn't hurt. It's a free service.
yeah ill go and do that this weekend. and probabaly will let you know if i was throwing any codes or not.

i will also check the fan blade as well.
__________________

driving is poetry in motion.
Appreciate 0
      05-25-2011, 10:13 PM   #15
Joesiph
Registered
0
Rep
2
Posts

 
Drives: 2007 bmw 328i coupe
Join Date: May 2011
Location: Canada

iTrader: (0)

hey Jeong?

Quote:
Originally Posted by c_jeong89 View Post
the shaking is gone now. which is good i guess lol.
I have a bmw 328i 2007 coupe.
i have the same problem as yours

Engine shakes while start up.... please let me know
how did the engine shaking of your car went off???
Appreciate 0
      05-25-2011, 10:14 PM   #16
Joesiph
Registered
0
Rep
2
Posts

 
Drives: 2007 bmw 328i coupe
Join Date: May 2011
Location: Canada

iTrader: (0)

Hello !!

I have a bmw 328i 2007 coupe.
i have the same problem as yours

Engine shakes while start up.... please let me know
how to get the engine shaking go off ???
Appreciate 0
      05-25-2011, 10:37 PM   #17
c_jeong89
Banned
United_States
27
Rep
2,097
Posts

 
Drives: E90 TiAg
Join Date: Feb 2009
Location: Irvine/Bay Area

iTrader: (16)

I would look into the suggestions said by other members in this post. My shaking went away after a day and never came back since so I don't know what the problem was.
Appreciate 0
      06-11-2011, 12:23 AM   #18
JatinderC
Private First Class
JatinderC's Avatar
United_States
1
Rep
105
Posts

 
Drives: BSM E90 328i LCI
Join Date: May 2011
Location: Miami

iTrader: (0)

My 2011 328i is 3 months old and does this too. It also seems like the shaking is getting worse. What can I do about this?
Appreciate 0
      06-11-2011, 12:51 AM   #19
digital01
Search or ban.
digital01's Avatar
United_States
7
Rep
362
Posts

 
Drives: 2006 BMW 325i
Join Date: Apr 2011
Location: Atlanta, GA

iTrader: (5)

Try starting the car with your AC off, as this was the culprit for me.
__________________
'06 325i Black // iDrive // Cold Weather Pkg // Terra Dakota Leather // Lux 5.1 AE LED // Comfort Access // Premium Pkg // Ray's Sebring 19x8.5 & 19x9.5 w/ 245.35.19 - Mich. PS2 & 275.30.19 - Conti. SportContact2 // Front Bumper Splitters // MSD Air Scoops
Appreciate 0
      06-11-2011, 09:36 AM   #20
JatinderC
Private First Class
JatinderC's Avatar
United_States
1
Rep
105
Posts

 
Drives: BSM E90 328i LCI
Join Date: May 2011
Location: Miami

iTrader: (0)

Yeah I always have my A/C off during startup and shutdown. Would an oil change be the culprit? I'm at 5,120k
Appreciate 0
      06-11-2011, 09:46 AM   #21
matrix76
Major
matrix76's Avatar
Canada
21
Rep
1,300
Posts

 
Drives: 2011 E90 328i xDrive Ex/Ps
Join Date: Sep 2009
Location: The West Coast, BC

iTrader: (1)

I have had the same problem for some time and I have now been informed there is a software update to correct this problem. I was notified by BMW about this and an appointment has been made for June 23rd to have the update done. The dealership that was working on mt car created a puma because they could not determine what was causing it. That is why I was contacted. I will see if I can find out more information specific to the update.
__________________
Brian
Black Sapphire, Black w/Burrwood Trim & Shifter, 162's, Mtec H8 AE's, DS1 HID 6000K

Appreciate 0
      06-15-2011, 07:33 AM   #22
JatinderC
Private First Class
JatinderC's Avatar
United_States
1
Rep
105
Posts

 
Drives: BSM E90 328i LCI
Join Date: May 2011
Location: Miami

iTrader: (0)

I took mine to the dealer. All they did was up the idle and said that the problem was gone. This morning when I start my car I'll check and see if it still shakes. Will keep you updated.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:29 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST