E90Post
 


Bimmertech
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > No heat ..? Blowing cold air....



Reply
 
Thread Tools Search this Thread
      10-31-2010, 10:14 PM   #1
tturbonegro
Private
 
Drives: audi quattro, f350, e90 sedan
Join Date: Oct 2009
Location: nj:philly

Posts: 55
iTrader: (0)

No heat ..? Blowing cold air....

2006 325i
heater is not working..and it's getting cold quick here in nj...
It's blowing cold air when I turn on the heat...any help appreciated...I'm thinking heater core? Thermo? Or the actual heat control pannel? Any way to narrow it down? Will this throw a code or will I see anything by hooking it up to the computer by any chance?
Thanks
tturbonegro is offline  
0
Reply With Quote
      10-31-2010, 10:30 PM   #2
Express
Major General
 
Express's Avatar
 
Drives: 06 330i
Join Date: Dec 2008
Location: The Promise Land

Posts: 8,701
iTrader: (17)

Garage List
2006 BMW 330i  [4.15]
is the knob on red? is the snowflake off? is the temp all the way up?
Express is offline   Israel
0
Reply With Quote
      10-31-2010, 10:49 PM   #3
ragingclue
One cam is enough
 
ragingclue's Avatar
 
Drives: VF
Join Date: Oct 2008
Location: mulletville

Posts: 6,774
iTrader: (1)

Dumb question, but does the coolant have enough time to heat up?

Forgive me if that sounds insulting, but it's something I have to ask. Also, I don't suppose you have a temp gauge, do you?
ragingclue is offline  
0
Reply With Quote
      11-01-2010, 08:38 AM   #4
Chriztofor
Colonel
 
Chriztofor's Avatar
 
Drives: '06 325i Auto
Join Date: Feb 2010
Location: Chicago Burbs

Posts: 2,699
iTrader: (1)

Quote:
Originally Posted by tturbonegro View Post
2006 325i
heater is not working..and it's getting cold quick here in nj...
It's blowing cold air when I turn on the heat...any help appreciated...I'm thinking heater core? Thermo? Or the actual heat control pannel? Any way to narrow it down? Will this throw a code or will I see anything by hooking it up to the computer by any chance?
Thanks
Thermostat is broken. If you change that, might as well change the water pump.
__________________
If no codes are being thrown use Chevron Techron fuel injector cleaner (concentrate). It solves rpm fluctuating upon cold start-up. Also, for most BMW problems start off by scanning your car with the Peake Research Tool. It contains the actual BMW codes. If you want to register a newly installed battery for free (just buy a $10 cable) and google/download BMWLogger
Chriztofor is offline   United_States
0
Reply With Quote
      11-01-2010, 08:41 AM   #5
Chriztofor
Colonel
 
Chriztofor's Avatar
 
Drives: '06 325i Auto
Join Date: Feb 2010
Location: Chicago Burbs

Posts: 2,699
iTrader: (1)

Quote:
Originally Posted by tturbonegro View Post
2006 325i
heater is not working..and it's getting cold quick here in nj...
It's blowing cold air when I turn on the heat...any help appreciated...I'm thinking heater core? Thermo? Or the actual heat control pannel? Any way to narrow it down? Will this throw a code or will I see anything by hooking it up to the computer by any chance?
Thanks
Curious how many miles and did you ever change the coolant?
__________________
If no codes are being thrown use Chevron Techron fuel injector cleaner (concentrate). It solves rpm fluctuating upon cold start-up. Also, for most BMW problems start off by scanning your car with the Peake Research Tool. It contains the actual BMW codes. If you want to register a newly installed battery for free (just buy a $10 cable) and google/download BMWLogger
Chriztofor is offline   United_States
0
Reply With Quote
      11-01-2010, 07:16 PM   #6
tturbonegro
Private
 
Drives: audi quattro, f350, e90 sedan
Join Date: Oct 2009
Location: nj:philly

Posts: 55
iTrader: (0)

Hmmm...temp all the way up, knob in red, snowflake not on..
Coplant has time to heat up, last few drives have been 20+ miles...
Friend has professional established shop with everything that he lets me use or helps,..I'm sure I can access a temp gauge..but not sure what you want me to do with it..haven't even told him yet, ha he's been busy with my truck suspension, turbo on my audi and all his normal work...I like to go online before I bother him incase it's something dumb or easy enough for me to handle..
90k miles...coolant hasn't been changed in 25k at least...
Heat did not work on Friday, Sat, yesterday, or this afternoon...now tonight it just worked out of nowhere...so now Im confused...could the thermo be sticking or something? Thanks for the quick awnsers already !
tturbonegro is offline  
0
Reply With Quote
      11-01-2010, 07:42 PM   #7
Chriztofor
Colonel
 
Chriztofor's Avatar
 
Drives: '06 325i Auto
Join Date: Feb 2010
Location: Chicago Burbs

Posts: 2,699
iTrader: (1)

Quote:
Originally Posted by tturbonegro View Post
Hmmm...temp all the way up, knob in red, snowflake not on..
Coplant has time to heat up, last few drives have been 20 miles...
Friend has professional established shop with everything that he lets me use or helps,..I'm sure I can access a temp gauge..but not sure what you want me to do with it..haven't even told him yet, ha he's been busy with my truck suspension, turbo on my audi and all his normal work...I like to go online before I bother him incase it's something dumb or easy enough for me to handle..
90k miles...coolant hasn't been changed in 25k at least...
Heat did not work on Friday, Sat, yesterday, or this afternoon...now tonight it just worked out of nowhere...so now Im confused...could the thermo be sticking or something? Thanks for the quick awnsers already !
Yes, thermostat is sticking, replace it.
__________________
If no codes are being thrown use Chevron Techron fuel injector cleaner (concentrate). It solves rpm fluctuating upon cold start-up. Also, for most BMW problems start off by scanning your car with the Peake Research Tool. It contains the actual BMW codes. If you want to register a newly installed battery for free (just buy a $10 cable) and google/download BMWLogger
Chriztofor is offline   United_States
0
Reply With Quote
      11-01-2010, 07:49 PM   #8
Express
Major General
 
Express's Avatar
 
Drives: 06 330i
Join Date: Dec 2008
Location: The Promise Land

Posts: 8,701
iTrader: (17)

Garage List
2006 BMW 330i  [4.15]
don't bother replacing the water pump unless its throwing a low voltage code.
Express is offline   Israel
0
Reply With Quote
      11-01-2010, 09:49 PM   #9
tturbonegro
Private
 
Drives: audi quattro, f350, e90 sedan
Join Date: Oct 2009
Location: nj:philly

Posts: 55
iTrader: (0)

Ok so actually it's only working when it's set all the way up to 84, otherwise it's cold...any write ups on thermostat replacement? And anywhere better to look for one other than the dealer? I get pretty good pricing there...
tturbonegro is offline  
0
Reply With Quote
      11-07-2010, 09:52 AM   #10
tturbonegro
Private
 
Drives: audi quattro, f350, e90 sedan
Join Date: Oct 2009
Location: nj:philly

Posts: 55
iTrader: (0)

Anyone?
tturbonegro is offline  
0
Reply With Quote
      11-07-2010, 10:04 AM   #11
SpmnE9zero
DENY THE WORLD THAT SURROUNDS YOU
 
SpmnE9zero's Avatar
 
Drives: JB 33ZERO
Join Date: Nov 2008
Location: City of Champions

Posts: 35,576
iTrader: (14)

Garage List
2006 330xi  [0.00]
Quote:
Originally Posted by tturbonegro View Post
Ok so actually it's only working when it's set all the way up to 84, otherwise it's cold...any write ups on thermostat replacement? And anywhere better to look for one other than the dealer? I get pretty good pricing there...
this is odd, I would have guessed thermostat as well.
__________________
Eurocharged V5 | ROW's / CC Delete | K&N's | H&R Springs | Single Fin G.B. Grill | Mode Carbon Diffuser | JBSpeed CF Spoiler |
Arkym Style CF Splitter | CF Mirror Caps | 5% Tints | 12mm Spacers |
SpmnE9zero is offline   United_States
0
Reply With Quote
      11-07-2010, 10:32 AM   #12
Chriztofor
Colonel
 
Chriztofor's Avatar
 
Drives: '06 325i Auto
Join Date: Feb 2010
Location: Chicago Burbs

Posts: 2,699
iTrader: (1)

Today is the 7th, what is the update?
__________________
If no codes are being thrown use Chevron Techron fuel injector cleaner (concentrate). It solves rpm fluctuating upon cold start-up. Also, for most BMW problems start off by scanning your car with the Peake Research Tool. It contains the actual BMW codes. If you want to register a newly installed battery for free (just buy a $10 cable) and google/download BMWLogger
Chriztofor is offline   United_States
0
Reply With Quote
      11-07-2010, 11:23 AM   #13
TheRox
Colonel
 
TheRox's Avatar
 
Drives: 6mt
Join Date: Oct 2009
Location: Here and there

Posts: 2,312
iTrader: (2)

wait our cars have heaters?

I thought the heat comes off the engine block.
TheRox is offline  
0
Reply With Quote
      10-30-2012, 01:41 PM   #14
eg9_dc2
Private
 
Drives: 335i
Join Date: May 2012
Location: uk

Posts: 59
iTrader: (0)

I have this same problem now....my heaters blow out hot air for a second then start blowing out cold air.

i thought if a thermostat sticks closed its over heats or sticks opens car runs too cool on long drives?
eg9_dc2 is offline  
0
Reply With Quote
      10-30-2012, 02:47 PM   #15
theblackmamba
Banned
 
Drives: 0
Join Date: Dec 2007
Location: 1

Posts: 2,288
iTrader: (8)

my car does the same from 82-84 then it blows hot, its normal.
theblackmamba is offline  
0
Reply With Quote
      11-05-2012, 02:40 PM   #16
eg9_dc2
Private
 
Drives: 335i
Join Date: May 2012
Location: uk

Posts: 59
iTrader: (0)

my car has the same problem, i changed the thermostat it has made no difference, the pipes from the core have been checked and they are hot....

so what does this leave me with? the flap/blend door(s?), the actuators.....or something else?

any advice would be appreciated....
eg9_dc2 is offline  
0
Reply With Quote
      11-05-2012, 03:03 PM   #17
bsamoul
Major General
 
bsamoul's Avatar
 
Drives: E90 325i
Join Date: Feb 2007
Location: Walnut Creek, California

Posts: 7,424
iTrader: (2)

Send a message via AIM to bsamoul
Blocked heater core?
__________________
-Brian
2X 2006 BMW 325i [Electric Red & Mystic Blue] | ZPP | V1 | Rear Fogs | M3 Lip Spoiler | EAS RemoteKey | BMS Powerbox | Projector90 Headlights w/ LED AE | LED plate lights | OEM Blacklines
http://www.tech-shine.com
bsamoul is offline   No_Country
0
Reply With Quote
      11-05-2012, 03:55 PM   #18
eg9_dc2
Private
 
Drives: 335i
Join Date: May 2012
Location: uk

Posts: 59
iTrader: (0)

hey the pipes going to and coming from the core are hot so it cant be blocked......i also told the mechanic do a 'back flush' too....water was flowing throw...

im gonna have it on a gt1 in a few hours hopefully but the luck im having!
eg9_dc2 is offline  
0
Reply With Quote
      01-04-2013, 12:02 PM   #19
dhc905
Private
 
Drives: 2006 325i
Join Date: Jul 2012
Location: East Bay, SF

Posts: 73
iTrader: (4)

Not exactly the same problem, but while I get heat, I can tell that every so often it gets cooler before pumping the heat back into the cabin. I'd say this happens every 30 minutes or so for 2-5 seconds. Does this indicate anything in any of your experiences?
dhc905 is offline   United_States
0
Reply With Quote
      01-07-2013, 08:23 PM   #20
sonitm
New Member
 
Drives: 2011 323i 6MT white
Join Date: Feb 2012
Location: Canada

Posts: 16
iTrader: (0)

Try flushing the coolant.
sonitm is offline  
0
Reply With Quote
      01-07-2013, 10:21 PM   #21
Bill330i
New Member
 
Drives: 2011 E92 335i
Join Date: Aug 2005
Location: Seattle, WA

Posts: 25
iTrader: (0)

I had the same problem with my 06 330i. It was the heat box. The dealer had to pull out the dash and replace parts after 2 times of trying other fixes prior.
__________________
2011 335i Coupe / Space Grey / Oyster Black Leather / Premium / M Sport / Cold / Nav / Step / Sirius / Comfort Access / BMW Apps / Active Steering / Harmon Kardon
Bill330i is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:22 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST