E90Post
 


Scorpp Design
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > BMW CODING success



Reply
 
Thread Tools Search this Thread
      11-17-2010, 03:31 PM   #199
scanboy
Lieutenant
 
Drives: E90 Montego Blue+Black Int.
Join Date: Sep 2007
Location: Torrance

Posts: 436
iTrader: (0)

Quote:
Originally Posted by heartpumper View Post
Thanks for posting what you have done i was wondering if you could post which module you looked in and the "terminology" to look at to change it to aktiv or nicht_aktiv
I c, here they are:

1. CAS - KOMFORTSCHLIESSUNG_FB for Windows up on holding lock button on remote.
2. NFRM - SPIEGEL_KOMFORT_EINKLAPP for Side mirror folding on holding lock button on remote.
3. NFRM - SIDEMARKER_US for Corner delete (side marker/signal light off when headlights on)

For corner delete, I don't have SIDEMARKER_US exactly, I think mine has 2 extra characters after US, something like SIDEMARKER_US_NF.

Last edited by scanboy; 11-17-2010 at 03:40 PM.
scanboy is offline   United_States
0
Reply With Quote
      11-17-2010, 05:35 PM   #200
moaad
New Member
 
Drives: e53
Join Date: Nov 2010
Location: belgium

Posts: 8
iTrader: (0)

a very good DIY

Thanks xxxjecxxx
moaad is offline  
0
Reply With Quote
      11-17-2010, 05:43 PM   #201
wchoy
First Lieutenant
 
Drives: '08 AW e90 335i
Join Date: Apr 2010
Location: Honolulu, Hawaii / LA

Posts: 312
iTrader: (0)

Quote:
Originally Posted by scanboy View Post
I c, here they are:

1. CAS - KOMFORTSCHLIESSUNG_FB for Windows up on holding lock button on remote.
2. NFRM - SPIEGEL_KOMFORT_EINKLAPP for Side mirror folding on holding lock button on remote.
3. NFRM - SIDEMARKER_US for Corner delete (side marker/signal light off when headlights on)

For corner delete, I don't have SIDEMARKER_US exactly, I think mine has 2 extra characters after US, something like SIDEMARKER_US_NF.
what year is your car?
wchoy is offline   United_States
0
Reply With Quote
      11-17-2010, 05:53 PM   #202
scanboy
Lieutenant
 
Drives: E90 Montego Blue+Black Int.
Join Date: Sep 2007
Location: Torrance

Posts: 436
iTrader: (0)

Quote:
Originally Posted by wchoy View Post
what year is your car?
07
scanboy is offline   United_States
0
Reply With Quote
      11-17-2010, 06:09 PM   #203
MrSkinny
First Lieutenant
 
Drives: 335i
Join Date: Oct 2005
Location: GTA

Posts: 340
iTrader: (6)

any successful 07 e92s?
MrSkinny is online now  
0
Reply With Quote
      11-17-2010, 06:17 PM   #204
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
Quote:
Originally Posted by scanboy View Post
I'm using the same ebay cable that you posted earlier :
http://cgi.ebay.com/ebaymotors/_W0QQ...#ht_7117wt_981

The software that I was using is the same version as what's available in this thread (at least for NCS Expert) but I find this thread a lot easier (specially the software installation) to follow for a beginner.

What I've successfully done so far:
1. Windows up on holding lock button on remote.
2. Side mirror folding on holding lock button on remote.
3. Corner delete (side marker/signal light off when headlights on)

I really want AE as DRL, but I was told it's not possible.
If you can't code them as DRLs you can wire them to your cigg lighter with a diode in between like I did...there is a DIY with the specs on the diode in the DIY forum. I have had this setup for about 3 months now....no problems so far....Knock on wood.

There is also a DIY that wires them to the ECU...but I have just come across this and don't know much about it.
fdriller9 is offline   United_States
0
Reply With Quote
      11-17-2010, 06:42 PM   #205
scanboy
Lieutenant
 
Drives: E90 Montego Blue+Black Int.
Join Date: Sep 2007
Location: Torrance

Posts: 436
iTrader: (0)

Quote:
Originally Posted by ********* View Post
If you can't code them as DRLs you can wire them to your cigg lighter with a diode in between like I did...there is a DIY with the specs on the diode in the DIY forum. I have had this setup for about 3 months now....no problems so far....Knock on wood.

There is also a DIY that wires them to the ECU...but I have just come across this and don't know much about it.
Yeah I saw the cigg one, I thought that's what I'm going to do if the coding is not possible. Coding is cleaner if it is possible, so I thought I explored that first.
scanboy is offline   United_States
0
Reply With Quote
      11-17-2010, 06:51 PM   #206
fdriller9
Banned
 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

Posts: 7,090
iTrader: (4)

Garage List
2006 330xi  [3.22]
Quote:
Originally Posted by scanboy View Post
Yeah I saw the cigg one, I thought that's what I'm going to do if the coding is not possible. Coding is cleaner if it is possible, so I thought I explored that first.
Ohh definitely. I was looking to do that as well but I haven't gotten my cable yet to explore.
fdriller9 is offline   United_States
0
Reply With Quote
      11-17-2010, 07:32 PM   #207
bugsandry
First Lieutenant
 
Drives: 2012 BMW F30 328i
Join Date: Apr 2010
Location: Vancouver, BC

Posts: 360
iTrader: (5)

Ok an update..

I manage to open the INPALOAD.exe file on my Win XP laptop after putting all the files in c:\ directory and setting the path to c:\ediabas\bin.

Now the problem is when I plug in my cable to the car and press start button and run INPALOAD, I didn't see the black dot confirming battery and Iginition ON

I am using an ELM 327 interface (r232) with USB port at the end of the cable (My friend uses this interface on his e46) and it supports OBD II protocols. Since this is a USB, the advanced option for the port is different and I cannot assign "use fifo uffers" or setting the receive and transmit buffers to "8" as per instructions.

I am guessing that's the reason why the INAPALOAD process cannot detect the car?

Anyone can shed some light?
bugsandry is offline   Canada
0
Reply With Quote
      11-17-2010, 08:02 PM   #208
wchoy
First Lieutenant
 
Drives: '08 AW e90 335i
Join Date: Apr 2010
Location: Honolulu, Hawaii / LA

Posts: 312
iTrader: (0)

any one find a good cable for 08 and later e90?
wchoy is offline   United_States
0
Reply With Quote
      11-17-2010, 08:24 PM   #209
MrSkinny
First Lieutenant
 
Drives: 335i
Join Date: Oct 2005
Location: GTA

Posts: 340
iTrader: (6)

Quote:
Originally Posted by wchoy View Post
any one find a good cable for 08 and later e90?
just join in on the gb
MrSkinny is online now  
0
Reply With Quote
      11-18-2010, 12:14 AM   #210
JonLerd
Lieutenant
 
Drives: Alpine White 335i coupe
Join Date: Mar 2009
Location: Orange County / Los Angeles

Posts: 542
iTrader: (3)

[QUOTE[/quote]


i got the same error but can connect to the alarm module just fine. Anyone seen this?
JonLerd is offline  
0
Reply With Quote
      11-18-2010, 01:57 PM   #211
Robben@ltbmw
 
Drives: E90 Space Grey
Join Date: Dec 2009
Location: ROSEMEAD, CA

Posts: 2,215
iTrader: (4)

Garage List
2007 328i  [0.00]
Send a message via AIM to Robben@ltbmw
Quote:
Originally Posted by scanboy View Post
I c, here they are:

1. CAS - KOMFORTSCHLIESSUNG_FB for Windows up on holding lock button on remote.
2. NFRM - SPIEGEL_KOMFORT_EINKLAPP for Side mirror folding on holding lock button on remote.
3. NFRM - SIDEMARKER_US for Corner delete (side marker/signal light off when headlights on)

For corner delete, I don't have SIDEMARKER_US exactly, I think mine has 2 extra characters after US, something like SIDEMARKER_US_NF.
I have 07 e92, is your e90 or e92? I changed the sidemarker_US to not active but corner delete still doesn't work. may be it is indeed a bad cable.. I will update once I can find a new cable to borrow.
scanboy: i see you're local to me, do you mind if I borrow the cable?
Robben@ltbmw is offline   United_States
0
Reply With Quote
      11-18-2010, 02:14 PM   #212
Whitevdub
Second Lieutenant
 
Drives: e90 Alpine White 328xi M-sport
Join Date: Jul 2010
Location: Long Island

Posts: 249
iTrader: (4)

is there a way to code off the 3 orange led's that come on with the e90 lci bi-xenon headlights?
Whitevdub is offline  
0
Reply With Quote
      11-18-2010, 02:23 PM   #213
Robben@ltbmw
 
Drives: E90 Space Grey
Join Date: Dec 2009
Location: ROSEMEAD, CA

Posts: 2,215
iTrader: (4)

Garage List
2007 328i  [0.00]
Send a message via AIM to Robben@ltbmw
Quote:
Originally Posted by JonLerd View Post


i got the same error but can connect to the alarm module just fine. Anyone seen this?
make sure you are opening up INPA.EXE (there are several INPA you can open up, some include loader and editor. only the .exe file will work)
Robben@ltbmw is offline   United_States
0
Reply With Quote
      11-18-2010, 03:03 PM   #214
bugsandry
First Lieutenant
 
Drives: 2012 BMW F30 328i
Join Date: Apr 2010
Location: Vancouver, BC

Posts: 360
iTrader: (5)

Quote:
Originally Posted by cbbplanet View Post
make sure you are opening up INPA.EXE (there are several INPA you can open up, some include loader and editor. only the .exe file will work)
The instruction told us to load INPALOAD.exe when we first run it ? So it should be INPA.exe then?
bugsandry is offline   Canada
0
Reply With Quote
      11-18-2010, 03:10 PM   #215
Robben@ltbmw
 
Drives: E90 Space Grey
Join Date: Dec 2009
Location: ROSEMEAD, CA

Posts: 2,215
iTrader: (4)

Garage List
2007 328i  [0.00]
Send a message via AIM to Robben@ltbmw
Quote:
Originally Posted by bugsandry View Post
The instruction told us to load INPALOAD.exe when we first run it ? So it should be INPA.exe then?
sry inpaload.exe is correct. I don't have the DIY in front of me so I was just recalling from my memory. Main point is make sure its the .exe program, because there are several INPAloader in there I remember. All of them are executable but under each description, i think only one of them will work. I forgot the name right now but I will go back home and look at my folders. If you're in a rush of doing it right now, try all the inpaloader executables.
Robben@ltbmw is offline   United_States
0
Reply With Quote
      11-18-2010, 03:58 PM   #216
scanboy
Lieutenant
 
Drives: E90 Montego Blue+Black Int.
Join Date: Sep 2007
Location: Torrance

Posts: 436
iTrader: (0)

Quote:
Originally Posted by cbbplanet View Post
I have 07 e92, is your e90 or e92? I changed the sidemarker_US to not active but corner delete still doesn't work. may be it is indeed a bad cable.. I will update once I can find a new cable to borrow.
scanboy: i see you're local to me, do you mind if I borrow the cable?
yeah, I just pm you, we can work something out. btw, mine is 07 e90.
scanboy is offline   United_States
0
Reply With Quote
      11-18-2010, 05:23 PM   #217
Dr. G
Brigadier General
 
Dr. G's Avatar
 
Drives: Black e92 335i
Join Date: Apr 2010
Location: Brampton, Ontario

Posts: 4,887
iTrader: (32)

Garage List
e92 BMW 335i  [4.35]
What is the recommended wire for 07 e92?

Just looking to use the DIY and code the digital speedo, since im in the US with a KM/H only speedo
Dr. G is offline  
0
Reply With Quote
      11-18-2010, 07:05 PM   #218
JonLerd
Lieutenant
 
Drives: Alpine White 335i coupe
Join Date: Mar 2009
Location: Orange County / Los Angeles

Posts: 542
iTrader: (3)

Quote:
Originally Posted by cbbplanet View Post
I have 07 e92, is your e90 or e92? I changed the sidemarker_US to not active but corner delete still doesn't work. may be it is indeed a bad cable.. I will update once I can find a new cable to borrow.
scanboy: i see you're local to me, do you mind if I borrow the cable?
hey i got a cable you can try also which i got at one stop electronics.com hit me up via pm if you havent tried that cable yet.

-Jon
JonLerd is offline  
0
Reply With Quote
      11-18-2010, 07:40 PM   #219
JonLerd
Lieutenant
 
Drives: Alpine White 335i coupe
Join Date: Mar 2009
Location: Orange County / Los Angeles

Posts: 542
iTrader: (3)

any socal guys LA/OC area want to meet up to do a group coding session? With the different versions and different cables im sure we can make some good progress.
JonLerd is offline  
0
Reply With Quote
      11-18-2010, 08:11 PM   #220
Greenkirby21
Vrooom :)
 
Greenkirby21's Avatar
 
Drives: BMW 128i
Join Date: Jun 2010
Location: Dream Land

Posts: 2,506
iTrader: (1)

Send a message via AIM to Greenkirby21
would this work on a 1 series?
__________________
2009 128i Coupe Crimson Red MODS: -Injen Intake-Magnaflow Exhaust-Carbon Fiber Spoiler - Carbon Fiber Grilles - OZ Ultraleggeras - CF Mirrors
Greenkirby21 is online now   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:27 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST