E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > BMW CODING success



Reply
 
Thread Tools Search this Thread
      03-13-2011, 10:59 AM   #2245
dav_lph
New Member
 
Drives: BMW 323i Highline
Join Date: Jun 2008
Location: Singapore

Posts: 27
iTrader: (0)

Quote:
After I finished coding the VO +K302 for my alarm and writing using FA_WRITE to the CAS and to the FRM I then recoded the other modules by just reading and then writing them back without making changes. Some of them gave me an error so I tried hitting the 'Process Car' button and that seemed to work. I had to go back in and recode everything else that I had coded (not alarm related).

Hope this helps.
Thanks for the feedback. Will try what you mentioned.

By the way, when you mentioned "Process Car", does that code very module in the car? So I guess you would have to use the full backup of the PSW_FSW.TRC file to allow it to "process car". Can you confirm this?

I have recently added $7XA for 'M-Sport Steering w/ Paddle Shift' to my VO to try to get my paddle shift to work while in D (it currently works only in DS). But no luck. Will try the above method and see how it goes.
dav_lph is offline  
0
Reply With Quote
      03-13-2011, 12:09 PM   #2246
AW128i
Major
 
AW128i's Avatar
 
Drives: E82 N51
Join Date: Nov 2010
Location: Southeastern, PA

Posts: 1,004
iTrader: (1)

Send a message via AIM to AW128i
Quote:
Originally Posted by spera23 View Post
I see what you mean about a one person job. Very annoying to keep coding one at a time and running in out out to check. As for the corned LED's, I'm not 100% sure on the e82 what it would control.

I was having a similar problem that once I coded on my low beams and welcome lights, it seemed to screw up the factory set welcome lights. On my e92, I noticed the WL_SL_2 controlled the rear brake lights while WL_SL_1 controlled the front Angel Eyes. I did not want the front parking lights (turn signals) on as welcome lights and the way I was able to accomplish this was using WL_BLK_V and setting it to nicht_aktiv. So as far as the e92, The WL_BLK_V (and H) are the front and rear turn signals (parking lights) and the WL_SL_2 was the rear brake lights.

Try changing WL_SL_2 to nicht aktiv and see if your brake lights change at all as welcome lights.
I can't remember what options I finally settled on, but now it works as I want it to; i.e., the front and rear turn signals blink twice upon unlock, and the low beams, city lights, front fog lights, and tail lights all come on as Welcome Lights. The front sidemarker lights DO NOT come on as Welcome Lights. Upon locking the car, the front/rear turn signals blink once, as expected.
AW128i is offline   United_States
0
Reply With Quote
      03-13-2011, 02:50 PM   #2247
Toad335
Private First Class
 
Drives: LCI 335i 6MT
Join Date: Mar 2011
Location: Cincinnati

Posts: 135
iTrader: (1)

Quote:
Originally Posted by el-drifot View Post
This is why your Efficient Dynamics Shift indicator dont goes away :
SCHALT_PKT_DAUERHAFT -> aktiv
This means in german that the shift indicator should be there ALWAYS. In my car it is set to nicht_aktiv, and I can activate and deactivate it on the blanc screenr with holding the BC button.

Greetz
El-Drifto
Thanks fixed it. Thanks! With this set nicht_aktiv I can hold the BC button to hide the up/down arrows at any time.

Quote:
Originally Posted by Wissam View Post
Thanks Toad335...No I didn't, I left the "SCHALT PKT DAUERHAFT" set to "nicht_aktiv", I assumed it was only for being able to toggle ON/OFF, I'll give it a try today...I noticed that people who coded this have cars 2008 and above, mine is build 11/2006, could this be the reason why mine doesn't work? and yes, I have 6MT...
Wissam - Not sure it's going to help. I turned that one bit off and mine still works. I'm in a 2009, but it seems weird that your car would have the bits if it didn't have the function...
Toad335 is offline  
0
Reply With Quote
      03-13-2011, 03:01 PM   #2248
Pseudo Nim
twinborific
 
Pseudo Nim's Avatar
 
Drives: fast, sometimes slow
Join Date: Nov 2008
Location: i am a citizen of the world

Posts: 4,732
iTrader: (9)

This shift indicator works only in 2009+, right?
__________________
Pseudo Nim is offline  
0
Reply With Quote
      03-13-2011, 03:33 PM   #2249
el-drifot
New Member
 
Drives: BMW e90 318d
Join Date: Feb 2011
Location: Germany

Posts: 11
iTrader: (0)

Efficient Dynamic is stock on bmw build since 2008, here in Europe.
Greetz
El-Drifto
el-drifot is offline  
0
Reply With Quote
      03-13-2011, 03:37 PM   #2250
Pseudo Nim
twinborific
 
Pseudo Nim's Avatar
 
Drives: fast, sometimes slow
Join Date: Nov 2008
Location: i am a citizen of the world

Posts: 4,732
iTrader: (9)

Quote:
Originally Posted by el-drifot View Post
Efficient Dynamic is stock on bmw build since 2008, here in Europe.
Greetz
El-Drifto
Any way to cheek if my North American 2008 has it?
__________________
Pseudo Nim is offline  
0
Reply With Quote
      03-13-2011, 05:56 PM   #2251
jphughan
Brigadier General
 
jphughan's Avatar
 
Drives: 2011.75 M3 E92 6MT
Join Date: Mar 2011
Location: Austin, TX

Posts: 3,394
iTrader: (0)

Quote:
Originally Posted by Pseudo Nim View Post
Any way to cheek if my North American 2008 has it?
It won't have it enabled by default or as a selectable option. If you're asking whether it can be made available via coding, try dumping your car's config and see whether it's there in the options. If you don't find it, this thread suggests that adding options that don't already exist in the module is a pretty bad idea.
jphughan is offline   United_States
0
Reply With Quote
      03-13-2011, 06:04 PM   #2252
Wissam
Private First Class
 
Drives: 2007 e90 328I
Join Date: Dec 2006
Location: GTA, Canada

Posts: 141
iTrader: (3)

I tried the "SCHALT PKT DAUERHAFT" set to "aktiv", still doesn't work...the ability to toggle ON/OFF is now gone, as expected...so seems like it's year dependent...
Wissam is offline   Canada
0
Reply With Quote
      03-13-2011, 08:06 PM   #2253
Kalud
Lieutenant
 
Kalud's Avatar
 
Drives: e92 335i
Join Date: Jun 2010
Location: Canada

Posts: 582
iTrader: (0)

Quote:
Originally Posted by jphughan View Post
I'd be very interested in additional information about this. I'll be picking up my 2011.75 M3 soon (2011.75 = Option 6NR) and I'd love to code it so Auto Start/Stop comes up in its last state rather than defaulting to OFF. Someone got this behavior coded by a dealer in Australia so it must be possible.

I'd also like to code M3s starting in Servotronic Sport mode so I don't have to push the M button to get it -- can't understand why BMW doesn't allow this!! Ideally I'd like to preserve a way to access Normal mode (maybe it can start up in Sport but if you go into M Drive and back out, it's Normal?)
I guess it would be possible, once you get the car, send the FSW_PSW.TRC of the whole car and we should be able to figure it out.

Quote:
Originally Posted by jphughan View Post
In other news, do the Daten files from ISTA 39 work on 2011.5 or 2011.75 M3s? Do I need 40? Something even newer?
Most modules will probably work and you will probably need an updated for the latest combox (not yet released / leaked) version 41 or something I guess.
Kalud is offline  
0
Reply With Quote
      03-13-2011, 08:10 PM   #2254
Kalud
Lieutenant
 
Kalud's Avatar
 
Drives: e92 335i
Join Date: Jun 2010
Location: Canada

Posts: 582
iTrader: (0)

Quote:
Originally Posted by Toad335 View Post
Any luck with this? Any noticable difference in the timing of your lowbeams kicking on when set to the different values?
I haven't been able to test fully, yesterday when I took the car it was rainy and I think my xenon would have been selected but I was still on angel eyes (less sensitivity setting). But its not enough tests yet to confirm. I will report back once I am more confident on the results
Kalud is offline  
0
Reply With Quote
      03-14-2011, 05:43 AM   #2255
tldoxmf87
Captain
 
tldoxmf87's Avatar
 
Drives: e92 TiAg
Join Date: Mar 2010
Location: Bellevue

Posts: 723
iTrader: (14)

Anyone know how to enable the foglights only with the angel eyes??
__________________
E92 TiAg
tldoxmf87 is offline   South Korea
0
Reply With Quote
      03-14-2011, 08:10 AM   #2256
AW128i
Major
 
AW128i's Avatar
 
Drives: E82 N51
Join Date: Nov 2010
Location: Southeastern, PA

Posts: 1,004
iTrader: (1)

Send a message via AIM to AW128i
Quote:
Originally Posted by Toad335 View Post
Any luck with this? Any noticable difference in the timing of your lowbeams kicking on when set to the different values?
I activated this on my car and I say yes, there is a noticeable difference. Prior to enabling this, during my drive to work, my lights would go on and off a couple times as my direction of travel and ambient light conditions changed due to overhanging trees, etc. This morning, I noted that my lights went off at one point and remained off for the rest of my drive until I entered the parking garage at work. I have mine set on the lowest sensitivity.
AW128i is offline   United_States
0
Reply With Quote
      03-14-2011, 08:44 AM   #2257
matrix76
Major
 
matrix76's Avatar
 
Drives: 2011 E90 328i xDrive Ex/Ps
Join Date: Sep 2009
Location: The West Coast, BC

Posts: 1,300
iTrader: (1)

Quote:
Originally Posted by AW128i View Post
I activated this on my car and I say yes, there is a noticeable difference. Prior to enabling this, during my drive to work, my lights would go on and off a couple times as my direction of travel and ambient light conditions changed due to overhanging trees, etc. This morning, I noted that my lights went off at one point and remained off for the rest of my drive until I entered the parking garage at work. I have mine set on the lowest sensitivity.
I changed mine as well and found the same results, this is a good feature if you set your AE's as DRL with corner deletes.
__________________
Brian
Black Sapphire, Black w/Burrwood Trim & Shifter, 162's, Mtec H8 AE's, DS1 HID 6000K

matrix76 is offline   Canada
0
Reply With Quote
      03-14-2011, 09:19 AM   #2258
Kalud
Lieutenant
 
Kalud's Avatar
 
Drives: e92 335i
Join Date: Jun 2010
Location: Canada

Posts: 582
iTrader: (0)

Quote:
Originally Posted by tldoxmf87 View Post
Anyone know how to enable the foglights only with the angel eyes??
Front fog lights are "NSW".

I would start to play with those:

Code:
DRL_TFL_MIT_NSW
	nicht_aktiv
NSW_DEF_CC_MELD_TFL
	nicht_aktiv
NSW_FKT_PARKL
	nicht_aktiv
NSW_FKT_SL
	nicht_aktiv
PARKL_FKT_MIT_NSW
	nicht_aktiv
SL_FKT_MIT_NSW
	nicht_aktiv
By activating one at a time, I am pretty sure it can be done. I might try myself later this week if you cannot make it work before.

Interesting find:

Cornering fog light :
Quote:
ABBIEGELICHT_MIT_NSW
nicht_aktiv
Kalud is offline  
0
Reply With Quote
      03-14-2011, 09:30 AM   #2259
onebadmofo
Banned
 
Drives: 2007 E92 335i
Join Date: Aug 2010
Location: Central NJ

Posts: 2,394
iTrader: (14)

Quote:
Originally Posted by tldoxmf87 View Post
Anyone know how to enable the foglights only with the angel eyes??
Switch headlights to parking (1 o'clock) and turn on fog lights? You need amber corners disabled though.
onebadmofo is offline   Russian Federation
0
Reply With Quote
      03-14-2011, 12:04 PM   #2260
AW128i
Major
 
AW128i's Avatar
 
Drives: E82 N51
Join Date: Nov 2010
Location: Southeastern, PA

Posts: 1,004
iTrader: (1)

Send a message via AIM to AW128i
Quote:
Originally Posted by matrix76 View Post
I changed mine as well and found the same results, this is a good feature if you set your AE's as DRL with corner deletes.
Did your car, like mine, reset things like the date and time, and the service info? My next service is showing as 5/2015! My oil, brakes, and inspection info are still the same, however.
AW128i is offline   United_States
0
Reply With Quote
      03-14-2011, 12:06 PM   #2261
AW128i
Major
 
AW128i's Avatar
 
Drives: E82 N51
Join Date: Nov 2010
Location: Southeastern, PA

Posts: 1,004
iTrader: (1)

Send a message via AIM to AW128i
Quote:
Originally Posted by Kalud View Post
Interesting find:

Cornering fog light :
Quote:
ABBIEGELICHT_MIT_NSW
nicht_aktiv
Have you tried this? Could prove interesting! I believe the current X5 uses the fog lights as cornering lights.
AW128i is offline   United_States
0
Reply With Quote
      03-14-2011, 12:47 PM   #2262
matrix76
Major
 
matrix76's Avatar
 
Drives: 2011 E90 328i xDrive Ex/Ps
Join Date: Sep 2009
Location: The West Coast, BC

Posts: 1,300
iTrader: (1)

Quote:
Originally Posted by AW128i View Post
Did your car, like mine, reset things like the date and time, and the service info? My next service is showing as 5/2015! My oil, brakes, and inspection info are still the same, however.

I know it changed the Date/Time but I didn't look at the service date, if yours changed then I can only bet that mind did as well. I'll check after work.
__________________
Brian
Black Sapphire, Black w/Burrwood Trim & Shifter, 162's, Mtec H8 AE's, DS1 HID 6000K

matrix76 is offline   Canada
0
Reply With Quote
      03-14-2011, 12:49 PM   #2263
DESI4life10
Banned
 
DESI4life10's Avatar
 
Drives: Coding: Desi4life10@gmail.com
Join Date: Oct 2008
Location: West of Toronto, Canada

Posts: 3,365
iTrader: (18)

Quote:
Originally Posted by matrix76 View Post
I know it changed the Date/Time but I didn't look at the service date, if yours changed then I can only bet that mind did as well. I'll check after work.
I coded this and nothing changed other than the Time being reset.
DESI4life10 is offline   Canada
0
Reply With Quote
      03-14-2011, 12:52 PM   #2264
carlosalbertogui
Second Lieutenant
 
Drives: bmw E91 facelifted by me
Join Date: Jun 2010
Location: portugal

Posts: 235
iTrader: (0)

Frm3 module

hi

iam in a nightmare

i went to bmw and they put frm3 on my car
reprograme the ligts xenon and rear lights LCI.....

by the way i notice that brake lights where always on even if i dont press the brake pedal .

in my home i try changing the wires to see if it goes off and nothing

in next day i went out when i was driving and dsc dbc rfm errors on screnn fuel pump fault etc car shut down.

trailer to bmw

is now on bmw and they dont know what the car haves
car dont even start just makes the noise and nothing errors dsc dbc etc

hey do a brake fuid change also it was time to do it

can you help me
carlosalbertogui is offline  
0
Reply With Quote
      03-14-2011, 01:30 PM   #2265
Kalud
Lieutenant
 
Kalud's Avatar
 
Drives: e92 335i
Join Date: Jun 2010
Location: Canada

Posts: 582
iTrader: (0)

Quote:
Originally Posted by carlosalbertogui View Post
hi

iam in a nightmare

i went to bmw and they put frm3 on my car
reprograme the ligts xenon and rear lights LCI.....
Maybe I don't understand exactly what you mean, but BMW installed a FRM3 and they have done the programming also ? You haven't tried to code anything yourself right? If so, I don't think you are posting in the appropriate thread...

Quote:
Originally Posted by carlosalbertogui View Post
by the way i notice that brake lights where always on even if i dont press the brake pedal .

in my home i try changing the wires to see if it goes off and nothing
This might only be DRL on the breake light. Canadian cars like mine has front (angel eyes) and rear (break light) on all the time. And it is possible to code them to not have break light as DRL. (RL_BL_2_MIT_TFL in FRM). Maybe the module they installed had this activated by default.

Quote:
Originally Posted by carlosalbertogui View Post
in next day i went out when i was driving and dsc dbc rfm errors on screnn fuel pump fault etc car shut down.

trailer to bmw

is now on bmw and they dont know what the car haves
car dont even start just makes the noise and nothing errors dsc dbc etc

hey do a brake fuid change also it was time to do it

can you help me
I would wait for those, BMW has the car right now? So they should be able to find out...
Kalud is offline  
0
Reply With Quote
      03-14-2011, 09:29 PM   #2266
Wissam
Private First Class
 
Drives: 2007 e90 328I
Join Date: Dec 2006
Location: GTA, Canada

Posts: 141
iTrader: (3)

I've recently noticed a little problem...when I set the headlight switch to Auto, the low beam headlights will always come on no matter how bright it is outside...this seems to have happened after coding the high beam DRL disable by changing DRL_V_GEDIMMT to nicht_aktiv in the FRM sub-module (my car does not an NFRM sub-module)...prior to coding, I had installed the Daeos DRL Harness but I'm pretty sure the headlight switch was still working normally in Auto after harness installation...I tried coding the Auto headlight sensor sensitivity but even at the lowest sensitivity setting, the headlights still come on in bright sunlight...any advice? I'm especially curious if others who disabled the DRL through the FRM sub-module per above have the same issue...
Wissam is offline   Canada
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:16 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST